]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
- patch to get goom visualisation usable
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6 #    only libXrandr 1.1 - with no gamma support; it causes application crash
7 #    on XRRSetCrtcGamma function called by SDL_SetVideoMode)
8 #  - add and/or fix users/groups permissions
9 #  - split to subpackages?
10 #  - check how it works with external python libraries
11 #
12 # Conditional build:
13 %bcond_with     external_python
14 %bcond_without  goom
15
16 Summary:        XBMC
17 Name:           xbmc
18 Version:        10.0
19 Release:        0.3
20 License:        GPL v3
21 Group:          Applications/Multimedia
22 Source0:        http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
23 # Source0-md5:  728fb514e5f43f27bb880305061b4e72
24 Source1:        goom_icon.png
25 # Source1-md5:  8c0ffe2055f2cfde1189687d12a68aa8
26 URL:            http://xbmc.org
27 Patch0:         %{name}-nobash.patch
28 Patch1:         %{name}-python27.patch
29 Patch2:         %{name}-subtitle_tags.patch
30 Patch3:         %{name}-goom_enable.patch
31 BuildRequires:  SDL_image-devel
32 BuildRequires:  SDL_mixer-devel
33 BuildRequires:  a52dec-libs-devel
34 BuildRequires:  alsa-lib-devel
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  avahi-devel
38 BuildRequires:  boost-devel
39 BuildRequires:  bzip2-devel
40 BuildRequires:  cmake
41 BuildRequires:  curl-devel
42 BuildRequires:  dbus-devel
43 BuildRequires:  enca-devel
44 BuildRequires:  faac-devel
45 BuildRequires:  faad2-devel
46 BuildRequires:  ffmpeg-devel
47 BuildRequires:  flac-devel
48 BuildRequires:  fontconfig-devel
49 BuildRequires:  freetype-devel
50 BuildRequires:  fribidi-devel
51 BuildRequires:  gawk
52 BuildRequires:  gettext-autopoint
53 BuildRequires:  gettext-devel
54 BuildRequires:  glew-devel
55 BuildRequires:  gperf
56 BuildRequires:  gtk+-devel
57 BuildRequires:  hal-devel
58 BuildRequires:  jasper-devel
59 BuildRequires:  libao-devel
60 BuildRequires:  libcdio-devel
61 BuildRequires:  libdts-devel
62 BuildRequires:  libjpeg-devel
63 BuildRequires:  libmad-devel
64 BuildRequires:  libmicrohttpd-devel
65 BuildRequires:  libmms-devel
66 BuildRequires:  libmodplug-devel
67 BuildRequires:  libmpeg2-devel
68 BuildRequires:  libogg-devel
69 BuildRequires:  libpng-devel
70 BuildRequires:  libsamplerate-devel
71 BuildRequires:  libsmbclient-devel
72 BuildRequires:  libtiff-devel
73 BuildRequires:  libtool
74 BuildRequires:  libvdpau-devel
75 BuildRequires:  libvorbis-devel
76 BuildRequires:  lzo-devel
77 BuildRequires:  mysql-devel
78 %ifarch %{ix86}
79 BuildRequires:  nasm
80 %endif
81 BuildRequires:  openssl-devel
82 BuildRequires:  pcre-cxx-devel
83 BuildRequires:  pkgconfig
84 BuildRequires:  pulseaudio-devel
85 BuildRequires:  python-devel
86 BuildRequires:  rpm-pythonprov
87 BuildRequires:  rpmbuild(macros) >= 1.566
88 # used internally
89 BuildRequires:  sed >= 4.0
90 BuildRequires:  sqlite3-devel
91 BuildRequires:  unzip
92 BuildRequires:  wavpack-devel
93 BuildRequires:  xmms-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXrandr-devel
96 BuildRequires:  xorg-lib-libXtst-devel
97 BuildRequires:  zip
98 BuildRequires:  zlib-devel
99 Requires:       /usr/bin/glxinfo
100 Requires:       lsb-release
101 Requires:       xorg-app-xdpyinfo
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %description
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %undos xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
110 %patch1 -p1
111 %patch2 -p1
112 %patch3 -p1
113
114 %build
115 ./bootstrap
116 %configure \
117         --disable-debug \
118         --enable-external-libraries \
119         --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python \
120         --%{?with_goom:en}%{!?with_goom:dis}able-goom
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128         install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/xbmc/addons/visualization.goom/icon.png
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %posttrans
134 %banner -e xbmc <<EOF
135 WARNING!
136 If you use nvidia binary drivers be sure that SDL is compiled without
137 XRandR and VidMode gamma ramps support.
138 This means that you need to rebuild it with command:
139 builder -bb --without new_gamma_ramp SDL
140 EOF
141
142 %files
143 %defattr(644,root,root,755)
144 #doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
145
146 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
147 %attr(755,root,root) %{_bindir}/*
148 %{_datadir}/%{name}
149 %attr(755,root,root) %{_libdir}/%{name}
150 %{_docdir}/%{name}
151 %{_desktopdir}/%{name}.desktop
152 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
153 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
154 %{_datadir}/xsessions/XBMC.desktop
This page took 0.068382 seconds and 5 git commands to generate.