]> git.pld-linux.org Git - packages/xbmc.git/blame - xbmc.spec
- patch to get goom visualisation usable
[packages/xbmc.git] / xbmc.spec
CommitLineData
18b90c81
SP
1#
2# TODO:
3a71016a 3# - fix build flags - some files are compiled with -O3 and without rpm*flags
c1b45330 4# - fix linking argument order
63ff963e 5# - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6# only libXrandr 1.1 - with no gamma support; it causes application crash
7# on XRRSetCrtcGamma function called by SDL_SetVideoMode)
92b96980 8# - add and/or fix users/groups permissions
63ff963e 9# - split to subpackages?
92b96980 10# - check how it works with external python libraries
18b90c81 11#
92b96980 12# Conditional build:
13%bcond_with external_python
9e98e23b 14%bcond_without goom
92b96980 15
18b90c81
SP
16Summary: XBMC
17Name: xbmc
92b96980 18Version: 10.0
b2f93b43 19Release: 0.3
2e649bc9 20License: GPL v3
18b90c81 21Group: Applications/Multimedia
54721144 22Source0: http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
92b96980 23# Source0-md5: 728fb514e5f43f27bb880305061b4e72
b2f93b43 24Source1: goom_icon.png
25# Source1-md5: 8c0ffe2055f2cfde1189687d12a68aa8
18b90c81 26URL: http://xbmc.org
01f2a87d 27Patch0: %{name}-nobash.patch
63ff963e 28Patch1: %{name}-python27.patch
0aae19c0 29Patch2: %{name}-subtitle_tags.patch
b2f93b43 30Patch3: %{name}-goom_enable.patch
18b90c81
SP
31BuildRequires: SDL_image-devel
32BuildRequires: SDL_mixer-devel
c462fd57 33BuildRequires: a52dec-libs-devel
18b90c81
SP
34BuildRequires: alsa-lib-devel
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: avahi-devel
5a2f2b01 38BuildRequires: boost-devel
18b90c81
SP
39BuildRequires: bzip2-devel
40BuildRequires: cmake
41BuildRequires: curl-devel
42BuildRequires: dbus-devel
43BuildRequires: enca-devel
44BuildRequires: faac-devel
5a2f2b01 45BuildRequires: faad2-devel
c462fd57 46BuildRequires: ffmpeg-devel
5a2f2b01 47BuildRequires: flac-devel
18b90c81
SP
48BuildRequires: fontconfig-devel
49BuildRequires: freetype-devel
50BuildRequires: fribidi-devel
51BuildRequires: gawk
63ff963e 52BuildRequires: gettext-autopoint
5a2f2b01 53BuildRequires: gettext-devel
18b90c81
SP
54BuildRequires: glew-devel
55BuildRequires: gperf
5a2f2b01 56BuildRequires: gtk+-devel
57BuildRequires: hal-devel
58BuildRequires: jasper-devel
59BuildRequires: libao-devel
18b90c81 60BuildRequires: libcdio-devel
c462fd57 61BuildRequires: libdts-devel
18b90c81
SP
62BuildRequires: libjpeg-devel
63BuildRequires: libmad-devel
63ff963e 64BuildRequires: libmicrohttpd-devel
18b90c81 65BuildRequires: libmms-devel
63ff963e 66BuildRequires: libmodplug-devel
c462fd57 67BuildRequires: libmpeg2-devel
18b90c81 68BuildRequires: libogg-devel
5a2f2b01 69BuildRequires: libpng-devel
18b90c81
SP
70BuildRequires: libsamplerate-devel
71BuildRequires: libsmbclient-devel
5a2f2b01 72BuildRequires: libtiff-devel
73BuildRequires: libtool
74BuildRequires: libvdpau-devel
18b90c81 75BuildRequires: libvorbis-devel
5a2f2b01 76BuildRequires: lzo-devel
77BuildRequires: mysql-devel
c1b45330 78%ifarch %{ix86}
26cae375 79BuildRequires: nasm
c1b45330 80%endif
18b90c81 81BuildRequires: openssl-devel
63ff963e 82BuildRequires: pcre-cxx-devel
5a2f2b01 83BuildRequires: pkgconfig
18b90c81 84BuildRequires: pulseaudio-devel
c462fd57 85BuildRequires: python-devel
3a71016a 86BuildRequires: rpm-pythonprov
6f41c837 87BuildRequires: rpmbuild(macros) >= 1.566
c462fd57 88# used internally
89BuildRequires: sed >= 4.0
18b90c81 90BuildRequires: sqlite3-devel
5a2f2b01 91BuildRequires: unzip
c462fd57 92BuildRequires: wavpack-devel
5a2f2b01 93BuildRequires: xmms-devel
94BuildRequires: xorg-lib-libXinerama-devel
18b90c81 95BuildRequires: xorg-lib-libXrandr-devel
5a2f2b01 96BuildRequires: xorg-lib-libXtst-devel
18b90c81
SP
97BuildRequires: zip
98BuildRequires: zlib-devel
63ff963e 99Requires: /usr/bin/glxinfo
a58652d4
SP
100Requires: lsb-release
101Requires: xorg-app-xdpyinfo
18b90c81
SP
102BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104%description
105
106%prep
c1b45330 107%setup -q
01f2a87d 108%patch0 -p1
bfde9a19 109%undos xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
51b524ca 110%patch1 -p1
0aae19c0 111%patch2 -p1
b2f93b43 112%patch3 -p1
18b90c81
SP
113
114%build
115./bootstrap
65712ad3 116%configure \
51b524ca
KK
117 --disable-debug \
118 --enable-external-libraries \
9e98e23b 119 --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python \
120 --%{?with_goom:en}%{!?with_goom:dis}able-goom
18b90c81
SP
121%{__make}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%{__make} install \
92b96980 127 DESTDIR=$RPM_BUILD_ROOT
b2f93b43 128 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/xbmc/addons/visualization.goom/icon.png
18b90c81
SP
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
0fc95f40 133%posttrans
134%banner -e xbmc <<EOF
135WARNING!
136If you use nvidia binary drivers be sure that SDL is compiled without
137XRandR and VidMode gamma ramps support.
138This means that you need to rebuild it with command:
139builder -bb --without new_gamma_ramp SDL
140EOF
141
18b90c81
SP
142%files
143%defattr(644,root,root,755)
47308569 144#doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
18b90c81 145
47308569 146#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
18b90c81
SP
147%attr(755,root,root) %{_bindir}/*
148%{_datadir}/%{name}
92b96980 149%attr(755,root,root) %{_libdir}/%{name}
150%{_docdir}/%{name}
c1b45330 151%{_desktopdir}/%{name}.desktop
92b96980 152%{_iconsdir}/hicolor/256x256/apps/%{name}.png
153%{_iconsdir}/hicolor/48x48/apps/%{name}.png
3a71016a 154%{_datadir}/xsessions/XBMC.desktop
This page took 0.108595 seconds and 5 git commands to generate.