]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- updated to 1.1.1
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  jack            # don't build JACK mm driver
5 %bcond_without  nas             # don't build NAS mm driver
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
8 #
9 # NOTE: wineconsole is a bit broken: try wineconsole cmd to see what will happen
10 #       As a workaroound use `wineconsole --backend=user cmd' (works fine)
11 #       ref: http://bugs.winehq.org/show_bug.cgi?id=8069
12 #
13 # NOTE: wine detects the following SONAMES for dlopen at build time:
14 #   libcrypto,libssl (wininet.dll)
15 #   libcups (winspool.dll.so,wineps.dll.so)
16 #   libcurses/libncurses (wineconsole program)
17 #   libfontconfig (gdi32.dll.so)
18 #   libfreetype (wineps.dll.so,gdi32.dll.so)
19 #   libGL (x11drv.dll.so,ddraw.dll.so)
20 #   libjack (winejack.drv.so - explicit dependency in subpackage)
21 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
22 # thus requires rebuild after change of any of the above.
23 #
24 # JACK requires ALSA
25 %if %{without alsa}
26 %undefine       with_jack
27 %endif
28 Summary:        Program that lets you launch Win applications
29 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
30 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
31 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
32 Name:           wine
33 Version:        1.1.1
34 Release:        1
35 Epoch:          1
36 License:        LGPL
37 Group:          Applications/Emulators
38 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
39 # Source0-md5:  7c68c241a52e88b69d290ffe569ee723
40 Source1:        %{name}-uninstaller.desktop
41 Patch0:         %{name}-fontcache.patch
42 Patch1:         %{name}-makedep.patch
43 Patch2:         %{name}-ncurses.patch
44 Patch3:         %{name}-bug9177_workaround.patch
45 Patch4:         %{name}-disable-valgrind.patch
46 #PatchX:        %{name}-dga.patch
47 URL:            http://www.winehq.org/
48 BuildRequires:  OpenGL-GLU-devel
49 %{?with_alsa:BuildRequires:     alsa-lib-devel}
50 %{?with_arts:BuildRequires:     artsc-devel}
51 BuildRequires:  autoconf
52 BuildRequires:  automake
53 BuildRequires:  bison
54 %{?with_cups:BuildRequires:     cups-devel}
55 BuildRequires:  docbook-dtd31-sgml
56 BuildRequires:  docbook-utils
57 BuildRequires:  flex
58 BuildRequires:  fontconfig-devel
59 BuildRequires:  fontforge
60 BuildRequires:  freetype-devel >= 2.0.5
61 BuildRequires:  giflib-devel
62 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
63 BuildRequires:  libjpeg-devel
64 BuildRequires:  libtool
65 %{?with_nas:BuildRequires:      nas-devel}
66 BuildRequires:  ncurses-devel
67 # db2* failed previously - probably openjade or opensp bug
68 BuildRequires:  openjade >= 1:1.3.3-0.pre1
69 BuildRequires:  openldap-devel
70 BuildRequires:  opensp >= 1:1.5.1
71 BuildRequires:  openssl-devel >= 0.9.7d
72 %{?with_sane:BuildRequires:     sane-backends-devel}
73 #BuildRequires: valgrind
74 BuildRequires:  xorg-lib-libXi-devel
75 BuildRequires:  xorg-lib-libXmu-devel
76 BuildRequires:  xorg-lib-libXrender-devel
77 BuildRequires:  xorg-lib-libXxf86dga-devel
78 BuildRequires:  xorg-lib-libXxf86vm-devel
79 Suggests:       binfmt-detector
80 # for winelauncher
81 Suggests:       xorg-app-xmessage
82 # for ntlm_auth
83 Suggests:       samba-common >= 1:3.0.25
84 # link to wine/ntdll.dll.so, without any SONAME
85 Provides:       libntdll.dll.so
86 Obsoletes:      wine-doc-pdf
87 Obsoletes:      wine-drv-arts
88 ExclusiveArch:  %{ix86}
89 ExcludeArch:    i386
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
93 %define         no_install_post_strip   1
94
95 %define         _winedir                %{_datadir}/%{name}
96
97 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
98
99 %undefine       debuginfocflags
100
101 %description
102 Wine is a program which allows running Microsoft Windows programs
103 (including DOS, Windows 3.x and Win32 executables) on Unix. It
104 consists of a program loader which loads and executes a Microsoft
105 Windows binary, and a library that implements Windows API calls using
106 their Unix or X11 equivalents. The library may also be used for
107 porting Win32 code into native Unix executables.
108
109 %description -l es.UTF-8
110 Ejecuta programas Windows en Linux.
111
112 %description -l pl.UTF-8
113 Wine jest programem dzięki któremu można uruchamiać programy napisane
114 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
115 loadera, który pozwala wczytywać i uruchamiać programy w formacie
116 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
117 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
118 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
119
120 %description -l pt_BR.UTF-8
121 O Wine é um programa que permite rodar programas MS-Windows no X11.
122 Ele consiste de um carregador de programa, que carrega e executa um
123 binário MS-Windows, e de uma biblioteca de emulação que traduz as
124 chamadas da API para as equivalentes Unix/X11.
125
126 %package devel
127 Summary:        Wine - header files
128 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
129 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
130 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
131 Group:          Development/Libraries
132 Requires:       %{name} = %{epoch}:%{version}-%{release}
133
134 %description devel
135 Wine - header files.
136
137 %description devel -l es.UTF-8
138 Biblioteca de desarrollo de wine.
139
140 %description devel -l pl.UTF-8
141 Wine - pliki nagłówkowe.
142
143 %description devel -l pt_BR.UTF-8
144 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
145 WINE.
146
147 %package programs
148 Summary:        Wine - programs
149 Summary(pl.UTF-8):      Wine - programy
150 Group:          Applications
151 Requires:       %{name} = %{epoch}:%{version}-%{release}
152
153 %description programs
154 Wine - programs.
155
156 %description programs -l pl.UTF-8
157 Wine - programy.
158
159 %package dll-d3d
160 Summary:        Direct3D implementation DLLs for Wine
161 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
162 Group:          Applications/Emulators
163 Requires:       %{name} = %{epoch}:%{version}-%{release}
164 Requires:       OpenGL
165
166 %description dll-d3d
167 Direct3D implementation DLLs for Wine (through OpenGL).
168
169 %description dll-d3d -l pl.UTF-8
170 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
171
172 %package dll-gl
173 Summary:        OpenGL implementation DLLs for Wine
174 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
175 Group:          Applications/Emulators
176 Requires:       %{name} = %{epoch}:%{version}-%{release}
177 Requires:       OpenGL
178
179 %description dll-gl
180 OpenGL implementation DLLs for Wine.
181
182 %description dll-gl -l pl.UTF-8
183 Biblioteki DLL z implementacją OpenGL dla Wine.
184
185 %package dll-twain
186 Summary:        TWAIN implementation DLL for Wine
187 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
188 Group:          Applications/Emulators
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190
191 %description dll-twain
192 TWAIN implementation DLL for Wine (through SANE).
193
194 %description dll-twain -l pl.UTF-8
195 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
196
197 %package drv-alsa
198 Summary:        ALSA driver for WINE mm.dll implementation
199 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
200 Group:          Applications/Emulators
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202
203 %description drv-alsa
204 ALSA driver for WINE mm.dll (multimedia system) implementation.
205
206 %description drv-alsa -l pl.UTF-8
207 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
208
209 %package drv-jack
210 Summary:        JACK driver for WINE mm.dll implementation
211 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
212 Group:          Applications/Emulators
213 Requires:       %{name} = %{epoch}:%{version}-%{release}
214 Requires:       jack-audio-connection-kit
215 # dlopened by SONAME detected at build time
216 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
217
218 %description drv-jack
219 JACK driver for WINE mm.dll (multimedia system) implementation.
220
221 %description drv-jack -l pl.UTF-8
222 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
223 Wine.
224
225 %package drv-nas
226 Summary:        NAS driver for WINE mm.dll implementation
227 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
228 Group:          Applications/Emulators
229 Requires:       %{name} = %{epoch}:%{version}-%{release}
230
231 %description drv-nas
232 NAS driver for WINE mm.dll (multimedia system) implementation.
233
234 %description drv-nas -l pl.UTF-8
235 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
236
237 %prep
238 %setup -q
239 %patch0 -p1
240 %patch1 -p1
241 %patch2 -p1
242 %patch3 -p1
243 %patch4 -p1
244
245 # turn off compilation of some tools
246 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
247 #sed -i -e "s|avitools||" programs/Makefile.in
248
249 %build
250 %{__autoconf}
251 %{__autoheader}
252 %configure \
253         %{!?debug:--disable-debug} \
254         %{!?debug:--disable-trace} \
255         --enable-curses \
256         --enable-opengl \
257         --with-x
258 %{__make} depend
259 %{__make}
260 %{__make} -C programs
261
262 %install
263 rm -rf $RPM_BUILD_ROOT
264 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
265
266 %{__make} install \
267         DESTDIR=$RPM_BUILD_ROOT
268
269 %{__make} -C programs install \
270         DESTDIR=$RPM_BUILD_ROOT
271
272 install tools/fnt2bdf                   $RPM_BUILD_ROOT%{_bindir}
273
274 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
275
276 install -d \
277         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
278         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
279         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
280         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
281         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
282
283 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
284 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
285 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
286
287 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
288 [mci]
289 cdaudio=mcicda.drv
290 sequencer=mciseq.drv
291 waveaudio=mciwave.drv
292 avivideo=mciavi.drv
293 videodisc=mcipionr.drv
294 vcr=mciviscd.drv
295 MPEGVideo=mciqtz.drv
296 EOF
297
298 %if %{?debug:0}%{!?debug:1}
299 echo "Strip executable binaries and shared object files."
300 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
301 elfexelist=`echo $filelist | xargs -r file | \
302         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
303 elfsharedlist=`echo $filelist | xargs -r file | \
304         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
305 if [ -n "$elfexelist" ]; then \
306         strip -R .note -R .comment $elfexelist
307 fi
308 if [ -n "$elfsharedlist" ]; then
309         strip --strip-unneeded -R .note -R .comment $elfsharedlist
310 fi
311 %endif
312
313 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
314
315 programs="msiexec notepad progman regedit regsvr32 uninstaller wineboot winebrowser winecfg wineconsole winedbg winefile winemine winepath"
316
317 BZZZ=`pwd`
318 rm -f files.so;         touch files.so
319 rm -f files.programs;   touch files.programs
320 cd $RPM_BUILD_ROOT%{_libdir}/wine
321 for f in *.so; do
322         case $f in
323                 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
324                         ;;
325                 *)
326                         echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
327         esac
328 done
329 cd -
330 for p in $programs; do
331         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
332         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
333         grep -v "$p\.exe\.so$" files.so > files.so.
334         mv -f files.so. files.so
335 done
336
337 install -d $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
338 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
339 install programs/winetest/winetest.svg $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
340
341 %clean
342 rm -rf $RPM_BUILD_ROOT
343
344 %post   -p /sbin/ldconfig
345 %postun -p /sbin/ldconfig
346
347 %triggerpostun -- wine < 1:0.9.12-1.9
348 rm -f /var/lock/subsys/wine
349 if [ -x /sbin/chkconfig ]; then
350         /sbin/chkconfig --del wine
351 fi
352
353 %files -f files.so
354 %defattr(644,root,root,755)
355 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
356 %lang(de) %doc documentation/README.de
357 %lang(es) %doc documentation/README.es
358 %lang(fr) %doc documentation/README.fr
359 %lang(it) %doc documentation/README.it
360 %lang(ko) %doc documentation/README.ko
361 %lang(nb) %doc documentation/README.no
362 %lang(pt) %doc documentation/README.pt
363 %lang(pt_BR) %doc documentation/README.pt_br
364 %attr(755,root,root) %{_bindir}/msiexec
365 %attr(755,root,root) %{_bindir}/wine
366 %attr(755,root,root) %{_bindir}/wineboot
367 %attr(755,root,root) %{_bindir}/winebrowser
368 %attr(755,root,root) %{_bindir}/winecfg
369 %attr(755,root,root) %{_bindir}/winedbg
370 %attr(755,root,root) %{_bindir}/wine-kthread
371 #%attr(755,root,root) %{_bindir}/winelauncher
372 %attr(755,root,root) %{_bindir}/wineprefixcreate
373 %attr(755,root,root) %{_bindir}/wine-preloader
374 %attr(755,root,root) %{_bindir}/wine-pthread
375 %attr(755,root,root) %{_bindir}/wineserver
376 %attr(755,root,root) %{_bindir}/wineshelllink
377 %attr(755,root,root) %{_libdir}/*.so*
378 %dir %{_libdir}/wine
379 %{_libdir}/wine/*.dll16
380 %{_libdir}/wine/*.drv16
381 %{_libdir}/wine/*.exe16
382 %{_libdir}/wine/*.mod16
383 %{_mandir}/man1/wine.1*
384 %{_mandir}/man1/winedbg.1*
385 %{_mandir}/man1/wineprefixcreate.1*
386 %{_mandir}/man1/wineserver.1*
387 %{_winedir}
388 %{_desktopdir}/wine.desktop
389 %{_desktopdir}/wine-uninstaller.desktop
390 %{_pixmapsdir}/wine.svg
391
392 %files programs -f files.programs
393 %defattr(644,root,root,755)
394
395 %files devel
396 %defattr(644,root,root,755)
397 %attr(755,root,root) %{_bindir}/fnt2bdf
398 %attr(755,root,root) %{_bindir}/function_grep.pl
399 %attr(755,root,root) %{_bindir}/widl
400 %attr(755,root,root) %{_bindir}/winebuild
401 %attr(755,root,root) %{_bindir}/winedump
402 %attr(755,root,root) %{_bindir}/wineg++
403 %attr(755,root,root) %{_bindir}/winegcc
404 %attr(755,root,root) %{_bindir}/winemaker
405 %attr(755,root,root) %{_bindir}/winecpp
406 #%attr(755,root,root) %{_bindir}/winewrap
407 %attr(755,root,root) %{_bindir}/wmc
408 %attr(755,root,root) %{_bindir}/wrc
409 %{_libdir}/wine/lib*.def
410 # no shared variants, so not separated
411 %{_libdir}/wine/lib*.def.a
412 %{_libdir}/wine/libadsiid.a
413 %{_libdir}/wine/libdx*.a
414 %{_libdir}/wine/libstrmiids.a
415 %{_libdir}/wine/libuuid.a
416 %{_libdir}/wine/libwinecrt0.a
417 %{_includedir}/wine
418 %{_mandir}/man1/widl.1*
419 %{_mandir}/man1/winedump.1*
420 %{_mandir}/man1/winegcc.1*
421 %{_mandir}/man1/wineg++.1*
422 %{_mandir}/man1/winemaker.1*
423 %{_mandir}/man1/winebuild.1*
424 %{_mandir}/man1/wmc.1*
425 %{_mandir}/man1/wrc.1*
426 %{_aclocaldir}/*.m4
427
428 %files dll-d3d
429 %defattr(644,root,root,755)
430 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
431 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
432 %attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
433 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
434
435 %files dll-gl
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
438 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
439
440 %if %{with sane}
441 %files dll-twain
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
444 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
445 %endif
446
447 %if %{with alsa}
448 %files drv-alsa
449 %defattr(644,root,root,755)
450 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
451 %endif
452
453 %if %{with jack}
454 %files drv-jack
455 %defattr(644,root,root,755)
456 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
457 %endif
458
459 %if %{with nas}
460 %files drv-nas
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
463 %endif
464
465 # additional dependencies in *.so not separated (yet?) from main package
466 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
467 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
468 #   ttydrv.dll.so depends on ncurses
This page took 0.073161 seconds and 3 git commands to generate.