]> git.pld-linux.org Git - packages/radsecproxy.git/blob - radsecproxy.spec
- rel.2 - upstart support
[packages/radsecproxy.git] / radsecproxy.spec
1 ####
2 # TODO:
3 # - docbook2x is required for manual build
4 Summary:        RADIUS proxy that in addition to to usual RADIUS UDP transport, also supports TLS (RadSec)
5 Name:           radsecproxy
6 Version:        1.4
7 Release:        2
8 License:        GPLv2+ or BSD-like
9 Group:          Networking/Daemons/Radius
10 Source0:        http://software.uninett.no/radsecproxy/%{name}-%{version}.tar.gz
11 # Source0-md5:  7b5248b2a7a133561cf685730824c893
12 Source1:        %{name}.init
13 Source2:        %{name}.logrotate
14 Source3:        %{name}.upstart
15 URL:            http://software.uninett.no/radsecproxy/
16 #For manual creation:
17 #BuildRequires: docbook2x-to-man
18 BuildRequires:  openssl-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 radsecproxy is a generic RADIUS proxy that in addition to to usual
23 RADIUS UDP transport, also supports TLS (RadSec). The aim is for the
24 proxy to have sufficient features to be flexible, while at the same
25 time to be small, efficient and easy to configure. Currently the
26 executable on Linux is only about 48 Kb, and it uses about 64 Kb
27 (depending on the number of peers) while running.
28
29 %package upstart
30 Summary:        Upstart job description for %{name}
31 Summary(pl.UTF-8):      Opis zadania Upstart dla %{name}
32 Group:          Daemons
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       upstart >= 0.6
35
36 %description upstart
37 Upstart job description for %{name}.
38
39 %description upstart -l pl.UTF-8
40 Opis zadania Upstart dla %{name}.
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_sysconfdir}/radsecproxy.conf.d \
52         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d,init}
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 install radsecproxy.conf-example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
58
59 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
60 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
61 install %{SOURCE3} $RPM_BUILD_ROOT/etc/init/%{name}.conf
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 /sbin/chkconfig --add %{name}
68 %service %{name} restart "RADIUS secure proxy"
69
70 %preun
71 if [ "$1" = "0" ]; then
72         %service %{name} stop
73         /sbin/chkconfig --del %{name}
74 fi
75
76 %post upstart
77 %upstart_post %{name}
78
79 %postun upstart
80 %upstart_postun %{name}
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS ChangeLog README
85 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/radsecproxy.conf
86 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
87 %attr(750,root,root) %dir %{_sysconfdir}/radsecproxy.conf.d
88 %attr(755,root,root) %{_sbindir}/radsecproxy
89 %attr(755,root,root) %{_bindir}/catgconf
90 %attr(754,root,root) /etc/rc.d/init.d/%{name}
91 %{_mandir}/man1/*
92 # With manual created:
93 #%{_mandir}/man5/*
94
95 %files upstart
96 %defattr(644,root,root,755)
97 %config(noreplace) %verify(not md5 mtime size) /etc/init/%{name}.conf
This page took 0.056018 seconds and 4 git commands to generate.