]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
- started to update to version 3.2
[packages/python3.git] / python3.spec
1 #
2 # TODO:
3 # - fix tests
4 # - check unpackaged files
5
6 # Conditional build:
7 %bcond_with     info                    # info pages (requires emacs)
8 %bcond_without  tkinter                 # disables tkinter module building
9 %bcond_without  tests                   # disables Python testing
10 %bcond_with     verbose_tests           # runs tests in verbose mode
11 #
12 # tests which will not work on 64-bit platforms
13 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
14 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16 # tests which fail because of some unknown/unresolved reason (this list should be empty)
17 %define         broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
18
19 %define beta            %{nil}
20
21 %define py_ver          3.2
22 %define py_prefix       %{_prefix}
23 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
24 %define py_incdir       %{_includedir}/python%{py_ver}
25 %define py_sitedir      %{py_libdir}/site-packages
26 %define py_dyndir       %{py_libdir}/lib-dynload
27
28 Summary:        Very high level scripting language with X interface
29 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
30 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
31 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
32 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
33 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
34 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
35 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
36 Name:           python3
37 Version:        %{py_ver}
38 Release:        0.%{beta}.1
39 Epoch:          1
40 License:        PSF
41 Group:          Applications
42 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
43 # Source0-md5:  92e94b5b6652b96349d6362b8337811d
44 Patch0:         %{name}-pythonpath.patch
45 Patch1:         %{name}-ac_fixes.patch
46 Patch2:         %{name}-lib64.patch
47 Patch3:         %{name}-noarch_to_datadir.patch
48 Patch4:         %{name}-cast-fix.patch
49 URL:            http://www.python.org/
50 BuildRequires:  autoconf
51 BuildRequires:  bluez-libs-devel
52 BuildRequires:  bzip2-devel
53 BuildRequires:  db-devel >= 4
54 %{?with_info:BuildRequires:     emacs >= 21}
55 BuildRequires:  expat-devel >= 1:1.95.7
56 BuildRequires:  file
57 BuildRequires:  gdbm-devel >= 1.8.3
58 BuildRequires:  gmp-devel >= 4.0
59 BuildRequires:  libffi-devel
60 BuildRequires:  libstdc++-devel
61 BuildRequires:  ncurses-ext-devel >= 5.2
62 BuildRequires:  openssl-devel >= 0.9.8
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-pythonprov
65 BuildRequires:  sed >= 4.0
66 BuildRequires:  sqlite3-devel >= 3.3.5
67 %{?with_info:BuildRequires:     tetex-makeindex}
68 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
69 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
70 BuildRequires:  zlib-devel
71 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         specflags_ppc   -D__ppc__=1
75 %define         specflags_ppc64 -D__ppc64__=1
76
77 %if %{with verbose_tests}
78 %define test_flags -v -l -x
79 %else
80 %define test_flags -w -l -x
81 %endif
82
83 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
84 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
85 %else
86 %define test_list %{nobuilder_tests} %{broken_tests}
87 %endif
88
89 %ifarch sparc
90 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
91 %endif
92
93 %description
94 Python is an interpreted, interactive, object-oriented programming
95 language. It incorporates modules, exceptions, dynamic typing, very
96 high level dynamic data types, and classes. Python combines remarkable
97 power with very clear syntax. It has interfaces to many system calls
98 and libraries, as well as to various window systems, and is extensible
99 in C or C++. It is also usable as an extension language for
100 applications that need a programmable interface. Finally, Python is
101 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
102 MS-DOS, Windows, Windows NT, and OS/2.
103
104 This package contains the Python binary.
105
106 %description -l de.UTF-8
107 Python ist eine interpretierte, interaktive, objektorientierte
108 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
109 Python enthält Module, Klassen, Exceptions, High-Level dynamische
110 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
111 zu vielen Systemaufrufen und Libraries, sowie verschiedene
112 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
113
114 Programmierer können neue built-in-Module für Python in C oder C++
115 schreiben. Python kann auch als Erweiterungssprache für Applikationen
116 benutzt werden, die ein programmierbares Interface brauchen. Dieses
117 Paket enthält die meisten Standard-Python-Module, und Module zum
118 Ansprechen von Tix (Tk-widget set) und RPM.
119
120 %description -l es.UTF-8
121 Python es un lenguaje de scripts interpretado orientado a objetos.
122 Contiene soporte para carga dinámica de objetos, clases, módulos y
123 excepciones.
124
125 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
126 través de código C, tornando Python fácil de usar en ambientes
127 particulares/personalizados. Este paquete Python incluye la mayoría de
128 los módulos padrón Python, junto con módulos para crear interfaces
129 para el conjunto de componentes Tix para Tk y RPM.
130
131 %description -l fr.UTF-8
132 Python est un langage de script interprété et orienté objet. Il gère
133 le chargement dynamique des objets, les classes, les modules et les
134 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
135 avec du code C est simple, ce qui rend Python facile à utiliser dans
136 des configs personnalisées.
137
138 Ce paquetage Python contient la plupart des modules Python standards,
139 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
140 et RPM.
141
142 %description -l pl.UTF-8
143 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
144 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
145 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
146 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
147 wielu wywołań systemowych i bibliotek, w tym również do różnych
148 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
149 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
150 użyty jako element aplikacji, którym potrzebny jest interpreter do
151 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
152 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
153 OS/2.
154
155 Ten pakiet zawiera binarkę Pythona.
156
157 %description -l pt_BR.UTF-8
158 Python é uma linguagem de scripts interpretada orientada a objetos.
159 Contém suporte para carga dinâmica de objetos, classes, módulos e
160 exceções. Adicionar interfaces para novos sistemas de biblioteca
161 através de código C é simples, tornando Python fácil de usar em
162 ambientes particulares/personalizados.
163
164 Este pacote Python inclui a maioria do módulos padrão Python, junto
165 com módulos para interfaceamento para o conjunto de componentes Tix
166 para Tk e RPM.
167
168 %description -l ru.UTF-8
169 Python - это интерпретируемый, объектно-ориентированный язык
170 программирования. Он поддерживает динамическую загрузку объектов,
171 классы, модули и обработку исключительных ситуаций (exceptions).
172 Простота добавления интерфейсов к новым системным библиотекам через
173 код на языке C делает Python хорошим выбором для использования в
174 специальных конфигурациях.
175
176 %description -l tr.UTF-8
177 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
178 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
179 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
180 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
181 arayüz birimlerini de içerir.
182
183 %description -l uk.UTF-8
184 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
185 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
186 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
187 нових системних бібліотек через код на мові C робить Python добрим
188 вибором для використання в спеціальних конфігураціях.
189
190 %package libs
191 Summary:        Python library
192 Summary(pl.UTF-8):      Biblioteka języka Python
193 Group:          Libraries/Python
194 # broken detection in rpm/pythondeps.sh
195 Provides:       python(abi) = %{py_ver}
196 # for compatibility with existing Ac packages
197 Provides:       python(bytecode) = %{py_ver}
198 %{!?with_info:Obsoletes:        python3-doc-info}
199
200 %description libs
201 Python shared library and very essental modules for Python binary.
202
203 %description libs -l pl.UTF-8
204 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
205 dla Pythona.
206
207 %package modules
208 Summary:        Python modules
209 Summary(pl.UTF-8):      Moduły języka Python
210 Group:          Libraries/Python
211 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
212 Obsoletes:      python3-modules-sqlite
213
214 %description modules
215 Python officially distributed modules.
216
217 %description modules -l pl.UTF-8
218 Oficjalnie rozprowadzane moduły języka Python.
219
220 %package -n pydoc3
221 Summary:        Python interactive module documentation access support
222 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
223 Group:          Applications
224 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
225
226 %description -n pydoc3
227 Python interactive module documentation access support.
228
229 %description -n pydoc3 -l pl.UTF-8
230 Interaktywne korzystanie z dokumentacji modułów języka Python.
231
232 %package -n idle3
233 Summary:        IDE for Python language
234 Summary(pl.UTF-8):      IDE dla języka Python
235 Group:          Applications
236 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
237
238 %description -n idle3
239 IDE for Python language.
240
241 %description -n idle3 -l pl.UTF-8
242 IDE dla języka Python.
243
244 %package devel
245 Summary:        Libraries and header files for building python code
246 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
247 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
248 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
249 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
250 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
251 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
252 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
253 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
254 Group:          Development/Languages/Python
255 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
256
257 %description devel
258 The Python interpreter is relatively easy to extend with dynamically
259 loaded extensions and to embed in other programs. This package
260 contains the header files and libraries which are needed to do both of
261 these tasks.
262
263 %description devel -l de.UTF-8
264 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
265 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
266 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
267 die für beide Aufgaben erforderlich sind.
268
269 %description devel -l es.UTF-8
270 El interpretador Python permite incluir con facilidad extensiones
271 cargadas dinámicamente. Python es también fácil de ser empotrado en
272 otros programas. Este paquete contiene los archivos de inclusión y
273 bibliotecas necesarios para estas dos tareas.
274
275 %description devel -l fr.UTF-8
276 L'interpréteur Python est relativement facile à étendre avec des
277 extensions chargées dynamiquement et à insérer dans d'autres
278 programmes. Ce paquetage contient les en-têtes et les bibliothèques
279 nécessaires à ces deux tâches.
280
281 %description devel -l pl.UTF-8
282 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
283 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
284 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
285 wszystko inne co potrzebne do tych celów.
286
287 %description devel -l pt_BR.UTF-8
288 O interpretador Python permite incluir com facilidade extensões
289 carregadas dinamicamente. Python é também fácil de ser embutido em
290 outros programas. Este pacote contém os arquivos de inclusão e
291 bibliotecas necessários para estas duas tarefas.
292
293 %description devel -l ru.UTF-8
294 Интерпретатор Python относительно легко расширяется при помощи
295 динамически загружаемых расширений и встраивается в другие программы.
296 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
297 задач.
298
299 %description devel -l tr.UTF-8
300 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
301 dosyalarını ve kitaplıkları içerir.
302
303 %description devel -l uk.UTF-8
304 Інтерпретатор Python відносно легко розширюється за допомогою
305 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
306 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
307
308 %package devel-src
309 Summary:        Python module sources
310 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
311 Group:          Development/Languages/Python
312 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
313
314 %description devel-src
315 Python module sources.
316
317 %description devel-src -l pl.UTF-8
318 Pliki źródłowe modułów Pythona.
319
320 %package devel-tools
321 Summary:        Python development tools
322 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
323 Group:          Development/Languages/Python
324 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
325
326 %description devel-tools
327 Python development tools such as profilers and debugger.
328
329 %description devel-tools -l pl.UTF-8
330 Narzędzia programistyczne języka Python takie jak profiler oraz
331 debugger.
332
333 %package 2to3
334 Summary:        Automated Python 2 to 3 code translation
335 Summary(pl.UTF-8):      Automatyczne tłumaczenie kody Pythona 2 do 3
336 Group:          Development/Languages/Pythona
337
338 %description 2to3
339 2to3 is a Python program that reads Python 2.x source code and applies a series
340 of fixers to transform it into valid Python 3.x code. The standard library
341 contains a rich set of fixers that will handle almost all code. 2to3 supporting
342 library lib2to3 is, however, a flexible and generic library, so it is possible
343 to write your own fixers for 2to3. lib2to3 could also be adapted to custom
344 applications in which Python code needs to be edited automatically.
345
346 %package static
347 Summary:        Static python library
348 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
349 Group:          Development/Languages/Python
350 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
351
352 %description static
353 Static python library.
354
355 %description static -l pl.UTF-8
356 Statyczna biblioteka Pythona.
357
358 %package doc-info
359 Summary:        Documentation on Python in texinfo format
360 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
361 Group:          Documentation
362
363 %description doc-info
364 Documentation on Python in texinfo format.
365
366 %description doc-info -l pl.UTF-8
367 Dokumentacja do Pythona w formacie texinfo.
368
369 %package tkinter
370 Summary:        Standard Python interface to the Tk GUI toolkit
371 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
372 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
373 Summary(fr.UTF-8):      Interface graphique Tk pour Python
374 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
375 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
376 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
377 Group:          Libraries/Python
378 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
379 Requires:       tcl >= 8.4.3
380 Requires:       tix >= 1:8.1.4-4
381 Requires:       tk >= 8.4.3
382
383 %description tkinter
384 Standard Python interface to the Tk GUI toolkit.
385
386 %description tkinter -l de.UTF-8
387 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
388 vielen Konfigurations-Tools genutzt.
389
390 %description tkinter -l es.UTF-8
391 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
392 herramientas de configuración.
393
394 %description tkinter -l fr.UTF-8
395 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
396 beaucoup des outils de configuration.
397
398 %description tkinter -l pl.UTF-8
399 Standardowy interfejs Pythona do biblioteki Tk.
400
401 %description tkinter -l pt_BR.UTF-8
402 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
403 muitas ferramentas de configuração.
404
405 %description tkinter -l ru.UTF-8
406 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
407
408 %description tkinter -l tr.UTF-8
409 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
410 kullanılan grafik bir arayüzdür.
411
412 %description tkinter -l uk.UTF-8
413 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
414
415 %package examples
416 Summary:        Example programs in Python
417 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
418 Group:          Development/Languages/Python
419
420 %description examples
421 Example programs in Python.
422
423 These are for Python 2.3.4, not %{version}.
424
425 %description examples -l pl.UTF-8
426 Przykładowe programy w Pythonie.
427
428 Przykłady te są dla Pythona 2.3.4, nie %{version}.
429
430 %prep
431 %setup -q -n Python-%{version}%{beta}
432 %patch0 -p1
433 %patch1 -p1
434 #%patch2 -p1
435 #%patch3 -p1
436 #%patch4 -p1
437
438 %build
439 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
440 %{__autoconf}
441 CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
442 %configure \
443         --with-cxx-main="%{__cxx}" \
444         --enable-shared \
445         --enable-ipv6 \
446         --with-dbmliborder=gdbm:bdb \
447         --with-wide-unicode \
448         --with-signal-module \
449         --with-tsc \
450         --with-threads \
451         --with-doc-strings \
452         --with-fpectl \
453         --with-system-ffi \
454         --with-computed-gotos \
455         LINKCC='$(PURIFY) $(CXX)' \
456         LDSHARED='$(CC) $(CFLAGS) -shared' \
457         BLDSHARED='$(CC) $(CFLAGS) -shared' \
458         LDFLAGS="%{rpmcflags} %{rpmldflags}"
459
460 %{__make} \
461         OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
462 BEGIN { fail = 0; logmsg = ""; }
463 {
464         if ($0 ~ /\*\*\* WARNING:/) {
465                 fail = 1;
466                 logmsg = logmsg $0;
467         }
468         print $0;
469 }
470 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
471
472 LC_ALL=C
473 export LC_ALL
474 %if %{with tests}
475 binlibdir=`echo build/lib.*`
476 %{__make} test \
477         TESTOPTS="%{test_flags} %{test_list}" \
478         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
479 %endif
480
481 %install
482 rm -rf $RPM_BUILD_ROOT
483 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
484         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
485         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
486         $RPM_BUILD_ROOT%{_infodir} \
487         $RPM_BUILD_ROOT/etc/shrc.d
488
489 %{__make} install \
490         DESTDIR=$RPM_BUILD_ROOT
491
492 %if %{with info}
493 %{__make} -C Doc/info
494 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
495 %endif
496
497 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
498 cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
499
500 #
501 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
502 #
503
504 # for python devel tools
505 for script in timeit profile pdb pstats; do
506     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
507 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
508
509 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
510         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
511
512 sed 's/=/ /' \
513         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
514         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
515
516 # for python modules
517 for script in smtpd webbrowser; do
518     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
519 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
520
521 sed 's/=/ /' \
522         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
523         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
524
525 # xgettext specific for Python code
526 #
527 # we will have two commands: pygettext.py (an alias) and pygettext;
528 # this way there are no import (which is impossible now) conflicts and
529 # pygettext.py is provided for compatibility
530 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
531
532 # rename file conflicting with python 2.*
533 mv $RPM_BUILD_ROOT%{_bindir}/2to3{,-%{py_ver}}
534
535 # just to cut the noise, as they are not packaged (now)
536 # first tests
537 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
538 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
539 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
540 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
541 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
542 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
543 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
544 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
545 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
546 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
547
548 # other files
549 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
550 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
551 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
552 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
553 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
554 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
555 rm -rf $RPM_BUILD_ROOT%{_bindir}/smtpd.py
556 # already in %%doc
557 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
558 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
559
560 %clean
561 rm -rf $RPM_BUILD_ROOT
562
563 %post   libs -p /sbin/ldconfig
564 %postun libs -p /sbin/ldconfig
565
566 %post doc-info  -p      /sbin/postshell
567 -/usr/sbin/fix-info-dir -c %{_infodir}
568
569 %postun doc-info        -p      /sbin/postshell
570 -/usr/sbin/fix-info-dir -c %{_infodir}
571
572 %files
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_bindir}/python%{py_ver}
575 %attr(755,root,root) %{_bindir}/python3
576 %{_mandir}/man1/python*.1*
577
578 %files modules
579 %defattr(644,root,root,755)
580 /etc/shrc.d/python*-modules*
581 %exclude %{py_scriptdir}/_abcoll.py[co]
582 %exclude %{py_scriptdir}/_weakrefset.py[co]
583 %exclude %{py_scriptdir}/abc.py[co]
584 %exclude %{py_scriptdir}/codecs.py[co]
585 %exclude %{py_scriptdir}/copyreg.py[co]
586 %exclude %{py_scriptdir}/genericpath.py[co]
587 %exclude %{py_scriptdir}/io.py[co]
588 %exclude %{py_scriptdir}/locale.py[co]
589 %exclude %{py_scriptdir}/posixpath.py[co]
590 %exclude %{py_scriptdir}/pdb.py[co]
591 %exclude %{py_scriptdir}/profile.py[co]
592 %exclude %{py_scriptdir}/pstats.py[co]
593 %exclude %{py_scriptdir}/pydoc.py[co]
594 %exclude %{py_scriptdir}/site.py[co]
595 %exclude %{py_scriptdir}/stat.py[co]
596 %exclude %{py_scriptdir}/timeit.py[co]
597 %exclude %{py_scriptdir}/os.py[co]
598 %exclude %{py_scriptdir}/encodings/*.py[co]
599 %exclude %{py_scriptdir}/types.py[co]
600
601 %{py_scriptdir}/*.py[co]
602
603 %{py_dyndir}/*.egg-info
604
605 #
606 # list .so modules to be sure that all of them are built
607 #
608
609 # modules below do not work on 64-bit architectures
610 # see Python README file for explanation
611 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
612 %attr(755,root,root) %{py_dyndir}/audioop.so
613 %endif
614
615 %attr(755,root,root) %{py_dyndir}/array.so
616 %attr(755,root,root) %{py_dyndir}/atexit.so
617 %attr(755,root,root) %{py_dyndir}/audioop.so
618 %attr(755,root,root) %{py_dyndir}/binascii.so
619 %attr(755,root,root) %{py_dyndir}/_bisect.so
620 %attr(755,root,root) %{py_dyndir}/bz2.so
621 %attr(755,root,root) %{py_dyndir}/cmath.so
622 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
623 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
624 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
625 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
626 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
627 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
628 %attr(755,root,root) %{py_dyndir}/_collections.so
629 %attr(755,root,root) %{py_dyndir}/crypt.so
630 %attr(755,root,root) %{py_dyndir}/_csv.so
631 %attr(755,root,root) %{py_dyndir}/_ctypes*.so
632 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
633 %attr(755,root,root) %{py_dyndir}/_curses.so
634 %attr(755,root,root) %{py_dyndir}/datetime.so
635 %attr(755,root,root) %{py_dyndir}/_elementtree.so
636 #%attr(755,root,root) %{py_dyndir}/_functools.so
637 %attr(755,root,root) %{py_dyndir}/_hashlib.so
638 %attr(755,root,root) %{py_dyndir}/_heapq.so
639 %attr(755,root,root) %{py_dyndir}/_json.so
640 #%attr(755,root,root) %{py_dyndir}/_locale.so
641 %attr(755,root,root) %{py_dyndir}/_lsprof.so
642 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
643 %attr(755,root,root) %{py_dyndir}/_multiprocessing.so
644 %attr(755,root,root) %{py_dyndir}/_pickle.so
645 %attr(755,root,root) %{py_dyndir}/_random.so
646 %attr(755,root,root) %{py_dyndir}/_socket.so
647 %attr(755,root,root) %{py_dyndir}/_ssl.so
648 %attr(755,root,root) %{py_dyndir}/_testcapi.so
649 %ifnarch sparc64
650 %attr(755,root,root) %{py_dyndir}/_dbm.so
651 %endif
652 %attr(755,root,root) %{py_dyndir}/fcntl.so
653 %attr(755,root,root) %{py_dyndir}/_gdbm.so
654 %attr(755,root,root) %{py_dyndir}/grp.so
655 %attr(755,root,root) %{py_dyndir}/itertools.so
656 %attr(755,root,root) %{py_dyndir}/math.so
657 %attr(755,root,root) %{py_dyndir}/mmap.so
658 %attr(755,root,root) %{py_dyndir}/nis.so
659 %attr(755,root,root) %{py_dyndir}/operator.so
660 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
661 %attr(755,root,root) %{py_dyndir}/parser.so
662 %attr(755,root,root) %{py_dyndir}/pyexpat.so
663 %attr(755,root,root) %{py_dyndir}/readline.so
664 %attr(755,root,root) %{py_dyndir}/resource.so
665 %attr(755,root,root) %{py_dyndir}/select.so
666 %attr(755,root,root) %{py_dyndir}/syslog.so
667 %attr(755,root,root) %{py_dyndir}/termios.so
668 %attr(755,root,root) %{py_dyndir}/time.so
669 %attr(755,root,root) %{py_dyndir}/spwd.so
670 %attr(755,root,root) %{py_dyndir}/unicodedata.so
671 %attr(755,root,root) %{py_dyndir}/zlib.so
672
673 %dir %{py_scriptdir}/plat-*
674 %{py_scriptdir}/plat-*/*.py[co]
675
676 %dir %{py_scriptdir}/ctypes
677 %dir %{py_scriptdir}/ctypes/macholib
678
679 %{py_scriptdir}/ctypes/*.py[co]
680 %{py_scriptdir}/ctypes/macholib/*.py[co]
681 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
682
683 %dir %{py_scriptdir}/curses
684 %{py_scriptdir}/curses/*.py[co]
685
686 %dir %{py_scriptdir}/dbm
687 %{py_scriptdir}/dbm/*.py[co]
688
689 %dir %{py_scriptdir}/distutils
690 %dir %{py_scriptdir}/distutils/command
691 %doc %{py_scriptdir}/distutils/README
692 %{py_scriptdir}/distutils/*.py[co]
693 %{py_scriptdir}/distutils/command/*.py[co]
694 %{py_scriptdir}/distutils/command/command_template
695
696 %dir %{py_scriptdir}/email
697 %dir %{py_scriptdir}/email/mime
698 %{py_scriptdir}/email/*.py[co]
699 %{py_scriptdir}/email/mime/*.py[co]
700
701 %dir %{py_scriptdir}/html
702 %{py_scriptdir}/html/*.py[co]
703
704 %dir %{py_scriptdir}/http
705 %{py_scriptdir}/http/*.py[co]
706
707 %dir %{py_scriptdir}/importlib
708 %{py_scriptdir}/importlib/*.py[co]
709
710 %dir %{py_scriptdir}/json
711 %{py_scriptdir}/json/*.py[co]
712
713 %dir %{py_scriptdir}/logging
714 %{py_scriptdir}/logging/*.py[co]
715
716 %dir %{py_scriptdir}/multiprocessing
717 %{py_scriptdir}/multiprocessing/*.py[co]
718 %dir %{py_scriptdir}/multiprocessing/dummy
719 %{py_scriptdir}/multiprocessing/dummy/*.py[co]
720
721 %dir %{py_scriptdir}/urllib
722 %{py_scriptdir}/urllib/*.py[co]
723
724 %dir %{py_scriptdir}/wsgiref
725 %{py_scriptdir}/wsgiref/*.py[co]
726 %{py_scriptdir}/wsgiref.egg-info
727
728 %dir %{py_scriptdir}/xml
729 %dir %{py_scriptdir}/xml/dom
730 %dir %{py_scriptdir}/xml/etree
731 %dir %{py_scriptdir}/xml/parsers
732 %dir %{py_scriptdir}/xml/sax
733 %{py_scriptdir}/xml/*.py[co]
734 %{py_scriptdir}/xml/dom/*.py[co]
735 %{py_scriptdir}/xml/etree/*.py[co]
736 %{py_scriptdir}/xml/parsers/*.py[co]
737 %{py_scriptdir}/xml/sax/*.py[co]
738
739 %dir %{py_scriptdir}/xmlrpc
740 %{py_scriptdir}/xmlrpc/*.py[co]
741
742 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
743 %dir %{py_scriptdir}/sqlite3
744 %{py_scriptdir}/sqlite3/*.py[co]
745
746 %files libs
747 %defattr(644,root,root,755)
748 %doc LICENSE
749 %attr(755,root,root) %{_libdir}/libpython*.so.*
750
751 %dir %{py_dyndir}
752 %dir %{py_scriptdir}
753 %dir %{py_libdir}
754 %dir %{py_sitescriptdir}
755 %dir %{py_sitedir}
756
757 # shared modules required by python library
758 %attr(755,root,root) %{py_dyndir}/_struct.so
759
760 # modules required by python library
761 %{py_scriptdir}/_abcoll.py[co]
762 %{py_scriptdir}/_weakrefset.py[co]
763 %{py_scriptdir}/abc.py[co]
764 %{py_scriptdir}/codecs.py[co]
765 %{py_scriptdir}/copyreg.py[co]
766 %{py_scriptdir}/genericpath.py[co]
767 %{py_scriptdir}/locale.py[co]
768 %{py_scriptdir}/io.py[co]
769 %{py_scriptdir}/posixpath.py[co]
770 %{py_scriptdir}/site.py[co]
771 %{py_scriptdir}/stat.py[co]
772 %{py_scriptdir}/os.py[co]
773 # needed by the dynamic sys.lib patch
774 %{py_scriptdir}/types.py[co]
775
776 # encodings required by python library
777 %dir %{py_scriptdir}/encodings
778 %{py_scriptdir}/encodings/*.py[co]
779
780 %files -n pydoc3
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_bindir}/pydoc3
783 %{py_scriptdir}/pydoc.py[co]
784 %dir %{py_scriptdir}/pydoc_data
785 %{py_scriptdir}/pydoc_data/*.py[co]
786
787 %files -n idle3
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_bindir}/idle3
790 %dir %{py_scriptdir}/idlelib
791 %dir %{py_scriptdir}/idlelib/Icons
792 %{py_scriptdir}/idlelib/*.py[co]
793 %doc %{py_scriptdir}/idlelib/*.txt
794 %doc %{py_scriptdir}/idlelib/ChangeLog
795 %{py_scriptdir}/idlelib/Icons/*
796 %{py_scriptdir}/idlelib/*.def
797
798 %files devel
799 %defattr(644,root,root,755)
800 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
801 %attr(755,root,root) %{_bindir}/python*-config
802 %attr(755,root,root) %{_libdir}/lib*.so
803 %dir %{py_incdir}
804 %{py_incdir}/*.h
805 %{_pkgconfigdir}/python*.pc
806
807 %dir %{py_libdir}/config
808 %attr(755,root,root) %{py_libdir}/config/makesetup
809 %attr(755,root,root) %{py_libdir}/config/install-sh
810 %{py_libdir}/config/Makefile
811 %{py_libdir}/config/Makefile.pre.in
812 %{py_libdir}/config/Setup
813 %{py_libdir}/config/Setup.config
814 %{py_libdir}/config/Setup.local
815 %{py_libdir}/config/config.c
816 %{py_libdir}/config/config.c.in
817 %{py_libdir}/config/python.o
818
819 %files devel-src
820 %defattr(644,root,root,755)
821 %attr(-,root,root) %{py_scriptdir}/*.py
822 %{py_scriptdir}/plat-*/*.py
823 %{py_scriptdir}/ctypes/*.py
824 %{py_scriptdir}/ctypes/macholib/*.py
825 %{py_scriptdir}/curses/*.py
826 %{py_scriptdir}/dbm/*.py
827 %{py_scriptdir}/distutils/*.py
828 %{py_scriptdir}/distutils/command/*.py
829 %{py_scriptdir}/email/*.py
830 %{py_scriptdir}/email/mime/*.py
831 %{py_scriptdir}/encodings/*.py
832 %{py_scriptdir}/html/*.py
833 %{py_scriptdir}/http/*.py
834 %{py_scriptdir}/idlelib/*.py
835 %{py_scriptdir}/importlib/*.py
836 %{py_scriptdir}/json/*.py
837 %{py_scriptdir}/lib2to3/*.py
838 %{py_scriptdir}/lib2to3/pgen2/*.py
839 %{py_scriptdir}/logging/*.py
840 %{py_scriptdir}/multiprocessing/*.py
841 %{py_scriptdir}/multiprocessing/dummy/*.py
842 %{py_scriptdir}/pydoc_data/*.py
843 %{py_scriptdir}/sqlite3/*.py
844 %{py_scriptdir}/tkinter/*.py
845 %{py_scriptdir}/urllib/*.py
846 %{py_scriptdir}/wsgiref/*.py
847 %{py_scriptdir}/xml/*.py
848 %{py_scriptdir}/xml/dom/*.py
849 %{py_scriptdir}/xml/etree/*.py
850 %{py_scriptdir}/xml/parsers/*.py
851 %{py_scriptdir}/xml/sax/*.py
852 %{py_scriptdir}/xmlrpc/*.py
853
854 %files devel-tools
855 %defattr(644,root,root,755)
856 %doc Lib/pdb.doc
857 /etc/shrc.d/python*-devel*
858
859 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
860
861 %{py_scriptdir}/pdb.py[co]
862 %{py_scriptdir}/profile.py[co]
863 %{py_scriptdir}/pstats.py[co]
864 %{py_scriptdir}/timeit.py[co]
865
866 %files 2to3
867 %attr(755,root,root) %{_bindir}/2to3-%{py_ver}
868 %dir %{py_scriptdir}/lib2to3
869 %{py_scriptdir}/lib2to3/*.txt
870 %{py_scriptdir}/lib2to3/*.pickle
871 %{py_scriptdir}/lib2to3/*.py[co]
872 %dir %{py_scriptdir}/lib2to3/fixes
873 %{py_scriptdir}/lib2to3/fixes/*.py
874 %{py_scriptdir}/lib2to3/fixes/*.py[co]
875 %dir %{py_scriptdir}/lib2to3/pgen2
876 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
877
878 %files static
879 %defattr(644,root,root,755)
880 %{_libdir}/lib*.a
881
882 %files examples
883 %defattr(644,root,root,755)
884 %{_examplesdir}/%{name}-%{version}
885
886 %if %{with info}
887 %files doc-info
888 %defattr(644,root,root,755)
889 %{_infodir}/*.info*
890 %endif
891
892 %if %{with tkinter}
893 %files tkinter
894 %defattr(644,root,root,755)
895 %dir %{py_scriptdir}/tkinter
896 %{py_scriptdir}/tkinter/*.py[co]
897 %attr(755,root,root) %{py_dyndir}/_tkinter.so
898 %endif
This page took 0.178068 seconds and 4 git commands to generate.