]> git.pld-linux.org Git - packages/python-SOAP.git/blob - python-SOAP.spec
- new URLs, updated to 0.12.22; still not python3 ready
[packages/python-SOAP.git] / python-SOAP.spec
1 # TODO: how to run tests in %build?
2 Summary:        A SOAP library for Python
3 Summary(pl.UTF-8):      Biblioteka SOAP dla Pythona
4 Name:           python-SOAP
5 Version:        0.12.22
6 Release:        1
7 License:        BSD
8 Group:          Libraries/Python
9 #Source0Download: https://github.com/kiorky/SOAPpy/releases
10 Source0:        https://github.com/kiorky/SOAPpy/archive/%{version}/SOAPpy-%{version}.tar.gz
11 # Source0-md5:  c93de2e7827bcbb6841a8a0ca1de5c59
12 Patch0:         %{name}-urltry.patch
13 URL:            https://github.com/kiorky/SOAPpy
14 BuildRequires:  python-devel >= 1:2.3
15 BuildRequires:  python-setuptools
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.714
18 BuildRequires:  sed >= 4.0
19 Requires:       python-modules
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Web services for Python programmers, both client and servers. This
25 includes SOAP, WSDL, UDDI, etc.
26
27 %description -l pl.UTF-8
28 Serwisy WWW dla programistów Pythona, zarówno klient i serwery. W tym
29 SOAP, WSDL, UDDI itp.
30
31 %prep
32 %setup -q -n SOAPpy-%{version}
33 %patch0 -p1
34 rm -f src/SOAPpy/*.orig
35
36 %build
37 %py_build
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %py_install
43
44 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
45 cp -pr bid contrib tests tools validate $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
46 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/*.py
47 %{__sed} -i -e '1s,#!/usr/bin/python\s*$,#!%{__python},' $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/tests/testleak.py
48
49 %py_postclean
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc CHANGES.txt LICENSE README.txt TODO old.Changelog docs/*.txt
57 %dir %{py_sitescriptdir}/SOAPpy
58 %{py_sitescriptdir}/SOAPpy/*.py[co]
59 %if "%{py_ver}" > "2.4"
60 %{py_sitescriptdir}/SOAPpy-%{version}-py2.7.egg-info
61 %endif
62 %{_examplesdir}/%{name}-%{version}
This page took 0.039193 seconds and 4 git commands to generate.