]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
- fixed build requirements and install section
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 Summary:        Python interface to OpenSSL
2 Name:           python-M2Crypto
3 Version:        0.06
4 Release:        1
5 License:        BSD-style
6 Source0:        http://www.pobox.org.sg/home/ngps/m2/m2crypto-%{version}.zip
7 URL:            http://www.pobox.org.sg/home/ngps/m2/
8 Group:          Development/Languages/Python
9 Group(de):      Entwicklung/Sprachen/Python
10 Group(pl):      Programowanie/Jêzyki/Python
11 %requires_eq    python
12 BuildRequires:  python-devel >= 1.5.2
13 BuildRequires:  openssl-devel >= 0.9.6
14 BuildRequires:  swig 
15 BuildRequires:  rpm-pythonprov
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %include /usr/lib/rpm/macros.python
19
20 %description
21 M2Crypto makes accessible to the Python programmer the following:
22 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
23 - SSL functionality to implement clients and servers.
24 - S/MIME v2.
25
26 M2Crypto is released under a very liberal BSD-style licence. See 
27 LICENCE for details.
28
29 %prep
30 %setup -q -n m2crypto-%{version}
31
32 %build
33 make -C swig INCLUDE="-I. -I%{py_incdir}"
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{py_sitedir}
38
39 cp -a M2Crypto $RPM_BUILD_ROOT%{py_sitedir}
40 %{py_comp} $RPM_BUILD_ROOT%{py_sitedir}
41 %{py_ocomp} $RPM_BUILD_ROOT%{py_sitedir}
42
43 gzip -9nf BUGS CHANGES INSTALL LICENCE README STORIES
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc *.gz doc/*.html demo 
51 %{py_sitedir}/M2Crypto
This page took 0.048189 seconds and 4 git commands to generate.