]> git.pld-linux.org Git - packages/python-M2Crypto.git/commitdiff
- fixed build requirements and install section
authorwrobell <wrobell@pld-linux.org>
Mon, 12 Nov 2001 15:50:34 +0000 (15:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- use standard python macros

Changed files:
    python-M2Crypto.spec -> 1.4

python-M2Crypto.spec

index b9b905ce40e5b777620cd985cd17153e374cd1de..934e9a194a7c695fdb311474159b5de30257bfc3 100644 (file)
@@ -8,19 +8,14 @@ URL:          http://www.pobox.org.sg/home/ngps/m2/
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
-Requires:      python >= 1.5.2
+%requires_eq   python
 BuildRequires: python-devel >= 1.5.2
 BuildRequires: openssl-devel >= 0.9.6
 BuildRequires: swig 
+BuildRequires: rpm-pythonprov
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
-%define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
-%define python_includedir  %{_includedir}/python%{python_version}
-%define python_libdir      %{python_prefix}/lib/python%{python_version}
-%define python_sitedir     %{python_libdir}/site-packages
-%define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
-%define python_compile     python -c "import compileall; compileall.compile_dir('.')"
+%include /usr/lib/rpm/macros.python
 
 %description
 M2Crypto makes accessible to the Python programmer the following:
@@ -35,17 +30,15 @@ LICENCE for details.
 %setup -q -n m2crypto-%{version}
 
 %build
-make -C swig INCLUDE="-I. -I%{python_includedir}"
-cd M2Crypto
-%{python_compile}
-%{python_compile_opt}
+make -C swig INCLUDE="-I. -I%{py_incdir}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{python_sitedir}
+install -d $RPM_BUILD_ROOT%{py_sitedir}
 
-find M2Crypto -name \*.py | xargs -r rm -f
-cp -a M2Crypto $RPM_BUILD_ROOT%{python_sitedir}
+cp -a M2Crypto $RPM_BUILD_ROOT%{py_sitedir}
+%{py_comp} $RPM_BUILD_ROOT%{py_sitedir}
+%{py_ocomp} $RPM_BUILD_ROOT%{py_sitedir}
 
 gzip -9nf BUGS CHANGES INSTALL LICENCE README STORIES
 
@@ -55,4 +48,4 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc *.gz doc/*.html demo 
-%{python_sitedir}/M2Crypto
+%{py_sitedir}/M2Crypto
This page took 0.131971 seconds and 4 git commands to generate.