]> git.pld-linux.org Git - packages/php-pecl-xslcache.git/blob - php-pecl-xslcache.spec
- initial
[packages/php-pecl-xslcache.git] / php-pecl-xslcache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         modname xslcache
6 Summary:        %{modname} - A modification of PHP's standard XSL extension that caches the parsed XSL stylesheet representation
7 Summary(pl.UTF-8):      %{modname} - modyfikacja standardowego rozszerzenia XSL PHP, które buforuje przetworzone reprezentacje arkuszów stylów XSL
8 Name:           php-pecl-%{modname}
9 Version:        0.7.1
10 Release:        1
11 License:        PHP 3.01
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
14 # Source0-md5:  1e32327f62122055ece6f78fa2b851b2
15 URL:            http://pecl.php.net/package/xslcache
16 BuildRequires:  libxslt
17 BuildRequires:  php-devel >= 3:5.0.0
18 BuildRequires:  rpmbuild(macros) >= 1.519
19 %{?requires_php_extension}
20 Requires:       php-common >= 4:5.0.4
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The XSL Cache extension is a modification of PHP's standard XSL
25 extension that caches the parsed XSL stylesheet representation between
26 sessions for 2.5x boost in performance for sites that repeatedly apply
27 the same transform. Although there is still some further work that
28 could be done on the extension, this code is already proving
29 beneficial in production use for a few applications on the New York
30 Times' website.
31
32 #%description -l pl.UTF-8
33
34 %prep
35 %setup -q -c
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %configure \
41         --with-xslcache=%{_libdir} \
42         --with-xsl-exsl-dir=%{_libdir}
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 #install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
48 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
49 #install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
50
51 %{__make} install \
52         INSTALL_ROOT=$RPM_BUILD_ROOT \
53         EXTENSION_DIR=%{php_extensiondir}
54 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
55 ; Enable %{modname} extension module
56 extension=%{modname}.so
57 EOF
58
59 #cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %php_webserver_restart
66
67 %postun
68 if [ "$1" = 0 ]; then
69         %php_webserver_restart
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc CREDITS EXPERIMENTAL
75 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
76 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
77 #%{_examplesdir}/%{name}-%{version}
This page took 0.065561 seconds and 4 git commands to generate.