]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blob - php-pecl-ssh2.spec
- updated to 0.6
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
1 %define         _modname        ssh2
2 %define         _status         beta
3
4 Summary:        %{_modname} - bindings for the libssh2 library
5 Summary(pl):    %{_modname} - dowi±zania do biblioteki libssh2
6 Name:           php-pecl-%{_modname}
7 Version:        0.6
8 Release:        1
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  ca8865727be13840e717de8d499d0768
13 URL:            http://pecl.php.net/package/ssh2/
14 BuildRequires:  libssh2-devel >= 0.5
15 BuildRequires:  libtool
16 BuildRequires:  openssl-devel >= 0.9.7d
17 BuildRequires:  php-devel >= 3:5.0.0
18 Requires:       php-common >= 3:5.0.0
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sysconfdir     /etc/php
23 %define         extensionsdir   %{_libdir}/php
24
25 %description
26 Provides bindings to the functions of libssh2 which implements the
27 SSH2 protocol.
28
29 In PECL status of this extension is: %{_status}.
30
31 %description -l pl
32 Dostarcza dowi±zañ do ró¿nych funkcji biblioteki libssh2
33 implementuj±cej protokó³ SSH2.
34
35 To rozszerzenie ma w PECL status: %{_status}.
36
37 %prep
38 %setup -q -c
39
40 %build
41 cd %{_modname}-%{version}
42 phpize
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{extensionsdir}
49
50 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
57
58 %preun
59 if [ "$1" = "0" ]; then
60         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.038391 seconds and 4 git commands to generate.