]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blob - php-pecl-ssh2.spec
- release 6 (by relup.sh)
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname ssh2
3 %define         status  beta
4 Summary:        %{modname} - bindings for the libssh2 library
5 Summary(pl.UTF-8):      %{modname} - dowiązania do biblioteki libssh2
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.11.0
8 Release:        6
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  9f5dcd5b92299458389038f7318cbc46
13 Patch0:         php-pecl-ssh2-libssh2.patch
14 Patch1:         branch.diff
15 URL:            http://pecl.php.net/package/ssh2/
16 BuildRequires:  %{php_name}-devel >= 4:5.0.4
17 BuildRequires:  libssh2-devel >= 0.16
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  rpmbuild(macros) >= 1.650
20 %{?requires_php_extension}
21 Provides:       php(%{modname}) = %{version}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Provides bindings to the functions of libssh2 which implements the
26 SSH2 protocol.
27
28 In PECL status of this extension is: %{status}.
29
30 %description -l pl.UTF-8
31 Dostarcza dowiązań do różnych funkcji biblioteki libssh2
32 implementującej protokół SSH2.
33
34 To rozszerzenie ma w PECL status: %{status}.
35
36 %prep
37 %setup -qc
38 mv %{modname}-%{version}/* .
39 %patch0 -p0
40 %patch1 -p0
41
42 %build
43 phpize
44 %configure
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
50 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
51 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
52 ; Enable %{modname} extension module
53 extension=%{modname}.so
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %php_webserver_restart
61
62 %postun
63 if [ "$1" = 0 ]; then
64         %php_webserver_restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
70 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.068327 seconds and 3 git commands to generate.