]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blob - php-pecl-ssh2.spec
- new
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
1 %define         _modname        ssh2
2 %define         _status         beta
3
4 Summary:        %{_modname} - bindings for the libssh2 library
5 Summary(pl):    %{_modname} - dowi±zania do biblioteki libssh2
6 Name:           php-pecl-%{_modname}
7 Version:        0.4.1
8 Release:        1
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  7da1cc5249f7394edb06809183d13c10
13 URL:            http://pecl.php.net/package/Modname/
14 BuildRequires:  libtool
15 BuildRequires:  php-devel >= 3:5.0.0
16 Requires:       php-common >= 3:5.0.0
17 Obsoletes:      php-pear-%{_modname}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sysconfdir     /etc/php
21 %define         extensionsdir   %{_libdir}/php
22
23 %description
24 Provides bindings to the functions of libssh2 which implements the
25 SSH2 protocol.
26
27 In PECL status of this extension is: %{_status}.
28
29 %description -l pl
30 Dostarcza dowi±zañ do ró¿nych funkcji biblioteki libssh2
31 implementuj±cej protokó³ SSH2.
32
33 To rozszerzenie ma w PECL status: %{_status}.
34
35 %prep
36 %setup -q -c
37
38 %build
39 cd %{_modname}-%{version}
40 phpize
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{extensionsdir}
47
48 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
55
56 %preun
57 if [ "$1" = "0" ]; then
58         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.069887 seconds and 3 git commands to generate.