]> git.pld-linux.org Git - packages/ocaml-net.git/blob - ocaml-net.spec
- add ocaml_opt bcond
[packages/ocaml-net.git] / ocaml-net.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %define         apxs    /usr/sbin/apxs
11 %define         apache  /usr/sbin/httpd
12 Summary:        Modules for Internet programming in OCaml
13 Summary(pl.UTF-8):      Moduły ułatwiające pisanie programów internetowych w OCamlu
14 Name:           ocaml-net
15 Version:        3.7.7
16 Release:        2
17 License:        GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
18 Group:          Libraries
19 Source0:        http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
20 # Source0-md5:  e15e0961d09057f0bbe4f69d6055506c
21 Patch0:         %{name}-buildfix.patch
22 Patch1:         %{name}-lablgtk2.patch
23 Patch2:         %{name}-apache-link.patch
24 URL:            http://projects.camlcity.org/projects/ocamlnet.html
25 BuildRequires:  %{apache}
26 BuildRequires:  %{apxs}
27 BuildRequires:  apache-devel >= 2.0
28 BuildRequires:  ncurses-devel
29 BuildRequires:  ocaml >= 1:3.09.2
30 BuildRequires:  ocaml-camlp4
31 BuildRequires:  ocaml-cryptgps-devel
32 BuildRequires:  ocaml-cryptokit-devel
33 BuildRequires:  ocaml-findlib
34 BuildRequires:  ocaml-findlib-devel
35 BuildRequires:  ocaml-lablgtk2-devel >= 2.14.2
36 BuildRequires:  ocaml-labltk-devel
37 BuildRequires:  ocaml-pcre-devel
38 BuildRequires:  ocaml-ssl-devel
39 BuildRequires:  ocaml-zip-devel
40 BuildRequires:  tcl-devel
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _apachepkglibdir        %(%{apxs} -q LIBEXECDIR 2>/dev/null)
44 %define         _apachesysconfdir       %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
45
46 %description
47 Modules for Internet programming in OCaml.
48
49 %description -l pl.UTF-8
50 Moduły ułatwiające pisanie programów internetowych w OCamlu.
51
52 %package doc
53 Summary:        ocaml-net documentation
54 Summary(pl.UTF-8):      Dokumentacja dla pakietów ocaml-net
55 License:        BSD-like
56 Group:          Development/Libraries
57
58 %description doc
59 ocaml-net documentation.
60
61 %description doc -l pl.UTF-8
62 Dokumentacja dla pakietów ocaml-net.
63
64 %package netcgi-devel
65 Summary:        Common Gateway Interface library
66 Summary(pl.UTF-8):      Biblioteka do tworzenia skryptów CGI
67 License:        LGPL v2+ (mod_caml), BSD-like (the rest)
68 Group:          Development/Libraries
69 Requires:       %{name}-netplex-devel = %{version}-%{release}
70 Requires:       %{name}-netstring-devel = %{version}-%{release}
71 Requires:       %{name}-netsys-devel = %{version}-%{release}
72 Obsoletes:      ocaml-net-cgi-devel
73 %requires_eq    ocaml
74
75 %description netcgi-devel
76 Common Gateway Interface library, part of Ocamlnet. This package
77 contains files needed to develop OCaml programs using netcgi library.
78
79 %description netcgi-devel -l pl.UTF-8
80 Biblioteka do tworzenia skryptów CGI, część pakietu Ocamlnet. Ten
81 pakiet zawiera pliki niezbędne do tworzenia programów używających
82 biblioteki netcgi.
83
84 %package -n apache-mod_netcgi
85 Summary:        Apache module:
86 Summary(pl.UTF-8):      Moduł Apache'a:
87 Group:          Networking/Daemons/HTTP
88 Requires:       apache(modules-api) = %apache_modules_api
89
90 %description -n apache-mod_netcgi
91
92 %description -n apache-mod_netcgi -l pl.UTF-8
93
94 %package equeue-devel
95 Summary:        Event queue library for OCaml
96 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla
97 License:        BSD-like
98 Group:          Development/Libraries
99 Requires:       %{name}-netsys-devel = %{version}-%{release}
100 %requires_eq    ocaml
101 Obsoletes:      ocaml-equeue-devel
102
103 %description equeue-devel
104 Equeue provides a generic event queue module, and a specific module
105 for file descriptor events.
106
107 This package contains files needed to develop OCaml programs using
108 equeue library.
109
110 %description equeue-devel -l pl.UTF-8
111 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
112 modułu obsługi zdarzeń na deskryptorach plików.
113
114 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
115 biblioteki equeue.
116
117 %package equeue-gtk2-devel
118 Summary:        GTK2 event queue library for OCaml
119 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń GTK2 dla OCamla
120 License:        BSD-like
121 Group:          Development/Libraries
122 Requires:       %{name}-equeue-devel = %{version}-%{release}
123 Requires:       ocaml-lablgtk2-devel
124 %requires_eq    ocaml
125
126 %description equeue-gtk2-devel
127 Equeue provides a generic event queue module, and a specific module
128 for file descriptor events.
129
130 This package contains files needed to develop OCaml programs using
131 GTK2 equeue library.
132
133 %description equeue-gtk2-devel -l pl.UTF-8
134 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
135 modułu obsługi zdarzeń na deskryptorach plików.
136
137 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
138 biblioteki equeue GTK2.
139
140 %package equeue-ssl
141 Summary:        Event queue library for OCaml, SSL support
142 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla SSL
143 License:        BSD-like
144 Group:          Libraries
145 %requires_eq    ocaml-runtime
146
147 %description equeue-ssl
148 This package makes it possible to let Equeue cooperate with the event
149 queue implementation of SSL.
150
151 This package contains files needed to run bytecode executables using
152 equeue-ssl library.
153
154 %description equeue-ssl -l pl.UTF-8
155 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
156 w SSL.
157
158 Ten pakiet zawiera moduł potrzebny do uruchamiania programów
159 używających biblioteki equeue-ssl.
160
161 %package equeue-ssl-devel
162 Summary:        Equeue SSL support - development part
163 Summary(pl.UTF-8):      Wsparcie dla SSL-a w equeue - cześć programistyczna
164 License:        BSD-like
165 Group:          Development/Libraries
166 Requires:       %{name}-equeue-devel = %{version}-%{release}
167 Requires:       %{name}-equeue-ssl = %{version}-%{release}
168 %requires_eq    ocaml-ssl-devel
169 %requires_eq    ocaml
170
171 %description equeue-ssl-devel
172 This package makes it possible to let Equeue cooperate with the event
173 queue implementation of SSL.
174
175 This package contains files needed to develop OCaml programs using
176 equeue-ssl library.
177
178 %description equeue-ssl-devel -l pl.UTF-8
179 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
180 w SSL.
181
182 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
183 biblioteki equeue-ssl.
184
185 %package equeue-tcl
186 Summary:        Event queue library for OCaml, Tcl support
187 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla Tcl
188 License:        BSD-like
189 Group:          Libraries
190 %requires_eq    ocaml-runtime
191 %requires_eq    ocaml-labltk
192 Obsoletes:      ocaml-equeue-tcl
193
194 %description equeue-tcl
195 This package makes it possible to let Equeue cooperate with the event
196 queue implementation of Tcl.
197
198 This package contains files needed to run bytecode executables using
199 equeue-tcl library.
200
201 %description equeue-tcl -l pl.UTF-8
202 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
203 w Tcl.
204
205 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
206 używających biblioteki equeue-tcl.
207
208 %package equeue-tcl-devel
209 Summary:        Equeue Tcl support - development part
210 Summary(pl.UTF-8):      Wsparcie dla Tcl-a w equeue - cześć programistyczna
211 License:        BSD-like
212 Group:          Development/Libraries
213 Requires:       %{name}-equeue-devel = %{version}-%{release}
214 Requires:       %{name}-equeue-tcl = %{version}-%{release}
215 %requires_eq    ocaml-labltk-devel
216 %requires_eq    ocaml
217 Obsoletes:      ocaml-equeue-tcl-devel
218
219 %description equeue-tcl-devel
220 This package makes it possible to let Equeue cooperate with the event
221 queue implementation of Tcl.
222
223 This package contains files needed to develop OCaml programs using
224 this library.
225
226 %description equeue-tcl-devel -l pl.UTF-8
227 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
228 w Tcl.
229
230 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
231 biblioteki equeue-tcl.
232
233 %package netcamlbox-devel
234 Summary:        Fast IPC mechanism for OCaml
235 Summary(pl.UTF-8):      Szybki mechanizm IPC dla OCamla
236 License:        BSD-like
237 Group:          Development/Libraries
238 Requires:       %{name}-netsys-devel = %{version}-%{release}
239 %requires_eq    ocaml
240
241 %description netcamlbox-devel
242 Camlboxes are a fast IPC mechanism to send Ocaml values from one
243 process to another. Source and destination processes must run on the
244 same machine (no network). The Ocaml value is copied to a shared
245 memory object where it can be directly accessed by the receiver
246 without unmarshalling step. This means the sender writes the value
247 into the shared memory in a format that can immediately interpreted by
248 the receiver.
249
250 This package contains files needed to develop OCaml programs using
251 netcamlbox library.
252
253 %description netcamlbox-devel -l pl.UTF-8
254 Camlboxy są szybkim mechanizmem IPC do przesyłania danych Ocamla
255 pomiędzy procesami. Nadawca i odbiorca muszą być uruchomione na tej
256 samej maszynie. Dane Ocamla są kopiowane do segmentu pamięci
257 dzielonej, gdzie mogą byc bezpośrednio odczytywane przez odbiorcę.
258
259 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
260 biblioteki netcamlbox.
261
262 %package netclient-devel
263 Summary:        HTTP 1.1 client for OCaml
264 Summary(pl.UTF-8):      Klient HTTP 1.1 dla OCamla
265 License:        BSD-like
266 Group:          Development/Libraries
267 Requires:       %{name}-equeue-devel = %{version}-%{release}
268 Requires:       %{name}-netstring-devel = %{version}-%{release}
269 %requires_eq    ocaml
270 Obsoletes:      ocaml-netclient-devel
271
272 %description netclient-devel
273 Implements much of HTTP/1.1. Implements the following advanced
274 features: chunked messages; persistent connections; connections in
275 pipelining mode ("full duplex" connections); modular authentication
276 methods, currently Basic and Digest; event-driven implementation;
277 allows concurrent service for several network connections.
278
279 This package contains files needed to develop OCaml programs using
280 netclient library.
281
282 %description netclient-devel -l pl.UTF-8
283 Biblioteka netclient implementuje większość HTTP/1.1, a także
284 następujące zaawansowane właściwości: komunikaty w kawałkach;
285 połączenia stałe; połączenia w trybie "full duplex"; modularne metody
286 uwierzytelniania, obecnie Basic i Digest; implementacja oparta na
287 zdarzeniach; umożliwia jednoczesną obsługę kilku połączeń.
288
289 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
290 biblioteki netclient.
291
292 %package netgssapi-devel
293 Summary:        GSS-API generic definition
294 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu GSSAPI
295 License:        GPL v2+
296 Group:          Development/Libraries
297 Requires:       %{name}-netstring-devel = %{version}-%{release}
298 Requires:       %{name}-netsys-devel = %{version}-%{release}
299 %requires_eq    ocaml
300
301 %description netgssapi-devel
302 GSSAPI library, part of Ocamlnet. This package contains the files
303 needed to develop OCaml programs using netgssapi library.
304
305 %description netgssapi-devel -l pl.UTF-8
306 Biblioteka do obsługi protokołu GSSAPI, część pakietu Ocamlnet. Ten
307 pakiet zawiera pliki niezbędne do tworzenia programów używających
308 biblioteki netgssapi.
309
310 %package nethttpd-devel
311 Summary:        HTTPd library
312 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu HTTP
313 License:        GPL v2+
314 Group:          Development/Libraries
315 Requires:       %{name}-equeue-devel = %{version}-%{release}
316 Requires:       %{name}-netcgi-devel = %{version}-%{release}
317 Requires:       %{name}-netplex-devel = %{version}-%{release}
318 %requires_eq    ocaml-pcre-devel
319 %requires_eq    ocaml
320
321 %description nethttpd-devel
322 HTTPd library, part of Ocamlnet. This package contains the files
323 needed to develop OCaml programs using nethttpd library.
324
325 %description nethttpd-devel -l pl.UTF-8
326 Biblioteka do obsługi protokołu HTTP, część pakietu Ocamlnet. Ten
327 pakiet zawiera pliki niezbędne do tworzenia programów używających
328 biblioteki nethttpd.
329
330 %package netmech-scram-devel
331 Summary:        SCRAM mechanism for authentication
332 Summary(pl.UTF-8):      Mechanizm autentykacji SCRAM
333 License:        GPL v2+
334 Group:          Development/Libraries
335 Requires:       %{name}-netcamlbox-devel = %{version}-%{release}
336 Requires:       %{name}-netplex-devel = %{version}-%{release}
337 %requires_eq    ocaml
338
339 %description netmech-scram-devel
340 Netmech-scram library, part of Ocamlnet. This package contains the
341 files needed to develop OCaml programs using netmech-scram library.
342
343 %description netmech-scram-devel -l pl.UTF-8
344 Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
345 Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
346 używających biblioteki netmech-scram.
347
348 %package netmulticore-devel
349 Summary:        Multi-processing for compute jobs
350 Summary(pl.UTF-8):      Obsługa wieloprocesorowych obliczeń
351 License:        GPL v2+
352 Group:          Development/Libraries
353 Requires:       %{name}-netcamlbox-devel = %{version}-%{release}
354 Requires:       %{name}-netplex-devel = %{version}-%{release}
355 %requires_eq    ocaml
356
357 %description netmulticore-devel
358 Netmcore library, part of Ocamlnet. This package contains the files
359 needed to develop OCaml programs using netmulticore library.
360
361 %description netmulticore-devel -l pl.UTF-8
362 Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
363 Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
364 używających biblioteki netmulticore.
365
366 %package netplex
367 Summary:        Server framework
368 Summary(pl.UTF-8):      Szkielet serwerowy
369 License:        BSD-like
370 Group:          Libraries
371 %requires_eq    ocaml-runtime
372 %requires_eq    ocaml-labltk
373
374 %description netplex
375 Server framework.
376
377 This package contains files needed to run bytecode executables using
378 netplex library.
379
380 %description netplex -l pl.UTF-8
381 Szkielet serwerowy.
382
383 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
384 używających biblioteki netplex.
385
386 %package netplex-devel
387 Summary:        Server framework - development part
388 Summary(pl.UTF-8):      Szkielet serwerowy - cześć programistyczna
389 License:        BSD-like
390 Group:          Development/Libraries
391 Requires:       %{name}-equeue-devel = %{version}-%{release}
392 Requires:       %{name}-netplex = %{version}-%{release}
393 Requires:       %{name}-netstring-devel = %{version}-%{release}
394 Requires:       %{name}-netsys-devel = %{version}-%{release}
395 Requires:       %{name}-rpc-devel = %{version}-%{release}
396 %requires_eq    ocaml
397
398 %description netplex-devel
399 Server framework.
400
401 This package contains files needed to develop OCaml programs using
402 netplex library.
403
404 %description netplex-devel -l pl.UTF-8
405 Szkielet serwerowy.
406
407 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
408 biblioteki netplex.
409
410 %package netshm-devel
411 Summary:        Shared memory support - development package
412 Summary(pl.UTF-8):      Obsługa pamięci dzielonej - pakiet programistyczny
413 License:        BSD-like
414 Group:          Development/Libraries
415 Requires:       %{name}-netsys-devel = %{version}-%{release}
416 %requires_eq    ocaml
417
418 %description netshm-devel
419 Shared memory support.
420
421 This package contains files needed to develop OCaml programs using
422 netshm library.
423
424 %description netshm-devel -l pl.UTF-8
425 Obsługa pamięci dzielonej.
426
427 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
428 biblioteki netshm.
429
430 %package netstring
431 Summary:        String processing library
432 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
433 License:        BSD-like
434 Group:          Libraries
435 Requires:       %{name}-netsys-devel = %{version}-%{release}
436 %requires_eq    ocaml-pcre-devel
437 %requires_eq    ocaml
438
439 %description netstring
440 String processing library, part of Ocamlnet.
441
442 %description netstring -l pl.UTF-8
443 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet.
444
445 %package netstring-devel
446 Summary:        String processing library
447 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
448 License:        BSD-like
449 Group:          Development/Libraries
450 Requires:       %{name}-netstring = %{version}-%{release}
451 Requires:       %{name}-netsys-devel = %{version}-%{release}
452 %requires_eq    ocaml-pcre-devel
453 %requires_eq    ocaml
454
455 %description netstring-devel
456 String processing library, part of Ocamlnet. This package contains
457 files needed to develop OCaml programs using netstring library.
458
459 %description netstring-devel -l pl.UTF-8
460 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet. Ten
461 pakiet zawiera pliki niezbędne do tworzenia programów używających
462 biblioteki netstring.
463
464 %package netsys
465 Summary:        OS-specific functions
466 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego
467 License:        BSD-like
468 Group:          Libraries
469 %requires_eq    ocaml-runtime
470
471 %description netsys
472 OS-specific functions.
473
474 This package contains files needed to run bytecode executables using
475 netsys library.
476
477 %description netsys -l pl.UTF-8
478 Funkcje specyficzne dla systemu operacyjnego.
479
480 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
481 używających biblioteki netsys.
482
483 %package netsys-devel
484 Summary:        OS-specific functions - development part
485 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego - cześć programistyczna
486 License:        BSD-like
487 Group:          Development/Libraries
488 Requires:       %{name}-netsys = %{version}-%{release}
489 %requires_eq    ocaml
490
491 %description netsys-devel
492 OS-specific functions.
493
494 This package contains files needed to develop OCaml programs using
495 netsys library.
496
497 %description netsys-devel -l pl.UTF-8
498 Funkcje specyficzne dla systemu operacyjnego.
499
500 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
501 biblioteki netsys.
502
503 %package netzip-devel
504 Summary:        Gzip channels - development part
505 Summary(pl.UTF-8):      Funkcje do kompresji kanałow - cześć programistyczna
506 License:        BSD-like
507 Group:          Development/Libraries
508 Requires:       %{name}-netstring-devel = %{version}-%{release}
509 %requires_eq    ocaml
510
511 %description netzip-devel
512 Gzip channels functions.
513
514 This package contains files needed to develop OCaml programs using
515 netzip library.
516
517 %description netzip-devel -l pl.UTF-8
518 Funkcje do kompresji kanałow.
519
520 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
521 biblioteki netzip.
522
523 %package pop3-devel
524 Summary:        Post Office Protocol (POP3) library
525 Summary(pl.UTF-8):      Biblioteka do obsługi POP3
526 License:        BSD-like
527 Group:          Development/Libraries
528 Requires:       %{name}-netstring-devel = %{version}-%{release}
529 %requires_eq    ocaml
530
531 %description pop3-devel
532 Post Office Protocol (POP3) library, part of Ocamlnet. This package
533 contains files needed to develop OCaml programs using pop library.
534
535 %description pop3-devel -l pl.UTF-8
536 Biblioteka do obsługi POP3, część pakietu Ocamlnet. Ten pakiet zawiera
537 pliki niezbędne do tworzenia programów używających biblioteki pop.
538
539 %package rpc
540 Summary:        Remote Procedure Call (RPC) libraries
541 Summary(pl.UTF-8):      Biblioteki do obsługi RPC
542 License:        BSD-like
543 Group:          Development/Libraries
544 Requires:       %{name}-equeue-ssl = %{version}-%{release}
545 %requires_eq    ocaml
546
547 %description rpc
548 Remote Procedure Call (RPC) libraries.
549
550 %description rpc -l pl.UTF-8
551 Biblioteki do obsługi RPC.
552
553 %package rpc-devel
554 Summary:        Remote Procedure Call (RPC) libraries - development part
555 Summary(pl.UTF-8):      Biblioteki do obsługi RPC - część programistyczna
556 License:        BSD-like
557 Group:          Development/Libraries
558 Requires:       %{name}-equeue-ssl-devel = %{version}-%{release}
559 Requires:       %{name}-rpc = %{version}-%{release}
560 %requires_eq    ocaml
561
562 %description rpc-devel
563 Remote Procedure Call (RPC) libraries - development part.
564
565 %description rpc-devel -l pl.UTF-8
566 Biblioteki do obsługi RPC - część programistyczna.
567
568 %package shell-devel
569 Summary:        Unix shell functions
570 Summary(pl.UTF-8):      Funkcje powłoki uniksowej
571 License:        BSD-like
572 Group:          Development/Libraries
573 Requires:       %{name}-equeue-devel = %{version}-%{release}
574 Requires:       %{name}-netsys-devel = %{version}-%{release}
575 %requires_eq    ocaml
576
577 %description shell-devel
578 Unix shell functions.
579
580 %description shell-devel -l pl.UTF-8
581 Funkcje powłoki uniksowej.
582
583 %package smtp-devel
584 Summary:        Simple Mail Transfer Protocol (SMTP) library
585 Summary(pl.UTF-8):      Biblioteka do obsługi SMTP
586 License:        BSD-like
587 Group:          Development/Libraries
588 Requires:       %{name}-netstring-devel = %{version}-%{release}
589 %requires_eq    ocaml
590
591 %description smtp-devel
592 Interface for the Simple Mail Tranfer Protocol (SMTP) as specified by
593 RFC 2821.
594
595 %description smtp-devel -l pl.UTF-8
596 Interfejs dla protokołu SMTP opisanego w RFC 2821.
597
598 %prep
599 %setup -q -n ocamlnet-%{version}
600 %patch0 -p1
601 %patch1 -p1
602 %patch2 -p1
603
604 %build
605 # no %%configure, please
606 ./configure \
607         -disable-gtk \
608         -enable-gtk2 \
609         -enable-ssl \
610         -enable-zip \
611         -enable-crypto \
612         -enable-apache \
613         -with-rpc-auth-dh \
614         -enable-tcl \
615         -equeue-tcl-libs "-ltcl" \
616         -with-nethttpd \
617         -apxs %{apxs} \
618         -apache %{apache}
619
620 %{__make} -j1 all %{?with_ocaml_opt:opt}
621
622 %install
623 rm -rf $RPM_BUILD_ROOT
624 install -d $RPM_BUILD_ROOT{%{_libdir}/ocaml/stublibs,%{_apachepkglibdir},%{_apachesysconfdir}}
625
626 %{__make} -j1 install \
627         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
628         DESTDIR=$RPM_BUILD_ROOT
629
630 cd src
631 for f in e* n* p* r* shell smtp ; do
632         [ -d $RPM_BUILD_ROOT%{_libdir}/ocaml/$f ] || continue
633         install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f
634         mv $RPM_BUILD_ROOT%{_libdir}/ocaml/$f/META \
635                 $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/
636         echo "directory = \"+$f\"" \
637                 >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/META
638 done
639 cd ..
640
641 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi2-apache/500netcgi_apache.info
642 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/mod_netcgi_apache.so*
643
644 install -p src/netcgi2-apache/mod_netcgi_apache.so $RPM_BUILD_ROOT%{_apachepkglibdir}/mod_netcgi.so
645 cat <<EOF >$RPM_BUILD_ROOT%{_apachesysconfdir}/90_mod_netcgi.conf
646 LoadModule netcgi_module     modules/mod_netcgi.so
647
648 <IfModule netcgi_module>
649         NetcgiLoad pcre/pcre.cma
650         NetcgiLoad netsys/netsys.cma
651         NetcgiLoad netstring/netstring.cma
652         NetcgiLoad str.cma
653         NetcgiLoad netcgi2/netcgi.cma
654         NetcgiLoad netcgi2-apache/netcgi_apache.cma
655
656         NetcgiHandler Netcgi_apache.bytecode
657         AddHandler ocaml-bytecode .cma
658
659 #       Alias /caml-bin/ /path/to/your/scripts/
660 #       <Location /caml-bin>
661 #               SetHandler ocaml-bytecode
662 #               NetcgiHandler Netcgi_apache.bytecode
663 #               Options ExecCGI
664 #               Allow from all
665 #       </Location>
666 </IfModule>
667 EOF
668
669 # not sure about *.o
670 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/*/*.mli
671
672 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-{netcgi,equeue,netcamlbox,netmulticore,netclient,nethttpd,pop3,rpc}-%{version}
673 cp -r examples/camlbox/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcamlbox-%{version}
674 cp -r examples/cgi/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcgi-%{version}
675 cp -r examples/equeue/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-equeue-%{version}
676 cp -r examples/multicore/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netmulticore-%{version}
677 cp -r examples/netclient/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netclient-%{version}
678 cp -r examples/nethttpd/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-nethttpd-%{version}
679 cp -r examples/pop/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-pop3-%{version}
680 cp -r examples/rpc/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-rpc-%{version}
681
682 %clean
683 rm -rf $RPM_BUILD_ROOT
684
685 %files doc
686 %defattr(644,root,root,755)
687 %doc LICENSE* ChangeLog RELNOTES doc/html-main
688
689 %files netcgi-devel
690 %defattr(644,root,root,755)
691 %dir %{_libdir}/ocaml/netcgi*
692 %{_libdir}/ocaml/netcgi*/*.cm[ixao]*
693 %{_libdir}/ocaml/netcgi*/*.a
694 %{_libdir}/ocaml/site-lib/*cgi*
695 %{_examplesdir}/%{name}-netcgi-%{version}
696
697 %files -n apache-mod_netcgi
698 %defattr(644,root,root,755)
699 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_apachesysconfdir}/*_mod_netcgi.conf
700 %attr(755,root,root) %{_apachepkglibdir}/mod_netcgi.so
701
702 %files equeue-devel
703 %defattr(644,root,root,755)
704 %dir %{_libdir}/ocaml/equeue
705 %{_libdir}/ocaml/equeue/*.cm[ixao]*
706 %{_libdir}/ocaml/equeue/*.a
707 %{_libdir}/ocaml/site-lib/equeue
708 %{_examplesdir}/%{name}-equeue-%{version}
709
710 %files equeue-gtk2-devel
711 %defattr(644,root,root,755)
712 %dir %{_libdir}/ocaml/equeue-gtk2
713 %{_libdir}/ocaml/equeue-gtk2/*.cm[ixao]*
714 %{_libdir}/ocaml/equeue-gtk2/*.a
715 %{_libdir}/ocaml/site-lib/equeue-gtk2
716
717 %files equeue-ssl
718 %defattr(644,root,root,755)
719 %dir %{_libdir}/ocaml/equeue-ssl
720 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllequeue_ssl.so
721 %{_libdir}/ocaml/stublibs/dllequeue_ssl.so.owner
722
723 %files equeue-ssl-devel
724 %defattr(644,root,root,755)
725 %{_libdir}/ocaml/equeue-ssl/*.cm[ixao]*
726 %{_libdir}/ocaml/equeue-ssl/*.a
727 %{_libdir}/ocaml/site-lib/equeue-ssl
728
729 %files equeue-tcl
730 %defattr(644,root,root,755)
731 %dir %{_libdir}/ocaml/equeue-tcl
732 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllequeue_tcl.so
733 %{_libdir}/ocaml/stublibs/dllequeue_tcl.so.owner
734
735 %files equeue-tcl-devel
736 %defattr(644,root,root,755)
737 %{_libdir}/ocaml/equeue-tcl/*.cm[ixao]*
738 %{_libdir}/ocaml/equeue-tcl/*.a
739 %{_libdir}/ocaml/site-lib/equeue-tcl
740
741 %files netcamlbox-devel
742 %defattr(644,root,root,755)
743 %dir %{_libdir}/ocaml/netcamlbox
744 %{_libdir}/ocaml/netcamlbox/*.cm[ixao]*
745 %{_libdir}/ocaml/netcamlbox/*.a
746 %{_libdir}/ocaml/site-lib/netcamlbox
747 %{_examplesdir}/%{name}-netcamlbox-%{version}
748
749 %files netclient-devel
750 %defattr(644,root,root,755)
751 %dir %{_libdir}/ocaml/netclient
752 %{_libdir}/ocaml/netclient/*.cm[ixao]*
753 %{_libdir}/ocaml/netclient/*.a
754 %{_libdir}/ocaml/site-lib/netclient
755 %{_examplesdir}/%{name}-netclient-%{version}
756
757 %files netgssapi-devel
758 %defattr(644,root,root,755)
759 %dir %{_libdir}/ocaml/netgssapi
760 %{_libdir}/ocaml/netgssapi/*.cm[ixao]*
761 %{_libdir}/ocaml/netgssapi/*.a
762 %{_libdir}/ocaml/site-lib/netgssapi
763
764 %files nethttpd-devel
765 %defattr(644,root,root,755)
766 %dir %{_libdir}/ocaml/nethttpd
767 %{_libdir}/ocaml/nethttpd/*.cm[ixa]*
768 %{_libdir}/ocaml/nethttpd/*.a
769 %{_libdir}/ocaml/site-lib/nethttpd
770 %{_examplesdir}/%{name}-nethttpd-%{version}
771
772 %files netmech-scram-devel
773 %defattr(644,root,root,755)
774 %dir %{_libdir}/ocaml/netmech-scram
775 %{_libdir}/ocaml/netmech-scram/*.cm[ixa]*
776 %{_libdir}/ocaml/netmech-scram/*.a
777 %{_libdir}/ocaml/site-lib/netmech-scram
778
779 %files netmulticore-devel
780 %defattr(644,root,root,755)
781 %dir %{_libdir}/ocaml/netmulticore
782 %{_libdir}/ocaml/netmulticore/*.cm[ixa]*
783 %{_libdir}/ocaml/netmulticore/*.a
784 %{_libdir}/ocaml/site-lib/netmulticore
785 %{_examplesdir}/%{name}-netmulticore-%{version}
786
787 %files netplex
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_bindir}/netplex-admin
790 %dir %{_libdir}/ocaml/netplex
791 %{_libdir}/ocaml/netplex/*.o
792
793 %files netplex-devel
794 %defattr(644,root,root,755)
795 %{_libdir}/ocaml/netplex/netplex-packlist
796 %{_libdir}/ocaml/netplex/*.cm[ixao]*
797 %{_libdir}/ocaml/netplex/*.a
798 %{_libdir}/ocaml/site-lib/netplex
799
800 %files netshm-devel
801 %defattr(644,root,root,755)
802 %dir %{_libdir}/ocaml/netshm
803 %{_libdir}/ocaml/netshm/*.cm[ixao]*
804 %{_libdir}/ocaml/netshm/*.a
805 %{_libdir}/ocaml/site-lib/netshm
806
807 %files netstring
808 %defattr(644,root,root,755)
809 %dir %{_libdir}/ocaml/netstring
810 %{_libdir}/ocaml/netstring/*.o
811 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetaccel_c.so
812 %{_libdir}/ocaml/stublibs/dllnetaccel_c.so.owner
813
814 %files netstring-devel
815 %defattr(644,root,root,755)
816 %{_libdir}/ocaml/netstring/netdb-packlist
817 %{_libdir}/ocaml/netstring/*.cm[ixao]*
818 %{_libdir}/ocaml/netstring/*.a
819 %{_libdir}/ocaml/site-lib/netstring
820
821 %files netsys
822 %defattr(644,root,root,755)
823 %dir %{_libdir}/ocaml/netsys
824 %{_libdir}/ocaml/netsys/*.o
825 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetsys.so
826 %{_libdir}/ocaml/stublibs/dllnetsys.so.owner
827
828 %files netsys-devel
829 %defattr(644,root,root,755)
830 %{_libdir}/ocaml/netsys/*.cm[ixao]*
831 %{_libdir}/ocaml/netsys/*.a
832 %{_libdir}/ocaml/netsys/netsys_c_event.h
833 %{_libdir}/ocaml/site-lib/netsys
834
835 %files netzip-devel
836 %defattr(644,root,root,755)
837 %dir %{_libdir}/ocaml/netzip
838 %{_libdir}/ocaml/netzip/*.cm[ixao]*
839 %{_libdir}/ocaml/netzip/*.a
840 %{_libdir}/ocaml/site-lib/netzip
841
842 %files pop3-devel
843 %defattr(644,root,root,755)
844 %dir %{_libdir}/ocaml/pop
845 %{_libdir}/ocaml/pop/*.cm[ixao]*
846 %{_libdir}/ocaml/pop/*.a
847 %{_libdir}/ocaml/site-lib/pop
848 %{_examplesdir}/%{name}-pop3-%{version}
849
850 %files rpc
851 %defattr(644,root,root,755)
852 %attr(755,root,root) %{_bindir}/ocamlrpcgen
853 %dir %{_libdir}/ocaml/rpc-auth-local
854 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllrpc_auth_local.so
855 %{_libdir}/ocaml/stublibs/dllrpc_auth_local.so.owner
856
857 %files rpc-devel
858 %defattr(644,root,root,755)
859 %dir %{_libdir}/ocaml/rpc
860 %dir %{_libdir}/ocaml/rpc-auth-dh
861 %dir %{_libdir}/ocaml/rpc-generator
862 %dir %{_libdir}/ocaml/rpc-ssl
863 %{_libdir}/ocaml/rpc-generator/rpcgen-packlist
864 %{_libdir}/ocaml/rpc*/*.cm[ixao]*
865 %{_libdir}/ocaml/rpc*/*.a
866 %{_libdir}/ocaml/site-lib/rpc*
867 %{_examplesdir}/%{name}-rpc-%{version}
868
869 %files shell-devel
870 %defattr(644,root,root,755)
871 %dir %{_libdir}/ocaml/shell
872 %{_libdir}/ocaml/shell/*.cm[ixao]*
873 %{_libdir}/ocaml/shell/*.a
874 %{_libdir}/ocaml/site-lib/shell
875
876 %files smtp-devel
877 %defattr(644,root,root,755)
878 %dir %{_libdir}/ocaml/smtp
879 %{_libdir}/ocaml/smtp/*.cm[ixao]*
880 %{_libdir}/ocaml/smtp/*.a
881 %{_libdir}/ocaml/site-lib/smtp
This page took 0.186813 seconds and 3 git commands to generate.