]> git.pld-linux.org Git - packages/ocaml-net.git/blame - ocaml-net.spec
- add ocaml_opt bcond
[packages/ocaml-net.git] / ocaml-net.spec
CommitLineData
d675728c
JR
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
84639fdc 10%define apxs /usr/sbin/apxs
cb8bf70d 11%define apache /usr/sbin/httpd
cfdcf47a 12Summary: Modules for Internet programming in OCaml
553e669b 13Summary(pl.UTF-8): Moduły ułatwiające pisanie programów internetowych w OCamlu
cfdcf47a 14Name: ocaml-net
05dd1797 15Version: 3.7.7
2bab87b8 16Release: 2
de448ef4 17License: GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
cfdcf47a 18Group: Libraries
6a48f6e4 19Source0: http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
05dd1797 20# Source0-md5: e15e0961d09057f0bbe4f69d6055506c
6a48f6e4 21Patch0: %{name}-buildfix.patch
84639fdc 22Patch1: %{name}-lablgtk2.patch
05dd1797 23Patch2: %{name}-apache-link.patch
6a48f6e4 24URL: http://projects.camlcity.org/projects/ocamlnet.html
cb8bf70d 25BuildRequires: %{apache}
8448aa07 26BuildRequires: %{apxs}
84639fdc 27BuildRequires: apache-devel >= 2.0
91c26977 28BuildRequires: ncurses-devel
84639fdc 29BuildRequires: ocaml >= 1:3.09.2
a85e3ddf 30BuildRequires: ocaml-camlp4
8448aa07
JR
31BuildRequires: ocaml-cryptgps-devel
32BuildRequires: ocaml-cryptokit-devel
2860521a 33BuildRequires: ocaml-findlib
a85e3ddf 34BuildRequires: ocaml-findlib-devel
84639fdc 35BuildRequires: ocaml-lablgtk2-devel >= 2.14.2
8448aa07
JR
36BuildRequires: ocaml-labltk-devel
37BuildRequires: ocaml-pcre-devel
b92aa72c 38BuildRequires: ocaml-ssl-devel
84639fdc 39BuildRequires: ocaml-zip-devel
b92aa72c 40BuildRequires: tcl-devel
cfdcf47a
MM
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
84639fdc
JR
43%define _apachepkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
44%define _apachesysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
45
cfdcf47a 46%description
802c9167
MM
47Modules for Internet programming in OCaml.
48
a73a9323
JR
49%description -l pl.UTF-8
50Moduły ułatwiające pisanie programów internetowych w OCamlu.
cfdcf47a 51
9de7b5fa
JR
52%package doc
53Summary: ocaml-net documentation
553e669b 54Summary(pl.UTF-8): Dokumentacja dla pakietów ocaml-net
de448ef4 55License: BSD-like
9de7b5fa
JR
56Group: Development/Libraries
57
58%description doc
9906ddba 59ocaml-net documentation.
9de7b5fa 60
a73a9323
JR
61%description doc -l pl.UTF-8
62Dokumentacja dla pakietów ocaml-net.
9de7b5fa 63
84639fdc 64%package netcgi-devel
b92aa72c
JR
65Summary: Common Gateway Interface library
66Summary(pl.UTF-8): Biblioteka do tworzenia skryptów CGI
de448ef4 67License: LGPL v2+ (mod_caml), BSD-like (the rest)
cfdcf47a 68Group: Development/Libraries
b92aa72c
JR
69Requires: %{name}-netplex-devel = %{version}-%{release}
70Requires: %{name}-netstring-devel = %{version}-%{release}
71Requires: %{name}-netsys-devel = %{version}-%{release}
8448aa07 72Obsoletes: ocaml-net-cgi-devel
cfdcf47a
MM
73%requires_eq ocaml
74
84639fdc 75%description netcgi-devel
b92aa72c 76Common Gateway Interface library, part of Ocamlnet. This package
2832b715 77contains files needed to develop OCaml programs using netcgi library.
cfdcf47a 78
84639fdc 79%description netcgi-devel -l pl.UTF-8
2832b715
JB
80Biblioteka do tworzenia skryptów CGI, część pakietu Ocamlnet. Ten
81pakiet zawiera pliki niezbędne do tworzenia programów używających
82biblioteki netcgi.
cfdcf47a 83
84639fdc
JR
84%package -n apache-mod_netcgi
85Summary: Apache module:
86Summary(pl.UTF-8): Moduł Apache'a:
87Group: Networking/Daemons/HTTP
88Requires: apache(modules-api) = %apache_modules_api
89
90%description -n apache-mod_netcgi
91
92%description -n apache-mod_netcgi -l pl.UTF-8
93
b92aa72c
JR
94%package equeue-devel
95Summary: Event queue library for OCaml
96Summary(pl.UTF-8): Biblioteka obsługująca kolejkę zdarzeń dla OCamla
de448ef4 97License: BSD-like
b92aa72c
JR
98Group: Development/Libraries
99Requires: %{name}-netsys-devel = %{version}-%{release}
100%requires_eq ocaml
101Obsoletes: ocaml-equeue-devel
b92aa72c
JR
102
103%description equeue-devel
104Equeue provides a generic event queue module, and a specific module
105for file descriptor events.
106
107This package contains files needed to develop OCaml programs using
2832b715 108equeue library.
b92aa72c
JR
109
110%description equeue-devel -l pl.UTF-8
111Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
112modułu obsługi zdarzeń na deskryptorach plików.
113
2832b715
JB
114Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
115biblioteki equeue.
b92aa72c 116
84639fdc
JR
117%package equeue-gtk2-devel
118Summary: GTK2 event queue library for OCaml
119Summary(pl.UTF-8): Biblioteka obsługująca kolejkę zdarzeń GTK2 dla OCamla
120License: BSD-like
121Group: Development/Libraries
122Requires: %{name}-equeue-devel = %{version}-%{release}
7be49e88 123Requires: ocaml-lablgtk2-devel
84639fdc
JR
124%requires_eq ocaml
125
126%description equeue-gtk2-devel
127Equeue provides a generic event queue module, and a specific module
128for file descriptor events.
129
130This package contains files needed to develop OCaml programs using
131GTK2 equeue library.
132
133%description equeue-gtk2-devel -l pl.UTF-8
134Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
135modułu obsługi zdarzeń na deskryptorach plików.
136
137Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
138biblioteki equeue GTK2.
139
b92aa72c
JR
140%package equeue-ssl
141Summary: Event queue library for OCaml, SSL support
142Summary(pl.UTF-8): Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla SSL
de448ef4 143License: BSD-like
b92aa72c
JR
144Group: Libraries
145%requires_eq ocaml-runtime
146
147%description equeue-ssl
148This package makes it possible to let Equeue cooperate with the event
149queue implementation of SSL.
150
151This package contains files needed to run bytecode executables using
2832b715 152equeue-ssl library.
b92aa72c
JR
153
154%description equeue-ssl -l pl.UTF-8
155Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
156w SSL.
157
2832b715
JB
158Ten pakiet zawiera moduł potrzebny do uruchamiania programów
159używających biblioteki equeue-ssl.
b92aa72c
JR
160
161%package equeue-ssl-devel
162Summary: Equeue SSL support - development part
163Summary(pl.UTF-8): Wsparcie dla SSL-a w equeue - cześć programistyczna
de448ef4 164License: BSD-like
b92aa72c
JR
165Group: Development/Libraries
166Requires: %{name}-equeue-devel = %{version}-%{release}
9a761410 167Requires: %{name}-equeue-ssl = %{version}-%{release}
b92aa72c
JR
168%requires_eq ocaml-ssl-devel
169%requires_eq ocaml
170
171%description equeue-ssl-devel
172This package makes it possible to let Equeue cooperate with the event
173queue implementation of SSL.
174
175This package contains files needed to develop OCaml programs using
2832b715 176equeue-ssl library.
b92aa72c
JR
177
178%description equeue-ssl-devel -l pl.UTF-8
179Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
180w SSL.
181
2832b715
JB
182Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
183biblioteki equeue-ssl.
b92aa72c
JR
184
185%package equeue-tcl
186Summary: Event queue library for OCaml, Tcl support
187Summary(pl.UTF-8): Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla Tcl
de448ef4 188License: BSD-like
b92aa72c
JR
189Group: Libraries
190%requires_eq ocaml-runtime
191%requires_eq ocaml-labltk
2832b715 192Obsoletes: ocaml-equeue-tcl
b92aa72c
JR
193
194%description equeue-tcl
195This package makes it possible to let Equeue cooperate with the event
196queue implementation of Tcl.
197
198This package contains files needed to run bytecode executables using
2832b715 199equeue-tcl library.
b92aa72c
JR
200
201%description equeue-tcl -l pl.UTF-8
202Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
203w Tcl.
204
2832b715
JB
205Ten pakiet zawiera moduły potrzebne do uruchamiania programów
206używających biblioteki equeue-tcl.
b92aa72c
JR
207
208%package equeue-tcl-devel
209Summary: Equeue Tcl support - development part
210Summary(pl.UTF-8): Wsparcie dla Tcl-a w equeue - cześć programistyczna
de448ef4 211License: BSD-like
b92aa72c
JR
212Group: Development/Libraries
213Requires: %{name}-equeue-devel = %{version}-%{release}
214Requires: %{name}-equeue-tcl = %{version}-%{release}
215%requires_eq ocaml-labltk-devel
216%requires_eq ocaml
2832b715 217Obsoletes: ocaml-equeue-tcl-devel
b92aa72c
JR
218
219%description equeue-tcl-devel
220This package makes it possible to let Equeue cooperate with the event
221queue implementation of Tcl.
222
223This package contains files needed to develop OCaml programs using
224this library.
225
226%description equeue-tcl-devel -l pl.UTF-8
227Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
228w Tcl.
229
2832b715
JB
230Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
231biblioteki equeue-tcl.
b92aa72c 232
84639fdc
JR
233%package netcamlbox-devel
234Summary: Fast IPC mechanism for OCaml
235Summary(pl.UTF-8): Szybki mechanizm IPC dla OCamla
236License: BSD-like
237Group: Development/Libraries
238Requires: %{name}-netsys-devel = %{version}-%{release}
239%requires_eq ocaml
240
241%description netcamlbox-devel
8448aa07
JR
242Camlboxes are a fast IPC mechanism to send Ocaml values from one
243process to another. Source and destination processes must run on the
244same machine (no network). The Ocaml value is copied to a shared
245memory object where it can be directly accessed by the receiver
246without unmarshalling step. This means the sender writes the value
247into the shared memory in a format that can immediately interpreted by
248the receiver.
84639fdc
JR
249
250This package contains files needed to develop OCaml programs using
251netcamlbox library.
252
253%description netcamlbox-devel -l pl.UTF-8
8448aa07
JR
254Camlboxy są szybkim mechanizmem IPC do przesyłania danych Ocamla
255pomiędzy procesami. Nadawca i odbiorca muszą być uruchomione na tej
256samej maszynie. Dane Ocamla są kopiowane do segmentu pamięci
257dzielonej, gdzie mogą byc bezpośrednio odczytywane przez odbiorcę.
84639fdc
JR
258
259Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
260biblioteki netcamlbox.
261
b92aa72c
JR
262%package netclient-devel
263Summary: HTTP 1.1 client for OCaml
264Summary(pl.UTF-8): Klient HTTP 1.1 dla OCamla
de448ef4 265License: BSD-like
b92aa72c
JR
266Group: Development/Libraries
267Requires: %{name}-equeue-devel = %{version}-%{release}
268Requires: %{name}-netstring-devel = %{version}-%{release}
269%requires_eq ocaml
270Obsoletes: ocaml-netclient-devel
271
272%description netclient-devel
273Implements much of HTTP/1.1. Implements the following advanced
274features: chunked messages; persistent connections; connections in
275pipelining mode ("full duplex" connections); modular authentication
276methods, currently Basic and Digest; event-driven implementation;
277allows concurrent service for several network connections.
278
279This package contains files needed to develop OCaml programs using
2832b715 280netclient library.
b92aa72c
JR
281
282%description netclient-devel -l pl.UTF-8
2832b715
JB
283Biblioteka netclient implementuje większość HTTP/1.1, a także
284następujące zaawansowane właściwości: komunikaty w kawałkach;
285połączenia stałe; połączenia w trybie "full duplex"; modularne metody
286uwierzytelniania, obecnie Basic i Digest; implementacja oparta na
287zdarzeniach; umożliwia jednoczesną obsługę kilku połączeń.
b92aa72c 288
2832b715
JB
289Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
290biblioteki netclient.
b92aa72c 291
84639fdc
JR
292%package netgssapi-devel
293Summary: GSS-API generic definition
294Summary(pl.UTF-8): Biblioteka do obsługi protokołu GSSAPI
295License: GPL v2+
296Group: Development/Libraries
297Requires: %{name}-netstring-devel = %{version}-%{release}
298Requires: %{name}-netsys-devel = %{version}-%{release}
299%requires_eq ocaml
300
301%description netgssapi-devel
302GSSAPI library, part of Ocamlnet. This package contains the files
303needed to develop OCaml programs using netgssapi library.
304
305%description netgssapi-devel -l pl.UTF-8
306Biblioteka do obsługi protokołu GSSAPI, część pakietu Ocamlnet. Ten
307pakiet zawiera pliki niezbędne do tworzenia programów używających
308biblioteki netgssapi.
309
9de7b5fa
JR
310%package nethttpd-devel
311Summary: HTTPd library
553e669b 312Summary(pl.UTF-8): Biblioteka do obsługi protokołu HTTP
de448ef4 313License: GPL v2+
9de7b5fa 314Group: Development/Libraries
b92aa72c 315Requires: %{name}-equeue-devel = %{version}-%{release}
8448aa07 316Requires: %{name}-netcgi-devel = %{version}-%{release}
b92aa72c 317Requires: %{name}-netplex-devel = %{version}-%{release}
9de7b5fa
JR
318%requires_eq ocaml-pcre-devel
319%requires_eq ocaml
320
321%description nethttpd-devel
9906ddba 322HTTPd library, part of Ocamlnet. This package contains the files
2832b715 323needed to develop OCaml programs using nethttpd library.
9de7b5fa 324
a73a9323 325%description nethttpd-devel -l pl.UTF-8
2832b715
JB
326Biblioteka do obsługi protokołu HTTP, część pakietu Ocamlnet. Ten
327pakiet zawiera pliki niezbędne do tworzenia programów używających
328biblioteki nethttpd.
9de7b5fa 329
84639fdc
JR
330%package netmech-scram-devel
331Summary: SCRAM mechanism for authentication
332Summary(pl.UTF-8): Mechanizm autentykacji SCRAM
333License: GPL v2+
334Group: Development/Libraries
335Requires: %{name}-netcamlbox-devel = %{version}-%{release}
336Requires: %{name}-netplex-devel = %{version}-%{release}
337%requires_eq ocaml
338
339%description netmech-scram-devel
8448aa07
JR
340Netmech-scram library, part of Ocamlnet. This package contains the
341files needed to develop OCaml programs using netmech-scram library.
84639fdc
JR
342
343%description netmech-scram-devel -l pl.UTF-8
8448aa07
JR
344Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
345Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
346używających biblioteki netmech-scram.
84639fdc
JR
347
348%package netmulticore-devel
349Summary: Multi-processing for compute jobs
350Summary(pl.UTF-8): Obsługa wieloprocesorowych obliczeń
351License: GPL v2+
352Group: Development/Libraries
353Requires: %{name}-netcamlbox-devel = %{version}-%{release}
354Requires: %{name}-netplex-devel = %{version}-%{release}
355%requires_eq ocaml
356
357%description netmulticore-devel
358Netmcore library, part of Ocamlnet. This package contains the files
359needed to develop OCaml programs using netmulticore library.
360
361%description netmulticore-devel -l pl.UTF-8
8448aa07
JR
362Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
363Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
364używających biblioteki netmulticore.
84639fdc 365
b92aa72c
JR
366%package netplex
367Summary: Server framework
2832b715 368Summary(pl.UTF-8): Szkielet serwerowy
de448ef4 369License: BSD-like
b92aa72c
JR
370Group: Libraries
371%requires_eq ocaml-runtime
372%requires_eq ocaml-labltk
373
374%description netplex
375Server framework.
376
377This package contains files needed to run bytecode executables using
2832b715 378netplex library.
b92aa72c 379
2832b715
JB
380%description netplex -l pl.UTF-8
381Szkielet serwerowy.
382
383Ten pakiet zawiera moduły potrzebne do uruchamiania programów
384używających biblioteki netplex.
b92aa72c
JR
385
386%package netplex-devel
387Summary: Server framework - development part
2832b715 388Summary(pl.UTF-8): Szkielet serwerowy - cześć programistyczna
de448ef4 389License: BSD-like
cfdcf47a 390Group: Development/Libraries
b92aa72c 391Requires: %{name}-equeue-devel = %{version}-%{release}
8448aa07 392Requires: %{name}-netplex = %{version}-%{release}
cfdcf47a 393Requires: %{name}-netstring-devel = %{version}-%{release}
b92aa72c 394Requires: %{name}-netsys-devel = %{version}-%{release}
8448aa07 395Requires: %{name}-rpc-devel = %{version}-%{release}
cfdcf47a
MM
396%requires_eq ocaml
397
b92aa72c
JR
398%description netplex-devel
399Server framework.
cfdcf47a 400
b92aa72c 401This package contains files needed to develop OCaml programs using
2832b715 402netplex library.
b92aa72c 403
2832b715
JB
404%description netplex-devel -l pl.UTF-8
405Szkielet serwerowy.
406
407Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
408biblioteki netplex.
b92aa72c
JR
409
410%package netshm-devel
2832b715
JB
411Summary: Shared memory support - development package
412Summary(pl.UTF-8): Obsługa pamięci dzielonej - pakiet programistyczny
de448ef4 413License: BSD-like
b92aa72c
JR
414Group: Development/Libraries
415Requires: %{name}-netsys-devel = %{version}-%{release}
416%requires_eq ocaml
417
418%description netshm-devel
419Shared memory support.
420
421This package contains files needed to develop OCaml programs using
2832b715 422netshm library.
b92aa72c 423
2832b715
JB
424%description netshm-devel -l pl.UTF-8
425Obsługa pamięci dzielonej.
426
427Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
428biblioteki netshm.
b92aa72c 429
a6bd7b81
JR
430%package netstring
431Summary: String processing library
432Summary(pl.UTF-8): Biblioteka do przetwarzania napisów
433License: BSD-like
434Group: Libraries
435Requires: %{name}-netsys-devel = %{version}-%{release}
436%requires_eq ocaml-pcre-devel
437%requires_eq ocaml
438
439%description netstring
440String processing library, part of Ocamlnet.
441
442%description netstring -l pl.UTF-8
443Biblioteka do przetwarzania napisów, część pakietu Ocamlnet.
444
b92aa72c
JR
445%package netstring-devel
446Summary: String processing library
447Summary(pl.UTF-8): Biblioteka do przetwarzania napisów
de448ef4 448License: BSD-like
b92aa72c 449Group: Development/Libraries
a6bd7b81 450Requires: %{name}-netstring = %{version}-%{release}
b92aa72c
JR
451Requires: %{name}-netsys-devel = %{version}-%{release}
452%requires_eq ocaml-pcre-devel
453%requires_eq ocaml
454
455%description netstring-devel
456String processing library, part of Ocamlnet. This package contains
2832b715 457files needed to develop OCaml programs using netstring library.
b92aa72c
JR
458
459%description netstring-devel -l pl.UTF-8
2832b715
JB
460Biblioteka do przetwarzania napisów, część pakietu Ocamlnet. Ten
461pakiet zawiera pliki niezbędne do tworzenia programów używających
462biblioteki netstring.
cfdcf47a 463
b92aa72c
JR
464%package netsys
465Summary: OS-specific functions
2832b715 466Summary(pl.UTF-8): Funkcje specyficzne dla systemu operacyjnego
de448ef4 467License: BSD-like
b92aa72c
JR
468Group: Libraries
469%requires_eq ocaml-runtime
470
471%description netsys
472OS-specific functions.
473
474This package contains files needed to run bytecode executables using
2832b715 475netsys library.
b92aa72c 476
2832b715
JB
477%description netsys -l pl.UTF-8
478Funkcje specyficzne dla systemu operacyjnego.
479
480Ten pakiet zawiera moduły potrzebne do uruchamiania programów
481używających biblioteki netsys.
b92aa72c
JR
482
483%package netsys-devel
484Summary: OS-specific functions - development part
2832b715 485Summary(pl.UTF-8): Funkcje specyficzne dla systemu operacyjnego - cześć programistyczna
de448ef4 486License: BSD-like
b92aa72c
JR
487Group: Development/Libraries
488Requires: %{name}-netsys = %{version}-%{release}
489%requires_eq ocaml
490
491%description netsys-devel
492OS-specific functions.
493
494This package contains files needed to develop OCaml programs using
2832b715 495netsys library.
b92aa72c 496
2832b715
JB
497%description netsys-devel -l pl.UTF-8
498Funkcje specyficzne dla systemu operacyjnego.
499
500Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
501biblioteki netsys.
b92aa72c 502
84639fdc
JR
503%package netzip-devel
504Summary: Gzip channels - development part
505Summary(pl.UTF-8): Funkcje do kompresji kanałow - cześć programistyczna
506License: BSD-like
507Group: Development/Libraries
7be49e88 508Requires: %{name}-netstring-devel = %{version}-%{release}
84639fdc
JR
509%requires_eq ocaml
510
511%description netzip-devel
512Gzip channels functions.
513
514This package contains files needed to develop OCaml programs using
515netzip library.
516
517%description netzip-devel -l pl.UTF-8
518Funkcje do kompresji kanałow.
519
520Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
521biblioteki netzip.
522
cfdcf47a
MM
523%package pop3-devel
524Summary: Post Office Protocol (POP3) library
553e669b 525Summary(pl.UTF-8): Biblioteka do obsługi POP3
de448ef4 526License: BSD-like
cfdcf47a
MM
527Group: Development/Libraries
528Requires: %{name}-netstring-devel = %{version}-%{release}
529%requires_eq ocaml
530
531%description pop3-devel
532Post Office Protocol (POP3) library, part of Ocamlnet. This package
2832b715 533contains files needed to develop OCaml programs using pop library.
cfdcf47a 534
a73a9323 535%description pop3-devel -l pl.UTF-8
2832b715
JB
536Biblioteka do obsługi POP3, część pakietu Ocamlnet. Ten pakiet zawiera
537pliki niezbędne do tworzenia programów używających biblioteki pop.
cfdcf47a 538
b92aa72c 539%package rpc
2832b715
JB
540Summary: Remote Procedure Call (RPC) libraries
541Summary(pl.UTF-8): Biblioteki do obsługi RPC
de448ef4 542License: BSD-like
b92aa72c
JR
543Group: Development/Libraries
544Requires: %{name}-equeue-ssl = %{version}-%{release}
545%requires_eq ocaml
546
547%description rpc
2832b715 548Remote Procedure Call (RPC) libraries.
b92aa72c
JR
549
550%description rpc -l pl.UTF-8
2832b715 551Biblioteki do obsługi RPC.
b92aa72c
JR
552
553%package rpc-devel
2832b715
JB
554Summary: Remote Procedure Call (RPC) libraries - development part
555Summary(pl.UTF-8): Biblioteki do obsługi RPC - część programistyczna
de448ef4 556License: BSD-like
b92aa72c
JR
557Group: Development/Libraries
558Requires: %{name}-equeue-ssl-devel = %{version}-%{release}
559Requires: %{name}-rpc = %{version}-%{release}
560%requires_eq ocaml
561
562%description rpc-devel
2832b715 563Remote Procedure Call (RPC) libraries - development part.
b92aa72c
JR
564
565%description rpc-devel -l pl.UTF-8
2832b715 566Biblioteki do obsługi RPC - część programistyczna.
b92aa72c
JR
567
568%package shell-devel
569Summary: Unix shell functions
2832b715 570Summary(pl.UTF-8): Funkcje powłoki uniksowej
de448ef4 571License: BSD-like
b92aa72c 572Group: Development/Libraries
b92aa72c 573Requires: %{name}-equeue-devel = %{version}-%{release}
8448aa07 574Requires: %{name}-netsys-devel = %{version}-%{release}
b92aa72c
JR
575%requires_eq ocaml
576
577%description shell-devel
578Unix shell functions.
579
2832b715
JB
580%description shell-devel -l pl.UTF-8
581Funkcje powłoki uniksowej.
b92aa72c 582
4067530e 583%package smtp-devel
034470d4 584Summary: Simple Mail Transfer Protocol (SMTP) library
553e669b 585Summary(pl.UTF-8): Biblioteka do obsługi SMTP
de448ef4 586License: BSD-like
034470d4
ER
587Group: Development/Libraries
588Requires: %{name}-netstring-devel = %{version}-%{release}
4067530e
SP
589%requires_eq ocaml
590
591%description smtp-devel
034470d4
ER
592Interface for the Simple Mail Tranfer Protocol (SMTP) as specified by
593RFC 2821.
8735b5fe 594
a73a9323 595%description smtp-devel -l pl.UTF-8
2832b715 596Interfejs dla protokołu SMTP opisanego w RFC 2821.
4067530e 597
cfdcf47a
MM
598%prep
599%setup -q -n ocamlnet-%{version}
6a48f6e4 600%patch0 -p1
84639fdc
JR
601%patch1 -p1
602%patch2 -p1
cfdcf47a
MM
603
604%build
cfdcf47a
MM
605# no %%configure, please
606./configure \
05dd1797 607 -disable-gtk \
84639fdc 608 -enable-gtk2 \
b92aa72c 609 -enable-ssl \
84639fdc
JR
610 -enable-zip \
611 -enable-crypto \
612 -enable-apache \
613 -with-rpc-auth-dh \
b92aa72c
JR
614 -enable-tcl \
615 -equeue-tcl-libs "-ltcl" \
84639fdc
JR
616 -with-nethttpd \
617 -apxs %{apxs} \
cb8bf70d 618 -apache %{apache}
b92aa72c 619
d675728c 620%{__make} -j1 all %{?with_ocaml_opt:opt}
cfdcf47a
MM
621
622%install
623rm -rf $RPM_BUILD_ROOT
a6bd7b81 624install -d $RPM_BUILD_ROOT{%{_libdir}/ocaml/stublibs,%{_apachepkglibdir},%{_apachesysconfdir}}
7b251678 625
9de7b5fa
JR
626%{__make} -j1 install \
627 OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
628 DESTDIR=$RPM_BUILD_ROOT
7b251678 629
b92aa72c
JR
630cd src
631for f in e* n* p* r* shell smtp ; do
632 [ -d $RPM_BUILD_ROOT%{_libdir}/ocaml/$f ] || continue
cfdcf47a
MM
633 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f
634 mv $RPM_BUILD_ROOT%{_libdir}/ocaml/$f/META \
7b251678 635 $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/
cfdcf47a
MM
636 echo "directory = \"+$f\"" \
637 >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/META
638done
639cd ..
b92aa72c 640
05dd1797 641%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi2-apache/500netcgi_apache.info
a6bd7b81 642%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/mod_netcgi_apache.so*
8448aa07 643
84639fdc
JR
644install -p src/netcgi2-apache/mod_netcgi_apache.so $RPM_BUILD_ROOT%{_apachepkglibdir}/mod_netcgi.so
645cat <<EOF >$RPM_BUILD_ROOT%{_apachesysconfdir}/90_mod_netcgi.conf
646LoadModule netcgi_module modules/mod_netcgi.so
647
648<IfModule netcgi_module>
649 NetcgiLoad pcre/pcre.cma
650 NetcgiLoad netsys/netsys.cma
651 NetcgiLoad netstring/netstring.cma
652 NetcgiLoad str.cma
653 NetcgiLoad netcgi2/netcgi.cma
654 NetcgiLoad netcgi2-apache/netcgi_apache.cma
655
656 NetcgiHandler Netcgi_apache.bytecode
657 AddHandler ocaml-bytecode .cma
658
659# Alias /caml-bin/ /path/to/your/scripts/
660# <Location /caml-bin>
661# SetHandler ocaml-bytecode
662# NetcgiHandler Netcgi_apache.bytecode
663# Options ExecCGI
664# Allow from all
665# </Location>
666</IfModule>
667EOF
668
7b251678
MM
669# not sure about *.o
670rm $RPM_BUILD_ROOT%{_libdir}/ocaml/*/*.mli
cfdcf47a 671
84639fdc
JR
672install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-{netcgi,equeue,netcamlbox,netmulticore,netclient,nethttpd,pop3,rpc}-%{version}
673cp -r examples/camlbox/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcamlbox-%{version}
674cp -r examples/cgi/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcgi-%{version}
b92aa72c 675cp -r examples/equeue/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-equeue-%{version}
84639fdc 676cp -r examples/multicore/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netmulticore-%{version}
b92aa72c 677cp -r examples/netclient/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netclient-%{version}
9de7b5fa 678cp -r examples/nethttpd/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-nethttpd-%{version}
b92aa72c
JR
679cp -r examples/pop/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-pop3-%{version}
680cp -r examples/rpc/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-rpc-%{version}
cfdcf47a 681
cfdcf47a
MM
682%clean
683rm -rf $RPM_BUILD_ROOT
684
9de7b5fa
JR
685%files doc
686%defattr(644,root,root,755)
b92aa72c
JR
687%doc LICENSE* ChangeLog RELNOTES doc/html-main
688
84639fdc 689%files netcgi-devel
b92aa72c
JR
690%defattr(644,root,root,755)
691%dir %{_libdir}/ocaml/netcgi*
692%{_libdir}/ocaml/netcgi*/*.cm[ixao]*
693%{_libdir}/ocaml/netcgi*/*.a
694%{_libdir}/ocaml/site-lib/*cgi*
84639fdc
JR
695%{_examplesdir}/%{name}-netcgi-%{version}
696
697%files -n apache-mod_netcgi
698%defattr(644,root,root,755)
699%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_apachesysconfdir}/*_mod_netcgi.conf
700%attr(755,root,root) %{_apachepkglibdir}/mod_netcgi.so
b92aa72c
JR
701
702%files equeue-devel
703%defattr(644,root,root,755)
704%dir %{_libdir}/ocaml/equeue
705%{_libdir}/ocaml/equeue/*.cm[ixao]*
706%{_libdir}/ocaml/equeue/*.a
b92aa72c
JR
707%{_libdir}/ocaml/site-lib/equeue
708%{_examplesdir}/%{name}-equeue-%{version}
709
84639fdc
JR
710%files equeue-gtk2-devel
711%defattr(644,root,root,755)
712%dir %{_libdir}/ocaml/equeue-gtk2
713%{_libdir}/ocaml/equeue-gtk2/*.cm[ixao]*
714%{_libdir}/ocaml/equeue-gtk2/*.a
715%{_libdir}/ocaml/site-lib/equeue-gtk2
716
b92aa72c
JR
717%files equeue-ssl
718%defattr(644,root,root,755)
719%dir %{_libdir}/ocaml/equeue-ssl
a6bd7b81
JR
720%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllequeue_ssl.so
721%{_libdir}/ocaml/stublibs/dllequeue_ssl.so.owner
b92aa72c
JR
722
723%files equeue-ssl-devel
724%defattr(644,root,root,755)
725%{_libdir}/ocaml/equeue-ssl/*.cm[ixao]*
726%{_libdir}/ocaml/equeue-ssl/*.a
727%{_libdir}/ocaml/site-lib/equeue-ssl
728
729%files equeue-tcl
730%defattr(644,root,root,755)
731%dir %{_libdir}/ocaml/equeue-tcl
a6bd7b81
JR
732%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllequeue_tcl.so
733%{_libdir}/ocaml/stublibs/dllequeue_tcl.so.owner
b92aa72c
JR
734
735%files equeue-tcl-devel
736%defattr(644,root,root,755)
737%{_libdir}/ocaml/equeue-tcl/*.cm[ixao]*
738%{_libdir}/ocaml/equeue-tcl/*.a
739%{_libdir}/ocaml/site-lib/equeue-tcl
740
84639fdc
JR
741%files netcamlbox-devel
742%defattr(644,root,root,755)
743%dir %{_libdir}/ocaml/netcamlbox
744%{_libdir}/ocaml/netcamlbox/*.cm[ixao]*
745%{_libdir}/ocaml/netcamlbox/*.a
746%{_libdir}/ocaml/site-lib/netcamlbox
747%{_examplesdir}/%{name}-netcamlbox-%{version}
748
b92aa72c
JR
749%files netclient-devel
750%defattr(644,root,root,755)
751%dir %{_libdir}/ocaml/netclient
752%{_libdir}/ocaml/netclient/*.cm[ixao]*
753%{_libdir}/ocaml/netclient/*.a
b92aa72c
JR
754%{_libdir}/ocaml/site-lib/netclient
755%{_examplesdir}/%{name}-netclient-%{version}
9de7b5fa 756
84639fdc
JR
757%files netgssapi-devel
758%defattr(644,root,root,755)
759%dir %{_libdir}/ocaml/netgssapi
760%{_libdir}/ocaml/netgssapi/*.cm[ixao]*
761%{_libdir}/ocaml/netgssapi/*.a
762%{_libdir}/ocaml/site-lib/netgssapi
763
9de7b5fa
JR
764%files nethttpd-devel
765%defattr(644,root,root,755)
84639fdc
JR
766%dir %{_libdir}/ocaml/nethttpd
767%{_libdir}/ocaml/nethttpd/*.cm[ixa]*
768%{_libdir}/ocaml/nethttpd/*.a
769%{_libdir}/ocaml/site-lib/nethttpd
9de7b5fa 770%{_examplesdir}/%{name}-nethttpd-%{version}
4067530e 771
84639fdc
JR
772%files netmech-scram-devel
773%defattr(644,root,root,755)
774%dir %{_libdir}/ocaml/netmech-scram
775%{_libdir}/ocaml/netmech-scram/*.cm[ixa]*
776%{_libdir}/ocaml/netmech-scram/*.a
777%{_libdir}/ocaml/site-lib/netmech-scram
778
779%files netmulticore-devel
780%defattr(644,root,root,755)
781%dir %{_libdir}/ocaml/netmulticore
782%{_libdir}/ocaml/netmulticore/*.cm[ixa]*
783%{_libdir}/ocaml/netmulticore/*.a
784%{_libdir}/ocaml/site-lib/netmulticore
785%{_examplesdir}/%{name}-netmulticore-%{version}
786
b92aa72c
JR
787%files netplex
788%defattr(644,root,root,755)
789%attr(755,root,root) %{_bindir}/netplex-admin
a6bd7b81
JR
790%dir %{_libdir}/ocaml/netplex
791%{_libdir}/ocaml/netplex/*.o
b92aa72c
JR
792
793%files netplex-devel
794%defattr(644,root,root,755)
b92aa72c
JR
795%{_libdir}/ocaml/netplex/netplex-packlist
796%{_libdir}/ocaml/netplex/*.cm[ixao]*
797%{_libdir}/ocaml/netplex/*.a
b92aa72c
JR
798%{_libdir}/ocaml/site-lib/netplex
799
800%files netshm-devel
801%defattr(644,root,root,755)
802%dir %{_libdir}/ocaml/netshm
803%{_libdir}/ocaml/netshm/*.cm[ixao]*
804%{_libdir}/ocaml/netshm/*.a
805%{_libdir}/ocaml/site-lib/netshm
806
a6bd7b81 807%files netstring
cfdcf47a 808%defattr(644,root,root,755)
cfdcf47a 809%dir %{_libdir}/ocaml/netstring
a6bd7b81
JR
810%{_libdir}/ocaml/netstring/*.o
811%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetaccel_c.so
812%{_libdir}/ocaml/stublibs/dllnetaccel_c.so.owner
813
814%files netstring-devel
815%defattr(644,root,root,755)
b92aa72c 816%{_libdir}/ocaml/netstring/netdb-packlist
4b20b465 817%{_libdir}/ocaml/netstring/*.cm[ixao]*
cfdcf47a
MM
818%{_libdir}/ocaml/netstring/*.a
819%{_libdir}/ocaml/site-lib/netstring
820
b92aa72c 821%files netsys
cfdcf47a 822%defattr(644,root,root,755)
b92aa72c 823%dir %{_libdir}/ocaml/netsys
84639fdc 824%{_libdir}/ocaml/netsys/*.o
a6bd7b81
JR
825%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetsys.so
826%{_libdir}/ocaml/stublibs/dllnetsys.so.owner
b92aa72c
JR
827
828%files netsys-devel
829%defattr(644,root,root,755)
830%{_libdir}/ocaml/netsys/*.cm[ixao]*
831%{_libdir}/ocaml/netsys/*.a
05dd1797 832%{_libdir}/ocaml/netsys/netsys_c_event.h
b92aa72c 833%{_libdir}/ocaml/site-lib/netsys
cfdcf47a 834
84639fdc
JR
835%files netzip-devel
836%defattr(644,root,root,755)
dcdd07f0 837%dir %{_libdir}/ocaml/netzip
84639fdc
JR
838%{_libdir}/ocaml/netzip/*.cm[ixao]*
839%{_libdir}/ocaml/netzip/*.a
840%{_libdir}/ocaml/site-lib/netzip
841
cfdcf47a
MM
842%files pop3-devel
843%defattr(644,root,root,755)
cfdcf47a 844%dir %{_libdir}/ocaml/pop
4b20b465 845%{_libdir}/ocaml/pop/*.cm[ixao]*
cfdcf47a
MM
846%{_libdir}/ocaml/pop/*.a
847%{_libdir}/ocaml/site-lib/pop
848%{_examplesdir}/%{name}-pop3-%{version}
4067530e 849
b92aa72c
JR
850%files rpc
851%defattr(644,root,root,755)
852%attr(755,root,root) %{_bindir}/ocamlrpcgen
853%dir %{_libdir}/ocaml/rpc-auth-local
a6bd7b81
JR
854%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllrpc_auth_local.so
855%{_libdir}/ocaml/stublibs/dllrpc_auth_local.so.owner
b92aa72c
JR
856
857%files rpc-devel
858%defattr(644,root,root,755)
859%dir %{_libdir}/ocaml/rpc
dcdd07f0
JR
860%dir %{_libdir}/ocaml/rpc-auth-dh
861%dir %{_libdir}/ocaml/rpc-generator
b92aa72c
JR
862%dir %{_libdir}/ocaml/rpc-ssl
863%{_libdir}/ocaml/rpc-generator/rpcgen-packlist
864%{_libdir}/ocaml/rpc*/*.cm[ixao]*
865%{_libdir}/ocaml/rpc*/*.a
866%{_libdir}/ocaml/site-lib/rpc*
867%{_examplesdir}/%{name}-rpc-%{version}
868
869%files shell-devel
870%defattr(644,root,root,755)
871%dir %{_libdir}/ocaml/shell
872%{_libdir}/ocaml/shell/*.cm[ixao]*
873%{_libdir}/ocaml/shell/*.a
b92aa72c
JR
874%{_libdir}/ocaml/site-lib/shell
875
4067530e
SP
876%files smtp-devel
877%defattr(644,root,root,755)
878%dir %{_libdir}/ocaml/smtp
879%{_libdir}/ocaml/smtp/*.cm[ixao]*
880%{_libdir}/ocaml/smtp/*.a
9de7b5fa 881%{_libdir}/ocaml/site-lib/smtp
This page took 0.222747 seconds and 4 git commands to generate.