]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
- package config, remove not needed .dir files
[packages/llvm.git] / llvm.spec
1 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2 Name:           llvm
3 Version:        2.1
4 Release:        0.1
5 License:        University of Illinois/NCSA Open Source License
6 Group:          Development/Languages
7 URL:            http://llvm.org/
8 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  b930e7213b37acc934d0d163cf13af18
10 Patch0:         %{name}-dirs.patch
11 BuildRequires:  gcc >= 3.4
12 Requires:       /sbin/ldconfig
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define _sysconfdir     /etc/%{name}
16
17 %description
18 LLVM is a compiler infrastructure designed for compile-time,
19 link-time, runtime, and idle-time optimization of programs from
20 arbitrary programming languages. LLVM is written in C++ and has been
21 developed since 2000 at the University of Illinois and Apple. It
22 currently supports compilation of C and C++ programs, using front-ends
23 derived from GCC 4.0.1. A new front-end for the C family of languages
24 is in development. The compiler infrastructure includes mirror sets of
25 programming tools as well as libraries with equivalent functionality.
26
27 %prep
28 %setup -q
29 %patch0 -p0
30
31 %build
32 %configure \
33         --enable-optimized \
34         --enable-assertions
35
36 %{__make} tools-only
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 find $RPM_BUILD_ROOT -name .dir |xargs rm -f
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post -p /sbin/ldconfig
50
51 %postun -p /sbin/ldconfig
52
53 %files
54 %defattr(644,root,root,755)
55 %doc CREDITS.TXT LICENSE.TXT README.txt docs
56 %attr(755,root,root) %{_bindir}/*
57 %dir %{_sysconfdir}
58 %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/*
59 %{_libdir}/*.o
60 %{_libdir}/*.a
61 %{_libdir}/*.la
62 %attr(755,root,root) %{_libdir}/*.so*
63 %{_includedir}/llvm
64 %{_includedir}/llvm-c
65 %{_mandir}/man?/llvm*
This page took 0.039626 seconds and 4 git commands to generate.