]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
- up to 0.15.4
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 Summary:        A C++ BitTorrent library
2 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
3 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
4 Name:           libtorrent-rasterbar
5 Version:        0.15.4
6 Release:        1
7 Epoch:          1
8 License:        BSD
9 Group:          Libraries
10 Source0:        http://libtorrent.googlecode.com/files/%{name}-%{version}.tar.gz
11 # Source0-md5:  58750b3a246d056335745f9e805bb949
12 URL:            http://www.rasterbar.com/products/libtorrent/
13 Patch0:         bashizm.patch
14 Patch1:         py27.patch
15 BuildRequires:  GeoIP-devel
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  boost-devel >= 1.35.0
19 BuildRequires:  boost-python-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  openssl-devel
23 BuildRequires:  pkgconfig >= 1:0.20
24 BuildRequires:  python-devel
25 BuildRequires:  python-modules
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  util-linux-ng
29 BuildRequires:  which
30 BuildRequires:  zlib-devel
31 Obsoletes:      rb_libtorrent
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 libtorrent-rasterbar is a C++ library that aims to be a good
36 alternative to all the other BitTorrent implementations around. It is
37 a library and not a full featured client, although it comes with a
38 working example client.
39
40 Its main goals are to be very efficient (in terms of CPU and memory
41 usage) as well as being very easy to use both as a user and developer.
42
43 %description -l hu.UTF-8
44 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
45 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
46 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
47 működő példa-klienst.
48
49 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
50 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
51
52 %description -l pl.UTF-8
53 libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
54 bycia dobrą alternatywą dla wszystkich innych implementacji
55 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
56 pakiet zawiera działającego przykładowego klienta.
57
58 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
59 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
60 dla użytkownika, jak i programisty.
61
62 %package devel
63 Summary:        Header files for %{name} library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
65 License:        BSD, zlib/libpng License, Boost Software License
66 Group:          Development/Libraries
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68 Requires:       boost-devel
69 Requires:       openssl-devel
70 Obsoletes:      rb_libtorrent-devel
71
72 %description    devel
73 The libtorrent-rasterbar-devel package contains libraries and header
74 files for developing applications that use libtorrent-rasterbar.
75
76 The various source and header files included in this package are
77 licensed under the revised BSD, zlib/libpng, and Boost Public
78 licenses.
79
80 %description devel -l hu.UTF-8
81 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
82 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
83 alkalmazásokat fejleszthetsz.
84
85 %description devel -l pl.UTF-8
86 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
87 rozwijania aplikacji używających libtorrent-rasterbar.
88
89 Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
90 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
91 License.
92
93 %package static
94 Summary:        Static %{name} library
95 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
98 Obsoletes:      rb_libtorrent-static
99
100 %description static
101 Static libtorrent-rasterbar library.
102
103 %description static -l hu.UTF-8
104 Statikus libtorrent-rasterbar könyvtár.
105
106 %description static -l pl.UTF-8
107 Statyczna biblioteka libtorrent-rasterbar.
108
109 %package -n python-libtorrent-rasterbar
110 Summary:        Python bindings for libtorrent-rasterbar
111 Group:          Libraries/Python
112 Requires:       %{name} = %{epoch}:%{version}-%{release}
113
114 %description -n python-libtorrent-rasterbar
115 Python bindings for libtorrent-rasterbar.
116
117 %prep
118 %setup -q
119 # %patch0 -p1
120 # %patch1 -p1
121 %{__sed} -i 's/ACLOCAL_AMFLAGS = -I m4/#ACLOCAL_AMFLAGS = -I m4/' Makefile.am
122
123 ## Some of the sources and docs are executable, which makes rpmlint against
124 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
125 find src docs -type f | xargs chmod a-x
126 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
127 ## The RST files are the sources used to create the final HTML files; and are
128 ## not needed.
129 rm -f docs/*.rst
130
131 %build
132 %{__libtoolize}
133 %{__aclocal} -I m4
134 %{__autoconf}
135 %{__automake}
136 %configure \
137         LIBS="-lpthread -lrt" \
138         --enable-python-binding \
139         --with-boost-libdir=%{_libdir} \
140         --with-boost-system=boost_system \
141         --with-boost-filesystem=boost_filesystem \
142         --with-boost-thread=boost_thread \
143         --with-boost-regex=boost_regex \
144         --with-boost-program-options=boost_program_options \
145         --with-asio=system \
146         --with-zlib=system \
147         --with-libgeoip=system \
148         --with-ssl
149
150 %{__make}
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 ## Ensure that we preserve our timestamps properly.
155 #export CPPROG="%{__cp} -p"
156 #make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
157 %{__make} install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 ## Do the renaming due to the somewhat limited %{_bindir} namespace.
161 rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post   -p /sbin/ldconfig
167 %postun -p /sbin/ldconfig
168
169 %files
170 %defattr(644,root,root,755)
171 %doc AUTHORS ChangeLog COPYING README
172 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
173
174 %files devel
175 %defattr(644,root,root,755)
176 %doc docs/
177 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
178 %{_libdir}/libtorrent-rasterbar.la
179 %{_pkgconfigdir}/libtorrent-rasterbar.pc
180 %{_includedir}/libtorrent
181
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/libtorrent-rasterbar.a
185
186 %files -n python-libtorrent-rasterbar
187 %defattr(644,root,root,755)
188 %{py_sitedir}/libtorrent.so
189 %{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.041621 seconds and 4 git commands to generate.