]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
- removed libtorrent-devel conflict (libtorrent-rb's files names are libtorrent-raste...
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 Summary:        A C++ BitTorrent library
2 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
3 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
4 Name:           libtorrent-rasterbar
5 Version:        0.13.1
6 Release:        3
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
10 # Source0-md5:  9d6b112fedc5861402647ff72e95dba0
11 Patch0:         %{name}-examples.patch
12 ## fix the build error with newest boost -- it will be fixed in the next libtorrent version
13 Patch1:         %{name}-boost.patch
14 Patch2:         %{name}-condition.patch
15 URL:            http://www.rasterbar.com/products/libtorrent/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  boost-devel >= 1.35.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  sed >= 4.0
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 libtorrent-rasterbar is a C++ library that aims to be a good
26 alternative to all the other BitTorrent implementations around. It is
27 a library and not a full featured client, although it comes with a
28 working example client.
29
30 Its main goals are to be very efficient (in terms of CPU and memory
31 usage) as well as being very easy to use both as a user and developer.
32
33 %description -l hu.UTF-8
34 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
35 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
36 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
37 működő példa-klienst.
38
39 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
40 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
41
42 %description -l pl.UTF-8
43 libtorrent-rasterbar jest biblioteką napisaną w C++ która aspiruje do
44 bycia dobrą alternatywą dla wszystkich innych implementacji
45 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, jakkolwiek
46 pakiet zawiera działającego przykładowego klienta.
47
48 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
49 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
50 dla użytkownika, jak i programisty.
51
52 %package devel
53 Summary:        Header files for %{name} library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
55 License:        BSD, zlib/libpng License, Boost Software License
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       boost-devel
59 Requires:       openssl-devel
60
61 %description    devel
62 The libtorrent-rasterbar-devel package contains libraries and header
63 files for developing applications that use libtorrent-rasterbar.
64
65 The various source and header files included in this package are
66 licensed under the revised BSD, zlib/libpng, and Boost Public
67 licenses.
68
69 %description devel -l hu.UTF-8
70 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
71 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
72 alkalmazásokat fejleszthetsz.
73
74 %description devel -l pl.UTF-8
75 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
76 rozwijania aplikacji używających libtorrent-rasterbar.
77
78 Różne pliki źródłowe i nagłówki dostarcozne z tym pakietem są
79 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public.
80
81 %package static
82 Summary:        Static %{name} library
83 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static libtorrent-rasterbar library.
89
90 %description static -l hu.UTF-8
91 Statikus libtorrent-rasterbar könyvtár.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka libtorrent-rasterbar.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101 ## Some of the sources and docs are executable, which makes rpmlint against
102 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
103 find src docs -type f | xargs chmod a-x
104 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
105 ## The RST files are the sources used to create the final HTML files; and are
106 ## not needed.
107 rm -f docs/*.rst
108
109 %build
110 %{__aclocal} -I m4
111 %{__libtoolize}
112 %{__autoconf}
113 %{__automake}
114 %configure \
115         --with-boost-system=boost_system\
116         --with-boost-date-time=boost_date_time\
117         --with-boost-filesystem=boost_filesystem\
118         --with-boost-thread=boost_thread\
119         --with-boost-regex=boost_regex\
120         --with-boost-program-options=boost_program_options\
121         --with-{asio,zlib}=system
122
123 %{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 ## Ensure that we preserve our timestamps properly.
128 #export CPPROG="%{__cp} -p"
129 #make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 ## Do the renaming due to the somewhat limited %{_bindir} namespace.
134 rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog COPYING README
145 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %doc docs/
150 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
151 %{_libdir}/libtorrent-rasterbar.la
152 %{_pkgconfigdir}/libtorrent-rasterbar.pc
153 %{_includedir}/libtorrent
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libtorrent-rasterbar.a
This page took 0.077533 seconds and 4 git commands to generate.