]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
- BR: python-modules, rpm-pythonprov
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 Summary:        A C++ BitTorrent library
2 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
3 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
4 Name:           libtorrent-rasterbar
5 Version:        0.14.7
6 Release:        1
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://downloads.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
10 # Source0-md5:  6959f719245d82758235fd73d93373b2
11 URL:            http://www.rasterbar.com/products/libtorrent/
12 Patch0:         bashizm.patch
13 BuildRequires:  GeoIP-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  boost-devel >= 1.35.0
17 BuildRequires:  boost-python-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool
20 BuildRequires:  openssl-devel
21 BuildRequires:  pkgconfig >= 1:0.20
22 BuildRequires:  python-devel
23 BuildRequires:  python-modules
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  sed >= 4.0
26 BuildRequires:  util-linux-ng
27 BuildRequires:  which
28 BuildRequires:  zlib-devel
29 Obsoletes:      rb_libtorrent
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libtorrent-rasterbar is a C++ library that aims to be a good
34 alternative to all the other BitTorrent implementations around. It is
35 a library and not a full featured client, although it comes with a
36 working example client.
37
38 Its main goals are to be very efficient (in terms of CPU and memory
39 usage) as well as being very easy to use both as a user and developer.
40
41 %description -l hu.UTF-8
42 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
43 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
44 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
45 működő példa-klienst.
46
47 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
48 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
49
50 %description -l pl.UTF-8
51 libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
52 bycia dobrą alternatywą dla wszystkich innych implementacji
53 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
54 pakiet zawiera działającego przykładowego klienta.
55
56 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
57 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
58 dla użytkownika, jak i programisty.
59
60 %package devel
61 Summary:        Header files for %{name} library
62 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
63 License:        BSD, zlib/libpng License, Boost Software License
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       boost-devel
67 Requires:       openssl-devel
68 Obsoletes:      rb_libtorrent-devel
69
70 %description    devel
71 The libtorrent-rasterbar-devel package contains libraries and header
72 files for developing applications that use libtorrent-rasterbar.
73
74 The various source and header files included in this package are
75 licensed under the revised BSD, zlib/libpng, and Boost Public
76 licenses.
77
78 %description devel -l hu.UTF-8
79 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
80 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
81 alkalmazásokat fejleszthetsz.
82
83 %description devel -l pl.UTF-8
84 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
85 rozwijania aplikacji używających libtorrent-rasterbar.
86
87 Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
88 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
89 License.
90
91 %package static
92 Summary:        Static %{name} library
93 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96 Obsoletes:      rb_libtorrent-static
97
98 %description static
99 Static libtorrent-rasterbar library.
100
101 %description static -l hu.UTF-8
102 Statikus libtorrent-rasterbar könyvtár.
103
104 %description static -l pl.UTF-8
105 Statyczna biblioteka libtorrent-rasterbar.
106
107 %package -n python-libtorrent-rasterbar
108 Summary:        Python bindings for libtorrent-rasterbar
109 Group:          Libraries/Python
110 Requires:       %{name} = %{version}-%{release}
111
112 %description -n python-libtorrent-rasterbar
113 Python bindings for libtorrent-rasterbar.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118 %{__sed} -i 's/ACLOCAL_AMFLAGS = -I m4/#ACLOCAL_AMFLAGS = -I m4/' Makefile.am
119
120 ## Some of the sources and docs are executable, which makes rpmlint against
121 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
122 find src docs -type f | xargs chmod a-x
123 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
124 ## The RST files are the sources used to create the final HTML files; and are
125 ## not needed.
126 rm -f docs/*.rst
127
128 %build
129 %{__libtoolize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__automake}
133 %configure \
134         LIBS="-lpthread" \
135         --enable-python-binding \
136         --with-boost-system=boost_system \
137         --with-boost-filesystem=boost_filesystem \
138         --with-boost-thread=boost_thread \
139         --with-boost-regex=boost_regex \
140         --with-boost-program-options=boost_program_options \
141         --with-asio=system \
142         --with-zlib=system \
143         --with-libgeoip=system \
144         --with-ssl
145
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 ## Ensure that we preserve our timestamps properly.
151 #export CPPROG="%{__cp} -p"
152 #make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 ## Do the renaming due to the somewhat limited %{_bindir} namespace.
157 rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc AUTHORS ChangeLog COPYING README
168 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %doc docs/
173 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
174 %{_libdir}/libtorrent-rasterbar.la
175 %{_pkgconfigdir}/libtorrent-rasterbar.pc
176 %{_includedir}/libtorrent
177
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libtorrent-rasterbar.a
181
182 %files -n python-libtorrent-rasterbar
183 %defattr(644,root,root,755)
184 %{py_sitedir}/libtorrent.so
185 %{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.073313 seconds and 4 git commands to generate.