]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
- added boost patch, release 3 (rebuild with boost 1.70)
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 #
2 # WARNING: Do not upgrade to 1.1.x, breaks qbittorrent
3 #
4 %define         tagver  %(echo %{version} | tr . _)
5 Summary:        A C++ BitTorrent library
6 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
7 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
8 Name:           libtorrent-rasterbar
9 Version:        1.0.11
10 Release:        3
11 Epoch:          2
12 License:        BSD
13 Group:          Libraries
14 Source0:        https://github.com/arvidn/libtorrent/releases/download/libtorrent-%{tagver}/%{name}-%{version}.tar.gz
15 # Source0-md5:  f49e43286a64e8bbdef9ea59baa78b55
16 Patch0:         %{name}-boost.patch
17 URL:            http://www.rasterbar.com/products/libtorrent/
18 BuildRequires:  GeoIP-devel
19 BuildRequires:  autoconf >= 2.63
20 BuildRequires:  automake >= 1:1.11
21 BuildRequires:  boost-devel >= 1.36
22 BuildRequires:  boost-python-devel >= 1.36
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:2.2.6
25 BuildRequires:  openssl-devel
26 BuildRequires:  pkgconfig >= 1:0.20
27 BuildRequires:  python-devel >= 1:2.4
28 BuildRequires:  python-modules >= 1:2.4
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  util-linux
32 BuildRequires:  which
33 BuildRequires:  zlib-devel
34 Obsoletes:      rb_libtorrent
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 libtorrent-rasterbar is a C++ library that aims to be a good
39 alternative to all the other BitTorrent implementations around. It is
40 a library and not a full featured client, although it comes with a
41 working example client.
42
43 Its main goals are to be very efficient (in terms of CPU and memory
44 usage) as well as being very easy to use both as a user and developer.
45
46 %description -l hu.UTF-8
47 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
48 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
49 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
50 működő példa-klienst.
51
52 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
53 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
54
55 %description -l pl.UTF-8
56 libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
57 bycia dobrą alternatywą dla wszystkich innych implementacji
58 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
59 pakiet zawiera działającego przykładowego klienta.
60
61 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
62 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
63 dla użytkownika, jak i programisty.
64
65 %package devel
66 Summary:        Header files for %{name} library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
68 License:        BSD, zlib/libpng License, Boost Software License
69 Group:          Development/Libraries
70 Requires:       %{name} = %{epoch}:%{version}-%{release}
71 Requires:       boost-devel
72 Requires:       openssl-devel
73 Obsoletes:      rb_libtorrent-devel
74
75 %description    devel
76 The libtorrent-rasterbar-devel package contains libraries and header
77 files for developing applications that use libtorrent-rasterbar.
78
79 The various source and header files included in this package are
80 licensed under the revised BSD, zlib/libpng, and Boost Public
81 licenses.
82
83 %description devel -l hu.UTF-8
84 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
85 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
86 alkalmazásokat fejleszthetsz.
87
88 %description devel -l pl.UTF-8
89 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
90 rozwijania aplikacji używających libtorrent-rasterbar.
91
92 Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
93 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
94 License.
95
96 %package static
97 Summary:        Static %{name} library
98 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
101 Obsoletes:      rb_libtorrent-static
102
103 %description static
104 Static libtorrent-rasterbar library.
105
106 %description static -l hu.UTF-8
107 Statikus libtorrent-rasterbar könyvtár.
108
109 %description static -l pl.UTF-8
110 Statyczna biblioteka libtorrent-rasterbar.
111
112 %package -n python-libtorrent-rasterbar
113 Summary:        Python bindings for libtorrent-rasterbar
114 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libtorrent-rasterbar
115 Group:          Libraries/Python
116 Requires:       %{name} = %{epoch}:%{version}-%{release}
117
118 %description -n python-libtorrent-rasterbar
119 Python bindings for libtorrent-rasterbar.
120
121 %description -n python-libtorrent-rasterbar -l pl.UTF-8
122 Wiązania Pythona do biblioteki libtorrent-rasterbar.
123
124 %prep
125 %setup -q
126 %patch0 -p1
127
128 ## Some of the sources and docs are executable, which makes rpmlint against
129 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
130 find src docs -type f | xargs chmod a-x
131 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
132 ## The RST files are the sources used to create the final HTML files; and are
133 ## not needed.
134 %{__rm} docs/*.rst
135
136 %build
137 %{__libtoolize}
138 %{__aclocal} -I m4
139 %{__autoconf}
140 %{__automake}
141 %configure \
142         LIBS="-lpthread -lrt" \
143         --disable-silent-rules \
144         --enable-python-binding \
145         --with-boost-libdir=%{_libdir} \
146         --with-boost-system=boost_system \
147         --with-boost-filesystem=boost_filesystem \
148         --with-boost-thread=boost_thread \
149         --with-boost-regex=boost_regex \
150         --with-boost-program-options=boost_program_options \
151         --with-asio=system \
152         --with-zlib=system \
153         --with-libgeoip=system \
154         --with-ssl
155
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post   -p /sbin/ldconfig
168 %postun -p /sbin/ldconfig
169
170 %files
171 %defattr(644,root,root,755)
172 %doc AUTHORS ChangeLog COPYING
173 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libtorrent-rasterbar.so.8
175
176 %files devel
177 %defattr(644,root,root,755)
178 %doc docs/
179 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
180 %{_libdir}/libtorrent-rasterbar.la
181 %{_pkgconfigdir}/libtorrent-rasterbar.pc
182 %{_includedir}/libtorrent
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libtorrent-rasterbar.a
187
188 %files -n python-libtorrent-rasterbar
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{py_sitedir}/libtorrent.so
191 %{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.067752 seconds and 3 git commands to generate.