]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
- release 3
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 Summary:        A C++ BitTorrent library
2 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
3 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
4 Name:           libtorrent-rasterbar
5 Version:        0.14.2
6 Release:        3
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
10 # Source0-md5:  97bb2db5ac21e9a81c96fc0e2abe6d29
11 URL:            http://www.rasterbar.com/products/libtorrent/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  boost-devel >= 1.35.0
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 BuildRequires:  openssl-devel
18 BuildRequires:  sed >= 4.0
19 BuildRequires:  util-linux-ng
20 BuildRequires:  which
21 BuildRequires:  zlib-devel
22 Obsoletes:      rb_libtorrent
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 libtorrent-rasterbar is a C++ library that aims to be a good
27 alternative to all the other BitTorrent implementations around. It is
28 a library and not a full featured client, although it comes with a
29 working example client.
30
31 Its main goals are to be very efficient (in terms of CPU and memory
32 usage) as well as being very easy to use both as a user and developer.
33
34 %description -l hu.UTF-8
35 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
36 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
37 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
38 működő példa-klienst.
39
40 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
41 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
42
43 %description -l pl.UTF-8
44 libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
45 bycia dobrą alternatywą dla wszystkich innych implementacji
46 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
47 pakiet zawiera działającego przykładowego klienta.
48
49 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
50 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
51 dla użytkownika, jak i programisty.
52
53 %package devel
54 Summary:        Header files for %{name} library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
56 License:        BSD, zlib/libpng License, Boost Software License
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       boost-devel
60 Requires:       openssl-devel
61 Obsoletes:      rb_libtorrent-devel
62
63 %description    devel
64 The libtorrent-rasterbar-devel package contains libraries and header
65 files for developing applications that use libtorrent-rasterbar.
66
67 The various source and header files included in this package are
68 licensed under the revised BSD, zlib/libpng, and Boost Public
69 licenses.
70
71 %description devel -l hu.UTF-8
72 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
73 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
74 alkalmazásokat fejleszthetsz.
75
76 %description devel -l pl.UTF-8
77 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
78 rozwijania aplikacji używających libtorrent-rasterbar.
79
80 Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
81 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
82 License.
83
84 %package static
85 Summary:        Static %{name} library
86 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Obsoletes:      rb_libtorrent-static
90
91 %description static
92 Static libtorrent-rasterbar library.
93
94 %description static -l hu.UTF-8
95 Statikus libtorrent-rasterbar könyvtár.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka libtorrent-rasterbar.
99
100 %prep
101 %setup -q
102
103 ## Some of the sources and docs are executable, which makes rpmlint against
104 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
105 find src docs -type f | xargs chmod a-x
106 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
107 ## The RST files are the sources used to create the final HTML files; and are
108 ## not needed.
109 rm -f docs/*.rst
110
111 %build
112 %{__aclocal} -I m4
113 %{__libtoolize}
114 %{__autoconf}
115 %{__automake}
116 %configure \
117         --with-boost-system=boost_system \
118         --with-boost-filesystem=boost_filesystem \
119         --with-boost-thread=boost_thread \
120         --with-boost-regex=boost_regex \
121         --with-boost-program-options=boost_program_options \
122         --with-{asio,zlib}=system \
123         --with-ssl
124
125 %{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 ## Ensure that we preserve our timestamps properly.
130 #export CPPROG="%{__cp} -p"
131 #make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 ## Do the renaming due to the somewhat limited %{_bindir} namespace.
136 rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog COPYING README
147 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %doc docs/
152 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
153 %{_libdir}/libtorrent-rasterbar.la
154 %{_pkgconfigdir}/libtorrent-rasterbar.pc
155 %{_includedir}/libtorrent
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libtorrent-rasterbar.a
This page took 0.061432 seconds and 3 git commands to generate.