]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- up to 4.4.3
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7 %bcond_without  dante   # Dante-based SOCKS support
8 %bcond_without  dnssec  # DNSSEC local validation
9 #
10 %if %{with ssl}
11 %define with_openssl 1
12 %endif
13
14 %if %{with gnutls} && %{with ssl}
15 %undefine with_openssl
16 %endif
17
18 Summary:        Sophisticated command line FTP/HTTP client
19 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
20 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
21 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
22 Summary(zh_CN.UTF-8):   lftp 客户端程序
23 Name:           lftp
24 Version:        4.4.3
25 Release:        1
26 License:        GPL v3+
27 Group:          Applications/Networking
28 Source0:        http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
29 # Source0-md5:  6d32f7314453babef80b41e8da5f2a43
30 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
31 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
32 Source2:        %{name}.desktop
33 Source3:        %{name}-icon.png
34 Patch0:         %{name}-makefile.patch
35 Patch1:         %{name}-m4.patch
36 Patch2:         aliases.patch
37 # maintained by me, sent upstream from time to time  --qboosh
38 Patch3:         %{name}-pl.po-update.patch
39 Patch4:         lftp-4.3.8-gets.patch
40 Patch5:         %{name}-am.patch
41 URL:            http://lftp.yar.ru/
42 BuildRequires:  autoconf >= 2.60
43 BuildRequires:  automake
44 %{?with_dante:BuildRequires:    dante-devel}
45 %{?with_dnssec:BuildRequires:   dnssec-tools-devel}
46 BuildRequires:  expat-devel
47 BuildRequires:  gettext-devel >= 0.14.2
48 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  libtool >= 1:1.4.2-9
51 BuildRequires:  ncurses-devel >= 5.2
52 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
53 BuildRequires:  pkgconfig
54 BuildRequires:  readline-devel >= 4.2
55 BuildRequires:  tar >= 1:1.22
56 BuildRequires:  xz
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
60 %if %{_gcc_ver} == 2
61 %define         __cxx           "%{__cc}"
62 %endif
63
64 %description
65 LFTP is a shell-like command line FTP/HTTP client. The main two
66 advantages over other FTP clients are reliability and ability to
67 perform tasks in background. It will reconnect and reget the file
68 being transferred if the connection broke. You can start a transfer in
69 background and continue browsing on the FTP site. It does this all in
70 one process. When you have started background jobs and feel you are
71 done, you can just exit lftp and it automatically moves to nohup mode
72 and completes the transfers. It has also such nice features as reput
73 and mirror.
74
75 %description -l pl.UTF-8
76 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
77 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
78 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
79 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
80 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
81 jako aplikacja do mirrorowania serwerów FTP.
82
83 %description -l pt_BR.UTF-8
84 O lftp é um programa de transferência de arquivos por linha de
85 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
86 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
87 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
88 o arquivo FEATURES para uma lista mais detalhada.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 #%patch3 -p1
96 %patch4 -p1
97 %patch5 -p1
98
99 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
100
101 %build
102 %{__libtoolize}
103 %{__gettextize}
104 %{__aclocal} -I m4
105 %{__autoconf}
106 %{__automake}
107 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
108 %configure \
109         --without-included-regex \
110         --with-dnssec-local-validation%{!?with_dnssec:=no} \
111         --with-modules \
112         --with-socksdante%{!?with_dante:=no} \
113         --with%{!?with_openssl:out}-openssl \
114         --with%{!?with_gnutls:out}-gnutls
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
125 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
126 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
127
128 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
129 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
131
132 %find_lang %{name}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
143 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
144 %attr(755,root,root) %{_bindir}/lftp
145 %attr(755,root,root) %{_bindir}/lftpget
146 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
148 %dir %{_libdir}/lftp
149 %attr(755,root,root) %{_libdir}/lftp/*.so
150 %attr(755,root,root) %{_datadir}/lftp
151 %{_mandir}/man1/lftp.1*
152 %{_mandir}/man1/lftpget.1*
153 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
154 %{_mandir}/man5/lftp.conf.5*
155 %{_desktopdir}/lftp.desktop
156 %{_pixmapsdir}/lftp.png
This page took 0.082027 seconds and 4 git commands to generate.