]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
- added timer-size-assert patch to fix 32-bit builds
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - FTL_JIT on !x86_64?
3 # - WEB_RTC+MEDIA_STREAM (experimental; BR: openwebrtc)
4 # - SPEECH_SYNTHESIS? (experimental; BR: flite-devel >= 2.2)
5 # - THUNDER? (BR: Thunder + ThunderClientLibraries)
6 #
7 # Conditional build:
8 %bcond_without  introspection   # GObject introspection
9 %bcond_without  libsoup2        # webkit-4.0 (libsoup2 based) variant
10 %bcond_without  libsoup3        # webkit-4.1 (libsoup3 based) variant (HTTP/2 support)
11 %bcond_without  gtk3            # webkit-4.x (gtk3 based) variants
12 %bcond_without  gtk4            # webkit-6.0 (gtk4/libsoup3 based) variant
13 %bcond_without  wayland         # Wayland target (requires GTK+ wayland target)
14 %bcond_with     lowmem          # try to reduce build memory usage by adjusting gcc gc
15 %bcond_with     lowmem2         # try to reduce build memory usage by disabling unified build (long)
16 #
17 # it's not possible to build this with debuginfo on 32bit archs due to
18 # memory constraints during linking
19 %ifarch %{ix86} x32
20 %define         _enable_debug_packages          0
21 %endif
22 Summary:        Port of WebKit embeddable web component to GTK+ 3
23 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
24 Name:           gtk-webkit4
25 # NOTE: 2.44.x is stable, 2.45.x devel
26 Version:        2.44.0
27 Release:        1
28 License:        BSD-like
29 Group:          X11/Libraries
30 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
31 # Source0-md5:  20fef6a9122fc46f66f2f8550d5f08c6
32 Patch0:         x32.patch
33 Patch1:         %{name}-icu59.patch
34 Patch2:         parallel-gir.patch
35 Patch3:         %{name}-driver-version-suffix.patch
36 Patch4:         webkit-timer-size-assert.patch
37 URL:            https://webkitgtk.org/
38 BuildRequires:  /usr/bin/ld.gold
39 BuildRequires:  EGL-devel
40 BuildRequires:  Mesa-libgbm-devel
41 BuildRequires:  OpenGL-GLX-devel
42 BuildRequires:  OpenGLESv2-devel
43 BuildRequires:  at-spi2-core-devel >= 2.5.3
44 BuildRequires:  atk-devel >= 1:2.16.0
45 BuildRequires:  bubblewrap >= 0.3.1
46 BuildRequires:  cairo-devel >= 1.16.0
47 BuildRequires:  cmake >= 3.20
48 BuildRequires:  docbook-dtd412-xml
49 BuildRequires:  enchant2-devel >= 2
50 BuildRequires:  fontconfig-devel >= 2.13.0
51 BuildRequires:  freetype-devel >= 1:2.9.0
52 BuildRequires:  gettext-devel
53 BuildRequires:  gettext-tools
54 BuildRequires:  gi-docgen
55 BuildRequires:  glib2-devel >= 1:2.70.0
56 BuildRequires:  glibc-misc
57 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
58 BuildRequires:  gperf >= 3.0.1
59 BuildRequires:  gstreamer-devel >= 1.18.4
60 BuildRequires:  gstreamer-gl-devel >= 1.18.4
61 # codecparsers >= 1.18.4, mpegts >= 1.18.4, webrtc >= 1.20
62 BuildRequires:  gstreamer-plugins-bad-devel >= 1.20
63 # app,audio,fft,pbutils,tag,video
64 BuildRequires:  gstreamer-plugins-base-devel >= 1.18.4
65 BuildRequires:  gstreamer-transcoder-devel >= 1.20
66 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.22.0}
67 %{?with_gtk4:BuildRequires:     gtk4-devel >= 4.6.0}
68 BuildRequires:  harfbuzz-devel >= 1.4.2
69 BuildRequires:  harfbuzz-icu-devel >= 1.4.2
70 BuildRequires:  hyphen-devel
71 BuildRequires:  lcms2-devel >= 2
72 %ifarch %arch64
73 %ifnarch %arch_with_atomics128
74 BuildRequires:  libatomic-devel
75 %endif
76 %endif
77 BuildRequires:  libavif-devel >= 0.9.0
78 BuildRequires:  libdrm-devel
79 BuildRequires:  libepoxy-devel >= 1.5.4
80 BuildRequires:  libgcrypt-devel >= 1.7.0
81 BuildRequires:  libicu-devel >= 61.2
82 BuildRequires:  libjpeg-devel
83 BuildRequires:  libjxl-devel >= 0.7.0
84 BuildRequires:  libmanette-devel >= 0.2.4
85 BuildRequires:  libnotify-devel
86 BuildRequires:  libpng-devel
87 BuildRequires:  libseccomp-devel
88 BuildRequires:  libsecret-devel
89 %{?with_libsoup2:BuildRequires: libsoup-devel >= 2.54}
90 %{?with_libsoup3:BuildRequires: libsoup3-devel >= 3.0}
91 # -std=c++2a; WebKitCommon.cmake says gcc 9.3.0 is minimum, but 9.5.0 fails to build
92 BuildRequires:  libstdc++-devel >= 6:10.2
93 BuildRequires:  libtasn1-devel
94 BuildRequires:  libwebp-devel
95 BuildRequires:  libwpe-devel >= 1.3.0
96 BuildRequires:  libxml2-devel >= 1:2.8.0
97 BuildRequires:  libxslt-devel >= 1.1.7
98 BuildRequires:  openjpeg2-devel >= 2.2.0
99 BuildRequires:  openssl-devel >= 3.0.0
100 BuildRequires:  pango-devel >= 1:1.32.0
101 BuildRequires:  perl-base >= 1:5.10.0
102 BuildRequires:  pkgconfig
103 BuildRequires:  python >= 1:2.7.0
104 BuildRequires:  rpm-build >= 4.6
105 BuildRequires:  rpmbuild(macros) >= 2.029
106 BuildRequires:  ruby >= 1:2.5
107 BuildRequires:  ruby-modules >= 1:2.5
108 BuildRequires:  sqlite3-devel >= 3
109 BuildRequires:  systemd-devel
110 BuildRequires:  tar >= 1:1.22
111 BuildRequires:  unifdef
112 %if %{with wayland}
113 BuildRequires:  wayland-devel >= 1.20
114 BuildRequires:  wayland-egl-devel
115 BuildRequires:  wayland-protocols >= 1.24
116 %endif
117 BuildRequires:  wpebackend-fdo-devel >= 1.9.0
118 BuildRequires:  woff2-devel >= 1.0.2
119 BuildRequires:  xdg-dbus-proxy
120 BuildRequires:  xorg-lib-libICE-devel
121 BuildRequires:  xorg-lib-libXcomposite-devel
122 BuildRequires:  xorg-lib-libXdamage-devel
123 BuildRequires:  xorg-lib-libXext-devel
124 BuildRequires:  xorg-lib-libXrender-devel
125 BuildRequires:  xorg-lib-libXt-devel
126 BuildRequires:  xz
127 BuildRequires:  zlib-devel
128 Requires:       at-spi2-core-libs >= 2.5.3
129 Requires:       atk >= 1:2.16.0
130 Requires:       cairo >= 1.16.0
131 Requires:       fontconfig-libs >= 2.13.0
132 Requires:       freetype >= 1:2.9.0
133 Requires:       glib2 >= 1:2.70.0
134 Requires:       gstreamer >= 1.2.3
135 Requires:       gstreamer-plugins-base >= 1.2.3
136 Requires:       gtk+3 >= 3.22.0
137 Requires:       harfbuzz >= 1.4.2
138 Requires:       libepoxy >= 1.5.4
139 Requires:       libgcrypt >= 1.7.0
140 Requires:       libjxl >= 0.7.0
141 Requires:       libsoup >= 2.54
142 Requires:       libwpe >= 1.3.0
143 Requires:       libxml2 >= 1:2.8.0
144 Requires:       libxslt >= 1.1.7
145 Requires:       openjpeg2 >= 2.2.0
146 Requires:       pango >= 1:1.32.0
147 Requires:       wayland >= 1.20
148 Requires:       woff2 >= 1.0.2
149 Requires:       wpebackend-fdo >= 1.9.0
150 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
151 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
152 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
153 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
154
155 # __once_call, __once_called non-function symbols from libstdc++
156 %define         skip_post_check_so      lib.*gtk-4.0.*
157
158 %description
159 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
160 3.
161
162 %description -l pl.UTF-8
163 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
164
165 %package devel
166 Summary:        Development files for WebKit for GTK+ 3
167 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
168 Group:          X11/Development/Libraries
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       glib2-devel >= 1:2.70.0
171 Requires:       gtk+3-devel >= 3.22.0
172 Requires:       libsoup-devel >= 2.54
173 Requires:       libstdc++-devel >= 6:10.2
174
175 %description devel
176 Development files for WebKit for GTK+ 3.
177
178 %description devel -l pl.UTF-8
179 Pliki programistyczne komponentu WebKit dla GTK+ 3.
180
181 %package apidocs
182 Summary:        API documentation for WebKit GTK+ 3 port
183 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK+ 3
184 Group:          Documentation
185 BuildArch:      noarch
186
187 %description apidocs
188 API documentation for WebKit GTK+ 3 port.
189
190 %description apidocs -l pl.UTF-8
191 Dokumentacja API portu WebKitu do GTK+ 3.
192
193 %package -n gtk-webkit4.1
194 Summary:        Port of WebKit embeddable web component to GTK+ 3 with HTTP/2 support
195 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3 z obsługą HTTP/2
196 Group:          X11/Libraries
197 Requires:       at-spi2-core-libs >= 2.5.3
198 Requires:       atk >= 1:2.16.0
199 Requires:       cairo >= 1.16.0
200 Requires:       fontconfig-libs >= 2.13.0
201 Requires:       freetype >= 1:2.9.0
202 Requires:       glib2 >= 1:2.70.0
203 Requires:       gstreamer >= 1.2.3
204 Requires:       gstreamer-plugins-base >= 1.2.3
205 Requires:       gtk+3 >= 3.22.0
206 Requires:       harfbuzz >= 1.4.2
207 Requires:       libgcrypt >= 1.7.0
208 Requires:       libjxl >= 0.7.0
209 Requires:       libsoup3 >= 3.0
210 Requires:       libwpe >= 1.3.0
211 Requires:       libxml2 >= 1:2.8.0
212 Requires:       libxslt >= 1.1.7
213 Requires:       openjpeg2 >= 2.2.0
214 Requires:       pango >= 1:1.32.0
215 Requires:       wayland >= 1.20
216 Requires:       woff2 >= 1.0.2
217 Requires:       wpebackend-fdo >= 1.9.0
218
219 %description -n gtk-webkit4.1
220 gtk-webkit4.1 is a port of the WebKit embeddable web component to GTK+
221 3 with HTTP/2 (libsoup 3) support.
222
223 %description -n gtk-webkit4.1 -l pl.UTF-8
224 gtk-webkit4.1 to port osadzalnego komponentu WWW WebKit do GTK+ 3 z
225 obsługą HTTP/2 (libsoup 3).
226
227 %package -n gtk-webkit4.1-devel
228 Summary:        Development files for WebKit for GTK+ 3 with HTTP/2 support
229 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3 z obsługą HTTP/2
230 Group:          X11/Development/Libraries
231 Requires:       gtk-webkit4.1 = %{version}-%{release}
232 Requires:       glib2-devel >= 1:2.70.0
233 Requires:       gtk+3-devel >= 3.22.0
234 Requires:       libsoup3-devel >= 3.0
235 Requires:       libstdc++-devel >= 6:10.2
236
237 %description -n gtk-webkit4.1-devel
238 Development files for WebKit for GTK+ 3 with HTTP/2 support.
239
240 %description -n gtk-webkit4.1-devel -l pl.UTF-8
241 Pliki programistyczne komponentu WebKit dla GTK+ 3 z obsługą HTTP/2.
242
243 %package -n gtk-webkit4.1-apidocs
244 Summary:        API documentation for WebKit GTK+ 3 port with HTTP/2 support
245 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK+ 3 z obsługą HTTP/2
246 Group:          Documentation
247 BuildArch:      noarch
248
249 %description -n gtk-webkit4.1-apidocs
250 API documentation for WebKit GTK+ 3 port with HTTP/2 support.
251
252 %description -n gtk-webkit4.1-apidocs -l pl.UTF-8
253 Dokumentacja API portu WebKitu do GTK+ 3 z obsługą HTTP/2.
254
255 %package -n gtk-webkit6
256 Summary:        Port of WebKit embeddable web component to GTK 4
257 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK 4
258 Group:          X11/Libraries
259 Requires:       at-spi2-core-libs >= 2.5.3
260 Requires:       atk >= 1:2.16.0
261 Requires:       cairo >= 1.16.0
262 Requires:       fontconfig-libs >= 2.13.0
263 Requires:       freetype >= 1:2.9.0
264 Requires:       glib2 >= 1:2.70.0
265 Requires:       gstreamer >= 1.2.3
266 Requires:       gstreamer-plugins-base >= 1.2.3
267 Requires:       gtk4 >= 4.6.0
268 Requires:       harfbuzz >= 1.4.2
269 Requires:       libgcrypt >= 1.7.0
270 Requires:       libjxl >= 0.7.0
271 Requires:       libsoup3 >= 3.0
272 Requires:       libwpe >= 1.3.0
273 Requires:       libxml2 >= 1:2.8.0
274 Requires:       libxslt >= 1.1.7
275 Requires:       openjpeg2 >= 2.2.0
276 Requires:       pango >= 1:1.32.0
277 Requires:       wayland >= 1.20
278 Requires:       woff2 >= 1.0.2
279 Requires:       wpebackend-fdo >= 1.9.0
280
281 %description -n gtk-webkit6
282 gtk-webkit6 is a port of the WebKit embeddable web component to GTK 4.
283
284 %description -n gtk-webkit6 -l pl.UTF-8
285 gtk-webkit6 to port osadzalnego komponentu WWW WebKit do GTK+ 4.
286
287 %package -n gtk-webkit6-devel
288 Summary:        Development files for WebKit for GTK 4
289 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK 4
290 Group:          X11/Development/Libraries
291 Requires:       gtk-webkit6 = %{version}-%{release}
292 Requires:       glib2-devel >= 1:2.70.0
293 Requires:       gtk4-devel >= 4.6.0
294 Requires:       libsoup3-devel >= 3.0
295 Requires:       libstdc++-devel >= 6:10.2
296
297 %description -n gtk-webkit6-devel
298 Development files for WebKit for GTK 4.
299
300 %description -n gtk-webkit6-devel -l pl.UTF-8
301 Pliki programistyczne komponentu WebKit dla GTK 4.
302
303 %package -n gtk-webkit6-apidocs
304 Summary:        API documentation for WebKit GTK 4 port
305 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK 4
306 Group:          Documentation
307 BuildArch:      noarch
308
309 %description -n gtk-webkit6-apidocs
310 API documentation for WebKit GTK 4 port.
311
312 %description -n gtk-webkit6-apidocs -l pl.UTF-8
313 Dokumentacja API portu WebKitu do GTK 4.
314
315 %prep
316 %setup -q -n webkitgtk-%{version}
317 %patch0 -p1
318 %patch1 -p1
319 %patch2 -p1
320 %patch3 -p1
321 %patch4 -p1
322
323 %build
324 %if %{with lowmem}
325 CXXFLAGS="%{rpmcxxflags} --param ggc-min-expand=20 --param ggc-min-heapsize=65536"
326 %endif
327 for kind in %{?with_gtk3:%{?with_libsoup2:soup2} %{?with_libsoup3:soup3}} %{?with_gtk4:gtk4} ; do
328 %cmake -B build-${kind} \
329         -DENABLE_GEOLOCATION=ON \
330         -DENABLE_GTKDOC=ON \
331         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
332         %{?with_lowmem2:-DENABLE_UNIFIED_BUILDS=OFF} \
333         -DENABLE_VIDEO=ON \
334         %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
335         -DENABLE_WEB_AUDIO=ON \
336         -DENABLE_WEBGL=ON \
337 %ifarch x32
338         -DENABLE_C_LOOP=ON \
339         -DENABLE_JIT=OFF \
340         -DENABLE_SAMPLING_PROFILER=OFF \
341 %endif
342 %ifarch %{ix86} %{x8664} x32
343         -DHAVE_SSE2_EXTENSIONS=ON \
344 %endif
345         -DPORT=GTK \
346         -DSHOULD_INSTALL_JS_SHELL=ON \
347         $([ "$kind" != "gtk4" ] && echo -DUSE_GTK4=OFF) \
348         -DUSE_LIBBACKTRACE=OFF \
349         $([ "$kind" = "soup2" ] && echo -DUSE_SOUP2=ON)
350
351 %{__make} -C build-${kind}
352 done
353
354 %install
355 rm -rf $RPM_BUILD_ROOT
356
357 for kind in %{?with_gtk3:%{?with_libsoup2:soup2} %{?with_libsoup3:soup3}} %{?with_gtk4:gtk4} ; do
358 %{__make} -C build-${kind} install \
359         DESTDIR=$RPM_BUILD_ROOT
360 done
361
362 install -d $RPM_BUILD_ROOT%{_gidocdir}
363 %{__mv} $RPM_BUILD_ROOT%{_docdir}/{javascriptcoregtk,webkit*gtk}-* $RPM_BUILD_ROOT%{_gidocdir}
364
365 %{?with_gtk3:%{?with_libsoup2:%find_lang WebKitGTK-4.0}}
366 %{?with_gtk3:%{?with_libsoup3:%find_lang WebKitGTK-4.1}}
367 %{?with_gtk4:%find_lang WebKitGTK-6.0}
368
369 %clean
370 rm -rf $RPM_BUILD_ROOT
371
372 %post   -p /sbin/ldconfig
373 %postun -p /sbin/ldconfig
374
375 %post   -n gtk-webkit4.1 -p /sbin/ldconfig
376 %postun -n gtk-webkit4.1 -p /sbin/ldconfig
377
378 %post   -n gtk-webkit6 -p /sbin/ldconfig
379 %postun -n gtk-webkit6 -p /sbin/ldconfig
380
381 %if %{with gtk3} && %{with libsoup2}
382 %files -f WebKitGTK-4.0.lang
383 %defattr(644,root,root,755)
384 %doc NEWS
385 %attr(755,root,root) %{_bindir}/WebKitWebDriver-4.0
386 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
387 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
388 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
389 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
390 %if %{with introspection}
391 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
392 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
393 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
394 %endif
395 %if "%{_libexecdir}" != "%{_libdir}"
396 %dir %{_libexecdir}/webkit2gtk-4.0
397 %endif
398 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/MiniBrowser
399 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitNetworkProcess
400 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitWebProcess
401 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/jsc
402 %dir %{_libdir}/webkit2gtk-4.0
403 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
404 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
405
406 %files devel
407 %defattr(644,root,root,755)
408 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
409 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
410 %if %{with introspection}
411 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
412 %{_datadir}/gir-1.0/WebKit2-4.0.gir
413 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
414 %endif
415 %{_includedir}/webkitgtk-4.0
416 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
417 %{_pkgconfigdir}/webkit2gtk-4.0.pc
418 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
419
420 %files apidocs
421 %defattr(644,root,root,755)
422 %{_gidocdir}/javascriptcoregtk-4.0
423 %{_gidocdir}/webkit2gtk-4.0
424 %{_gidocdir}/webkit2gtk-web-extension-4.0
425 %endif
426
427 %if %{with gtk3} && %{with libsoup3}
428 %files -n gtk-webkit4.1 -f WebKitGTK-4.1.lang
429 %defattr(644,root,root,755)
430 %doc NEWS
431 %attr(755,root,root) %{_bindir}/WebKitWebDriver-4.1
432 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.1.so.*.*.*
433 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.1.so.0
434 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.1.so.*.*.*
435 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.1.so.0
436 %if %{with introspection}
437 %{_libdir}/girepository-1.0/JavaScriptCore-4.1.typelib
438 %{_libdir}/girepository-1.0/WebKit2-4.1.typelib
439 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.1.typelib
440 %endif
441 %if "%{_libexecdir}" != "%{_libdir}"
442 %dir %{_libexecdir}/webkit2gtk-4.1
443 %endif
444 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/MiniBrowser
445 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/WebKitNetworkProcess
446 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/WebKitWebProcess
447 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/jsc
448 %dir %{_libdir}/webkit2gtk-4.1
449 %dir %{_libdir}/webkit2gtk-4.1/injected-bundle
450 %attr(755,root,root) %{_libdir}/webkit2gtk-4.1/injected-bundle/libwebkit2gtkinjectedbundle.so
451
452 %files -n gtk-webkit4.1-devel
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.1.so
455 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.1.so
456 %if %{with introspection}
457 %{_datadir}/gir-1.0/JavaScriptCore-4.1.gir
458 %{_datadir}/gir-1.0/WebKit2-4.1.gir
459 %{_datadir}/gir-1.0/WebKit2WebExtension-4.1.gir
460 %endif
461 %{_includedir}/webkitgtk-4.1
462 %{_pkgconfigdir}/javascriptcoregtk-4.1.pc
463 %{_pkgconfigdir}/webkit2gtk-4.1.pc
464 %{_pkgconfigdir}/webkit2gtk-web-extension-4.1.pc
465
466 %files -n gtk-webkit4.1-apidocs
467 %defattr(644,root,root,755)
468 %{_gidocdir}/javascriptcoregtk-4.1
469 %{_gidocdir}/webkit2gtk-4.1
470 %{_gidocdir}/webkit2gtk-web-extension-4.1
471 %endif
472
473 %if %{with gtk4}
474 %files -n gtk-webkit6 -f WebKitGTK-6.0.lang
475 %defattr(644,root,root,755)
476 %doc NEWS
477 %attr(755,root,root) %{_bindir}/WebKitWebDriver-6.0
478 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-6.0.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-6.0.so.1
480 %attr(755,root,root) %{_libdir}/libwebkitgtk-6.0.so.*.*.*
481 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-6.0.so.4
482 %if %{with introspection}
483 %{_libdir}/girepository-1.0/JavaScriptCore-6.0.typelib
484 %{_libdir}/girepository-1.0/WebKit-6.0.typelib
485 %{_libdir}/girepository-1.0/WebKitWebProcessExtension-6.0.typelib
486 %endif
487 %if "%{_libexecdir}" != "%{_libdir}"
488 %dir %{_libexecdir}/webkitgtk-6.0
489 %endif
490 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/MiniBrowser
491 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/WebKitNetworkProcess
492 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/WebKitWebProcess
493 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/jsc
494 %dir %{_libdir}/webkitgtk-6.0
495 %dir %{_libdir}/webkitgtk-6.0/injected-bundle
496 %attr(755,root,root) %{_libdir}/webkitgtk-6.0/injected-bundle/libwebkitgtkinjectedbundle.so
497
498 %files -n gtk-webkit6-devel
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libdir}/libwebkitgtk-6.0.so
501 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-6.0.so
502 %if %{with introspection}
503 %{_datadir}/gir-1.0/JavaScriptCore-6.0.gir
504 %{_datadir}/gir-1.0/WebKit-6.0.gir
505 %{_datadir}/gir-1.0/WebKitWebProcessExtension-6.0.gir
506 %endif
507 %{_includedir}/webkitgtk-6.0
508 %{_pkgconfigdir}/javascriptcoregtk-6.0.pc
509 %{_pkgconfigdir}/webkitgtk-6.0.pc
510 %{_pkgconfigdir}/webkitgtk-web-process-extension-6.0.pc
511
512 %files -n gtk-webkit6-apidocs
513 %defattr(644,root,root,755)
514 %{_gidocdir}/javascriptcoregtk-6.0
515 %{_gidocdir}/webkitgtk-6.0
516 %{_gidocdir}/webkitgtk-web-process-extension-6.0
517 %endif
This page took 0.116809 seconds and 3 git commands to generate.