]> git.pld-linux.org Git - packages/graphviz.git/blob - graphviz.spec
- updated to 1.8.9
[packages/graphviz.git] / graphviz.spec
1 #
2 # Conditional build:
3 # _with_dynagraph - with dynagraph program (they say it requires gcc 3.1;
4 #       it builds with 2.95.4, but doesn't seem to work - fstream problems)
5 #
6 Summary:        Graph Visualization Tools
7 Summary(pl):    Narzêdzie do wizualizacji w postaci grafów
8 Name:           graphviz
9 Version:        1.8.9
10 Release:        1
11 License:        custom (AT&T)
12 Group:          X11/Applications/Graphics
13 Source0:        http://www.graphviz.org/pub/graphviz/%{name}-%{version}.tar.gz
14 Patch0:         %{name}-lt14d.patch
15 # must wait
16 #Patch1:        %{name}-system-gd.patch
17 URL:            http://www.graphviz.org/
18 BuildRequires:  XFree86-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  bison
22 BuildRequires:  flex
23 BuildRequires:  freetype-devel >= 2.0.0
24 BuildRequires:  gawk
25 #BuildRequires: gd-devel(gif) >= 2.0.1
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool
30 BuildRequires:  tcl-devel >= 8.3.0
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _prefix         /usr/X11R6
35 %define         _mandir         %{_prefix}/man
36
37 %description
38 A collection of tools and tcl packages for the manipulation and layout
39 of graphs (as in nodes and edges, not as in barcharts).
40
41 %description -l pl
42 Kolekcja narzêdzi oraz pakietów tcl s³u¿±cych do manipulacji i
43 rozmieszczania grafów.
44
45 %package graphs
46 Summary:        Demo graphs for graphviz
47 Summary(pl):    Przyk³adowe grafy dla graphviza
48 Group:          X11/Applications/Graphics
49 Requires:       %{name} = %{version}
50
51 %description graphs
52 This package provides some example graphs.
53
54 %description graphs -l pl
55 Ten pakiet zawiera trochê przyk³adowych grafów.
56
57 %package tcl
58 Summary:        Tcl extension tools for graphviz
59 Summary(pl):    Rozszerzenia Tcl dla graphviza
60 Group:          X11/Applications/Graphics
61 Requires:       %{name} = %{version}
62
63 %description tcl
64 This package contains the various tcl packages (extensions) using
65 graphviz.
66
67 %description tcl -l pl
68 Ten pakiet zawiera ró¿ne pakiety (rozszerzenia) tcl u¿ywaj±ce
69 graphviza.
70
71 %package devel
72 Summary:        Header files for graphviz libraries
73 Summary(pl):    Pliki nag³ówkowe do bibliotek graphviz
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}
76
77 %description devel
78 This package contains the header files for graphviz libraries.
79
80 %description devel -l pl
81 Ten pakiet zawiera pliki nag³ówkowe do bibliotek graphviz.
82 %prep
83 %setup -q
84 if grep -q '^VERSION=1\.4d$' /usr/bin/libtool ; then
85 %patch0 -p1
86 fi
87 # requires gd with GIF support - must wait for patched gd...
88 #%patch1 -p1
89
90 %build
91 rm -f missing
92 %{__libtoolize}
93 aclocal
94 %{__autoconf}
95 %{__automake}
96 %configure \
97         %{?_with_dynagraph:--with-dynagraph}
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 # tcl doesn't find pkgIndex.tcl outside /usr/lib...
108 install -d $RPM_BUILD_ROOT/usr/lib/graphviz
109 sed -e "s@\$dir @%{_libdir}/graphviz/@" $RPM_BUILD_ROOT%{_libdir}/graphviz/pkgIndex.tcl \
110         > $RPM_BUILD_ROOT/usr/lib/graphviz/pkgIndex.tcl
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS COPYING ChangeLog FAQ.txt NEWS doc/*.pdf
121 %attr(755,root,root) %{_bindir}/*
122 %dir %{_libdir}/graphviz
123 # *.so links are needed here for tcl
124 %attr(755,root,root) %{_libdir}/graphviz/lib*.so*
125 %dir %{_datadir}/graphviz
126 %{_datadir}/graphviz/lefty
127 %{_mandir}/man1/*
128
129 %files graphs
130 %defattr(644,root,root,755)
131 %{_datadir}/graphviz/graphs
132
133 %files tcl
134 %defattr(644,root,root,755)
135 %dir /usr/lib/graphviz
136 /usr/lib/graphviz/pkgIndex.tcl
137 %{_mandir}/mann/*
138 %dir %{_datadir}/graphviz/demo
139 %{_datadir}/graphviz/demo/pathplan_data
140 %{_datadir}/graphviz/demo/*.*
141 %attr(755,root,root) %{_datadir}/graphviz/demo/dge
142 %attr(755,root,root) %{_datadir}/graphviz/demo/doted
143 %attr(755,root,root) %{_datadir}/graphviz/demo/entities
144 %attr(755,root,root) %{_datadir}/graphviz/demo/gcat
145 %attr(755,root,root) %{_datadir}/graphviz/demo/ihi
146 %attr(755,root,root) %{_datadir}/graphviz/demo/pathplan
147 %attr(755,root,root) %{_datadir}/graphviz/demo/spline
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/graphviz/lib*.la
152 %{_includedir}/graphviz
153 %{_mandir}/man3/*
This page took 0.048472 seconds and 3 git commands to generate.