]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
bash_compdir included with rpm macros 1.673
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.9.0
14 Release:        2
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  e16c14b27c644b8e0dd72bdb5ff77450
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Source7:        gitolite.pl
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 Patch3:         cherry-picked-commitlog.patch
30 Patch4:         %{name}-svn-exit-errors.patch
31 URL:            http://git-scm.com/
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 BuildRequires:  curl-devel
35 BuildRequires:  expat-devel
36 BuildRequires:  gettext-devel
37 BuildRequires:  openssl-devel
38 %{?with_pcre:BuildRequires:     pcre-devel}
39 BuildRequires:  perl-Error > 0.15
40 BuildRequires:  perl-base
41 BuildRequires:  python-devel
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.673
45 BuildRequires:  tcl
46 BuildRequires:  zlib-devel
47 %if %{with doc}
48 BuildRequires:  asciidoc >= 7.1.2-3
49 BuildRequires:  docbook-dtd45-xml
50 BuildRequires:  xmlto
51 %endif
52 %if %{with tests}
53 %if %{with tests_cvs}
54 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
55 BuildRequires:  cvs-gnu-client < 1.13
56 BuildRequires:  cvs-gnu-client >= 1.12
57 %endif
58 %{?with_tests_svn:BuildRequires:  subversion}
59 Conflicts:      pdksh < 5.2.14-46
60 %endif
61 Requires:       coreutils
62 Requires:       diffutils
63 Requires:       findutils
64 Requires:       grep
65 Requires:       openssh-clients
66 Requires:       perl-Error
67 Requires:       perl-Git = %{version}-%{release}
68 Requires:       sed
69 Suggests:       git-core-bzr
70 Suggests:       git-core-cvs
71 Suggests:       git-core-hg
72 Suggests:       git-core-p4
73 Suggests:       git-core-svn
74 Suggests:       less
75 Suggests:       rsync
76 Obsoletes:      python-Git
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 # html docs have links to txt files
80 %define         _noautocompressdoc      *.txt
81
82 %define         webapp          gitweb
83 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
84 %define         appdir          %{_datadir}/%{webapp}
85 %define         cgibindir       %{_prefix}/lib/cgi-bin
86
87 %description
88 "git" can mean anything, depending on your mood.
89
90 - random three-letter combination that is pronounceable, and not
91   actually used by any common UNIX command. The fact that it is a
92   mispronunciation of "get" may or may not be relevant.
93 - stupid. contemptible and despicable. simple. Take your pick from the
94   dictionary of slang.
95 - "global information tracker": you're in a good mood, and it actually
96   works for you. Angels sing, and a light suddenly fills the room.
97 - "goddamn idiotic truckload of sh*t": when it breaks
98
99 This is a stupid (but extremely fast) directory content manager. It
100 doesn't do a whole lot, but what it 'does' do is track directory
101 contents efficiently.
102
103 %description -l pl.UTF-8
104 "git" może oznaczać cokolwiek, w zależności od nastroju.
105
106 - losową kombinację trzech liter, która jest wymawialna i właściwie
107   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
108   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
109 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
110 - "global information tracker" (narzędzie do globalnego śledzenia
111   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
112   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
113 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
114   g*) - kiedy się zepsuje.
115
116 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
117 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
118 katalogu.
119
120 %package doc
121 Summary:        Documentation for git-core
122 Summary(pl.UTF-8):      Dokumentacja do git-core
123 Group:          Documentation
124
125 %description doc
126 Documentation for git-core.
127
128 %description doc -l pl.UTF-8
129 Dokumentacja do git-core.
130
131 %description doc -l fr.UTF-8
132 Javadoc pour git-core.
133
134 %package daemon-inetd
135 Summary:        Files necessary to run git-daemon as an inetd service
136 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
137 Group:          Networking/Daemons
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       setup >= 2.4.11-1
140 Provides:       git-core-daemon
141 Obsoletes:      git-core-daemon
142 Obsoletes:      git-core-daemon-standalone
143
144 %description daemon-inetd
145 Git-daemon is a really simple TCP git daemon that can serve git
146 repositories. This package provides all necessarry files to run
147 git-daemon as an inetd service.
148
149 %description daemon-inetd -l pl.UTF-8
150 Git-daemon to prosty demon git korzystający z protokołu TCP do
151 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
152 do uruchomienia git-demona w trybie usługi inetd.
153
154 %package daemon-standalone
155 Summary:        Files necessary to run git-daemon as a standalone service
156 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
157 Group:          Networking/Daemons
158 Requires:       %{name} = %{version}-%{release}
159 Provides:       git-core-daemon
160 Obsoletes:      git-core-daemon
161 Obsoletes:      git-core-daemon-inetd
162
163 %description daemon-standalone
164 Git-daemon is a really simple TCP git daemon that can serve git
165 repositories. This package provides all necessarry files to run
166 git-daemon as an standalone service.
167
168 %description daemon-standalone -l pl.UTF-8
169 Git-daemon to prosty demon git korzystający z protokołu TCP do
170 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
171 do uruchomienia git-daemona w trybie usługi samodzielnej.
172
173 %package devel
174 Summary:        Git library with header files
175 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
176 Group:          Development/Libraries
177 Requires:       zlib-devel
178
179 %description devel
180 Git library with header files.
181
182 %description devel -l pl.UTF-8
183 Biblioteka Gita oraz pliki nagłówkowe.
184
185 %package gitk
186 Summary:        Tcl/Tk interface to the Git version control system
187 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
188 Group:          Development/Tools
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       tk
191
192 %description gitk
193 gitk displays changes in a repository or a selected set of commits.
194 This includes visualizing the commit graph, showing information
195 related to each commit, and the files in the trees of each revision.
196
197 Historically, gitk was the first repository browser. It's written in
198 Tcl/Tk and started off in a separate repository but was later merged
199 into the main git repository.
200
201 %description gitk -l pl.UTF-8
202 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
203 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
204 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
205
206 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
207 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
208 osobnym repozytorium, ale z czasem został włączony do głównego
209 repozytorium gita.
210
211 %package gitweb
212 Summary:        Web frontend to git
213 Summary(pl.UTF-8):      Frontend WWW do gita
214 Group:          Development/Tools
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       webapps
217 Requires:       webserver(access)
218 Requires:       webserver(alias)
219 Requires:       webserver(cgi)
220 Suggests:       webserver(setenv)
221
222 %description gitweb
223 This package provides a web interface for browsing git repositories.
224
225 %description gitweb -l pl.UTF-8
226 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
227
228 %package gitview
229 Summary:        A GTK+ based repository browser for git
230 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
231 Group:          Development/Tools
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       python >= 1:2.4
234 Requires:       python-pycairo >= 1.0
235 Requires:       python-pygobject
236 Requires:       python-pygtk-gtk >= 2:2.8
237 Suggests:       python-gnome-desktop-gtksourceview
238
239 %description gitview
240 A GTK+ based repository browser for git.
241
242 %description gitview -l pl.UTF-8
243 Oparta na GTK+ przeglądarka repozytorium gita.
244
245 %package gui
246 Summary:        Tcl/Tk interface to the Git version control system
247 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
248 Group:          Development/Tools
249 Requires:       %{name} = %{version}-%{release}
250 Requires:       tk
251 Requires:       xdg-utils
252 Suggests:       meld
253
254 %description gui
255 Displays changes in a repository or a selected set of commits. This
256 includes visualizing the commit graph, showing information related to
257 each commit, and the files in the trees of each revision.
258
259 Historically, gitk was the first repository browser. It's written in
260 Tcl/Tk and started off in a separate repository but was later merged
261 into the main git repository.
262
263 %description gui -l pl.UTF-8
264 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
265 to wizualizację grafu commitów, wyświetlanie informacji związanych z
266 każdym z commitów oraz listę plików dla każdej rewizji.
267
268 Z punktu widzenia historii, gitk był pierwszą przeglądarką
269 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
270 osobnym repozytorium, ale z czasem został włączony do głównego
271 repozytorium gita.
272
273 %package arch
274 Summary:        Git tools for importing Arch repositories
275 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
276 Group:          Development/Tools
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       tla
279
280 %description arch
281 Git tools for importing Arch repositories.
282
283 %description arch -l pl.UTF-8
284 Narzędzia Gita do importowania repozytoriów Archa.
285
286 %package bzr
287 Summary:        Git tools for working with bzr repositories
288 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
289 Group:          Development/Tools
290 Requires:       %{name} = %{version}-%{release}
291 Requires:       bzr
292
293 %description bzr
294 Git tools for working with bzr repositories.
295
296 %description bzr -l pl.UTF-8
297 Narzędzia Gita do pracy z repozytoriami bzr.
298
299 %package cvs
300 Summary:        CVS support for Git
301 Summary(pl.UTF-8):      Obsługa CVS dla Gita
302 Group:          Development/Tools
303 Requires:       %{name} = %{version}-%{release}
304 Requires:       cvsps >= 2.1-2
305 Requires:       rcs
306
307 %description cvs
308 CVS support for Git.
309
310 %description cvs -l pl.UTF-8
311 Obsługa CVS dla Gita.
312
313 %package hg
314 Summary:        Git tools for working with mercurial repositories
315 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
316 Group:          Development/Tools
317 Requires:       %{name} = %{version}-%{release}
318 Requires:       mercurial >= 1.8
319
320 %description hg
321 Git tools for working with mercurial repositories.
322
323 %description hg -l pl.UTF-8
324 Narzędzia Gita do pracy z repozytoriami mercuriala.
325
326 %package p4
327 Summary:        Git tools for working with Perforce depots
328 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
329 Group:          Development/Tools
330 Requires:       %{name} = %{version}-%{release}
331
332 %description p4
333 Git tools for working with Perforce depots.
334
335 %description p4 -l pl.UTF-8
336 Narzędzia Gita do pracy z magazynami Perforce'a.
337
338 %package svn
339 Summary:        Subversion support for Git
340 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
341 Group:          Development/Tools
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       perl-Encode
344 Requires:       perl-Term-ReadKey
345
346 %description svn
347 Subversion support for Git.
348
349 %description svn -l pl.UTF-8
350 Obsługa Subversion dla Gita.
351
352 %package email
353 Summary:        Git tools for sending email
354 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
355 Group:          Development/Tools
356 Requires:       %{name} = %{version}-%{release}
357
358 %description email
359 Git tools for sending email.
360
361 %description email -l pl.UTF-8
362 Narzędzia Gita do wysyłania poczty.
363
364 %package -n bash-completion-git
365 Summary:        bash-completion for git
366 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
367 Group:          Applications/Shells
368 Requires:       %{name} = %{version}-%{release}
369 Requires:       bash-completion >= 2.0
370
371 %description -n bash-completion-git
372 This package provides bash-completion for git.
373
374 %description -n bash-completion-git -l pl.UTF-8
375 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
376
377 %package -n perl-Git
378 Summary:        Perl interface to the Git version control system
379 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
380 Group:          Development/Languages/Perl
381 Obsoletes:      perl-git-core
382
383 %description -n perl-Git
384 This module provides Perl scripts easy way to interface the Git
385 version control system. The modules have an easy and well-tested way
386 to call arbitrary Git commands; in the future, the interface will also
387 provide specialized methods for doing easily operations which are not
388 totally trivial to do over the generic command interface.
389
390 %description -n perl-Git -l pl.UTF-8
391 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
392 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
393 dowolne polecenia Gita; w przyszłości interfejs udostępni także
394 specjalne metody do łatwego wykonywania operacji nietrywialnych do
395 wykonania przy użyciu ogólnego interfejsu poleceń.
396
397 %prep
398 %setup -q -n git-%{version}
399 %patch0 -p1
400 %patch1 -p0
401 %patch2 -p1
402 %patch3 -p1
403 %patch4 -p1
404
405 %build
406 %{__aclocal}
407 %{__autoconf}
408 %configure \
409         --sysconfdir=%{_sysconfdir}/git-core \
410         %{?with_pcre:--with-libpcre} \
411         --with-openssl
412
413 echo "BLK_SHA1=1" >> config.mak
414
415 %{__make} \
416         INSTALLDIRS=vendor \
417         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
418         GITWEB_PROJECTROOT="/var/lib/git" \
419         GITWEB_CSS="/gitweb/gitweb.css" \
420         GITWEB_LOGO="/gitweb/git-logo.png" \
421         GITWEB_FAVICON="/gitweb/git-favicon.png" \
422         V=1
423
424 %{__make} -C contrib/subtree
425
426 %if %{with doc}
427 %{__make} -C Documentation \
428         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
429         V=1
430 %endif
431
432 %if %{with tests}
433 %if %{without tests_cvs}
434 %{__rm} t/t*cvs*.sh || :
435 %endif
436 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
437 %endif
438
439 %install
440 rm -rf $RPM_BUILD_ROOT
441 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
442 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
443 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
444 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
445 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
446 [init]
447         templatedir = %{_sysconfdir}/%{name}/templates
448 EOF
449
450 %{__make} install \
451         INSTALLDIRS=vendor \
452         DESTDIR=$RPM_BUILD_ROOT
453
454 %if %{with doc}
455 %{__make} -C Documentation install \
456         DESTDIR=$RPM_BUILD_ROOT
457 %endif
458
459 # copy templates except sample hooks
460 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
461 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
462
463 # header files and lib
464 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
465 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
466 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
467 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
468 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
469 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
470 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
471 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
472
473 %{__make} -C contrib/subtree install \
474         libexecdir=%{_libdir}/%{name} \
475         DESTDIR=$RPM_BUILD_ROOT
476
477 %if %{with doc}
478 %{__make} -C contrib/subtree install-doc \
479         DESTDIR=$RPM_BUILD_ROOT
480 %endif
481
482 # bash completion
483 install -d $RPM_BUILD_ROOT%{bash_compdir}
484 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
485
486 # Install bzr and hg remote helpers from contrib
487 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
488
489 # gitweb
490 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
491 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
492 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
493 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
494 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
495 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
496 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
497
498 # gitview
499 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
500
501 # git-daemon related files
502 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
503 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
504 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
505
506 # paths cleanup
507 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
508 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
509
510 # hardlink
511 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
512 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
513 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
514 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
515
516 # remove unneeded files
517 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
518 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
519 %py_postclean
520
521 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
522 %find_lang git
523
524 %clean
525 rm -rf $RPM_BUILD_ROOT
526
527 %post daemon-inetd
528 %service -q rc-inetd reload
529
530 %postun daemon-inetd
531 if [ "$1" = "0" ]; then
532         %service -q rc-inetd reload
533 fi
534
535 %post daemon-standalone
536 /sbin/chkconfig --add git-daemon
537 %service git-daemon restart "git-daemon"
538
539 %preun daemon-standalone
540 if [ "$1" = "0" ]; then
541         %service git-daemon stop
542         /sbin/chkconfig --del git-daemon
543 fi
544
545 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
546 %webapp_register apache %{webapp}
547
548 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
549 %webapp_unregister apache %{webapp}
550
551 %triggerin gitweb -- apache < 2.2.0, apache-base
552 %webapp_register httpd %{webapp}
553
554 %triggerun gitweb -- apache < 2.2.0, apache-base
555 %webapp_unregister httpd %{webapp}
556
557 %triggerin gitweb -- lighttpd
558 %webapp_register lighttpd %{webapp}
559
560 %triggerun gitweb -- lighttpd
561 %webapp_unregister lighttpd %{webapp}
562
563 %files -f git.lang
564 %defattr(644,root,root,755)
565 %doc README contrib
566 %attr(755,root,root) %{_bindir}/git
567 %attr(755,root,root) %{_bindir}/git-receive-pack
568 %attr(755,root,root) %{_bindir}/git-shell
569 %attr(755,root,root) %{_bindir}/git-upload-archive
570 %attr(755,root,root) %{_bindir}/git-upload-pack
571 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
572
573 %if %{with doc}
574 %{_mandir}/man1/git-*.1*
575 %exclude %{_mandir}/man1/git-archimport.1*
576 %exclude %{_mandir}/man1/git-svn.1*
577 %exclude %{_mandir}/man1/git-cvs*.1*
578 %exclude %{_mandir}/man1/git-imap-send*.1*
579 %exclude %{_mandir}/man1/*email*.1*
580 %{_mandir}/man1/git.1*
581 %{_mandir}/man1/gitremote-helpers.1*
582 %{_mandir}/man5/gitattributes.5*
583 %{_mandir}/man5/githooks.5*
584 %{_mandir}/man5/gitignore.5*
585 %{_mandir}/man5/gitmodules.5*
586 %{_mandir}/man5/gitrepository-layout.5*
587 %{_mandir}/man7/gitcli.7*
588 %{_mandir}/man7/gitcore-tutorial.7*
589 %{_mandir}/man7/gitcredentials.7*
590 %{_mandir}/man7/gitdiffcore.7*
591 %{_mandir}/man7/gitglossary.7*
592 %{_mandir}/man7/gitnamespaces.7*
593 %{_mandir}/man7/gitrevisions.7*
594 %{_mandir}/man7/gittutorial-2.7*
595 %{_mandir}/man7/gittutorial.7*
596 %{_mandir}/man7/gitworkflows.7*
597 %endif
598
599 %dir %{_libdir}/%{name}
600 %attr(755,root,root) %{_libdir}/%{name}/*-*
601 %attr(755,root,root) %{_libdir}/%{name}/git
602 %dir %{_libdir}/%{name}/mergetools
603 %{_libdir}/%{name}/mergetools/*
604
605 %{_datadir}/%{name}
606 %{_localstatedir}/lib/git
607
608 # subpackages
609 %exclude %{_libdir}/%{name}/*email*
610 %exclude %{_libdir}/%{name}/*p4*
611 %exclude %{_libdir}/%{name}/git-archimport
612 %exclude %{_libdir}/%{name}/git-cvs*
613 %exclude %{_libdir}/%{name}/git-gui
614 %exclude %{_libdir}/%{name}/git-imap-send
615 %exclude %{_libdir}/%{name}/git-instaweb
616 %exclude %{_libdir}/%{name}/git-remote-bzr
617 %exclude %{_libdir}/%{name}/git-remote-hg
618 %exclude %{_libdir}/%{name}/git-remote-testsvn
619 %exclude %{_libdir}/%{name}/git-svn
620 %exclude %{_libdir}/%{name}/mergetools/p4merge
621
622 %if %{with doc}
623 %files doc
624 %defattr(644,root,root,755)
625 %doc Documentation/RelNotes*
626 %doc Documentation/*.html Documentation/howto Documentation/technical
627 %endif
628
629 %files daemon-inetd
630 %defattr(644,root,root,755)
631 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
632
633 %files daemon-standalone
634 %defattr(644,root,root,755)
635 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
636 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
637
638 %files devel
639 %defattr(644,root,root,755)
640 %{_includedir}/%{name}
641 %{_libdir}/libgit.a
642 %{_libdir}/libgit_xdiff.a
643
644 %files gitk
645 %defattr(644,root,root,755)
646 %if %{with doc}
647 %{_mandir}/man1/gitk.1*
648 %endif
649 %attr(755,root,root) %{_bindir}/gitk
650 %dir %{_datadir}/gitk
651 %dir %{_datadir}/gitk/lib
652 %dir %{_datadir}/gitk/lib/msgs
653 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
654 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
655 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
656 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
657 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
658 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
659 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
660 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
661 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
662 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
663
664 %files gitweb
665 %defattr(644,root,root,755)
666 %doc gitweb/{README,INSTALL}
667 %dir %{webappdir}
668 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
669 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
670 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
671 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
672 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
673 %attr(755,root,root) %{cgibindir}/gitweb.cgi
674 %{appdir}
675 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
676 %if %{with doc}
677 %{_mandir}/man1/gitweb.1*
678 %{_mandir}/man5/gitweb.conf.5*
679 %endif
680
681 %files gitview
682 %defattr(644,root,root,755)
683 %doc contrib/gitview/gitview.txt
684 %attr(755,root,root) %{_bindir}/gitview
685
686 %files gui
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/%{name}/git-gui
689 %dir %{_datadir}/git-gui
690 %dir %{_datadir}/git-gui/lib
691 %dir %{_datadir}/git-gui/lib/msgs
692 %{_datadir}/git-gui/lib/git-gui.ico
693 %{_datadir}/git-gui/lib/tclIndex
694 %{_datadir}/git-gui/lib/*.js
695 %{_datadir}/git-gui/lib/*.tcl
696 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
697 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
698 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
699 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
700 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
701 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
702 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
703 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
704 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
705 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
706 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
707 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
708
709 %files arch
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
712 %if %{with doc}
713 %{_mandir}/man1/git-archimport.1*
714 %endif
715
716 %files bzr
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
719
720 %files cvs
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_bindir}/git-cvsserver
723 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
724 %if %{with doc}
725 %{_mandir}/man1/git-cvs*.1*
726 %{_mandir}/man7/gitcvs-migration.7*
727 %endif
728
729 %files hg
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
732
733 %files p4
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/%{name}/git-p4
736 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
737
738 %files svn
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/%{name}/git-svn
741 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
742 %{perl_vendorlib}/Git/SVN
743 %{perl_vendorlib}/Git/SVN.pm
744 %if %{with doc}
745 %{_mandir}/man1/git-svn.1*
746 %endif
747
748 %files email
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
751 %attr(755,root,root) %{_libdir}/%{name}/*email*
752 %if %{with doc}
753 %{_mandir}/man1/*email*.1*
754 %{_mandir}/man1/*imap-send*.1*
755 %endif
756
757 %files -n bash-completion-git
758 %defattr(644,root,root,755)
759 %{bash_compdir}/git
760
761 %files -n perl-Git
762 %defattr(644,root,root,755)
763 %{perl_vendorlib}/Git.pm
764 %dir %{perl_vendorlib}/Git
765 %{perl_vendorlib}/Git/I18N.pm
766 %{perl_vendorlib}/Git/IndexInfo.pm
767 %{_mandir}/man3/Git*.3pm*
This page took 0.085266 seconds and 4 git commands to generate.