]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- tests fail with cvs-nserver-client; BC it
[packages/git-core.git] / git-core.spec
1
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The stupid content tracker
8 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
9 Name:           git-core
10 Version:        1.5.3.6
11 Release:        1
12 License:        GPL v2
13 Group:          Development/Tools
14 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
15 # Source0-md5:  9b0a6cea7b084f3fc78f264cd2fb49bd
16 Source1:        %{name}-gitweb.conf
17 Source2:        %{name}-gitweb-httpd.conf
18 URL:            http://git.or.cz/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-base
26 BuildRequires:  python
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuild(macros) >= 1.264
29 BuildRequires:  zlib-devel
30 %if %{with doc}
31 BuildRequires:  asciidoc >= 7.1.2-3
32 BuildRequires:  xmlto
33 %endif
34 %if %{with tests}
35 BuildRequires:  cvs
36 # tests fail when using this client
37 BuildConflicts: cvs-nserver-client
38 BuildRequires:  pdksh >= 5.2.14-46
39 %endif
40 Requires:       coreutils
41 Requires:       cpio
42 Requires:       curl
43 Requires:       diffutils
44 Requires:       findutils
45 Requires:       grep
46 Requires:       openssh-clients
47 Requires:       perl-Error
48 Requires:       rcs
49 Requires:       sed
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 # html docs have links to txt files
53 %define         _noautocompressdoc      *.txt
54
55 %define         webapp          gitweb
56 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
57 %define         appdir          %{_datadir}/%{webapp}
58 %define         cgibindir       %{_prefix}/lib/cgi-bin
59
60 %description
61 "git" can mean anything, depending on your mood.
62
63  - random three-letter combination that is pronounceable, and not
64    actually used by any common UNIX command. The fact that it is a
65    mispronunciation of "get" may or may not be relevant.
66  - stupid. contemptible and despicable. simple. Take your pick from the
67    dictionary of slang.
68  - "global information tracker": you're in a good mood, and it actually
69    works for you. Angels sing, and a light suddenly fills the room.
70  - "goddamn idiotic truckload of sh*t": when it breaks
71
72 This is a stupid (but extremely fast) directory content manager. It
73 doesn't do a whole lot, but what it 'does' do is track directory
74 contents efficiently.
75
76 %description -l pl.UTF-8
77 "git" może oznaczać cokolwiek, w zależności od nastroju.
78
79 - losową kombinację trzech liter, która jest wymawialna i
80   właściwie nie używana przez żadne popularne polecenie uniksowe.
81   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
82   mieć znaczenia.
83 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
84 - "global information tracker" (narzędzie do globalnego śledzenia
85   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
86   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
87 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
88   g*) - kiedy się zepsuje.
89
90 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
91 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
92 katalogu.
93
94 %package devel
95 Summary:        Header files for git-core
96 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
97 Group:          Development/Libraries
98
99 %description devel
100 Header files for git-core.
101
102 %description devel -l pl.UTF-8
103 Pliki nagłówkowe dla git-core.
104
105 %package gitk
106 Summary:        Tcl/Tk interface to the Git version control system
107 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
108 Group:          Development/Tools
109 Requires:       %{name} = %{version}-%{release}
110 Requires:       tk
111
112 %description gitk
113 Displays changes in a repository or a selected set of commits. This
114 includes visualizing the commit graph, showing information related to
115 each commit, and the files in the trees of each revision.
116
117 Historically, gitk was the first repository browser. It's written in
118 Tcl/Tk and started off in a separate repository but was later merged
119 into the main git repository.
120
121 %description gitk -l pl.UTF-8
122 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
123 to wizualizację grafu commitów, wyświetlanie informacji związanych z
124 każdym z commitów oraz listę plików dla każdej rewizji.
125
126 Z punktu widzenia historii, gitk był pierwszą przeglądarką
127 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
128 osobnym repozytorium, ale z czasem został włączony do głównego
129 repozytorium gita.
130
131 %package gitweb
132 Summary:        Web frontend to git
133 Summary(pl.UTF-8):      Webowy frontend do git
134 Group:          Development/Tools
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       webapps
137
138 %description gitweb
139 This package provides a web interface for browsing git repositories.
140
141 %description gitweb -l pl.UTF-8
142 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
143
144 %package gitview
145 Summary:        A GTK+ based repository browser for git
146 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
147 Group:          Development/Tools
148 Requires:       %{name} = %{version}-%{release}
149 #Requires:      pytongowe mambo dżambo
150
151 %description gitview
152 A GTK+ based repository browser for git.
153
154 %description gitview -l pl.UTF-8
155 Oparta na GTK+ przeglądarka repozytorium gita.
156
157 %package -n bash-completion-git
158 Summary:        bash-completion for git
159 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
160 Group:          Applications/Shells
161 Requires:       bash-completion
162
163 %description -n bash-completion-git
164 This package provides bash-completion for git.
165
166 %description -n bash-completion-git -l pl.UTF-8
167 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
168
169 %package -n perl-Git
170 Summary:        Perl interface to the Git version control system
171 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
172 Group:          Development/Languages/Perl
173 Requires:       %{name} = %{version}-%{release}
174 Obsoletes:      perl-git-core
175
176 %description -n perl-Git
177 This module provides Perl scripts easy way to interface the Git
178 version control system. The modules have an easy and well-tested way
179 to call arbitrary Git commands; in the future, the interface will also
180 provide specialized methods for doing easily operations which are not
181 totally trivial to do over the generic command interface.
182
183 %description -n perl-Git -l pl.UTF-8
184 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
185 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
186 dowolne polecenia Gita; w przyszłości interfejs udostępni także
187 specjalne metody do łatwego wykonywania operacji nietrywialnych do
188 wykonania przy użyciu ogólnego interfejsu poleceń.
189
190 %package -n vim-syntax-gitcommit
191 Summary:        Vim syntax: gitcommit
192 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
193 Group:          Applications/Editors/Vim
194 # for _vimdatadir existence
195 Requires:       vim >= 4:6.3.058-3
196
197 %description -n vim-syntax-gitcommit
198 This plugin provides syntax highlighting for git's commit messages.
199
200 %description -n vim-syntax-gitcommit -l pl.UTF-8
201 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
202
203 %prep
204 %setup -q -n git-%{version}
205
206 %build
207 %{__aclocal}
208 %{__autoconf}
209 %configure \
210         --with-openssl
211
212 %{__make} \
213         INSTALLDIRS=vendor \
214         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
215         GITWEB_PROJECTROOT="/var/lib/git" \
216         GITWEB_CSS="/gitweb/gitweb.css" \
217         GITWEB_LOGO="/gitweb/git-logo.png" \
218         GITWEB_FAVICON="/gitweb/git-favicon.png"
219
220 %{?with_doc:%{__make} -C Documentation}
221
222 %{?with_tests:%{__make} test}
223
224 %install
225 rm -rf $RPM_BUILD_ROOT
226 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
227 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
228 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
229 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
230
231 %{__make} install \
232         INSTALLDIRS=vendor \
233         DESTDIR=$RPM_BUILD_ROOT
234
235 %if %{with doc}
236 %{__make} -C Documentation install \
237         DESTDIR=$RPM_BUILD_ROOT
238 %endif
239
240 # header files and lib
241 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
242 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
243 install libgit.a $RPM_BUILD_ROOT%{_libdir}
244
245 # bash completion
246 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
247
248 # vim syntax
249 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
250
251 # gitweb
252 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
253 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
254 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
255 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
256 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
257
258 # gitview
259 install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
260
261 # remove unneeded files
262 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
263 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
264
265 %clean
266 rm -rf $RPM_BUILD_ROOT
267
268 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
269 %webapp_register apache %{webapp}
270
271 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
272 %webapp_unregister apache %{webapp}
273
274 %triggerin gitweb -- apache < 2.2.0, apache-base
275 %webapp_register httpd %{webapp}
276
277 %triggerun gitweb -- apache < 2.2.0, apache-base
278 %webapp_unregister httpd %{webapp}
279
280 %files
281 %defattr(644,root,root,755)
282 %doc README contrib
283 %if %{with doc}
284 %doc Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical
285 %{_mandir}/man1/git-*.1*
286 %{_mandir}/man5/gitattributes.5*
287 %{_mandir}/man5/gitignore.5*
288 %{_mandir}/man5/gitmodules.5*
289 %{_mandir}/man7/git.7*
290 %endif
291 %attr(755,root,root) %{_bindir}/git
292 %attr(755,root,root) %{_bindir}/git-*
293 %{_datadir}/%{name}
294 %{_datadir}/git-gui
295 %{_sharedstatedir}/git
296
297 %files devel
298 %defattr(644,root,root,755)
299 %{_includedir}/*
300 %{_libdir}/*.a
301
302 %files gitk
303 %defattr(644,root,root,755)
304 %if %{with doc}
305 %doc Documentation/gitk.html
306 %{_mandir}/man1/gitk.1*
307 %endif
308 %attr(755,root,root) %{_bindir}/gitk
309
310 %files gitweb
311 %defattr(644,root,root,755)
312 %doc gitweb/{README,INSTALL}
313 %dir %{webappdir}
314 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
315 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
316 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
317 %attr(755,root,root) %{cgibindir}/gitweb.cgi
318 %{appdir}
319
320 %files gitview
321 %defattr(644,root,root,755)
322 %doc contrib/gitview/gitview.txt
323 %attr(755,root,root) %{_bindir}/gitview
324
325 %files -n bash-completion-git
326 %defattr(644,root,root,755)
327 %{_sysconfdir}/bash_completion.d/*
328
329 %files -n perl-Git
330 %defattr(644,root,root,755)
331 %{perl_vendorlib}/Git.pm
332 %{_mandir}/man3/Git.3pm*
333
334 %files -n vim-syntax-gitcommit
335 %defattr(644,root,root,755)
336 %doc contrib/vim/README
337 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.049297 seconds and 4 git commands to generate.