]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- fix build with OpenEXR 3, rel 5
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # apidocs
4 %bcond_without  lua             # without lua support
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # API introspection
7 %bcond_without  vala            # Vala API
8
9 %if %{without introspection}
10 %undefine       with_vala
11 %endif
12
13 %ifarch x32
14 %undefine       with_lua
15 %endif
16
17 %define babl_ver        0.1.78
18 %define mrg_ver         0.1.4
19
20 Summary:        Generic image processing library
21 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
22 Name:           gegl
23 Version:        0.4.30
24 Release:        5
25 License:        LGPL v3+/GPL v3+
26 Group:          Libraries
27 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.xz
28 # Source0-md5:  6ae601b8c7cab8af5a36406df0b95ebf
29 Patch1:         %{name}-ruby1.9.patch
30 Patch2:         %{name}-build.patch
31 Patch3:         umfpack.patch
32 Patch4:         %{name}-link.patch
33 Patch5:         %{name}-no-lua.patch
34 Patch6:         openexr3.patch
35 URL:            https://www.gegl.org/
36 BuildRequires:  OpenEXR-devel >= 1.6.1
37 BuildRequires:  SDL2-devel >= 2.0.5
38 BuildRequires:  UMFPACK-devel
39 BuildRequires:  asciidoc
40 BuildRequires:  babl-devel >= %{babl_ver}
41 BuildRequires:  bash
42 BuildRequires:  cairo-devel >= 1.12.2
43 BuildRequires:  enscript
44 BuildRequires:  exiv2-devel >= 0.25
45 # libavcodec >= 55.69.100, libavformat >= 55.48.100, libavutil >= 55.92.100, libswscale >= 2.6.100
46 BuildRequires:  ffmpeg-devel >= 2.3
47 BuildRequires:  gcc >= 5:4.7
48 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
49 BuildRequires:  gettext-tools >= 0.19.8
50 BuildRequires:  gexiv2-devel
51 BuildRequires:  glib2-devel >= 1:2.44.0
52 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
53 BuildRequires:  graphviz
54 BuildRequires:  gtk-doc >= 1.0
55 BuildRequires:  jasper-devel >= 1.900.1
56 BuildRequires:  json-glib-devel >= 1.2.6
57 BuildRequires:  lcms2-devel >= 2.8
58 BuildRequires:  lensfun-devel >= 0.2.5
59 BuildRequires:  libjpeg-devel >= 1.0.0
60 BuildRequires:  libnsgif-devel
61 BuildRequires:  libpng-devel >= 2:1.6.0
62 BuildRequires:  libraw-devel >= 0.15.4
63 BuildRequires:  librsvg-devel >= 1:2.40.6
64 BuildRequires:  libspiro-devel >= 0.5.0
65 BuildRequires:  libstdc++-devel >= 6:5
66 BuildRequires:  libtiff-devel >= 4.0.0
67 BuildRequires:  libv4l-devel >= 1.0.1
68 BuildRequires:  libwebp-devel >= 0.5.0
69 %if %{with lua}
70 BuildRequires:  luajit-devel >= 2.0.4
71 BuildRequires:  lua51-devel >= 5.1.5-2
72 %endif
73 BuildRequires:  maxflow-devel >= 3.0.4
74 BuildRequires:  meson >= 0.50.0
75 BuildRequires:  mrg-devel >= %{mrg_ver}
76 BuildRequires:  ninja >= 1.5
77 BuildRequires:  pango-devel >= 1:1.38.0
78 BuildRequires:  perl-base >= 5
79 BuildRequires:  pkgconfig
80 BuildRequires:  poppler-glib-devel >= 0.71.0
81 BuildRequires:  python3 >= 1:3.2
82 %if %{with introspection}
83 # for tests only
84 #BuildRequires: python-pygobject3-devel >= 3.2.0
85 %endif
86 BuildRequires:  poly2tri-c-devel
87 BuildRequires:  rpmbuild(macros) >= 1.736
88 BuildRequires:  ruby >= 1.9
89 BuildRequires:  tar >= 1:1.22
90 %if %{with vala}
91 BuildRequires:  vala >= 2:0.20.0
92 BuildRequires:  vala-babl >= %{babl_ver}
93 %endif
94 BuildRequires:  xz
95 BuildRequires:  zlib-devel >= 1.2.0
96 Requires:       OpenEXR >= 1.6.1
97 Requires:       SDL2 >= 2.0.5
98 Requires:       babl >= %{babl_ver}
99 Requires:       cairo >= 1.12.2
100 Requires:       gdk-pixbuf2 >= 2.32.0
101 Requires:       glib2 >= 1:2.44.0
102 Requires:       jasper-libs >= 1.900.1
103 Requires:       json-glib >= 1.2.6
104 Requires:       lcms2 >= 2.8
105 Requires:       lensfun >= 0.2.5
106 Requires:       libraw >= 0.15.4
107 Requires:       librsvg >= 1:2.40.6
108 Requires:       libspiro >= 0.5.0
109 Requires:       libtiff >= 4.0.0
110 Requires:       libwebp >= 0.5.0
111 Requires:       maxflow >= 3.0.4
112 Requires:       mrg-libs >= %{mrg_ver}
113 Requires:       pango >= 1:1.38.0
114 Requires:       poppler-glib >= 0.71.0
115 Requires:       zlib >= 1.2.0
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %description
119 GEGL (Generic Graphics Library) is a graph based image processing
120 framework.
121
122 GEGL's original design was made to scratch GIMP's itches for a new
123 compositing and processing core. This core is being designed to have
124 minimal dependencies and a simple well defined API.
125
126 %description -l pl.UTF-8
127 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
128 przetwarzania obrazu.
129
130 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
131 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
132 projektowany tak, by miał minimalne zależności i proste, dobrze
133 zdefiniowane API.
134
135 %package devel
136 Summary:        Header files for gegl library
137 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
138 Group:          Development/Libraries
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       babl-devel >= %{babl_ver}
141 Requires:       glib2-devel >= 1:2.44.0
142 Requires:       json-glib-devel >= 1.2.6
143 Requires:       poly2tri-c-devel
144
145 %description devel
146 Header files for gegl library.
147
148 %description devel -l pl.UTF-8
149 Pliki nagłówkowe biblioteki gegl.
150
151 %package static
152 Summary:        Static gegl library
153 Summary(pl.UTF-8):      Statyczna biblioteka gegl
154 Group:          Development/Libraries
155 Requires:       %{name}-devel = %{version}-%{release}
156
157 %description static
158 Static gegl library.
159
160 %description static -l pl.UTF-8
161 Statyczna biblioteka gegl.
162
163 %package apidocs
164 Summary:        gegl library API documentation
165 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
166 Group:          Documentation
167 Requires:       gtk-doc-common
168 BuildArch:      noarch
169
170 %description apidocs
171 gegl library API documentation.
172
173 %description apidocs -l pl.UTF-8
174 Dokumentacja API biblioteki gegl.
175
176 %package -n vala-gegl
177 Summary:        Vala API for gegl library
178 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
179 Group:          Development/Libraries
180 Requires:       %{name}-devel = %{version}-%{release}
181 BuildArch:      noarch
182
183 %description -n vala-gegl
184 Vala API for gegl library.
185
186 %description -n vala-gegl -l pl.UTF-8
187 API języka Vala dla biblioteki gegl.
188
189 %prep
190 %setup -q
191 %patch1 -p1
192 %patch2 -p1
193 %patch3 -p1
194 %patch4 -p1
195 %patch5 -p1
196 %patch6 -p1
197
198 %build
199 CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack"
200 %meson build \
201         %{?with_doc:-Ddocs=true} \
202         %{!?with_introspection:-Dintrospection=false} \
203         %{!?with_lua:-Dlua=disabled} \
204         -Dworkshop=true
205
206 %ninja_build -C build
207
208 %if %{with doc}
209 rmdir build/docs/operations/RAM
210 # possible gegl-tester coredumps?
211 rm -f build/docs/operations/core*
212 %endif
213
214 %install
215 rm -rf $RPM_BUILD_ROOT
216
217 %ninja_install -C build
218
219 %find_lang %{name}-0.4
220
221 %clean
222 rm -rf $RPM_BUILD_ROOT
223
224 %post   -p /sbin/ldconfig
225 %postun -p /sbin/ldconfig
226
227 %files -f %{name}-0.4.lang
228 %defattr(644,root,root,755)
229 %doc AUTHORS MAINTAINERS
230 %attr(755,root,root) %{_bindir}/gegl
231 %attr(755,root,root) %{_bindir}/gegl-imgcmp
232 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
233 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
234 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
235 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
236 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
237 %dir %{_libdir}/gegl-0.4
238 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
239 %{_libdir}/gegl-0.4/dropshadow2.json
240 %{_libdir}/gegl-0.4/grey2.json
241 %if %{with lua}
242 %dir %{_datadir}/gegl-0.4
243 %{_datadir}/gegl-0.4/lua
244 %endif
245
246 %files devel
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
249 %{_includedir}/gegl-0.4
250 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
251 %{_pkgconfigdir}/gegl-0.4.pc
252 %{_pkgconfigdir}/gegl-sc-0.4.pc
253
254 %if %{with static_libs}
255 %files static
256 %defattr(644,root,root,755)
257 %{_libdir}/libgegl-0.4.a
258 %{_libdir}/libgegl-npd-0.4.a
259 %{_libdir}/libgegl-sc-0.4.a
260 %endif
261
262 %if %{with doc}
263 %files apidocs
264 %defattr(644,root,root,755)
265 %doc build/docs/{operations,*.html,*.png}
266 %{_gtkdocdir}/gegl
267 %endif
268
269 %if %{with vala}
270 %files -n vala-gegl
271 %defattr(644,root,root,755)
272 %{_datadir}/vala/vapi/gegl-0.4.deps
273 %{_datadir}/vala/vapi/gegl-0.4.vapi
274 %endif
This page took 0.063506 seconds and 3 git commands to generate.