]> git.pld-linux.org Git - packages/gdm.git/blob - gdm.spec
- added patch so /var/lib/gdm can be 770 root.xdm
[packages/gdm.git] / gdm.spec
1 Summary:        GNOME Display Manager
2 Summary(es):    Administrador de Entrada del GNOME
3 Summary(pl):    gdm
4 Summary(pt_BR): Gerenciador de Entrada do GNOME
5 Name:           gdm
6 Version:        2.2.5.4
7 Release:        2
8 Epoch:          1
9 License:        LGPL/GPL
10 Group:          X11/Applications
11 Group(de):      X11/Applikationen
12 Group(es):      X11/Aplicaciones
13 Group(pl):      X11/Aplikacje
14 Group(pt_BR):   X11/Aplicações
15 Group(pt):      X11/Aplicações
16 Source0:        ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{version}.tar.bz2
17 Source1:        %{name}.pamd
18 Source2:        %{name}.init
19 Source3:        %{name}.conf
20 Patch0:         %{name}-xdmcp.patch
21 Patch1:         %{name}-am_fixes.patch
22 Patch2:         %{name}-permissions.patch
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  esound-devel
26 BuildRequires:  gdk-pixbuf-devel
27 BuildRequires:  gettext-devel
28 BuildRequires:  gnome-libs-devel
29 BuildRequires:  gtk+-devel
30 BuildRequires:  libglade-devel
31 BuildRequires:  libtool
32 BuildRequires:  libxml-devel
33 BuildRequires:  perl-modules
34 BuildRequires:  scrollkeeper
35 BuildRequires:  intltool >= 0.14
36 Requires:       gnome-libs >= 1.0.0
37 Requires:       which
38 Requires:       /usr/X11R6/bin/sessreg
39 Prereq:         scrollkeeper
40 Prereq:         shadow
41 Prereq:         /sbin/chkconfig
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43 Obsoletes:      xdm kdm wdm
44
45 %define         _prefix         /usr/X11R6
46 %define         _bindir         %{_prefix}/bin
47 %define         _datadir        %{_prefix}/share
48 %define         _sbindir        %{_prefix}/sbin
49 %define         _mandir         %{_prefix}/man
50 %define         _localstatedir  /var/lib
51 %define         _sysconfdir     /etc/X11
52 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
53
54 %description 
55 gdm manages local and remote displays and provides the user with a
56 graphical login window.
57
58 %description -l es
59 Administrador de Entrada del GNOME.
60
61 %description -l pl
62 gdm zarz±dza lokalnymi i zdalnymi X serwerami i udostêpnia
63 u¿ytkownikowi graficzne okienko logowania.
64
65 %description -l pt_BR
66 Gerenciador de Entrada do GNOME.
67
68 %package Xnest
69 Summary:        Xnest (ie embedded X) server for GDM
70 Group:          X11/Applications
71 Group(de):      X11/Applikationen
72 Group(es):      X11/Aplicaciones
73 Group(pl):      X11/Aplikacje
74 Group(pt_BR):   X11/Aplicações
75 Group(pt):      X11/Aplicações
76 Requires:       %{name} = %{version}
77 Requires:       XFree86-Xnest
78
79 %description Xnest
80 Gdm (the GNOME Display Manager) is a highly configurable
81 reimplementation of xdm, the X Display Manager. Gdm allows you to log
82 into your system with the X Window System running and supports running
83 several different X sessions on your local machine at the same time.
84
85 This package add support for Xnest server in gdm.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92
93 %build
94 rm -f missing
95 libtoolize --copy --force
96 gettextize --copy --force
97 aclocal -I %{_aclocaldir}/gnome
98 autoconf
99 automake -a -c
100 %configure \
101         --with-xinerama=yes \
102         --with-xdmcp=yes \
103         --with-tcp-wrappers=yes \
104         --disable-console-helper
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,security}
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         Settingsdir=%{_applnkdir}/Settings/GNOME \
115         Systemdir=%{_applnkdir}/System \
116         omf_dest_dir=%{_omf_dest_dir}/omf/%{name}
117
118 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/gdm
119 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/gdm
120 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/gdm.conf
121 touch $RPM_BUILD_ROOT/etc/security/blacklist.gdm
122
123 mv $RPM_BUILD_ROOT%{_applnkdir}/System/gdmconfig.desktop \
124         $RPM_BUILD_ROOT%{_applnkdir}/Settings/GNOME/
125
126 gzip -9nf AUTHORS ChangeLog NEWS README TODO
127
128 %find_lang %{name} --all-name --with-gnome
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %pre
134 /usr/sbin/groupadd -g 55 -r -f xdm
135
136 if [ -z "`id -u xdm 2>/dev/null`" ]; then
137         /usr/sbin/useradd -u 55 -r -d /dev/null -s /bin/false -c 'X Display Manager' -g xdm xdm 1>&2
138 fi
139
140 %post
141 /sbin/chkconfig --add gdm
142 if [ -f /var/lock/subsys/gdm ]; then
143         echo "Run \"/etc/rc.d/init.d/gdm restart\" to restart gdm." >&2
144 else
145         echo "Run \"/etc/rc.d/init.d/gdm start\" to start gdm." >&2
146 fi
147 /usr/bin/scrollkeeper-update
148
149 %preun
150 if [ "$1" = "0" ]; then
151         if [ -f /var/lock/subsys/gdm ]; then
152                  /etc/rc.d/init.d/gdm stop >&2
153         fi
154         /sbin/chkconfig --del gdm
155 fi
156
157 %postun
158 if [ "$1" = "0" ]; then
159         if [ -n "`id -u xdm 2>/dev/null`" ]; then
160                 /usr/sbin/userdel xdm
161         fi
162         /usr/sbin/groupdel xdm
163 fi
164 /usr/bin/scrollkeeper-update
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc *.gz
169 %attr(755,root,root) %{_bindir}/gdm
170 %attr(755,root,root) %{_bindir}/gdmchooser
171 %attr(755,root,root) %{_bindir}/gdmconfig
172 %attr(755,root,root) %{_bindir}/gdmflexiserver
173 %attr(755,root,root) %{_bindir}/gdmlogin
174 %attr(755,root,root) %{_bindir}/gdmmktemp
175 %attr(755,root,root) %{_bindir}/gdmphotosetup
176 %attr(755,root,root) %{_sbindir}/*
177 %attr(755,root,root) %config %{_sysconfdir}/gdm/Init
178 %attr(755,root,root) %config %{_sysconfdir}/gdm/PreSession
179 %attr(755,root,root) %config %{_sysconfdir}/gdm/Sessions
180 %attr(755,root,root) %config %{_sysconfdir}/gdm/PostSession
181 %attr(755,root,root) %config %{_sysconfdir}/gdm/gnomerc
182 %attr(755,root,root) %config %{_sysconfdir}/gdm/XKeepsCrashing
183 %config %{_sysconfdir}/gdm/factory-gdm.conf
184 %config %{_sysconfdir}/gdm/gdm.conf
185 %config %{_sysconfdir}/gdm/locale.alias
186 %attr(755,root,root) %dir %{_sysconfdir}/gdm
187 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/gdm
188 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.gdm
189 %attr(770,root,xdm)  /var/lib/gdm
190 %attr(754,root,root) /etc/rc.d/init.d/gdm
191 %{_pixmapsdir}/*
192 # these lines to devel subpackage?
193 %{_applnkdir}/Settings/GNOME/*
194 %{_applnkdir}/System/gdmflexiserver.desktop
195 %{_datadir}/gdm
196 %{_omf_dest_dir}/omf/%{name}
197
198 %files Xnest
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_bindir}/gdmXnestchooser
201 %{_applnkdir}/System/gdmflexiserver-xnest.desktop
This page took 0.077007 seconds and 4 git commands to generate.