]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- teach gdb about little-endian IBM long double (required for binutils 2.24.51.0.1)
[packages/gdb.git] / gdb.spec
1 # NOTE
2 # - Do not remove -lib package, it is required by FPC
3
4 # TODO
5 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6 #
7 # Conditional build:
8 %bcond_without  python          # build without python support
9
10 Summary:        A GNU source-level debugger for C, C++ and Fortran
11 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
12 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
13 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
14 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
15 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
16 Summary(ru.UTF-8):      Символический отладчик для C и других языков
17 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
18 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
19 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
20 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
21 %define         snap    20120926
22 Name:           gdb
23 Version:        7.6.1
24 Release:        2
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
28 # Source0-md5:  fbc4dab4181e6e9937075b43a4ce2732
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 Patch100:       gdb-6.6-buildid-locate.patch
33 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
34 Patch102:       gdb-6.6-buildid-locate-rpm.patch
35 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch105:       gdb-6.3-gstack-20050411.patch
38 Patch106:       gdb-gdb-add-index-script.patch
39 Patch107:       floatformat_ibm_long_double.patch
40 Patch1000:      %{name}-readline.patch
41 Patch1001:      %{name}-info.patch
42 Patch1002:      %{name}-passflags.patch
43 Patch1005:      %{name}-pretty-print-by-default.patch
44 Patch1006:      buildid-locate-rpm-pld.patch
45 URL:            http://www.gnu.org/software/gdb/
46 BuildRequires:  autoconf >= 2.69
47 BuildRequires:  automake
48 BuildRequires:  bison
49 BuildRequires:  expat-devel
50 BuildRequires:  flex
51 BuildRequires:  gettext-devel
52 BuildRequires:  libselinux-devel
53 BuildRequires:  libtool
54 BuildRequires:  libunwind-devel >= 0.97
55 BuildRequires:  ncurses-devel >= 5.2
56 BuildRequires:  pkgconfig
57 BuildRequires:  readline-devel
58 BuildRequires:  rpmbuild(macros) >= 1.219
59 BuildRequires:  texinfo >= 4.4
60 BuildRequires:  zlib-devel
61 %if %{with python}
62 BuildRequires:  python-devel
63 BuildRequires:  rpm-pythonprov
64 Obsoletes:      python-gdb
65 # for traceback module
66 Requires:       python-modules
67 %endif
68 Requires:       libunwind >= 0.97
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Gdb is a full featured, command driven debugger. Gdb allows you to
73 trace the execution of programs and examine their internal state at
74 any time. Gdb works for C and C++ compiled with the GNU C compiler
75 gcc.
76
77 %description -l de.UTF-8
78 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
79 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
80 kompiliertes C++.
81
82 %description -l es.UTF-8
83 Este es un debugger orientado a comandos repleto de características.
84 Te permite rastrear la ejecución de programas y examinar su estado
85 interno a cualquier momento. Funciona para C y C++ compilado con el
86 compilador GNU C.
87
88 %description -l fr.UTF-8
89 Débugger complet, piloté par commandes. Permet de tracer l'exécution
90 des programmes et d'examiner à tout moment leur état interne.
91 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
92 de GNU, gcc.
93
94 %description -l pl.UTF-8
95 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
96 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
97 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
98 przy pomocy kompilatora GNU (gcc).
99
100 %description -l pt_BR.UTF-8
101 Este é um debugger orientado a comandos repleto de características.
102 Ele permite à você rastrear a execução de programas e examinar o seu
103 estado interno a qualquer momento. Ele funciona para para C e C++
104 compilado com o compilador GNU C.
105
106 %description -l ru.UTF-8
107 Это полноценный отладчик, управляемый командами. Он позволяет
108 трассировать исполнение программ и изучать их внутреннее состояние в
109 любой момент времени. Работает с программами на C и C++,
110 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
111
112 %description -l tr.UTF-8
113 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
114 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
115 verir.
116
117 %description -l uk.UTF-8
118 Це повноцінний відладчик, що керується командами. Він дозволяє
119 трасувати виконання програм та вивчати їх внутрішній стан в довільний
120 момент часу. Працює з програмами на C та C++, зкомпільованими
121 компіляторами GNU C (gcc, egcs, pgcc).
122
123 %package gdbserver
124 Summary:        A standalone server for GDB (the GNU source-level debugger)
125 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
126 Group:          Development/Debuggers
127
128 %description gdbserver
129 GDB, the GNU debugger, allows you to debug programs written in C, C++,
130 Java, and other languages, by executing them in a controlled fashion
131 and printing their data.
132
133 This package provides a program that allows you to run GDB on a
134 different machine than the one which is running the program being
135 debugged.
136
137 %description gdbserver -l pl.UTF-8
138 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
139 innych językach programowania poprzez wykonywanie ich w sposób
140 kontrolowany oraz wypisywanie ich danych.
141
142 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
143 maszynie niż ta, na której działa śledzony program.
144
145 %package lib
146 Summary:        GDB in the form of a static library
147 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
148 Group:          Development/Debuggers
149 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
150 Requires:       binutils-devel >= 2.17.50
151 Requires:       expat-devel
152 Requires:       libselinux-devel
153 Requires:       libsepol-devel
154 Requires:       ncurses-devel
155 Requires:       python-devel
156 Requires:       readline-devel
157 Requires:       xz-devel
158 Requires:       zlib-devel
159
160 %description lib
161 GDB in the form of a static library.
162
163 %description lib -l pl.UTF-8
164 GDB w postaci biblioteki statycznej.
165
166 %prep
167 %setup -q
168
169 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
170 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
171 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
172
173 %patch100 -p1
174 %patch101 -p1
175 %patch102 -p1
176 %patch103 -p1
177 %patch104 -p1
178 %patch105 -p1
179 %patch106 -p1
180 %patch107 -p1
181
182 %patch1000 -p1
183 %patch1001 -p1
184 %patch1002 -p1
185 %patch1005 -p1
186 %patch1006 -p1
187
188 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
189 cat > gdb/version.in << EOF
190 %{version}-%{release} (PLD Linux)
191 EOF
192
193 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
194
195 %build
196 # omit hand-written gdb/testsuite aclocal.m4
197 for dir in gdb gdb/gdbserver ; do
198         olddir=$(pwd)
199         cd $dir
200         %{__rm} aclocal.m4
201         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
202         cd $olddir
203 done
204 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
205         dir=$(dirname "$dir")
206         olddir=$(pwd)
207         cd $dir
208         %{__autoconf}
209         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
210         cd $olddir
211 done
212 cp -f /usr/share/automake/config.* .
213 # don't --enable-shared here, there would be libs version mismatch with binutils
214 %configure \
215         --with-gdb-datadir=%{_datadir}/gdb \
216         --with-separate-debug-dir=/usr/lib/debug \
217 %if %{with python}
218         --with-python=yes \
219         --with-pythondir=%{py_sitescriptdir} \
220 %else
221         --without-python \
222 %endif
223         --disable-gdbtk \
224         --disable-shared \
225         --enable-gdbcli \
226         --enable-gdbmi \
227         --enable-multi-ice \
228         --enable-netrom \
229         --enable-nls \
230         --enable-tui \
231         --with-system-readline \
232         --with-cpu=%{_target_cpu} \
233 %ifnarch alpha
234         --with-mmalloc \
235 %endif
236         --without-included-gettext \
237         --without-included-regex \
238         --without-x
239
240 %{__make}
241 %{__make} -j1 info
242
243 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
244 %{__make} -C gdb libgdb.a
245
246 %install
247 rm -rf $RPM_BUILD_ROOT
248 install -d $RPM_BUILD_ROOT%{_infodir}
249
250 %{__make} -j1 install install-info \
251         DESTDIR=$RPM_BUILD_ROOT
252
253 # gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
254 # window is created too.
255 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
256 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
257
258 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
259 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
260
261 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
262 rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
263
264 %if %{with python}
265 # Temporarily now:
266 for LIB in lib lib64; do
267         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
268         install -d $LIBPATH
269 done
270
271 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
272 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
273 %py_postclean
274 %endif
275
276 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
277
278 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
279
280 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
281 # These are part of binutils
282 rm -rf $RPM_BUILD_ROOT%{_localedir}
283 rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
284 rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
285 rm -f $RPM_BUILD_ROOT%{_infodir}/mmalloc*
286 rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
287 rm -rf $RPM_BUILD_ROOT%{_includedir}
288 rm -rf $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*,iberty*,mmalloc*}
289
290 %clean
291 rm -rf $RPM_BUILD_ROOT
292
293 %post   -p /sbin/postshell
294 -/usr/sbin/fix-info-dir -c %{_infodir}
295
296 %postun -p /sbin/postshell
297 -/usr/sbin/fix-info-dir -c %{_infodir}
298
299 %files
300 %defattr(644,root,root,755)
301 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
302 %attr(755,root,root) %{_bindir}/gdb
303 %attr(755,root,root) %{_bindir}/gdbtui
304 %attr(755,root,root) %{_bindir}/gdb-add-index
305 %attr(755,root,root) %{_bindir}/gstack
306 %dir %{_datadir}/gdb
307 %dir %{_datadir}/gdb/auto-load
308 %dir %{_datadir}/gdb/auto-load%{_prefix}
309 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
310 %ifarch %{x8664}
311 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
312 %endif
313 %{_datadir}/gdb/syscalls
314 %{_datadir}/gdb/python
315 %{_mandir}/man1/gdb.1*
316 %{_mandir}/man1/gdbtui.1*
317 %{_mandir}/man1/gstack.1*
318 %lang(es) %{_mandir}/es/man1/*
319 %lang(fr) %{_mandir}/fr/man1/*
320 %lang(hu) %{_mandir}/hu/man1/*
321 %lang(ja) %{_mandir}/ja/man1/*
322 %lang(pl) %{_mandir}/pl/man1/*
323 %{_infodir}/annotate.info*
324 %{_infodir}/gdb.info*
325 %{_infodir}/gdbint.info*
326 %{_infodir}/stabs.info*
327
328 %files gdbserver
329 %defattr(644,root,root,755)
330 %attr(755,root,root) %{_bindir}/gdbserver
331 %{_mandir}/man1/gdbserver.1*
332 %attr(755,root,root) %{_libdir}/libinproctrace.so
333
334 %files lib
335 %defattr(644,root,root,755)
336 %{_libdir}/libdecnumber.a
337 %{_libdir}/libgdb.a
This page took 0.05448 seconds and 4 git commands to generate.