]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- no subshells
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen
3 Summary(es):    Depurador de programas C y otras lenguajes
4 Summary(fr):    Débugger symbolique pour C et d'autres langages
5 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
6 Summary(pt_BR): Depurador de programas C e outras linguagens
7 Summary(ru):    óÉÍ×ÏÌÉÞÅÓËÉÊ ÏÔÌÁÄÞÉË ÄÌÑ C É ÄÒÕÇÉÈ ÑÚÙËÏ×
8 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
9 Summary(uk):    óÉÍ×ÏÌØÎÉʠצÄÌÁÄÞÉË ÄÌÑ ó ÔÁ ¦ÎÛÉÈ ÍÏ×
10 Name:           gdb
11 Version:        5.2
12 Release:        1
13 License:        GPL
14 Group:          Development/Debuggers
15 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.gz
16 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
17 Patch0:         %{name}-gettext.patch
18 Patch1:         %{name}-ncurses.patch
19 Patch2:         %{name}-readline.patch
20 Patch3:         %{name}-info.patch
21 Patch4:         %{name}-procfs.patch
22 Patch5:         %{name}-passflags.patch
23 BuildRequires:  XFree86-devel
24 BuildRequires:  autoconf >= 2.53
25 BuildRequires:  libtool
26 BuildRequires:  ncurses-devel >= 5.2
27 BuildRequires:  readline-devel >= 4.2
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Gdb is a full featured, command driven debugger. Gdb allows you to
32 trace the execution of programs and examine their internal state at
33 any time. Gdb works for C and C++ compiled with the GNU C compiler
34 gcc.
35
36 %description -l de
37 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
38 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
39 kompiliertes C++.
40
41 %description -l es
42 Este es un debugger orientado a comandos repleto de características.
43 Te permite rastrear la ejecución de programas y examinar su estado
44 interno a cualquier momento. Funciona para C y C++ compilado con el
45 compilador GNU C.
46
47 %description -l fr
48 Débugger complet, piloté par commandes. Permet de tracer l'exécution
49 des programmes et d'examiner à tout moment leur état interne.
50 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
51 de GNU, gcc.
52
53 %description -l pl
54 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
55 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
56 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
57 przy pomocy kompilatora GNU (gcc).
58
59 %description -l pt_BR
60 Este é um debugger orientado a comandos repleto de características.
61 Ele permite à você rastrear a execução de programas e examinar o seu
62 estado interno a qualquer momento. Ele funciona para para C e C++
63 compilado com o compilador GNU C.
64
65 %description -l ru
66 üÔÏ ÐÏÌÎÏÃÅÎÎÙÊ ÏÔÌÁÄÞÉË, ÕÐÒÁ×ÌÑÅÍÙÊ ËÏÍÁÎÄÁÍÉ. ïΠÐÏÚ×ÏÌÑÅÔ
67 ÔÒÁÓÓÉÒÏ×ÁÔØ ÉÓÐÏÌÎÅÎÉÅ ÐÒÏÇÒÁÍÍ É ÉÚÕÞÁÔØ ÉÈ ×ÎÕÔÒÅÎÎÅÅ ÓÏÓÔÏÑÎÉÅ ×
68 ÌÀÂÏÊ ÍÏÍÅÎÔ ×ÒÅÍÅÎÉ. òÁÂÏÔÁÅÔ Ó ÐÒÏÇÒÁÍÍÁÍÉ ÎÁ C É C++,
69 ÓËÏÍÐÉÌÉÒÏ×ÁÎÎÙÍÉ GNU ËÏÍÐÉÌÑÔÏÒÏÍ C (gcc, egcs, pgcc).
70
71 %description -l tr
72 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
73 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
74 verir.
75
76 %description -l uk
77 ãÅ ÐÏ×ÎÏæÎÎÉʠצÄÌÁÄÞÉË, ÝÏ ËÅÒÕ¤ÔØÓÑ ËÏÍÁÎÄÁÍÉ. ÷¦Î ÄÏÚ×ÏÌѤ
78 ÔÒÁÓÕ×ÁÔÉ ×ÉËÏÎÁÎÎÑ ÐÒÏÇÒÁÍ ÔÁ ×É×ÞÁÔÉ §È ×ÎÕÔÒ¦ÛΦʠÓÔÁΠנÄÏצÌØÎÉÊ
79 ÍÏÍÅÎÔ ÞÁÓÕ. ðÒÁÃÀ¤ Ú ÐÒÏÇÒÁÍÁÍÉ ÎÁ C ÔÁ C++, ÚËÏÍЦÌØÏ×ÁÎÉÍÉ
80 ËÏÍЦÌÑÔÏÒÁÍÉ GNU C (gcc, egcs, pgcc).
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p1
88 %patch4 -p1
89 %patch5 -p1
90
91 %build
92 cd gdb
93 %{__autoconf}
94 cd doc
95 %{__autoconf}
96 cd ../testsuite
97 %{__autoconf}
98 cd gdb.asm
99 %{__autoconf}
100 cd ../gdb.base
101 %{__autoconf}
102 cd ../gdb.c++
103 %{__autoconf}
104 cd ../gdb.chill
105 %{__autoconf}
106 cd ../gdb.disasm
107 %{__autoconf}
108 #cd ../gdb.fortran
109 #%{__autoconf}
110 cd ../gdb.java
111 %{__autoconf}
112 cd ../gdb.mi
113 %{__autoconf}
114 cd ../gdb.stabs
115 %{__autoconf}
116 cd ../gdb.threads
117 %{__autoconf}
118 cd ../gdb.trace
119 %{__autoconf}
120 cd ../../gdbserver
121 %{__autoconf}
122 cd ../..
123 # !! Don't enable shared here !!
124 # This will cause serious problems --misiek
125 %configure2_13 \
126         --disable-shared \
127         --enable-nls \
128         --without-included-gettext \
129         --without-included-regex \
130         --enable-gdcli \
131         --enable-gdbmi \
132         --enable-multi-ice \
133         --enable-netrom \
134         --with-cpu=%{_target_cpu} \
135         --enable-tui \
136 %ifnarch alpha
137         --with-mmalloc
138 %endif
139
140 # something is wrong after above - e.g. $exeext=="no" - fix it:
141 cd gdb
142 %configure
143 cd ..
144
145 %{__make}
146 %{__make} info
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT%{_infodir}
151
152 %{__make} install install-info \
153         prefix=$RPM_BUILD_ROOT%{_prefix} \
154         bindir=$RPM_BUILD_ROOT%{_bindir} \
155         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
156         infodir=$RPM_BUILD_ROOT%{_infodir} \
157         includedir=$RPM_BUILD_ROOT%{_includedir} \
158         libdir=$RPM_BUILD_ROOT%{_libdir} \
159         mandir=$RPM_BUILD_ROOT%{_mandir}
160
161 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post
167 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
168
169 %postun
170 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
171
172 %files
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/*
175
176 %{_mandir}/man1/*
177 %lang(es) %{_mandir}/es/man1/*
178 %lang(fr) %{_mandir}/fr/man1/*
179 %lang(hu) %{_mandir}/hu/man1/*
180 %lang(ja) %{_mandir}/ja/man1/*
181 %lang(pl) %{_mandir}/pl/man1/*
182 %{_infodir}/gdb*.info*
183 %{_infodir}/stabs*.info*
This page took 0.063703 seconds and 4 git commands to generate.