]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- added info directory fixes to info patch
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        5.0
8 Release:        7
9 License:        GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Group(de):      Entwicklung/Debugger
13 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.bz2
14 Patch0:         %{name}-gettext.patch
15 Patch1:         %{name}-ncurses.patch
16 Patch2:         %{name}-readline.patch
17 Patch3:         %{name}-info.patch
18 Patch4:         %{name}-procfs.patch
19 BuildRequires:  ncurses-devel >= 5.2
20 BuildRequires:  readline-devel >= 4.2
21 BuildRequires:  XFree86-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Gdb is a full featured, command driven debugger. Gdb allows you to
28 trace the execution of programs and examine their internal state at
29 any time. Gdb works for C and C++ compiled with the GNU C compiler
30 gcc.
31
32 %description -l de
33 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
34 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
35 kompiliertes C++.
36
37 %description -l fr
38 Débugger complet, piloté par commandes. Permet de tracer l'exécution
39 des programmes et d'examiner à tout moment leur état interne.
40 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
41 de GNU, gcc.
42
43 %description -l pl
44 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
45 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
46 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
47 przy pomocy kompilatora GNU (gcc).
48
49 %description -l tr
50 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
51 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
52 verir.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57 %patch1 -p1
58 %patch2 -p1
59 %patch3 -p1
60 %patch4 -p1
61
62 %build
63 (cd gdb; libtoolize --copy --force; aclocal; autoconf)
64 (cd gdb/doc; autoconf)
65 (cd gdb/testsuite; autoconf)
66 (cd gdb/testsuite/gdb.asm; autoconf)
67 (cd gdb/testsuite/gdb.base; autoconf)
68 (cd gdb/testsuite/gdb.c++; autoconf)
69 (cd gdb/testsuite/gdb.disasm; autoconf)
70 (cd gdb/testsuite/gdb.chill; autoconf)
71 (cd gdb/testsuite/gdb.mi; autoconf)
72 (cd gdb/testsuite/gdb.threads; autoconf)
73 (cd gdb/testsuite/gdb.trace; autoconf)
74 (cd gdb/testsuite/gdb.stabs; autoconf)
75 (cd gdb/gdbserver; autoconf)
76 # !! Don't enable shared here !! 
77 # This will cause serious problems --misiek
78 %configure2_13 \
79         --disable-shared \
80         --enable-nls \
81         --without-included-gettext \
82         --enable-multi-ice \
83         --enable-gdbmi \
84         --enable-netrom \
85         --with-cpu=%{_target_cpu} \
86         --with-x \
87 %ifnarch alpha
88         --with-mmalloc \
89 %endif
90         --with-mmap
91 #       --enable-tui
92
93 # rebuild main Makefile again (due to some bug, Makefile is deleted)
94 %configure2_13 \
95         --norecursion
96                         
97 %{__make}
98 %{__make} info
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT%{_infodir}
103
104 %{__make} install install-info \
105         prefix=$RPM_BUILD_ROOT%{_prefix} \
106         bindir=$RPM_BUILD_ROOT%{_bindir} \
107         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
108         infodir=$RPM_BUILD_ROOT%{_infodir} \
109         includedir=$RPM_BUILD_ROOT%{_includedir} \
110         libdir=$RPM_BUILD_ROOT%{_libdir} \
111         mandir=$RPM_BUILD_ROOT%{_mandir}
112
113 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
114
115 %post
116 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
117
118 %postun
119 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/*
127
128 %{_mandir}/man1/*
129 %{_infodir}/gdb*.info*
130 %{_infodir}/stabs*.info*
This page took 0.04946 seconds and 3 git commands to generate.