]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- python %install fix
[packages/gdal.git] / gdal.spec
1 # TODO: csharp, java
2 #
3 # Conditional build:
4 %bcond_without  odbc    # disable odbc support
5 %bcond_without  xerces  # disable xerces support
6 %bcond_without  ruby    # disable ruby support
7 #
8 Summary:        Geospatial Data Abstraction Library
9 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
10 Name:           gdal
11 Version:        1.5.4
12 Release:        3
13 License:        BSD-like
14 Group:          Libraries
15 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
16 # Source0-md5:  d5e411b6f11bd1f144af67d2045d2606
17 Patch0:         %{name}-dods.patch
18 Patch1:         %{name}-perl.patch
19 Patch2:         %{name}-ruby.patch
20 Patch3:         %{name}-asneeded.patch
21 Patch4:         %{name}-ogdi.patch
22 Patch5:         %{name}-python_install.patch
23 URL:            http://www.gdal.org/
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 BuildRequires:  cfitsio-devel
27 BuildRequires:  doxygen
28 BuildRequires:  expat-devel >= 1.95.0
29 BuildRequires:  geos-devel >= 2.0
30 BuildRequires:  giflib-devel >= 4.0
31 BuildRequires:  hdf-devel >= 4.0
32 BuildRequires:  hdf5-devel
33 BuildRequires:  jasper-devel
34 BuildRequires:  libcsf-devel
35 BuildRequires:  libdap-devel >= 3.5
36 BuildRequires:  libgeotiff-devel >= 1.2.1
37 BuildRequires:  libjpeg-devel >= 6b
38 BuildRequires:  libpng-devel >= 2:1.2.8
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtiff-devel >= 3.6.0
41 BuildRequires:  libtool
42 BuildRequires:  netcdf-devel
43 BuildRequires:  ogdi-devel >= 3.1
44 BuildRequires:  perl-devel
45 BuildRequires:  postgresql-backend-devel
46 BuildRequires:  postgresql-devel
47 BuildRequires:  python-devel >= 1:2.5
48 BuildRequires:  python-numpy-devel >= 1:1.0.0
49 %{?with_ruby:BuildRequires:     ruby-devel}
50 BuildRequires:  sqlite3-devel >= 3
51 BuildRequires:  swig-python >= 1.3
52 %{?with_ruby:BuildRequires:     swig-ruby}
53 %{?with_odbc:BuildRequires:     unixODBC-devel}
54 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.2.0}
55 BuildRequires:  zlib-devel >= 1.1.4
56 Requires:       geos >= 2.0
57 Requires:       libgeotiff >= 1.2.1
58 Requires:       libpng >= 2:1.2.8
59 Requires:       libtiff >= 3.6.0
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 GDAL is a translator library for raster geospatial data formats that
64 is released under an Open Source license. As a library, it presents a
65 single abstract data model to the calling application for all
66 supported formats. The related OGR library (which lives within the
67 GDAL source tree) provides a similar capability for simple features
68 vector data.
69
70 %description -l pl.UTF-8
71 GDAL to biblioteka konwertująca między formatami rastrowych danych
72 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
73 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
74 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
75 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
76 możliwości dla danych wektorowych.
77
78 %package devel
79 Summary:        GDAL library header files
80 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       cfitsio-devel
84 Requires:       expat-devel >= 1.95.0
85 Requires:       geos-devel >= 2.0
86 Requires:       giflib-devel
87 Requires:       hdf-devel >= 4.0
88 Requires:       hdf5-devel
89 Requires:       jasper-devel
90 Requires:       libcsf-devel
91 Requires:       libdap-devel >= 3.5
92 Requires:       libgeotiff-devel >= 1.2.1
93 Requires:       libjpeg-devel
94 Requires:       libpng-devel >= 2:1.2.8
95 Requires:       libstdc++-devel
96 Requires:       libtiff-devel >= 3.6.0
97 Requires:       netcdf-devel
98 Requires:       ogdi-devel >= 3.1
99 Requires:       postgresql-devel
100 Requires:       sqlite3-devel >= 3
101 %{?with_odbc:Requires:  unixODBC-devel}
102 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
103
104 %description devel
105 GDAL library header files.
106
107 %description devel -l pl.UTF-8
108 Pliki nagłówkowe biblioteki GDAL.
109
110 %package static
111 Summary:        GDAL static libraries
112 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115
116 %description static
117 GDAL static libraries.
118
119 %description static -l pl.UTF-8
120 Statyczne biblioteki GDAL.
121
122 %package -n perl-gdal
123 Summary:        Perl bindings for GDAL
124 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
125 Group:          Development/Languages/Perl
126 Requires:       %{name} = %{version}-%{release}
127
128 %description -n perl-gdal
129 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
130
131 %description -n perl-gdal -l pl.UTF-8
132 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
133
134 %package -n python-gdal
135 Summary:        GDAL Python module
136 Summary(pl.UTF-8):      Moduł Pythona GDAL
137 Group:          Libraries/Python
138 Requires:       %{name} = %{version}-%{release}
139 %pyrequires_eq  python-libs
140
141 %description -n python-gdal
142 GDAL Python module.
143
144 %description -n python-gdal -l pl.UTF-8
145 Moduł Pythona GDAL.
146
147 %package -n ruby-gdal
148 Summary:        Ruby bindings for GDAL
149 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
150 Group:          Development/Languages
151 Requires:       %{name} = %{version}-%{release}
152 %{?ruby_mod_ver_requires_eq}
153
154 %description -n ruby-gdal
155 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
156
157 %description -n ruby-gdal -l pl.UTF-8
158 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
159 osr.
160
161 %prep
162 %setup -q
163 %patch0 -p1
164 %patch1 -p1
165 %patch2 -p1
166 %patch3 -p1
167 %patch4 -p1
168
169 # need to regenerate (old ones don't support perl 5.10)
170 rm swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
171
172 %build
173 # $PYTHON_INCLUDES is set only with --with-ogpython, but we have --with-python,
174 # and $PYTHON_INCLUDES is needed to detect numpy properly
175 export PYTHON_INCLUDES=-I%{py_incdir}
176
177 %{__libtoolize}
178 cp -f /usr/share/automake/config.* .
179 %{__aclocal} -I m4
180 %{__autoconf}
181 # disable grass/libgrass here, it can be built from separate gdal-grass package
182 %configure \
183         --datadir=%{_datadir}/gdal \
184         --with-dods-root=/usr \
185         --with-hide-internal-symbols \
186         --with-perl \
187         --with-python \
188         %{?with_ruby:--with-ruby} \
189         --with-sqlite3 \
190         %{?with_xerces:--with-xerces} \
191         --with-xerces-inc=/usr/include/xercesc \
192         --with-xerces-lib="-lxerces-c" \
193         --without-grass \
194         --without-libgrass
195 # --with-php needs Zend API update
196 # java broken, no configure option
197 # csharp builds, but has no configure option
198
199 # regenerate where needed
200 %{__make} -j1 -C swig/perl generate
201
202 %{__make} -j1
203
204 %{__make} -j1 docs
205
206 %install
207 rm -rf $RPM_BUILD_ROOT
208
209 %{__make} -j1 install install-man \
210         DESTDIR=$RPM_BUILD_ROOT
211
212 rm -rf _html
213 cp -a html _html
214 cp -a ogr/html _html/ogr
215
216 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
217 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
218 %py_postclean
219
220 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
221 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
222 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
223 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
224 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
225
226 # some doxygen trash
227 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL.dox
228 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL/Const.dox
229 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OGR.dox
230 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OSR.dox
231
232 %if %{with ruby}
233 %{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/gdal/*.la
234 %endif
235
236 %clean
237 rm -rf $RPM_BUILD_ROOT
238
239 %post   -p /sbin/ldconfig
240 %postun -p /sbin/ldconfig
241
242 %files
243 %defattr(644,root,root,755)
244 %doc NEWS PROVENANCE.TXT
245 %attr(755,root,root) %{_bindir}/*
246 %exclude %{_bindir}/gdal-config
247 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
248 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
249 %{_datadir}/gdal
250 %{_mandir}/man1/*
251 %exclude %{_mandir}/man1/gdal-config.1*
252
253 %files devel
254 %defattr(644,root,root,755)
255 %doc _html/*
256 %attr(755,root,root) %{_bindir}/gdal-config
257 %attr(755,root,root) %{_libdir}/libgdal.so
258 %{_libdir}/libgdal.la
259 %{_includedir}/*.h
260 %{_mandir}/man1/gdal-config.1*
261
262 %files static
263 %defattr(644,root,root,755)
264 %{_libdir}/libgdal.a
265
266 %files -n perl-gdal
267 %defattr(644,root,root,755)
268 %dir %{perl_vendorarch}/Geo
269 %{perl_vendorarch}/Geo/GDAL.pm
270 %dir %{perl_vendorarch}/Geo/GDAL
271 %{perl_vendorarch}/Geo/GDAL/Const.pm
272 %{perl_vendorarch}/Geo/OGR.pm
273 %{perl_vendorarch}/Geo/OSR.pm
274 %dir %{perl_vendorarch}/auto/Geo
275 %dir %{perl_vendorarch}/auto/Geo/GDAL
276 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
277 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
278 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
279 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
280 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
281 %dir %{perl_vendorarch}/auto/Geo/OGR
282 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
283 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
284 %dir %{perl_vendorarch}/auto/Geo/OSR
285 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
286 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
287
288 %files -n python-gdal
289 %defattr(644,root,root,755)
290 %{py_sitedir}/gdal.py[co]
291 %{py_sitedir}/gdalconst.py[co]
292 %{py_sitedir}/gdalnumeric.py[co]
293 %{py_sitedir}/ogr.py[co]
294 %{py_sitedir}/osr.py[co]
295 %{py_sitedir}/GDAL-*.egg-info
296 %dir %{py_sitedir}/osgeo
297 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
298 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
299 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
300 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
301 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
302 %{py_sitedir}/osgeo/*.py[co]
303
304 %if %{with ruby}
305 %files -n ruby-gdal
306 %defattr(644,root,root,755)
307 %dir %{ruby_sitearchdir}/gdal
308 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
309 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
310 %attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
311 %attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
312 %endif
This page took 0.117767 seconds and 4 git commands to generate.