]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
copy config.rpath
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - MongoCXX (mongo/client/dbclient.h, -lmongoclient -lboost_system -lboost_thread -lboost_regex)
6 # - rasterlite2
7 # - sfcgal >= 1.2.2
8 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9 # - libkml (1.3.0 needed, not released yet)
10 # - wait for newer pcidsk, switch to external again
11 # - csharp, java
12 # - additional, proprietary(?) formats support:
13 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17 #   - MrSID (http://www.lizardtech.com/developer/)
18 #   - LuraTech JP2Lura 
19 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
20 #   - Ingres (--with-ingres=/path)
21 #   - Informix DB (--with-idb)
22 #   - DWGdirect (members only? http://www.opendwg.org/)
23 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24 #   - Teigha DWG/DGN (https://www.opendesign.com/products/drawings?)
25 #
26 # Conditional build:
27 %bcond_without  armadillo       # Armadillo support for faster TPS transform
28 %bcond_without  crnlib          # DDS support via crunch/crnlib
29 %bcond_without  epsilon         # EPSILON wavelet compression support
30 %bcond_without  fyba            # SOSI geodata support using FYBA
31 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
32 %bcond_without  gta             # GTA format support
33 %bcond_without  kea             # KEA format support
34 %bcond_without  mysql           # MySQL DB support
35 %bcond_with     oci             # ORACLE OCI DB and Georaster support
36 %bcond_without  odbc            # ODBC DB support
37 %bcond_without  opencl          # OpenCL (GPU) support
38 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
39 %bcond_with     podofo          # PDF support via podofo instead of poppler
40 %bcond_without  poppler         # PDF support via poppler
41 %bcond_with     rasdaman        # Rasdaman support
42 %bcond_with     spatialite      # SpatiaLite support
43 %bcond_without  xerces          # Xerces support
44 %bcond_without  java            # Java and MDB support
45
46 %if %{with podofo}
47 %undefine       with_poppler
48 %endif
49 Summary:        Geospatial Data Abstraction Library
50 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
51 Name:           gdal
52 Version:        3.0.4
53 Release:        6
54 License:        BSD-like
55 Group:          Libraries
56 Source0:        https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
57 # Source0-md5:  c6bbb5caca06e96bd97a32918e0aa9aa
58 Patch0:         %{name}-perl.patch
59 Patch1:         %{name}-pc.patch
60 Patch2:         %{name}-dds.patch
61 Patch3:         %{name}-rasdaman.patch
62 Patch4:         %{name}-pluginsdir.patch
63 Patch5:         libx32.patch
64 Patch7:         decl.patch
65 Patch8:         %{name}_tirpcinc.patch
66 Patch9:         jasper.patch
67 URL:            http://www.gdal.org/
68 # 1.x or 2.x supported
69 BuildRequires:  CharLS-devel
70 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
71 %{?with_armadillo:BuildRequires:        armadillo-devel}
72 BuildRequires:  autoconf >= 2.52
73 BuildRequires:  automake
74 BuildRequires:  cfitsio-devel
75 %{?with_crnlib:BuildRequires:   crnlib-devel}
76 BuildRequires:  cryptopp-devel
77 BuildRequires:  curl-devel
78 BuildRequires:  doxygen >= 1.4.2
79 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
80 BuildRequires:  expat-devel >= 1.95.0
81 %{?with_fyba:BuildRequires:     fyba-devel}
82 BuildRequires:  freexl-devel >= 1.0
83 BuildRequires:  gcc >= 6:4.1
84 BuildRequires:  geos-devel >= 3.1.0
85 BuildRequires:  giflib-devel >= 4.0
86 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
87 BuildRequires:  hdf-devel >= 4.2.5
88 BuildRequires:  hdf5-devel
89 BuildRequires:  jasper-devel
90 %{?with_java:BuildRequires:     jdk}
91 %{?with_java:BuildRequires:     jpackage-utils}
92 BuildRequires:  json-c-devel >= 0.11
93 %{?with_kea:BuildRequires:      kealib-devel}
94 BuildRequires:  libcsf-devel >= 2.0-0.041111.6
95 BuildRequires:  libdap-devel >= 3.10
96 BuildRequires:  libgeotiff-devel >= 1.2.1
97 %{?with_gta:BuildRequires:      libgta-devel}
98 BuildRequires:  libjpeg-devel >= 6b
99 #BuildRequires: libkml-devel >= 1.3.0
100 BuildRequires:  libpng-devel >= 2:1.2.8
101 %{?with_spatialite:BuildRequires:       libspatialite-devel}
102 BuildRequires:  libstdc++-devel
103 BuildRequires:  libtiff-devel >= 4.0
104 BuildRequires:  libtirpc-devel
105 BuildRequires:  libtool
106 BuildRequires:  libuuid-devel
107 BuildRequires:  libwebp-devel
108 BuildRequires:  libxml2-devel >= 2
109 #%{?with_mysql:BuildRequires:   mysql-devel >= 4}
110 %{?with_mysql:BuildRequires:    /usr/bin/mysql_config}
111 BuildRequires:  netcdf-devel >= 4.1
112 BuildRequires:  ogdi-devel >= 3.1
113 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
114 # 8.1.7 for DB support, 10.0.1 for georaster
115 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
116 #BuildRequires: pcidsk-devel > 0.3
117 BuildRequires:  pcre-devel
118 BuildRequires:  perl-devel
119 BuildRequires:  pkgconfig >= 1:0.21
120 %{?with_podofo:BuildRequires:   podofo-devel}
121 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
122 # ensure it's compiled with PQescapeStringConn support
123 BuildRequires:  postgresql-backend-devel >= 8.1.4
124 BuildRequires:  postgresql-devel >= 8.1.4
125 BuildRequires:  proj-devel >= 4
126 BuildRequires:  python-devel >= 1:2.5
127 BuildRequires:  python-numpy-devel >= 1:1.0.0
128 BuildRequires:  python-setuptools
129 BuildRequires:  qhull-devel >= 2012
130 %{?with_rasdaman:BuildRequires: rasdaman-devel}
131 BuildRequires:  rpm-pythonprov
132 BuildRequires:  rpmbuild(macros) >= 1.344
133 BuildRequires:  sed >= 4.0
134 BuildRequires:  sqlite3-devel >= 3.0.0
135 BuildRequires:  swig-perl
136 BuildRequires:  swig-python >= 1.3
137 BuildRequires:  texlive-dvips
138 BuildRequires:  texlive-latex
139 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
140 %{?with_xerces:BuildRequires:   xerces-c-devel >= 3.1.0}
141 BuildRequires:  xz-devel
142 BuildRequires:  zlib-devel >= 1.1.4
143 # for ZSTD compression in TIFF
144 BuildRequires:  zstd-devel
145 Requires:       freexl >= 1.0
146 Requires:       geos >= 3.1.0
147 Requires:       hdf >= 4.2.5
148 Requires:       libgeotiff >= 1.2.1
149 Requires:       libpng >= 2:1.2.8
150 Requires:       libtiff >= 4.0
151 %{?with_openjpeg:Requires:      openjpeg2 >= 2.1.0}
152 Requires:       qhull >= 2012
153 %{?with_xerces:Requires:        xerces-c >= 3.1.0}
154 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
155
156 %description
157 GDAL is a translator library for raster geospatial data formats that
158 is released under an Open Source license. As a library, it presents a
159 single abstract data model to the calling application for all
160 supported formats. The related OGR library (which lives within the
161 GDAL source tree) provides a similar capability for simple features
162 vector data.
163
164 %description -l pl.UTF-8
165 GDAL to biblioteka konwertująca między formatami rastrowych danych
166 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
167 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
168 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
169 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
170 możliwości dla danych wektorowych.
171
172 %package devel
173 Summary:        GDAL library header files
174 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
175 Group:          Development/Libraries
176 Requires:       %{name} = %{version}-%{release}
177 Requires:       CharLS-devel
178 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
179 %{?with_armadillo:Requires:     armadillo-devel}
180 Requires:       cfitsio-devel
181 %{?with_crnlib:Requires:        crnlib-devel}
182 Requires:       cryptopp-devel
183 Requires:       curl-devel
184 %{?with_epsilon:Requires:       epsilon-compressor-devel}
185 %{?with_fyba:Requires:  fyba-devel}
186 Requires:       expat-devel >= 1.95.0
187 Requires:       freexl-devel >= 1.0
188 Requires:       geos-devel >= 3.1.0
189 Requires:       giflib-devel >= 4.0
190 Requires:       hdf-devel >= 4.2.5
191 Requires:       hdf5-devel
192 Requires:       jasper-devel
193 Requires:       json-c-devel >= 0.11
194 %{?with_kea:Requires:   kealib-devel}
195 Requires:       libcsf-devel
196 Requires:       libdap-devel >= 3.10
197 Requires:       libgeotiff-devel >= 1.2.1
198 %{?with_gta:Requires:   libgta-devel}
199 Requires:       libjpeg-devel >= 6b
200 Requires:       libpng-devel >= 2:1.2.8
201 %{?with_spatialite:Requires:    libspatialite-devel}
202 Requires:       libstdc++-devel
203 Requires:       libtiff-devel >= 4.0
204 Requires:       libuuid-devel
205 Requires:       libwebp-devel
206 Requires:       libxml2-devel >= 2
207 %{?with_mysql:Requires: /usr/bin/mysql_config}
208 Requires:       netcdf-devel >= 4
209 Requires:       ogdi-devel >= 3.1
210 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.1.0}
211 #Requires:      pcidsk-devel > 0.3
212 Requires:       pcre-devel
213 %{?with_podofo:Requires:        podofo-devel}
214 %{?with_poppler:Requires:       poppler-devel >= 0.24}
215 Requires:       postgresql-devel
216 Requires:       proj-devel >= 4
217 Requires:       qhull-devel >= 2012
218 %{?with_rasdaman:Requires:      rasdaman-devel}
219 Requires:       sqlite3-devel >= 3.0.0
220 %{?with_odbc:Requires:  unixODBC-devel}
221 %{?with_xerces:Requires:        xerces-c-devel >= 3.1.0}
222 Requires:       xz-devel
223 Requires:       zlib-devel >= 1.1.4
224 Requires:       zstd-devel
225
226 %description devel
227 GDAL library header files.
228
229 %description devel -l pl.UTF-8
230 Pliki nagłówkowe biblioteki GDAL.
231
232 %package static
233 Summary:        GDAL static libraries
234 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
235 Group:          Development/Libraries
236 Requires:       %{name}-devel = %{version}-%{release}
237
238 %description static
239 GDAL static libraries.
240
241 %description static -l pl.UTF-8
242 Statyczne biblioteki GDAL.
243
244 %package -n perl-gdal
245 Summary:        Perl bindings for GDAL
246 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
247 Group:          Development/Languages/Perl
248 Requires:       %{name} = %{version}-%{release}
249
250 %description -n perl-gdal
251 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
252
253 %description -n perl-gdal -l pl.UTF-8
254 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
255
256 %package -n python-gdal
257 Summary:        GDAL Python module
258 Summary(pl.UTF-8):      Moduł Pythona GDAL
259 Group:          Libraries/Python
260 Requires:       %{name} = %{version}-%{release}
261 Requires:       python-libs
262
263 %description -n python-gdal
264 GDAL Python module.
265
266 %description -n python-gdal -l pl.UTF-8
267 Moduł Pythona GDAL.
268
269 %prep
270 %setup -q
271 %patch0 -p1
272 %patch1 -p1
273 %patch2 -p1
274 %patch3 -p1
275 %patch4 -p1
276 %patch5 -p1
277 %patch7 -p1
278 %patch8 -p1
279 %patch9 -p2
280
281 # need to regenerate (old ones don't support perl 5.10)
282 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
283
284 # our man path
285 sed -i -e 's#^mandir=.*##g' configure.ac
286
287 %{__rm} -r man
288
289 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
290
291 sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
292           -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
293           -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
294       swig/python/scripts/epsg_tr.py \
295       swig/python/scripts/esri2wkt.py \
296       swig/python/scripts/gcps2vec.py \
297       swig/python/scripts/gcps2wld.py \
298       swig/python/scripts/gdal2tiles.py \
299       swig/python/scripts/gdal2xyz.py \
300       swig/python/scripts/gdal_auth.py \
301       swig/python/scripts/gdal_calc.py \
302       swig/python/scripts/gdal_edit.py \
303       swig/python/scripts/gdal_fillnodata.py \
304       swig/python/scripts/gdal_merge.py \
305       swig/python/scripts/gdal_pansharpen.py \
306       swig/python/scripts/gdal_polygonize.py \
307       swig/python/scripts/gdal_proximity.py \
308       swig/python/scripts/gdal_retile.py \
309       swig/python/scripts/gdal_sieve.py \
310       swig/python/scripts/gdalchksum.py \
311       swig/python/scripts/gdalcompare.py \
312       swig/python/scripts/gdalident.py \
313       swig/python/scripts/gdalimport.py \
314       swig/python/scripts/gdalmove.py \
315       swig/python/scripts/mkgraticule.py \
316       swig/python/scripts/ogrmerge.py \
317       swig/python/scripts/pct2rgb.py \
318       swig/python/scripts/rgb2pct.py
319
320 %build
321 cp -f /usr/share/gettext/config.rpath .
322
323 %ifarch %{x8664}
324 jvm_arch=amd64
325 %endif
326 %ifarch %{ix86}
327 jvm_arch=i386
328 %endif
329 %ifarch x32
330 jvm_arch=x32
331 %endif
332
333 %{__libtoolize}
334 %{__aclocal} -I m4
335 %{__autoconf}
336 %{__autoheader}
337 %configure \
338         --includedir=%{_includedir}/gdal \
339         --datadir=%{_datadir}/gdal \
340         --with-dods-root=/usr \
341         %{?with_armadillo:--with-armadillo} \
342         %{?with_crnlib:--with-dds} \
343         %{?with_epsilon:--with-epsilon} \
344         %{?with_grass:--with-grass} \
345         %{!?with_gta:--without-gta} \
346         --with-hide-internal-symbols \
347         %{?with_java:--with-java=%{java_home}} \
348         --with-liblzma \
349         %{!?with_kea:--without-kea} \
350         %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
351         %{?with_mysql:--with-mysql} \
352         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
353         %{?with_opencl:--with-opencl} \
354         --with-perl \
355         %{?with_podofo:--with-podofo} \
356         %{?with_poppler:--with-poppler} \
357         --with-python \
358         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
359         %{?with_fyba:--with-sosi} \
360         %{?with_spatialite:--with-spatialite} \
361         --with-sqlite3 \
362         --with-webp \
363         %{?with_xerces:--with-xerces} \
364         --with-xerces-inc=/usr/include \
365         --with-xerces-lib="-lxerces-c" \
366         --without-libgrass
367 #       --with-pcidsk=/usr (needs > 0.3)
368 # csharp builds, but has no configure option nor install target
369
370 # regenerate where needed
371 %{__make} -j1 -C swig/perl generate
372
373 %{__make} \
374         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
375         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
376
377 %{__make} -j1 docs
378
379 %{__make} -j1 man
380
381 %install
382 rm -rf $RPM_BUILD_ROOT
383
384 %{__make} -j1 install install-man \
385         DESTDIR=$RPM_BUILD_ROOT
386
387 # TODO: remove libgdal.la when gdal.pc gets maintained Requires.private/Libs.private list
388
389 rm -rf _html
390 cp -a html _html
391
392 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
393 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
394 %py_postclean
395
396 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
397 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
398 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
399 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
400 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
401
402 %clean
403 rm -rf $RPM_BUILD_ROOT
404
405 %post   -p /sbin/ldconfig
406 %postun -p /sbin/ldconfig
407
408 %files
409 %defattr(644,root,root,755)
410 %doc NEWS PROVENANCE.TXT
411 %attr(755,root,root) %{_bindir}/epsg_tr.py
412 %attr(755,root,root) %{_bindir}/esri2wkt.py
413 %attr(755,root,root) %{_bindir}/gcps2vec.py
414 %attr(755,root,root) %{_bindir}/gcps2wld.py
415 %attr(755,root,root) %{_bindir}/gdal2tiles.py
416 %attr(755,root,root) %{_bindir}/gdal2xyz.py
417 %attr(755,root,root) %{_bindir}/gdaladdo
418 %attr(755,root,root) %{_bindir}/gdal_auth.py
419 %attr(755,root,root) %{_bindir}/gdalbuildvrt
420 %attr(755,root,root) %{_bindir}/gdal_calc.py
421 %attr(755,root,root) %{_bindir}/gdalchksum.py
422 %attr(755,root,root) %{_bindir}/gdalcompare.py
423 %attr(755,root,root) %{_bindir}/gdal_contour
424 %attr(755,root,root) %{_bindir}/gdaldem
425 %attr(755,root,root) %{_bindir}/gdal_edit.py
426 %attr(755,root,root) %{_bindir}/gdalenhance
427 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
428 %attr(755,root,root) %{_bindir}/gdal_grid
429 %attr(755,root,root) %{_bindir}/gdalident.py
430 %attr(755,root,root) %{_bindir}/gdalimport.py
431 %attr(755,root,root) %{_bindir}/gdalinfo
432 %attr(755,root,root) %{_bindir}/gdallocationinfo
433 %attr(755,root,root) %{_bindir}/gdalmanage
434 %attr(755,root,root) %{_bindir}/gdal_merge.py
435 %attr(755,root,root) %{_bindir}/gdalmove.py
436 %attr(755,root,root) %{_bindir}/gdal_pansharpen.py
437 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
438 %attr(755,root,root) %{_bindir}/gdal_proximity.py
439 %attr(755,root,root) %{_bindir}/gdal_rasterize
440 %attr(755,root,root) %{_bindir}/gdal_retile.py
441 %attr(755,root,root) %{_bindir}/gdalserver
442 %attr(755,root,root) %{_bindir}/gdal_sieve.py
443 %attr(755,root,root) %{_bindir}/gdalsrsinfo
444 %attr(755,root,root) %{_bindir}/gdaltindex
445 %attr(755,root,root) %{_bindir}/gdaltransform
446 %attr(755,root,root) %{_bindir}/gdal_translate
447 %attr(755,root,root) %{_bindir}/gdalwarp
448 %attr(755,root,root) %{_bindir}/gnmanalyse
449 %attr(755,root,root) %{_bindir}/gnmmanage
450 %attr(755,root,root) %{_bindir}/mkgraticule.py
451 %attr(755,root,root) %{_bindir}/nearblack
452 %attr(755,root,root) %{_bindir}/ogr2ogr
453 %attr(755,root,root) %{_bindir}/ogrinfo
454 %attr(755,root,root) %{_bindir}/ogrlineref
455 %attr(755,root,root) %{_bindir}/ogrmerge.py
456 %attr(755,root,root) %{_bindir}/ogrtindex
457 %attr(755,root,root) %{_bindir}/pct2rgb.py
458 %attr(755,root,root) %{_bindir}/rgb2pct.py
459 %attr(755,root,root) %{_bindir}/testepsg
460 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
461 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.26
462 %dir %{_libdir}/gdalplugins
463 %{_datadir}/gdal
464 %{_mandir}/man1/gdal2tiles.1*
465 %{_mandir}/man1/gdal_calc.1*
466 %{_mandir}/man1/gdal_contour.1*
467 %{_mandir}/man1/gdal_edit.1*
468 %{_mandir}/man1/gdal_fillnodata.1*
469 %{_mandir}/man1/gdal_grid.1*
470 %{_mandir}/man1/gdal_merge.1*
471 %{_mandir}/man1/gdal_polygonize.1*
472 %{_mandir}/man1/gdal_proximity.1*
473 %{_mandir}/man1/gdal_rasterize.1*
474 %{_mandir}/man1/gdal_retile.1*
475 %{_mandir}/man1/gdal_sieve.1*
476 %{_mandir}/man1/gdal_translate.1*
477 %{_mandir}/man1/gdal_utilities.1*
478 %{_mandir}/man1/gdaladdo.1*
479 %{_mandir}/man1/gdalbuildvrt.1*
480 %{_mandir}/man1/gdalcompare.1*
481 %{_mandir}/man1/gdaldem.1*
482 %{_mandir}/man1/gdalinfo.1*
483 %{_mandir}/man1/gdallocationinfo.1*
484 %{_mandir}/man1/gdalmanage.1*
485 %{_mandir}/man1/gdalmove.1*
486 %{_mandir}/man1/gdalsrsinfo.1*
487 %{_mandir}/man1/gdaltindex.1*
488 %{_mandir}/man1/gdaltransform.1*
489 %{_mandir}/man1/gdalwarp.1*
490 %{_mandir}/man1/nearblack.1*
491 %{_mandir}/man1/ogr2ogr.1*
492 %{_mandir}/man1/ogr_utilities.1*
493 %{_mandir}/man1/ogrinfo.1*
494 %{_mandir}/man1/ogrlineref.1*
495 %{_mandir}/man1/ogrtindex.1*
496 %{_mandir}/man1/pct2rgb.1*
497 %{_mandir}/man1/rgb2pct.1*
498 %{_mandir}/man1/gdal_pansharpen.1*
499 %{_mandir}/man1/gnm_utilities.1*
500 %{_mandir}/man1/gnmanalyse.1*
501 %{_mandir}/man1/gnmmanage.1*
502 %{_mandir}/man1/ogrmerge.1*
503
504 %files devel
505 %defattr(644,root,root,755)
506 %doc _html/*
507 %attr(755,root,root) %{_bindir}/gdal-config
508 %attr(755,root,root) %{_libdir}/libgdal.so
509 %{_libdir}/libgdal.la
510 %{_pkgconfigdir}/gdal.pc
511 %{_includedir}/gdal
512 %{_mandir}/man1/gdal-config.1*
513
514 %files static
515 %defattr(644,root,root,755)
516 %{_libdir}/libgdal.a
517
518 %files -n perl-gdal
519 %defattr(644,root,root,755)
520 %dir %{perl_vendorarch}/Geo
521 %{perl_vendorarch}/Geo/GDAL.pm
522 %dir %{perl_vendorarch}/Geo/GDAL
523 %{perl_vendorarch}/Geo/GDAL/Const.pm
524 %{perl_vendorarch}/Geo/OGR.pm
525 %{perl_vendorarch}/Geo/OSR.pm
526 %dir %{perl_vendorarch}/auto/Geo
527 %dir %{perl_vendorarch}/auto/Geo/GDAL
528 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
529 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
530 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
531 %dir %{perl_vendorarch}/auto/Geo/GNM
532 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
533 %dir %{perl_vendorarch}/auto/Geo/OGR
534 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
535 %dir %{perl_vendorarch}/auto/Geo/OSR
536 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
537 %{_mandir}/man3/Geo::GDAL.3pm*
538 %{perl_vendorarch}/Geo/GNM.pm
539
540 %files -n python-gdal
541 %defattr(644,root,root,755)
542 %{py_sitedir}/gdal.py[co]
543 %{py_sitedir}/gdalconst.py[co]
544 %{py_sitedir}/gdalnumeric.py[co]
545 %{py_sitedir}/ogr.py[co]
546 %{py_sitedir}/osr.py[co]
547 %{py_sitedir}/GDAL-*.egg-info
548 %dir %{py_sitedir}/osgeo
549 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
550 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
551 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
552 %attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
553 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
554 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
555 %{py_sitedir}/osgeo/*.py[co]
This page took 0.094254 seconds and 3 git commands to generate.