]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
- new snap 2002-03-11; updated buildrequires
[packages/gcc.git] / gcc.spec
1 %define         DASHED_SNAP     2002-03-11
2 %define         SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
3 %define         GCC_VERSION     3.1
4 %define         STDC_VERSION    3.1
5 %define         GCJ_VERSION     3.1
6 %define         KSI_VERSION     pre48
7 Summary:        GNU Compiler Collection
8 Summary(pl):    Kolekcja kompilatorów GNU
9 Name:           gcc
10 Version:        %{GCC_VERSION}
11 Release:        0.%{SNAP}.1
12 License:        GPL
13 Group:          Development/Languages
14 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/%{DASHED_SNAP}/%{name}-%{SNAP}.tar.bz2
15 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
16 Patch0:         %{name}-slibdir.patch
17 Patch1:         %{name}-paths.patch
18 Patch2:         %{name}-ada-no-addr2line.patch
19 Patch3:         %{name}-ada-no-prefix.o.patch
20 BuildRequires:  bison
21 BuildRequires:  texinfo >= 4.1
22 BuildRequires:  zlib-devel
23 BuildRequires:  fileutils >= 4.0.41
24 BuildRequires:  autoconf
25 BuildRequires:  gcc
26 BuildRequires:  gcc-ada
27 Requires:       binutils >= 2.9.1.0.25
28 Requires:       cpp = %{version}
29 URL:            http://gcc.gnu.org/
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _slibdir        /lib
33
34 %description
35 A compiler aimed at integrating all the optimizations and features
36 necessary for a high-performance and stable development environment.
37
38 %description -l pl
39 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
40 wyprodukowania szybkiego i stablinego kodu wynikowego.
41
42 %package c++
43 Summary:        C++ support for gcc
44 Group:          Development/Languages
45 Obsoletes:      egcc-c++
46 Obsoletes:      egcs-c++
47 Requires:       gcc = %{GCC_VERSION}
48
49 %description c++
50 This package adds C++ support to the GNU C compiler. It includes
51 support for most of the current C++ specification, including templates
52 and exception handling. It does not include a standard C++ library,
53 which is available separately.
54
55 %description -l de c++
56 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
57 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
58 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
59 sie ist getrennt erhältlich.
60
61 %description -l fr c++
62 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
63 support pour la plupart des spécifications actuelles de C++, dont les
64 modéles et la gestion des exceptions. Il ne comprend pas une
65 bibliothéque C++ standard, qui est disponible séparément.
66
67 %description -l pl c++
68 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
69 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
70 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
71
72 %description -l tr c++
73 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
74 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
75 C++ kitaplýðý bu pakette yer almaz.
76
77 %package objc
78 Summary:        Objective C support for gcc
79 Summary(de):    Objektive C-Unterstützung für gcc
80 Summary(fr):    Gestion d'Objective C pour gcc
81 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
82 Summary(tr):    gcc için Objective C desteði
83 Group:          Development/Languages
84 Obsoletes:      egcc-objc
85 Obsoletes:      egcs-objc
86 Requires:       libobjc = %{GCC_VERSION}
87 Requires:       gcc = %{GCC_VERSION}
88
89 %description objc
90 This package adds Objective C support to the GNU C compiler. Objective
91 C is a object oriented derivative of the C language, mainly used on
92 systems running NeXTSTEP. This package does not include the standard
93 objective C object library.
94
95 %description -l de objc
96 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
97 Objective C ist ein objektorientiertes Derivat von C, das zur
98 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
99 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
100
101 %description -l fr objc
102 Ce package ajoute un support Objective C au compilateur C GNU.
103 L'Objective C est un langage orienté objetdérivé du langage C,
104 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
105 pas la bibliothéque Objective C standard.
106
107 %description -l pl objc
108 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
109 pakiecie nie ma jeszcze bibliotek C-obj.
110
111 %description -l tr objc
112 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
113 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
114 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
115 kitaplýðý bu pakette yer almaz.
116
117 %package -n libobjc
118 Summary:        Objective C Libraries
119 Summary(pl):    Biblioteki Obiektowego C
120 Group:          Libraries
121
122 %description -n libobjc
123 Objective C Libraries
124
125 %description -n libobjc -l pl
126 Biblioteki Obiektowego C
127
128 %package -n libobjc-static
129 Summary:        Static Objective C Libraries
130 Summary(pl):    Statyczne Biblioteki Obiektowego C
131 Group:          Development/Libraries
132 Epoch:          2
133 Requires:       libobjc = %{GCC_VERSION}
134
135 %description -n libobjc-static
136 Static Objective C Libraries
137
138 %description -l pl -n libobjc-static
139 Statyczne Obiektowego C
140
141 %package g77
142 Summary:        Fortran 77 support for gcc
143 Summary(pl):    Wspomaganie Fortran 77 dla gcc
144 Group:          Development/Languages
145 Obsoletes:      egcs-g77
146 Requires:       libg2c = %{GCC_VERSION}
147
148 %description g77
149 This apckage adds support for compiling Fortran 77 programs with the
150 GNU compiler.
151
152 %description -l pl g77
153 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
154 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
155
156 %package -n libg2c
157 Summary:        Fortran 77 Libraries
158 Summary(pl):    Biblioteki Fortranu 77
159 Group:          Libraries
160
161 %description -n libg2c
162 Fortran 77 Libraries
163
164 %description -n libg2c -l pl
165 Biblioteki Fortranu 77
166
167 %package -n libg2c-static
168 Summary:        Static Fortran 77 Libraries
169 Summary(pl):    Statyczne Biblioteki Fortranu 77
170 Group:          Development/Libraries
171 Epoch:          2
172 Requires:       libg2c = %{GCC_VERSION}
173
174 %description -n libg2c-static
175 Static Fortran 77 Libraries
176
177 %description -l pl -n libg2c-static
178 Statyczne Fortranu 77
179
180 %package chill
181 Summary:        CHILL support for gcc
182 Summary(pl):    Wspomoganie CHILL dla gcc
183 Group:          Development/Languages
184 Requires:       %{name} = %{version}
185
186 %description chill
187 This package adds support for compiling CHILL programs with the GNU
188 compiler.
189
190 Chill is the "CCITT High-Level Language", where CCITT is the old name
191 for what is now ITU, the International Telecommunications Union. It is
192 is language in the Modula2 family, and targets many of the same
193 applications as Ada (especially large embedded systems). Chill was
194 never used much in the United States, but is still being used in
195 Europe, Brazil, Korea, and other places.
196
197 %package java
198 Summary:        Java support for gcc
199 Summary(pl):    Wspomoganie Java dla gcc
200 Group:          Development/Languages
201 Requires:       %{name} = %{version}
202 Requires:       libgcj >= 3.0.0
203
204 %description java
205 This package adds experimental support for compiling Java(tm) programs
206 and bytecode into native code. To use this you will also need the
207 libgcj package.
208
209 %description -l pl java
210 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
211 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
212 przeprowadziæ kompilacjê.
213
214 %package -n libgcj
215 Summary:        Java Class Libraries
216 Summary(pl):    Biblioteki Klas Javy
217 Group:          Libraries
218 Version:        %{GCJ_VERSION}
219 Epoch:          2
220 Requires:       zlib
221
222 %description -n libgcj
223 Java Class Libraries
224
225 %description -n libgcj -l pl
226 Biblioteki Klass Javy
227
228 %package -n libgcj-devel
229 Summary:        Development files for Java Class Libraries
230 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
231 Group:          Development/Libraries
232 Version:        %{GCJ_VERSION}
233 Epoch:          2
234 Requires:       libgcj = %{GCJ_VERSION}
235 Requires:       %{name}-java
236
237 %description -n libgcj-devel
238 Development files for Java Class Libraries
239
240 %description -n libgcj-devel -l pl
241 Pliki nag³ówkowe dla Bibliotek Klass Javy
242
243 %package -n libgcj-static
244 Summary:        Static Java Class Libraries
245 Summary(pl):    Statyczne Biblioteki Klass Javy
246 Group:          Development/Libraries
247 Version:        %{GCJ_VERSION}
248 Epoch:          2
249 Requires:       libstdc++-devel = %{GCJ_VERSION}
250
251 %description -n libgcj-static
252 Static Java Class Libraries
253
254 %description -l pl -n libgcj-static
255 Statyczne Biblioteki Klass Javy
256
257 %package -n libstdc++
258 Summary:        GNU c++ library
259 Summary(pl):    Biblioteki GNU C++ 
260 Group:          Libraries
261 Version:        %{STDC_VERSION}
262 Obsoletes:      libg++
263
264 %description -n libstdc++
265 This is the GNU implementation of the standard C++ libraries, along
266 with additional GNU tools. This package includes the shared libraries
267 necessary to run C++ applications.
268
269 %description -l de -n libstdc++
270 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
271 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
272 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
273
274 %description -l fr -n libstdc++
275 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
276 des outils GNU supplémentaires. Ce package comprend les librairies
277 partagées nécessaires à l'exécution d'application C++.
278
279 %description -l pl -n libstdc++  
280 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
281 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
282 uruchomienia aplikacji napisanych w C++.
283
284 %description -l tr -n libstdc++
285 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
286 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
287
288 %package -n libstdc++-devel
289 Summary:        Header files and libraries for C++ development
290 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
291 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
292 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
293 Group:          Development/Libraries
294 Version:        %{STDC_VERSION}
295 Requires:       libstdc++ = %{STDC_VERSION}
296 Requires:       %{name}-c++
297 Obsoletes:      libg++-devel
298
299 %description -n libstdc++-devel
300 This is the GNU implementation of the standard C++ libraries. This
301 package includes the header files and libraries needed for C++
302 development.
303
304 %description -l pl -n libstdc++-devel
305 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
306 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
307 programowaniu w jêzyku C++.
308
309 %package -n libstdc++-static
310 Summary:        Static c++ standard library
311 Summary(pl):    Biblioteka statyczna c++
312 Group:          Development/Libraries
313 Version:        %{STDC_VERSION}
314 Requires:       libstdc++-devel = %{STDC_VERSION}
315
316 %description -n libstdc++-static
317 Static c++ standard library.
318
319 %description -l pl -n libstdc++-static
320 Biblioteka statyczna C++.
321
322 %package -n libgcc
323 Summary:        Shared gcc library
324 Summary(pl):    Biblioteka gcc
325 Group:          Libraries
326 Version:        %{version}
327
328 %description -n libgcc
329 Shared gcc library.
330
331 %description -l pl -n libgcc
332 Biblioteka dynamiczna gcc.
333
334 %package -n cpp
335 Summary:        The C Pre Processor
336 Summary(pl):    Preprocesor C
337 Group:          Development/Languages
338 Version:        %{version}
339 Obsoletes:      egcs-cpp
340 Obsoletes:      gcc-cpp
341
342 %description -n cpp
343 The C preprocessor is a "macro processor" that is used automatically
344 by the C compiler to transform your program before actual compilation.
345 It is called a macro processor because it allows you to define
346 "macros", which are brief abbreviations for longer constructs.
347
348 The C preprocessor provides four separate facilities that you can use
349 as you see fit:
350
351 - Inclusion of header files. These are files of declarations that can
352   be substituted into your program.
353 - Macro expansion. You can define "macros", which are abbreviations
354   for arbitrary fragments of C code, and then the C preprocessor will
355   replace the macros with their definitions throughout the program.
356 - Conditional compilation. Using special preprocessing directives, you
357   can include or exclude parts of the program according to various
358   conditions.
359 - Line control. If you use a program to combine or rearrange source
360   files into an intermediate file which is then compiled, you can use
361   line control to inform the compiler of where each source line
362   originally came from.
363
364 %description -l pl -n cpp
365 Przeprocesor C jest "makro procesorem" który jest automatycznie
366 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
367 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
368 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
369 d³ugich konstrukcji w jêzyku C.
370
371 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
372
373 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
374   deklaracji polecenia do³±czenia innego pliku.
375 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
376   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
377   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
378 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
379   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
380   fragmenty obrabianego strumienia tekstów.
381 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
382   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
383   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
384   odpowiada fragment pliku wynikowego.
385
386 %package ksi
387 Summary:        Ksi support for gcc
388 Summary(pl):    Wspomoganie Ksi dla gcc
389 Version:        %{GCC_VERSION}.%{KSI_VERSION}
390 Group:          Development/Languages
391 Requires:       gcc = %{GCC_VERSION}
392
393 %description ksi
394 This package adds experimental support for compiling Ksi programs
395 into native code. You proabably don't need it, unless your are going
396 to develop a compiler using Ksi as intermediate representation or
397 you are using such compiler (like Gont).
398
399 %description -l pl ksi
400 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
401 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
402 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jakos reprezentacji
403 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
404
405 %package ada
406 Summary:        Ada support for gcc
407 Summary(pl):    Wsparcie dla Ady do gcc
408 Group:          Development/Languages
409 Requires:       libgnat = %{GCC_VERSION}
410 Requires:       gcc = %{GCC_VERSION}
411 Obsoletes:      gnat-devel
412
413 %description ada
414 This package adds experimental support for compiling Ada programs.
415
416 %description -l pl ada
417 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
418 w Adzie.
419
420 %package -n libgnat
421 Summary:        Ada standard libraries
422 Summary(pl):    Biblioteki standardowe dla Ady
423 Group:          Libraries
424 Obsoletes:      gnat
425
426 %description -n libgnat
427 This package contains shared libraries needed to run programs written
428 in Ada.
429
430 %description -l pl -n libgnat
431 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów napisanych
432 w Adzie.
433
434 %package -n libgnat-static
435 Summary:        Static Ada standard libraries
436 Summary(pl):    Statyczne biblioteki standardowe dla Ady
437 Group:          Libraries
438 Obsoletes:      gnat-static
439
440 %description -n libgnat
441 This package contains static libraries needed to run programs written
442 in Ada.
443
444 %description -l pl -n libgnat-static
445 Ten pakiet zawiera biblioteki statyczne potrzebne do uruchamiania
446 programów napisanych w Adzie.
447
448 %prep
449 %setup -q -a1 -n %{name}-%{SNAP}
450 mv ksi-%{KSI_VERSION} gcc/ksi
451 %patch0 -p1
452 %patch1 -p1
453 %patch2 -p1
454 %patch3 -p1
455
456 %build
457 # cd gcc && autoconf; cd ..
458 # autoconf is not needed!
459 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
460
461 CFLAGS="%{rpmcflags}" \
462 CXXFLAGS="%{rpmcflags}" \
463 TEXCONFIG=false ../configure \
464         --prefix=%{_prefix} \
465         --infodir=%{_infodir} \
466         --mandir=%{_mandir} \
467         --enable-shared \
468         --enable-threads=posix \
469         --enable-languages="c,c++,f77,gcov,java,objc,ksi,ada" \
470         --enable-long-long \
471         --enable-multilib \
472         --with-gnu-as \
473         --with-gnu-ld \
474         --with-system-zlib \
475         --with-slibdir=%{_slibdir} \
476         --without-x \
477         %{_target_platform}
478
479 PATH=$PATH:/sbin:%{_sbindir}
480
481 # this dircty hack is relict of setting, where objdir is subdir of srcdir
482 sed -e 's/srcdir=\$(fsrcdir)/srcdir=\$(fsrcdir) VPATH=\$(fsrcdir)/' \
483         gcc/ada/Makefile > makefile.tmp
484 mv -f makefile.tmp gcc/ada/Makefile
485
486 cd ..
487 %{__make} -C obj-%{_target_platform} bootstrap-lean \
488         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
489         mandir=%{_mandir} \
490         infodir=%{_infodir}
491
492 %{__make} -C obj-%{_target_platform}/gcc gnatlib gnattools gnatlib-shared \
493         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
494         mandir=%{_mandir} \
495         infodir=%{_infodir}
496
497 # make Gnat Reference Manual
498 cd gcc/ada
499 ln -s ../doc/include/fdl.texi gfdl.texi
500 makeinfo gnat_rm.texi
501 cd ../..
502
503 %install
504 rm -rf $RPM_BUILD_ROOT
505 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
506
507 cd obj-%{_target_platform}
508 PATH=$PATH:/sbin:%{_sbindir}
509
510 %{__make} install \
511         prefix=$RPM_BUILD_ROOT%{_prefix} \
512         mandir=$RPM_BUILD_ROOT%{_mandir} \
513         infodir=$RPM_BUILD_ROOT%{_infodir} \
514         slibdir=$RPM_BUILD_ROOT/lib
515
516 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
517 echo .so gcc.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
518
519 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
520 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
521
522 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
523  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/ ; \
524  ln -sf ../../../${LIBSTDC} libstdc++.so)
525
526 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
527         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
528
529 # move ada shared libraries to proper place...
530 mv $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*-*so \
531         $RPM_BUILD_ROOT%{_libdir}
532 rm -f $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.so
533 (cd $RPM_BUILD_ROOT%{_libdir} && \
534  ln -s libgnat-*so libgnat.so && \
535  ln -s libgnarl-*so libgnarl.so)
536
537 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
538
539 cd ..
540
541 install gcc/ada/gnat_rm.info* $RPM_BUILD_ROOT%{_infodir}
542
543 gzip -9nf READ* ChangeLog
544 gzip -9nf gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
545
546 mkdir java-doc
547 mv -f libjava/doc/cni.sgml libjava/READ* java-doc
548 mv -f fastjar/README java-doc/README.fastjar
549 mv -f libffi/README java-doc/README.libffi
550 mv -f libffi/LICENSE java-doc/LICENSE.libffi
551 gzip -9nf java-doc/*
552
553 mv libobjc/README gcc/objc/README.libobjc
554 gzip -9nf gcc/objc/READ*
555
556 %find_lang %{name}
557
558 %post
559 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
560
561 %postun
562 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
563
564 %post g77
565 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
566
567 %postun g77
568 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
569
570 %post chill
571 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
572
573 %postun chill
574 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
575
576 %post java
577 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
578
579 %postun java
580 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
581
582 %post -n cpp
583 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
584
585 %postun -n cpp
586 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
587
588 %post ksi
589 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
590
591 %postun ksi
592 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
593
594 %post   -p /sbin/ldconfig -n libgcc
595 %postun -p /sbin/ldconfig -n libgcc
596 %post   -p /sbin/ldconfig -n libstdc++
597 %postun -p /sbin/ldconfig -n libstdc++
598 %post   -p /sbin/ldconfig -n libgcj
599 %postun -p /sbin/ldconfig -n libgcj
600 %post   -p /sbin/ldconfig -n libg2c
601 %postun -p /sbin/ldconfig -n libg2c
602 %post   -p /sbin/ldconfig -n libobjc
603 %postun -p /sbin/ldconfig -n libobjc
604 %post   -p /sbin/ldconfig -n libgnat
605 %postun -p /sbin/ldconfig -n libgnat
606
607 %clean
608 rm -rf $RPM_BUILD_ROOT
609
610 %files -f %{name}.lang
611 %defattr(644,root,root,755)
612 %doc READ* ChangeLog.gz
613 %dir %{_libdir}/gcc-lib
614 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
615 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
616 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
617 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
618 %attr(755,root,root) %{_bindir}/gcc
619 %attr(755,root,root) %{_bindir}/gccbug
620 %attr(755,root,root) %{_bindir}/gcov
621 %attr(755,root,root) %{_bindir}/cc
622
623 %{_mandir}/man1/gcc.1*
624 %{_mandir}/man1/cc.1*
625 %{_mandir}/man1/gcov.1*
626 %{_infodir}/gcc*
627
628 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
629 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
630 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
631 #%ifnarch alpha
632 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
633 #%endif
634 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
635 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
636
637 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
638 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
639 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
640 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
641 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
642 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
643 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
644 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
645 %ifarch %{ix86}
646 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/mmintrin.h
647 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/xmmintrin.h
648 %endif
649
650 %files c++
651 %defattr(644,root,root,755)
652 %{_mandir}/man1/g++.1.gz
653 %attr(755,root,root) %{_bindir}/g++
654 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
655 %attr(755,root,root) %{_bindir}/c++
656 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
657 %attr(755,root,root) %{_bindir}/c++filt
658 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
659 %attr(755,root,root) %{_libdir}/libsupc++.la
660 %{_libdir}/libsupc++.a
661
662 %files objc
663 %defattr(644,root,root,755)
664 %doc gcc/objc/*.gz
665 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
666 %attr(755,root,root) %{_libdir}/libobjc.so
667 %attr(755,root,root) %{_libdir}/libobjc.la
668 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
669
670 %files -n libobjc
671 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
672
673 %files -n libobjc-static
674 %defattr(644,root,root,755)
675 %{_libdir}/libobjc.a
676
677 %files g77
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_bindir}/g77
680 %attr(755,root,root) %{_bindir}/f77
681 %{_infodir}/g77*
682 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
683 %attr(755,root,root) %{_libdir}/libg2c.la
684 %attr(755,root,root) %{_libdir}/libg2c.so
685 %{_mandir}/man1/g77.1*
686 %{_mandir}/man1/f77.1*
687 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
688
689 %files -n libg2c
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/libg2c.so.*.*.*
692
693 %files -n libg2c-static
694 %{_libdir}/libg2c.a
695
696 %files ksi
697 %defattr(644,root,root,755)
698 %doc gcc/ksi/*.gz gcc/ksi/t/*.gz
699 %{_infodir}/ksi*
700 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
701
702 %files ada
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/gnat1
705 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adainclude
706 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib
707 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.ali
708 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgmem.a
709 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/Makefile.adalib
710 %attr(755,root,root) %{_bindir}/gnat*
711 %{_infodir}/gnat*
712 %attr(755,root,root) %{_libdir}/libgnat.so
713 %attr(755,root,root) %{_libdir}/libgnarl.so
714
715 %files -n libgnat-static
716 %defattr(644,root,root,755)
717 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgna*.a
718
719 %files -n libgnat
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/libgna*-*so
722
723 %ifarch no_longer_supported_by_gcc_team
724 %files chill
725 %defattr(644,root,root,755)
726 %doc gcc/ch/chill.brochure.gz
727
728 %attr(755,root,root) %{_bindir}/chill
729 %{_infodir}/chill*
730 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
731 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
732 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
733 %endif
734
735 %files java
736 %defattr(644,root,root,755)
737 %doc java-doc/*.gz
738 %attr(755,root,root) %{_bindir}/gcj*
739 %attr(755,root,root) %{_bindir}/gij
740 %attr(755,root,root) %{_bindir}/jcf-dump
741 %attr(755,root,root) %{_bindir}/jv-*
742 %attr(755,root,root) %{_bindir}/rmi*
743 %attr(755,root,root) %{_bindir}/jar
744 %attr(755,root,root) %{_bindir}/grepjar
745 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
746 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
747 %{_infodir}/gcj*
748 %{_mandir}/man1/jcf-*
749 %{_mandir}/man1/jv-*
750 %{_mandir}/man1/gij*
751 %{_mandir}/man1/gcj*
752
753 %files -n libgcj
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_bindir}/addr2name.awk
756 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
757
758 %files -n libgcj-devel
759 %defattr(644,root,root,755)
760 %{_includedir}/java
761 %{_includedir}/javax
762 %{_includedir}/org
763 %{_includedir}/gcj
764 %{_includedir}/j*.h
765 %{_includedir}/gnu/*
766 %{_libdir}/lib*cj.spec
767 %{_libdir}/security/*
768 %{_datadir}/libgcj.jar
769 %attr(755,root,root) %{_libdir}/lib*cj*.la
770 %attr(755,root,root) %{_libdir}/lib*cj*.so
771
772 %files -n libgcj-static
773 %defattr(644,root,root,755)
774 %{_libdir}/lib*cj*.a
775
776 %files -n libstdc++
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
779
780 %files -n libstdc++-devel
781 %defattr(644,root,root,755)
782 %doc libstdc++-v3/docs/html
783 %{_includedir}/g++*
784 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
785
786 %files -n libstdc++-static
787 %defattr(644,root,root,755)
788 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
789
790 %files -n libgcc
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_slibdir}/lib*.so*
793
794 %files -n cpp
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_slibdir}/cpp
797 %attr(755,root,root) %{_bindir}/cpp
798 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
799 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
800 %{_mandir}/man1/cpp.1*
801 %{_infodir}/cpp*
This page took 0.090719 seconds and 4 git commands to generate.