]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
- release 12: added bison to BuildRequires.
[packages/gcc.git] / gcc.spec
1 %define         STDC_VERSION 2.10.0
2 Summary:        GNU Compiler Collection
3 Summary(pl):    Kolekcja kompilatorów GNU
4 Name:           gcc
5 Version:        2.95.3
6 Release:        12
7 License:        GPL
8 Group:          Development/Languages
9 Group(de):      Entwicklung/Sprachen
10 Group(pl):      Programowanie/Jêzyki
11 Source0:        ftp://ftp.gnu.org/pub/gnu/gcc/%{name}-2.95.2.tar.gz
12 Source1:        gcov.1
13 Patch0:         %{name}-info.patch
14 Patch1:         %{name}-pld-linux.patch
15 Patch2:         %{name}-libstdc++.patch
16 Patch3:         %{name}-bootstrap.patch
17 Patch4:         %{name}-cpp-macro-doc.patch
18 Patch5:         %{name}-default-arch.patch
19 Patch6:         %{name}-cvs-updates-20000220.patch.gz
20 Patch7:         %{name}-libstdc++-out-of-mem.patch
21 Patch8:         %{name}-libstdc++-wstring.patch
22 Patch9:         %{name}-libstdc++-wall3.patch
23 Patch10:        %{name}-libstdc++-bastring.patch
24 Patch11:        %{name}-manpage.patch
25 Patch12:        %{name}-cpp-dos-newlines.patch
26 Patch13:        %{name}-g++-is-tree.patch
27 Patch14:        %{name}-gpc.patch
28 Patch15:        %{name}-arm-config.patch
29 Patch16:        %{name}-m68k-pic.patch
30 Patch17:        %{name}-sparc32-rfi.patch
31 Patch18:        %{name}-builtin-apply.patch
32 Patch19:        %{name}-gcj-backport.patch
33 Patch20:        %{name}-ppc-ice.patch
34 Patch21:        %{name}-ppc-descriptions.patch
35 Patch22:        %{name}-ppc-andrew-dwarf-eh.patch
36
37 Patch23:        %{name}-alpha-complex-float.patch
38 Patch24:        %{name}-emit-rtl.patch
39 Patch25:        %{name}-empty-struct-init.patch
40 Patch26:        %{name}-gcj-vs-iconv.patch
41 Patch27:        %{name}-libobjc.patch
42 Patch28:        %{name}-pointer-arith.patch
43
44 Patch29:        %{name}-glibc-2.2.patch
45
46 BuildRequires:  bison
47 Requires:       binutils >= 2.9.1.0.25
48 Requires:       cpp = %{version}
49 URL:            http://gcc.gnu.org/
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 A compiler aimed at integrating all the optimizations and features
54 necessary for a high-performance and stable development environment.
55
56 %description -l pl
57 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
58 wyprodukowania szybkiego i stablinego kodu wynikowego.
59
60 %package c++
61 Summary:        C++ support for gcc
62 Summary(fr):    Support C++ pour le compilateur gcc
63 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
64 Summary(tr):    gcc için C++ desteði
65 Group:          Development/Languages
66 Group(de):      Entwicklung/Sprachen
67 Group(pl):      Programowanie/Jêzyki
68 Obsoletes:      egcc-c++
69 Obsoletes:      egcs-c++
70
71 %description c++
72 This package adds C++ support to the GNU C compiler. It includes
73 support for most of the current C++ specification, including templates
74 and exception handling. It does not include a standard C++ library,
75 which is available separately.
76
77 %description -l de c++
78 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
79 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
80 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
81 sie ist getrennt erhältlich.
82
83 %description -l fr c++
84 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
85 support pour la plupart des spécifications actuelles de C++, dont les
86 modéles et la gestion des exceptions. Il ne comprend pas une
87 bibliothéque C++ standard, qui est disponible séparément.
88
89 %description -l pl c++
90 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
91 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
92 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
93
94 %description -l tr c++
95 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
96 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
97 C++ kitaplýðý bu pakette yer almaz.
98
99 %package objc
100 Summary:        Objective C support for gcc
101 Summary(de):    Objektive C-Unterstützung für gcc
102 Summary(fr):    Gestion d'Objective C pour gcc
103 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
104 Summary(tr):    gcc için Objective C desteði
105 Group:          Development/Languages
106 Group(de):      Entwicklung/Sprachen
107 Group(pl):      Programowanie/Jêzyki
108 Obsoletes:      egcc-objc
109 Obsoletes:      egcs-objc
110
111 %description objc
112 This package adds Objective C support to the GNU C compiler. Objective
113 C is a object oriented derivative of the C language, mainly used on
114 systems running NeXTSTEP. This package does not include the standard
115 objective C object library.
116
117 %description -l de objc
118 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
119 Objective C ist ein objektorientiertes Derivat von C, das zur
120 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
121 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
122
123 %description -l fr objc
124 Ce package ajoute un support Objective C au compilateur C GNU.
125 L'Objective C est un langage orienté objetdérivé du langage C,
126 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
127 pas la bibliothéque Objective C standard.
128
129 %description -l pl objc
130 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
131 pakiecie nie ma jeszcze bibliotek C-obj.
132
133 %description -l tr objc
134 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
135 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
136 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
137 kitaplýðý bu pakette yer almaz.
138
139 %package g77
140 Summary:        Fortran 77 support for gcc
141 Summary(pl):    Wspomaganie Fortran 77 dla gcc
142 Group:          Development/Languages
143 Group(de):      Entwicklung/Sprachen
144 Group(pl):      Programowanie/Jêzyki
145 Obsoletes:      egcs-g77
146
147 %description g77
148 This apckage adds support for compiling Fortran 77 programs with the
149 GNU compiler.
150
151 %description -l pl g77
152 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
153 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
154
155 %package chill
156 Summary:        CHILL support for gcc
157 Summary(pl):    Wspomoganie CHILL dla gcc
158 Group:          Development/Languages
159 Group(de):      Entwicklung/Sprachen
160 Group(pl):      Programowanie/Jêzyki
161 Requires:       %{name} = %{version}
162
163 %description chill
164 This package adds support for compiling CHILL programs with the GNU
165 compiler.
166
167 Chill is the "CCITT High-Level Language", where CCITT is the old name
168 for what is now ITU, the International Telecommunications Union. It is
169 is language in the Modula2 family, and targets many of the same
170 applications as Ada (especially large embedded systems). Chill was
171 never used much in the United States, but is still being used in
172 Europe, Brazil, Korea, and other places.
173
174 %package java
175 Summary:        Java support for gcc
176 Summary(pl):    Wspomoganie Java dla gcc
177 Group:          Development/Languages
178 Group(de):      Entwicklung/Sprachen
179 Group(pl):      Programowanie/Jêzyki
180 Requires:       %{name} = %{version}
181 Requires:       libgcj >= 2.95.1
182
183 %description java
184 This package adds experimental support for compiling Java(tm) programs
185 and bytecode into native code. To use this you will also need the
186 libgcj package.
187
188 %package -n libstdc++
189 Summary:        GNU c++ library
190 Summary(pl):    Biblioteki GNU C++ 
191 Group:          Libraries
192 Group(de):      Libraries
193 Group(fr):      Librairies
194 Group(pl):      Biblioteki
195 Version:        %{STDC_VERSION}
196 Obsoletes:      libg++
197
198 %description -n libstdc++
199 This is the GNU implementation of the standard C++ libraries, along
200 with additional GNU tools. This package includes the shared libraries
201 necessary to run C++ applications.
202
203 %description -l de -n libstdc++
204 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
205 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
206 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
207
208 %description -l fr -n libstdc++
209 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
210 des outils GNU supplémentaires. Ce package comprend les librairies
211 partagées nécessaires à l'exécution d'application C++.
212
213 %description -l pl -n libstdc++  
214 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
215 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
216 uruchomienia aplikacji napisanych w C++.
217
218 %description -l tr -n libstdc++
219 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
220 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
221
222 %package -n libstdc++-devel
223 Summary:        Header files and libraries for C++ development
224 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
225 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
226 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
227 Group:          Development/Libraries
228 Group(de):      Entwicklung/Libraries
229 Group(fr):      Development/Librairies
230 Group(pl):      Programowanie/Biblioteki
231 Version:        %{STDC_VERSION}
232 Requires:       libstdc++ = %{STDC_VERSION}
233 Requires:       %{name}-c++
234 Obsoletes:      libg++-devel
235
236 %description -n libstdc++-devel
237 This is the GNU implementation of the standard C++ libraries. This
238 package includes the header files and libraries needed for C++
239 development.
240
241 %description -l pl -n libstdc++-devel
242 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
243 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
244 programowaniu w jêzyku C++.
245
246 %package -n libstdc++-static
247 Summary:        Static c++ standard library
248 Summary(pl):    Biblioeka statyczna c++
249 Group:          Development/Libraries
250 Group(de):      Entwicklung/Libraries
251 Group(fr):      Development/Librairies
252 Group(pl):      Programowanie/Biblioteki
253 Version:        %{STDC_VERSION}
254 Requires:       libstdc++-devel = %{STDC_VERSION}
255
256 %description -n libstdc++-static
257 Static c++ standard library.
258
259 %description -l pl -n libstdc++-static
260 Biblioteka statyczna C++.
261
262 %package -n cpp
263 Summary:        The C Pre Processor
264 Summary(pl):    Preprocesor C
265 Group:          Development/Languages
266 Group(de):      Entwicklung/Sprachen
267 Group(pl):      Programowanie/Jêzyki
268 Obsoletes:      egcs-cpp
269
270 %description -n cpp
271 The C preprocessor is a "macro processor" that is used automatically
272 by the C compiler to transform your program before actual compilation.
273 It is called a macro processor because it allows you to define
274 "macros", which are brief abbreviations for longer constructs.
275
276 The C preprocessor provides four separate facilities that you can use
277 as you see fit:
278
279 - Inclusion of header files. These are files of declarations that can
280   be substituted into your program.
281 - Macro expansion. You can define "macros", which are abbreviations
282   for arbitrary fragments of C code, and then the C preprocessor will
283   replace the macros with their definitions throughout the program.
284 - Conditional compilation. Using special preprocessing directives, you
285   can include or exclude parts of the program according to various
286   conditions.
287 - Line control. If you use a program to combine or rearrange source
288   files into an intermediate file which is then compiled, you can use
289   line control to inform the compiler of where each source line
290   originally came from.
291
292 %description -l pl -n cpp
293 Przeprocesor C jest "makro procesorem" który jest automatycznie
294 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
295 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
296 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
297 d³ugich konstrukcji w jêzyku C.
298
299 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
300
301 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
302   deklaracji polecenia do³±czenia innego pliku.
303 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
304   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
305   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
306 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
307   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
308   fragmenty obrabianego strumienia tekstów.
309 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
310   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
311   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
312   odpowiada fragment pliku wynikowego.
313
314 %prep
315 %setup -q -n %{name}-2.95.2
316 %patch0 -p1
317 %patch1 -p1
318 %patch2 -p1
319 %patch3 -p1
320 %patch4 -p0
321 %patch5 -p0
322 %patch6 -p1
323 %patch7 -p0
324 %patch8 -p0
325 %patch9 -p0
326 %patch10 -p0
327 %patch11 -p0
328 %patch12 -p0
329 %patch13 -p1
330 %patch14 -p1
331 %ifarch arm
332 %patch15 -p0
333 %endif
334 %ifarch m68k
335 %patch16 -p0
336 %endif
337 %ifarch sparc sparc32
338 %patch17 -p0
339 %patch18 -p0
340 %patch19 -p1
341 %endif
342 %ifarch ppc
343 %patch20 -p0
344 %patch21 -p0
345 %patch22 -p0
346 %endif
347 %ifarch alpha
348 %patch23 -p1
349 %endif
350 %patch24 -p0
351 %patch25 -p0
352 %patch26 -p0
353 %patch27 -p0
354 %patch28 -p0
355 %patch29 -p1
356
357 %build
358 (cd gcc; autoconf)
359 rm -rf obj-%{_target_platform}
360 install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
361
362 CFLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O -g}"
363 CXXFLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O -g}" 
364 ../configure \
365         --prefix=%{_prefix} \
366         --infodir=%{_infodir} \
367         --enable-shared \
368 %ifnarch sparc sparc64
369         --enable-threads \
370         --enable-haifa \
371 %endif
372         --with-gnu-as \
373         --with-gnu-ld \
374         --with-gxx-include-dir="\$\{prefix\}/include/g++" \
375         %{_target_platform}
376
377 PATH=$PATH:/sbin:%{_sbindir}
378 touch  ../gcc/c-gperf.h
379
380 %{__make} LDFLAGS_FOR_TARGET="%{!?debug:-s}" \
381         mandir=%{_mandir} \
382         infodir=%{_infodir}
383
384 %install
385 rm -rf $RPM_BUILD_ROOT
386 install -d $RPM_BUILD_ROOT%{_datadir}
387
388 cd obj-%{_target_platform}
389 PATH=$PATH:/sbin:%{_sbindir}
390
391 %{__make} install \
392         prefix=$RPM_BUILD_ROOT%{_prefix} \
393         mandir=$RPM_BUILD_ROOT%{_mandir} \
394         infodir=$RPM_BUILD_ROOT%{_infodir}
395
396 %{__make} install \
397         prefix=$RPM_BUILD_ROOT%{_prefix} \
398         mandir=$RPM_BUILD_ROOT%{_mandir} \
399         infodir=$RPM_BUILD_ROOT%{_infodir} -C texinfo
400
401 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
402
403 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
404 echo .so cccp.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cpp.1
405 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
406
407 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
408
409 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
410
411 install -d $RPM_BUILD_ROOT/lib
412 (cd $RPM_BUILD_ROOT; \
413 ln -sf ../`dirname usr/lib/gcc-lib/%{_target_cpu}*/*/cpp`/cpp $RPM_BUILD_ROOT/lib/cpp)
414
415 gzip -9nf ../READ* ../ChangeLog ../gcc/ch/chill.brochure
416
417 %post
418 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
419
420 %postun
421 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
422
423 %post g77
424 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
425
426 %postun g77
427 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
428
429 %post chill
430 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
431
432 %postun chill
433 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
434
435 %post -n cpp
436 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
437
438 %postun -n cpp
439 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
440
441 %post   -p /sbin/ldconfig -n libstdc++
442 %postun -p /sbin/ldconfig -n libstdc++
443
444 %clean
445 rm -rf $RPM_BUILD_ROOT
446
447 %files
448 %defattr(644,root,root,755)
449 %doc READ* ChangeLog.gz
450
451 %dir %{_libdir}/gcc-lib
452 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
453 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
454 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
455
456 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
457 %attr(755,root,root) %{_bindir}/gcc
458 %attr(755,root,root) %{_bindir}/gcov
459 %attr(755,root,root) %{_bindir}/protoize
460 %attr(755,root,root) %{_bindir}/unprotoize
461 %attr(755,root,root) %{_bindir}/cc
462
463 %{_mandir}/man1/gcc.1*
464 %{_mandir}/man1/gcov.1*
465 %{_infodir}/gcc*
466
467 %{_libdir}/gcc-lib/%{_target_cpu}*/*/SYSCALLS.c.X
468 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
469 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
470 %{_libdir}/gcc-lib/%{_target_cpu}*/*/lib*.map
471 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
472
473 %ifnarch alpha
474 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
475 %endif
476
477 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
478
479 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
480 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
481 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
482 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
483 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
484 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
485 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
486 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
487 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/va-*.h
488 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
489
490 %files c++
491 %defattr(644,root,root,755)
492
493 %{_mandir}/man1/g++.1.gz
494
495 %attr(755,root,root) %{_bindir}/g++
496 %attr(755,root,root) %{_bindir}/c++
497 %attr(755,root,root) %{_bindir}/c++filt
498 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
499
500 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/exception
501 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new
502 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/typeinfo
503 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new.h
504
505 %files objc
506 %defattr(644,root,root,755)
507
508 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
509
510 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
511 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
512
513 %files g77
514 %defattr(644,root,root,755)
515
516 %attr(755,root,root) %{_bindir}/g77
517 %attr(755,root,root) %{_bindir}/f77
518
519 %{_infodir}/g77*
520
521 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
522 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
523
524 %{_mandir}/man1/g77.1*
525 %{_mandir}/man1/f77.1*
526
527 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
528
529 %files chill
530 %defattr(644,root,root,755)
531 %doc gcc/ch/chill.brochure.gz
532
533 %attr(755,root,root) %{_bindir}/chill
534
535 %{_infodir}/chill*
536
537 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
538 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
539 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
540
541 %files java
542 %defattr(644,root,root,755)
543
544 %attr(755,root,root) %{_bindir}/gcj
545 %attr(755,root,root) %{_bindir}/gcjh
546 %attr(755,root,root) %{_bindir}/jcf-dump
547 %attr(755,root,root) %{_bindir}/jv-scan
548
549 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
550 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
551
552 %files -n libstdc++
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
555
556 %files -n libstdc++-devel
557 %defattr(644,root,root,755)
558 %{_includedir}/g++
559 %attr(755,root,root) %{_libdir}/libstdc++.so
560
561 %files -n libstdc++-static
562 %defattr(644,root,root,755)
563 %attr(644,root,root) %{_libdir}/libstdc++.a
564
565 %files -n cpp
566 %defattr(644,root,root,755)
567 %attr(755,root,root) /lib/cpp
568
569 %{_mandir}/man1/cpp.1*
570 %{_mandir}/man1/cccp.1*
571 %{_infodir}/cpp.info*.gz
572
573 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp
This page took 0.08745 seconds and 4 git commands to generate.