]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
- -java Obsoletes: fastjar
[packages/gcc.git] / gcc.spec
1 #
2 # Conditional build:
3 # _without_ada  - build without ADA support
4 # _without_java - build without Java support
5 #
6 %define         DASHED_SNAP     %{nil}
7 %define         SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
8 %define         GCC_VERSION     3.2.1
9 %define         KSI_VERSION     pre55
10 %define         EPOCH           5
11
12 Summary:        GNU Compiler Collection
13 Summary(pl):    Kolekcja kompilatorów GNU
14 Name:           gcc
15 Version:        %{GCC_VERSION}
16 Release:        1
17 Epoch:          %{EPOCH}
18 License:        GPL
19 Group:          Development/Languages
20 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
21 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
22 Source2:        %{name}-non-english-man-pages.tar.bz2
23 Patch0:         %{name}-slibdir.patch
24 Patch1:         %{name}-paths.patch
25 Patch2:         %{name}-ada-no-addr2line.patch
26 Patch3:         %{name}-ada-no-prefix.o.patch
27 Patch4:         %{name}-nolocalefiles.patch
28
29 Patch6:         %{name}-info.patch
30 # -- stolen patches from RH --
31 Patch10:        gcc32-ada-link.patch
32 Patch11:        gcc32-attr-visibility.patch
33 Patch12:        gcc32-attr-visibility2.patch
34 Patch13:        gcc32-attr-visibility3.patch
35 Patch14:        gcc32-attr-visibility4.patch
36 Patch15:        gcc32-attr-visibility5.patch
37 Patch16:        gcc32-boehm-gc-libs.patch
38 Patch17:        gcc32-bogus-inline.patch
39 Patch18:        gcc32-c++-nrv-test.patch
40 Patch19:        gcc32-c++-pretty_function.patch
41 Patch20:        gcc32-c++-tsubst-asm.patch
42 Patch21:        gcc32-cfg-eh.patch
43 Patch22:        gcc32-debug-pr7241.patch
44
45 Patch24:        gcc32-duplicate-decl.patch
46 Patch25:        gcc32-dwarf2-pr6381.patch
47 Patch26:        gcc32-dwarf2-pr6436-test.patch
48 Patch27:        gcc32-fde-merge-compat.patch
49 Patch28:        gcc32-fold-const-associate.patch
50 Patch29:        gcc32-hard-reg-sharing.patch
51 Patch30:        gcc32-hard-reg-sharing2.patch
52 Patch31:        gcc32-i386-default-momit-leaf-frame-pointer.patch
53 Patch32:        gcc32-i386-memtest-test.patch
54 Patch33:        gcc32-i386-no-default-momit-leaf-frame-pointer.patch
55 Patch34:        gcc32-i386-pic-label-thunk.patch
56 Patch35:        gcc32-i386-profile-olfp.patch
57 Patch36:        gcc32-inline-label.patch
58 Patch37:        gcc32-java-no-rpath.patch
59 Patch38:        gcc32-pr6842.patch
60 Patch39:        gcc32-sparc-sll1.patch
61 Patch40:        gcc32-test-rh65771.patch
62 Patch41:        gcc32-test-rotate.patch
63 Patch42:        gcc32-tls-dwarf2.patch
64 Patch43:        gcc32-tls.patch
65 Patch44:        gcc32-tls2.patch
66 Patch45:        gcc32-tls3.patch
67 Patch46:        gcc32-tls4.patch
68 Patch47:        gcc32-tls5.patch
69 BuildRequires:  autoconf
70 BuildRequires:  bison
71 BuildRequires:  fileutils >= 4.0.41
72 BuildRequires:  gcc
73 %{!?_without_ada:BuildRequires: gcc-ada}
74 BuildRequires:  glibc-devel >= 2.2.5-20
75 BuildRequires:  perl-devel
76 BuildRequires:  texinfo >= 4.1
77 BuildRequires:  zlib-devel
78 BuildRequires:  gettext-devel
79 Requires:       binutils >= 2.12.90.0.4
80 Requires:       cpp = %{GCC_VERSION}
81 Requires:       libgcc = %{GCC_VERSION}
82 Conflicts:      glibc-devel < 2.2.5-20
83 URL:            http://gcc.gnu.org/
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         _slibdir        /lib
87
88 %description
89 A compiler aimed at integrating all the optimizations and features
90 necessary for a high-performance and stable development environment.
91
92 %description -l pl
93 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
94 wyprodukowania szybkiego i stablinego kodu wynikowego.
95
96 %package -n libgcc
97 Summary:        Shared gcc library
98 Summary(pl):    Biblioteka gcc
99 Group:          Libraries
100 Version:        %{GCC_VERSION}
101
102 %description -n libgcc
103 Shared gcc library.
104
105 %description -n libgcc -l pl
106 Biblioteka dynamiczna gcc.
107
108 %package c++
109 Summary:        C++ support for gcc
110 Summary(pl):    Obs³uga C++ dla gcc
111 Group:          Development/Languages
112 Obsoletes:      egcc-c++
113 Obsoletes:      egcs-c++
114 Requires:       gcc = %{GCC_VERSION}
115
116 %description c++
117 This package adds C++ support to the GNU C compiler. It includes
118 support for most of the current C++ specification, including templates
119 and exception handling. It does not include a standard C++ library,
120 which is available separately.
121
122 %description c++ -l de
123 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
124 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
125 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
126 sie ist getrennt erhältlich.
127
128 %description c++ -l fr
129 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
130 support pour la plupart des spécifications actuelles de C++, dont les
131 modéles et la gestion des exceptions. Il ne comprend pas une
132 bibliothéque C++ standard, qui est disponible séparément.
133
134 %description c++ -l pl
135 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
136 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
137 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
138
139 %description c++ -l tr
140 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
141 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
142 C++ kitaplýðý bu pakette yer almaz.
143
144 %package objc
145 Summary:        Objective C support for gcc
146 Summary(de):    Objektive C-Unterstützung für gcc
147 Summary(fr):    Gestion d'Objective C pour gcc
148 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
149 Summary(tr):    gcc için Objective C desteði
150 Group:          Development/Languages
151 Obsoletes:      egcc-objc
152 Obsoletes:      egcs-objc
153 Requires:       libobjc = %{GCC_VERSION}
154 Requires:       gcc = %{GCC_VERSION}
155
156 %description objc
157 This package adds Objective C support to the GNU C compiler. Objective
158 C is a object oriented derivative of the C language, mainly used on
159 systems running NeXTSTEP. This package does not include the standard
160 objective C object library.
161
162 %description objc -l de
163 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
164 Objective C ist ein objektorientiertes Derivat von C, das zur
165 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
166 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
167
168 %description objc -l fr
169 Ce package ajoute un support Objective C au compilateur C GNU.
170 L'Objective C est un langage orienté objetdérivé du langage C,
171 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
172 pas la bibliothéque Objective C standard.
173
174 %description objc -l pl
175 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
176 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
177 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
178 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
179
180 %description objc -l tr
181 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
182 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
183 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
184 kitaplýðý bu pakette yer almaz.
185
186 %package -n libobjc
187 Summary:        Objective C Libraries
188 Summary(pl):    Biblioteki Obiektowego C
189 Group:          Libraries
190 Version:        %{GCC_VERSION}
191
192 %description -n libobjc
193 Objective C Libraries.
194
195 %description -n libobjc -l pl
196 Biblioteki Obiektowego C.
197
198 %package -n libobjc-static
199 Summary:        Static Objective C Libraries
200 Summary(pl):    Statyczne Biblioteki Obiektowego C
201 Group:          Development/Libraries
202 Version:        %{GCC_VERSION}
203 Requires:       libobjc = %{GCC_VERSION}
204
205 %description -n libobjc-static
206 Static Objective C Libraries.
207
208 %description -n libobjc-static -l pl
209 Statyczne biblioteki Obiektowego C.
210
211 %package g77
212 Summary:        Fortran 77 support for gcc
213 Summary(pl):    Obs³uga Fortranu 77 dla gcc
214 Group:          Development/Languages
215 Version:        %{GCC_VERSION}
216 Obsoletes:      egcs-g77
217 Requires:       libg2c = %{GCC_VERSION}
218
219 %description g77
220 This apckage adds support for compiling Fortran 77 programs with the
221 GNU compiler.
222
223 %description g77 -l pl
224 Ten pakiet dodaje obs³ugê Fortranu 77 do kompilatora gcc. Jest
225 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
226
227 %package -n libg2c
228 Summary:        Fortran 77 Libraries
229 Summary(pl):    Biblioteki Fortranu 77
230 Group:          Libraries
231 Version:        %{GCC_VERSION}
232
233 %description -n libg2c
234 Fortran 77 Libraries.
235
236 %description -n libg2c -l pl
237 Biblioteki Fortranu 77.
238
239 %package -n libg2c-static
240 Summary:        Static Fortran 77 Libraries
241 Summary(pl):    Statyczne Biblioteki Fortranu 77
242 Group:          Development/Libraries
243 Version:        %{GCC_VERSION}
244 Requires:       libg2c = %{GCC_VERSION}
245
246 %description -n libg2c-static
247 Static Fortran 77 Libraries.
248
249 %description -n libg2c-static -l pl
250 Statyczne biblioteki Fortranu 77.
251
252 %package java
253 Summary:        Java support for gcc
254 Summary(pl):    Obs³uga Javy dla gcc
255 Group:          Development/Languages
256 Version:        %{GCC_VERSION}
257 Requires:       %{name} = %{version}
258 Requires:       libgcj >= 3.0.0
259 Provides:       gcj = %{epoch}:%{GCC_VERSION}-%{release}
260 Provides:       jar = %{epoch}:%{GCC_VERSION}-%{release}
261 Obsoletes:      fastjar
262
263 %description java
264 This package adds experimental support for compiling Java(tm) programs
265 and bytecode into native code. To use this you will also need the
266 libgcj package.
267
268 %description -l pl java
269 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
270 do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
271 by³o przeprowadziæ kompilacjê.
272
273 %package -n libgcj
274 Summary:        Java Class Libraries
275 Summary(pl):    Biblioteki Klas Javy
276 Group:          Libraries
277 Version:        %{GCC_VERSION}
278 Requires:       zlib
279
280 %description -n libgcj
281 Java Class Libraries.
282
283 %description -n libgcj -l pl
284 Biblioteki Klas Javy.
285
286 %package -n libgcj-devel
287 Summary:        Development files for Java Class Libraries
288 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
289 Group:          Development/Libraries
290 Version:        %{GCC_VERSION}
291 Requires:       libgcj = %{GCC_VERSION}
292 Requires:       %{name}-java
293
294 %description -n libgcj-devel
295 Development files for Java Class Libraries.
296
297 %description -n libgcj-devel -l pl
298 Pliki nag³ówkowe dla Bibliotek Klas Javy.
299
300 %package -n libgcj-static
301 Summary:        Static Java Class Libraries
302 Summary(pl):    Statyczne Biblioteki Klas Javy
303 Group:          Development/Libraries
304 Version:        %{GCC_VERSION}
305 Requires:       libstdc++-devel = %{GCC_VERSION}
306 Requires:       libgcj-devel = %{GCC_VERSION}
307
308 %description -n libgcj-static
309 Static Java Class Libraries.
310
311 %description -n libgcj-static -l pl
312 Statyczne Biblioteki Klas Javy.
313
314 %package -n libstdc++
315 Summary:        GNU c++ library
316 Summary(pl):    Biblioteki GNU C++
317 Group:          Libraries
318 Version:        %{GCC_VERSION}
319 Obsoletes:      libg++
320
321 %description -n libstdc++
322 This is the GNU implementation of the standard C++ libraries, along
323 with additional GNU tools. This package includes the shared libraries
324 necessary to run C++ applications.
325
326 %description -n libstdc++ -l de
327 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
328 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
329 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
330
331 %description -n libstdc++ -l fr
332 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
333 des outils GNU supplémentaires. Ce package comprend les librairies
334 partagées nécessaires à l'exécution d'application C++.
335
336 %description -n libstdc++ -l pl
337 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
338 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
339 uruchomienia aplikacji napisanych w C++.
340
341 %description -n libstdc++ -l tr
342 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
343 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
344
345 %package -n libstdc++-devel
346 Summary:        Header files and documentatino for C++ development
347 Summary(de):    Header-Dateien zur Entwicklung mit C++
348 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++
349 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
350 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
351 Group:          Development/Libraries
352 Version:        %{GCC_VERSION}
353 Requires:       libstdc++ = %{GCC_VERSION}
354 Requires:       %{name}-c++
355 Obsoletes:      libg++-devel
356
357 %description -n libstdc++-devel
358 This is the GNU implementation of the standard C++ libraries. This
359 package includes the header files needed for C++ development and
360 library documentation.
361
362 %description -n libstdc++-devel -l pl
363 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
364 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
365 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
366
367 %package -n libstdc++-static
368 Summary:        Static C++ standard library
369 Summary(pl):    Statyczna biblioteka standardowa C++
370 Group:          Development/Libraries
371 Version:        %{GCC_VERSION}
372 Requires:       libstdc++-devel = %{GCC_VERSION}
373
374 %description -n libstdc++-static
375 Static C++ standard library.
376
377 %description -n libstdc++-static -l pl
378 Statycza biblioteka standardowa C++.
379
380 %package ada
381 Summary:        Ada support for gcc
382 Summary(pl):    Obs³uga Ady do gcc
383 Group:          Development/Languages
384 Version:        %{GCC_VERSION}
385 Requires:       libgnat = %{GCC_VERSION}
386 Requires:       gcc = %{GCC_VERSION}
387 Obsoletes:      gcc-gnat
388 Obsoletes:      gnat-devel
389
390 %description ada
391 This package adds experimental support for compiling Ada programs.
392
393 %description -l pl ada
394 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
395 w Adzie.
396
397 %package -n libgnat
398 Summary:        Ada standard libraries
399 Summary(pl):    Biblioteki standardowe dla Ady
400 Group:          Libraries
401 Version:        %{GCC_VERSION}
402 Obsoletes:      gnat
403
404 %description -n libgnat
405 This package contains shared libraries needed to run programs written
406 in Ada.
407
408 %description -n libgnat -l pl
409 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów napisanych
410 w Adzie.
411
412 %package -n libgnat-static
413 Summary:        Static Ada standard libraries
414 Summary(pl):    Statyczne biblioteki standardowe dla Ady
415 Group:          Libraries
416 Version:        %{GCC_VERSION}
417 Obsoletes:      gnat-static
418
419 %description -n libgnat-static
420 This package contains static libraries for programs written in Ada.
421
422 %description -n libgnat-static -l pl
423 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
424 Adzie.
425
426 %package ksi
427 Summary:        Ksi support for gcc
428 Summary(pl):    Obs³uga Ksi dla gcc
429 Version:        %{GCC_VERSION}.%{KSI_VERSION}
430 Group:          Development/Languages
431 Requires:       gcc = %{GCC_VERSION}
432
433 %description ksi
434 This package adds experimental support for compiling Ksi programs
435 into native code. You proabably don't need it, unless your are going
436 to develop a compiler using Ksi as intermediate representation or
437 you are using such compiler (like Gont).
438
439 %description ksi -l pl
440 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
441 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
442 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jako reprezentacji
443 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
444
445 %package -n cpp
446 Summary:        The C Pre Processor
447 Summary(pl):    Preprocesor C
448 Group:          Development/Languages
449 Version:        %{GCC_VERSION}
450 Obsoletes:      egcs-cpp
451 Obsoletes:      gcc-cpp
452
453 %description -n cpp
454 The C preprocessor is a "macro processor" that is used automatically
455 by the C compiler to transform your program before actual compilation.
456 It is called a macro processor because it allows you to define
457 "macros", which are brief abbreviations for longer constructs.
458
459 The C preprocessor provides four separate facilities that you can use
460 as you see fit:
461
462 - Inclusion of header files. These are files of declarations that can
463   be substituted into your program.
464 - Macro expansion. You can define "macros", which are abbreviations
465   for arbitrary fragments of C code, and then the C preprocessor will
466   replace the macros with their definitions throughout the program.
467 - Conditional compilation. Using special preprocessing directives, you
468   can include or exclude parts of the program according to various
469   conditions.
470 - Line control. If you use a program to combine or rearrange source
471   files into an intermediate file which is then compiled, you can use
472   line control to inform the compiler of where each source line
473   originally came from.
474
475 %description -n cpp -l pl
476 Przeprocesor C jest "makro procesorem" który jest automatycznie
477 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
478 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
479 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
480 d³ugich konstrukcji w jêzyku C.
481
482 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
483
484 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
485   deklaracji polecenia do³±czenia innego pliku.
486 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
487   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
488   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
489 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
490   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
491   fragmenty obrabianego strumienia tekstów.
492 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
493   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
494   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
495   odpowiada fragment pliku wynikowego.
496
497 %prep
498 %setup -q -a1 -n %{name}-%{GCC_VERSION}
499 mv ksi-%{KSI_VERSION} gcc/ksi
500
501 %patch0 -p1
502 %patch1 -p1
503 %patch2 -p1
504 %patch3 -p1
505 %patch4 -p1
506
507 %patch10
508 %patch11
509 %patch12
510 %patch13
511 %patch14
512 %patch15
513 %patch16
514 %patch17
515 %patch18
516 %patch19
517 %patch20
518 %patch21
519 %patch22
520
521 %patch24
522 %patch25
523 %patch26
524 %patch27
525 %patch28
526 %patch29
527 %patch30
528 %patch31
529 %patch32
530 %patch33
531 %patch34
532 %patch35
533 %patch36
534 %patch37
535 %patch38
536 %patch39
537 %patch40
538 %patch41
539 %patch42
540 %patch43
541 %patch44
542 %patch45
543 %patch46
544 %patch47
545
546 %patch6 -p1
547
548 perl -p -i -e 's/";/ (PLD Linux)";/' gcc/version.c
549
550 %build
551 # cd gcc && autoconf; cd ..
552 # autoconf is not needed!
553 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform}
554
555 CFLAGS="%{rpmcflags}" \
556 CXXFLAGS="%{rpmcflags}" \
557 TEXCONFIG=false ../configure \
558         --prefix=%{_prefix} \
559         --infodir=%{_infodir} \
560         --mandir=%{_mandir} \
561         --enable-shared \
562         --enable-threads=posix \
563         --enable-__cxa_atexit \
564         --enable-languages="c,c++,f77,gcov,objc,ksi%{!?_without_ada:,ada}%{!?_without_java:,java}" \
565         --enable-c99 \
566         --enable-long-long \
567         --enable-multilib \
568         --enable-nls \
569         --with-gnu-as \
570         --with-gnu-ld \
571         --with-system-zlib \
572         --with-slibdir=%{_slibdir} \
573         --without-x \
574         %{_target_platform}
575
576 PATH=$PATH:/sbin:%{_sbindir}
577
578 # this dirty hack is relict of setting, where objdir is subdir of srcdir
579 %if %{!?_without_ada:1}%{?_without_ada:0}
580 sed -e 's/srcdir=\$(fsrcdir)/srcdir=\$(fsrcdir) VPATH=\$(fsrcdir)/' \
581         gcc/ada/Makefile > makefile.tmp
582 mv -f makefile.tmp gcc/ada/Makefile
583 %endif
584
585 cd ..
586 %{__make} -C obj-%{_target_platform} bootstrap-lean \
587         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
588         mandir=%{_mandir} \
589         infodir=%{_infodir}
590
591 %if %{!?_without_ada:1}%{?_without_ada:0}
592 %{__make} -C obj-%{_target_platform}/gcc gnatlib gnattools gnatlib-shared \
593         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
594         mandir=%{_mandir} \
595         infodir=%{_infodir}
596
597 # make Gnat Reference Manual
598 %{__make} -C obj-%{_target_platform}/gcc/ada doc
599 %endif
600
601 %install
602 rm -rf $RPM_BUILD_ROOT
603 install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_infodir}}
604
605 cd obj-%{_target_platform}
606 PATH=$PATH:/sbin:%{_sbindir}
607
608 %{__make} install \
609         prefix=$RPM_BUILD_ROOT%{_prefix} \
610         mandir=$RPM_BUILD_ROOT%{_mandir} \
611         infodir=$RPM_BUILD_ROOT%{_infodir} \
612         slibdir=$RPM_BUILD_ROOT/lib
613
614 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
615 echo .so gcc.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
616
617 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
618 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
619
620 %if %{!?_without_ada:1}%{?_without_ada:0}
621 # move ada shared libraries to proper place...
622 mv $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*-*so.1 \
623         $RPM_BUILD_ROOT%{_libdir}
624 rm -f $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.so.1
625 (cd $RPM_BUILD_ROOT%{_libdir} && \
626  ln -s libgnat-*so.1 libgnat.so.1   && ln -s libgnat-*so.1 libgnat.so && \
627  ln -s libgnarl-*so.1 libgnarl.so.1 && ln -s libgnarl-*so.1 libgnarl.so)
628 %endif
629
630 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
631
632 cd ..
633
634 %if %{!?_without_ada:1}%{?_without_ada:0}
635 install obj-%{_target_platform}/gcc/ada/gnat_rm.info* $RPM_BUILD_ROOT%{_infodir}
636 install obj-%{_target_platform}/gcc/ada/gnat_ug_unx.info* $RPM_BUILD_ROOT%{_infodir}
637 %endif
638
639 %if %{!?_without_java:1}%{?_without_java:0}
640 install -d java-doc
641 cp -f libjava/doc/cni.sgml libjava/READ* java-doc
642 cp -f fastjar/README java-doc/README.fastjar
643 cp -f libffi/README java-doc/README.libffi
644 cp -f libffi/LICENSE java-doc/LICENSE.libffi
645
646 cp -f libobjc/README gcc/objc/README.libobjc
647 %endif
648
649 bzip2 -dc %{SOURCE2} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
650 mv -f $RPM_BUILD_ROOT%{_mandir}/ja/man1/{cccp,cpp}.1
651
652 %find_lang %{name}
653 %find_lang libstdc\+\+
654
655 %clean
656 rm -rf $RPM_BUILD_ROOT
657
658 %post
659 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
660
661 %postun
662 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
663
664 %post g77
665 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
666
667 %postun g77
668 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
669
670 %post java
671 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
672
673 %postun java
674 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
675
676 %post ksi
677 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
678
679 %postun ksi
680 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
681
682 %post -n cpp
683 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
684
685 %postun -n cpp
686 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
687
688 %post   -p /sbin/ldconfig -n libgcc
689 %postun -p /sbin/ldconfig -n libgcc
690 %post   -p /sbin/ldconfig -n libstdc++
691 %postun -p /sbin/ldconfig -n libstdc++
692 %post   -p /sbin/ldconfig -n libobjc
693 %postun -p /sbin/ldconfig -n libobjc
694 %post   -p /sbin/ldconfig -n libg2c
695 %postun -p /sbin/ldconfig -n libg2c
696 %post   -p /sbin/ldconfig -n libgcj
697 %postun -p /sbin/ldconfig -n libgcj
698 %post   -p /sbin/ldconfig -n libgnat
699 %postun -p /sbin/ldconfig -n libgnat
700
701 %files -f %{name}.lang
702 %defattr(644,root,root,755)
703 %doc READ* ChangeLog
704 %dir %{_libdir}/gcc-lib
705 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
706 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
707 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
708 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
709 %attr(755,root,root) %{_bindir}/gcc
710 %attr(755,root,root) %{_bindir}/gccbug
711 %attr(755,root,root) %{_bindir}/gcov
712 %attr(755,root,root) %{_bindir}/cc
713
714 %{_mandir}/man1/gcc.1*
715 %{_mandir}/man1/cc.1*
716 %{_mandir}/man1/gcov.1*
717 %lang(fr) %{_mandir}/fr/man1/gcc.1*
718 %lang(ja) %{_mandir}/ja/man1/gcc.1*
719 %{_infodir}/gcc*
720
721 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
722 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
723 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
724 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
725 %ifarch ppc
726 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ecrt*.o
727 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ncrt*.o
728 %{_libdir}/gcc-lib/%{_target_cpu}*/*/nof
729 %dir %{_libdir}/nof
730 %endif
731 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
732 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
733
734 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
735 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
736 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
737 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
738 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
739 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
740 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
741 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
742 %ifarch %{ix86}
743 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/mmintrin.h
744 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/xmmintrin.h
745 %endif
746 %ifarch ppc
747 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/altivec.h
748 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/ppc-asm.h
749 %endif
750
751 %files -n libgcc
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_slibdir}/lib*.so*
754
755 %files c++
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_bindir}/g++
758 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
759 %attr(755,root,root) %{_bindir}/c++
760 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
761 %attr(755,root,root) %{_bindir}/c++filt
762 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
763 %{_libdir}/libsupc++.la
764 %ifarch ppc
765 %{_libdir}/nof/libsupc++.la
766 %{_libdir}/nof/libsupc++.a
767 %endif
768 %{_libdir}/libsupc++.a
769 %{_mandir}/man1/g++.1*
770 %lang(es) %{_mandir}/es/man1/c++filt.1*
771 %lang(ja) %{_mandir}/ja/man1/g++.1*
772
773 %files -n libstdc++ -f libstdc++.lang
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
776 %ifarch ppc
777 %attr(755,root,root) %{_libdir}/nof/libstdc++.so.*.*.*
778 %endif
779
780 %files -n libstdc++-devel
781 %defattr(644,root,root,755)
782 %doc libstdc++-v3/docs/html
783 %dir %{_includedir}/c++
784 %{_includedir}/c++/%{GCC_VERSION}
785 %attr(755,root,root) %{_libdir}/libstdc++.so
786 %{_libdir}/libstdc++.la
787 %ifarch ppc
788 %attr(755,root,root) %{_libdir}/nof/libstdc++.so
789 %{_libdir}/nof/libstdc++.la
790 %endif
791
792 %files -n libstdc++-static
793 %defattr(644,root,root,755)
794 %{_libdir}/libstdc++.a
795 %ifarch ppc
796 %{_libdir}/nof/libstdc++.a
797 %endif
798
799 %files objc
800 %defattr(644,root,root,755)
801 %doc gcc/objc/READ*
802 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
803 %attr(755,root,root) %{_libdir}/libobjc.so
804 %{_libdir}/libobjc.la
805 %ifarch ppc
806 %attr(755,root,root) %{_libdir}/nof/libobjc.so
807 %{_libdir}/nof/libobjc.la
808 %endif
809 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
810
811 %files -n libobjc
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
814 %ifarch ppc
815 %attr(755,root,root) %{_libdir}/nof/libobjc.so.*.*.*
816 %endif
817
818 %files -n libobjc-static
819 %defattr(644,root,root,755)
820 %{_libdir}/libobjc.a
821 %ifarch ppc
822 %{_libdir}/nof/libobjc.a
823 %endif
824
825 %files g77
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{_bindir}/g77
828 %attr(755,root,root) %{_bindir}/f77
829 %{_infodir}/g77*
830 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
831 %{_libdir}/libfrtbegin.a
832 %{_libdir}/libg2c.la
833 %attr(755,root,root) %{_libdir}/libg2c.so
834 %ifarch ppc
835 %{_libdir}/nof/libfrtbegin.a
836 %{_libdir}/nof/libg2c.la
837 %attr(755,root,root) %{_libdir}/nof/libg2c.so
838 %endif
839 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
840 %{_mandir}/man1/g77.1*
841 %{_mandir}/man1/f77.1*
842 %lang(ja) %{_mandir}/ja/man1/g77.1*
843 %lang(ja) %{_mandir}/ja/man1/f77.1*
844
845 %files -n libg2c
846 %defattr(644,root,root,755)
847 %attr(755,root,root) %{_libdir}/libg2c.so.*.*.*
848 %ifarch ppc
849 %attr(755,root,root) %{_libdir}/nof/libg2c.so.*.*.*
850 %endif
851
852 %files -n libg2c-static
853 %defattr(644,root,root,755)
854 %{_libdir}/libg2c.a
855 %ifarch ppc
856 %{_libdir}/nof/libg2c.a
857 %endif
858
859 %if %{!?_without_java:1}%{?_without_java:0}
860 %files java
861 %defattr(644,root,root,755)
862 %doc java-doc/*
863 %attr(755,root,root) %{_bindir}/gcj*
864 %attr(755,root,root) %{_bindir}/gij
865 %attr(755,root,root) %{_bindir}/jcf-dump
866 %attr(755,root,root) %{_bindir}/jv-*
867 %attr(755,root,root) %{_bindir}/rmi*
868 %attr(755,root,root) %{_bindir}/jar
869 %attr(755,root,root) %{_bindir}/grepjar
870 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
871 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
872 %{_infodir}/gcj*
873 %{_mandir}/man1/jcf-*
874 %{_mandir}/man1/jv-*
875 %{_mandir}/man1/gij*
876 %{_mandir}/man1/gcj*
877 %{_mandir}/man1/rmi*
878
879 %files -n libgcj
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_bindir}/addr2name.awk
882 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
883 %ifarch ppc
884 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so.*
885 %endif
886
887 %files -n libgcj-devel
888 %defattr(644,root,root,755)
889 %{_includedir}/java
890 %{_includedir}/javax
891 %{_includedir}/org
892 %{_includedir}/gcj
893 %{_includedir}/j*.h
894 %{_includedir}/gnu/*
895 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/gcj
896 %{_libdir}/security/*
897 %dir %{_datadir}/java
898 %{_datadir}/java/libgcj*.jar
899 %{_libdir}/lib*cj.spec
900 %{_libdir}/lib*cj*.la
901 %attr(755,root,root) %{_libdir}/lib*cj*.so
902 %ifarch ppc
903 %{_libdir}/nof/lib*cj.spec
904 %{_libdir}/nof/lib*cj*.la
905 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so
906 %endif
907
908 %files -n libgcj-static
909 %defattr(644,root,root,755)
910 %{_libdir}/lib*cj*.a
911 %ifarch ppc
912 %{_libdir}/nof/lib*cj*.a
913 %endif
914 %endif
915
916 %if %{!?_without_ada:1}%{?_without_ada:0}
917 %files ada
918 %defattr(644,root,root,755)
919 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/gnat1
920 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adainclude
921 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib
922 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.ali
923 %ifnarch ppc
924 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgmem.a
925 %endif
926 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/Makefile.adalib
927 %attr(755,root,root) %{_bindir}/gnat*
928 %{_infodir}/gnat*
929 %attr(755,root,root) %{_libdir}/libgnat.so*
930 %attr(755,root,root) %{_libdir}/libgnarl.so*
931
932 %files -n libgnat
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/libgna*-*so.1
935
936 %files -n libgnat-static
937 %defattr(644,root,root,755)
938 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgna*.a
939 %endif
940
941 %files ksi
942 %defattr(644,root,root,755)
943 %doc gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
944 %{_infodir}/ksi*
945 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
946
947 %files -n cpp
948 %defattr(644,root,root,755)
949 %attr(755,root,root) %{_slibdir}/cpp
950 %attr(755,root,root) %{_bindir}/cpp
951 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
952 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
953 %{_mandir}/man1/cpp.1*
954 %lang(ja) %{_mandir}/ja/man1/cpp.1*
955 %{_infodir}/cpp*
This page took 0.089771 seconds and 4 git commands to generate.