]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
- _slibdir still need workaround (sorry)
[packages/gcc.git] / gcc.spec
1 %define         GCC_VERSION     3.0
2 %define         STDC_VERSION    3.0.0
3 %define         GCJ_VERSION     3.0.0
4 Summary:        GNU Compiler Collection
5 Summary(pl):    Kolekcja kompilatorów GNU
6 Name:           gcc
7 Version:        3.0.0
8 Release:        0.85
9 License:        GPL
10 Group:          Development/Languages
11 Group(de):      Entwicklung/Sprachen
12 Group(pl):      Programowanie/Jêzyki
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
14 BuildRequires:  bison
15 BuildRequires:  texinfo
16 BuildRequires:  zlib-devel
17 BuildRequires:  fileutils >= 4.0.41
18 BuildRequires:  autoconf
19 Requires:       binutils >= 2.9.1.0.25
20 Requires:       cpp = %{version}
21 URL:            http://gcc.gnu.org/
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _slibdir        /lib
25
26 %description
27 A compiler aimed at integrating all the optimizations and features
28 necessary for a high-performance and stable development environment.
29
30 %description -l pl
31 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
32 wyprodukowania szybkiego i stablinego kodu wynikowego.
33
34 %package c++
35 Summary:        C++ support for gcc
36 Summary(fr):    Support C++ pour le compilateur gcc
37 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
38 Summary(tr):    gcc için C++ desteði
39 Group:          Development/Languages
40 Group(de):      Entwicklung/Sprachen
41 Group(pl):      Programowanie/Jêzyki
42 Obsoletes:      egcc-c++
43 Obsoletes:      egcs-c++
44
45 %description c++
46 This package adds C++ support to the GNU C compiler. It includes
47 support for most of the current C++ specification, including templates
48 and exception handling. It does not include a standard C++ library,
49 which is available separately.
50
51 %description -l de c++
52 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
53 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
54 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
55 sie ist getrennt erhältlich.
56
57 %description -l fr c++
58 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
59 support pour la plupart des spécifications actuelles de C++, dont les
60 modéles et la gestion des exceptions. Il ne comprend pas une
61 bibliothéque C++ standard, qui est disponible séparément.
62
63 %description -l pl c++
64 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
65 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
66 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
67
68 %description -l tr c++
69 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
70 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
71 C++ kitaplýðý bu pakette yer almaz.
72
73 %package objc
74 Summary:        Objective C support for gcc
75 Summary(de):    Objektive C-Unterstützung für gcc
76 Summary(fr):    Gestion d'Objective C pour gcc
77 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
78 Summary(tr):    gcc için Objective C desteði
79 Group:          Development/Languages
80 Group(de):      Entwicklung/Sprachen
81 Group(pl):      Programowanie/Jêzyki
82 Obsoletes:      egcc-objc
83 Obsoletes:      egcs-objc
84
85 %description objc
86 This package adds Objective C support to the GNU C compiler. Objective
87 C is a object oriented derivative of the C language, mainly used on
88 systems running NeXTSTEP. This package does not include the standard
89 objective C object library.
90
91 %description -l de objc
92 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
93 Objective C ist ein objektorientiertes Derivat von C, das zur
94 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
95 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
96
97 %description -l fr objc
98 Ce package ajoute un support Objective C au compilateur C GNU.
99 L'Objective C est un langage orienté objetdérivé du langage C,
100 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
101 pas la bibliothéque Objective C standard.
102
103 %description -l pl objc
104 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
105 pakiecie nie ma jeszcze bibliotek C-obj.
106
107 %description -l tr objc
108 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
109 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
110 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
111 kitaplýðý bu pakette yer almaz.
112
113 %package g77
114 Summary:        Fortran 77 support for gcc
115 Summary(pl):    Wspomaganie Fortran 77 dla gcc
116 Group:          Development/Languages
117 Group(de):      Entwicklung/Sprachen
118 Group(pl):      Programowanie/Jêzyki
119 Obsoletes:      egcs-g77
120
121 %description g77
122 This apckage adds support for compiling Fortran 77 programs with the
123 GNU compiler.
124
125 %description -l pl g77
126 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
127 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
128
129 %package chill
130 Summary:        CHILL support for gcc
131 Summary(pl):    Wspomoganie CHILL dla gcc
132 Group:          Development/Languages
133 Group(de):      Entwicklung/Sprachen
134 Group(pl):      Programowanie/Jêzyki
135 Requires:       %{name} = %{version}
136
137 %description chill
138 This package adds support for compiling CHILL programs with the GNU
139 compiler.
140
141 Chill is the "CCITT High-Level Language", where CCITT is the old name
142 for what is now ITU, the International Telecommunications Union. It is
143 is language in the Modula2 family, and targets many of the same
144 applications as Ada (especially large embedded systems). Chill was
145 never used much in the United States, but is still being used in
146 Europe, Brazil, Korea, and other places.
147
148 %package java
149 Summary:        Java support for gcc
150 Summary(pl):    Wspomoganie Java dla gcc
151 Group:          Development/Languages
152 Group(de):      Entwicklung/Sprachen
153 Group(pl):      Programowanie/Jêzyki
154 Requires:       %{name} = %{version}
155 Requires:       libgcj >= 2.95.1
156
157 %description java
158 This package adds experimental support for compiling Java(tm) programs
159 and bytecode into native code. To use this you will also need the
160 libgcj package.
161
162 %description -l pl java
163 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
164 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
165 przeprowadziæ kompilacjê.
166
167 %package -n libgcj
168 Summary:        Java Class Libraries
169 Summary(pl):    Biblioteki Klas Javy
170 Group:          Libraries
171 Group(de):      Libraries
172 Group(es):      Bibliotecas
173 Group(fr):      Librairies
174 Group(pl):      Biblioteki
175 Version:        %{GCJ_VERSION}
176 Requires:       zlib
177
178 %description -n libgcj
179 Java Class Libraries
180
181 %description -n libgcj -l pl
182 Biblioteki Klass Javy
183
184 %package -n libgcj-devel
185 Summary:        Development files for Java Class Libraries
186 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
187 Group:          Development/Libraries
188 Group(de):      Entwicklung/Libraries
189 Group(fr):      Development/Librairies
190 Group(pl):      Programowanie/Biblioteki
191 Version:        %{GCJ_VERSION}
192 Requires:       libgcj = %{GCJ_VERSION}
193 Requires:       %{name}-java
194
195 %description -n libgcj-devel
196 Development files for Java Class Libraries
197
198 %description -n libgcj-devel -l pl
199 Pliki nag³ówkowe dla Bibliotek Klass Javy
200
201 %package -n libgcj-static
202 Summary:        Static Java Class Libraries
203 Summary(pl):    Statyczne Biblioteki Klass Javy
204 Group:          Development/Libraries
205 Group(de):      Entwicklung/Libraries
206 Group(fr):      Development/Librairies
207 Group(pl):      Programowanie/Biblioteki
208 Version:        %{GCJ_VERSION}
209 Requires:       libstdc++-devel = %{GCJ_VERSION}
210
211 %description -n libgcj-static
212 Static Java Class Libraries
213
214 %description -l pl -n libgcj-static
215 Statyczne Biblioteki Klass Javy
216
217 %package -n libstdc++
218 Summary:        GNU c++ library
219 Summary(pl):    Biblioteki GNU C++ 
220 Group:          Libraries
221 Group(de):      Libraries
222 Group(es):      Bibliotecas
223 Group(fr):      Librairies
224 Group(pl):      Biblioteki
225 Version:        %{STDC_VERSION}
226 Obsoletes:      libg++
227
228 %description -n libstdc++
229 This is the GNU implementation of the standard C++ libraries, along
230 with additional GNU tools. This package includes the shared libraries
231 necessary to run C++ applications.
232
233 %description -l de -n libstdc++
234 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
235 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
236 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
237
238 %description -l fr -n libstdc++
239 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
240 des outils GNU supplémentaires. Ce package comprend les librairies
241 partagées nécessaires à l'exécution d'application C++.
242
243 %description -l pl -n libstdc++  
244 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
245 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
246 uruchomienia aplikacji napisanych w C++.
247
248 %description -l tr -n libstdc++
249 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
250 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
251
252 %package -n libstdc++-devel
253 Summary:        Header files and libraries for C++ development
254 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
255 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
256 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
257 Group:          Development/Libraries
258 Group(de):      Entwicklung/Libraries
259 Group(fr):      Development/Librairies
260 Group(pl):      Programowanie/Biblioteki
261 Version:        %{STDC_VERSION}
262 Requires:       libstdc++ = %{STDC_VERSION}
263 Requires:       %{name}-c++
264 Obsoletes:      libg++-devel
265
266 %description -n libstdc++-devel
267 This is the GNU implementation of the standard C++ libraries. This
268 package includes the header files and libraries needed for C++
269 development.
270
271 %description -l pl -n libstdc++-devel
272 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
273 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
274 programowaniu w jêzyku C++.
275
276 %package -n libstdc++-static
277 Summary:        Static c++ standard library
278 Summary(pl):    Biblioteka statyczna c++
279 Group:          Development/Libraries
280 Group(de):      Entwicklung/Libraries
281 Group(fr):      Development/Librairies
282 Group(pl):      Programowanie/Biblioteki
283 Version:        %{STDC_VERSION}
284 Requires:       libstdc++-devel = %{STDC_VERSION}
285
286 %description -n libstdc++-static
287 Static c++ standard library.
288
289 %description -l pl -n libstdc++-static
290 Biblioteka statyczna C++.
291
292 %package -n libgcc
293 Summary:        Shared gcc library
294 Summary(pl):    Biblioteka gcc
295 Group:          Libraries
296 Group(de):      Libraries
297 Group(fr):      Librairies
298 Group(pl):      Biblioteki
299 Version:        %{version}
300
301 %description -n libgcc
302 Shared gcc library.
303
304 %description -l pl -n libgcc
305 Biblioteka dynamiczna gcc.
306
307 %package -n cpp
308 Summary:        The C Pre Processor
309 Summary(pl):    Preprocesor C
310 Group:          Development/Languages
311 Group(de):      Entwicklung/Sprachen
312 Group(pl):      Programowanie/Jêzyki
313 Version:        %{version}
314 Obsoletes:      egcs-cpp
315 Obsoletes:      gcc-cpp
316
317 %description -n cpp
318 The C preprocessor is a "macro processor" that is used automatically
319 by the C compiler to transform your program before actual compilation.
320 It is called a macro processor because it allows you to define
321 "macros", which are brief abbreviations for longer constructs.
322
323 The C preprocessor provides four separate facilities that you can use
324 as you see fit:
325
326 - Inclusion of header files. These are files of declarations that can
327   be substituted into your program.
328 - Macro expansion. You can define "macros", which are abbreviations
329   for arbitrary fragments of C code, and then the C preprocessor will
330   replace the macros with their definitions throughout the program.
331 - Conditional compilation. Using special preprocessing directives, you
332   can include or exclude parts of the program according to various
333   conditions.
334 - Line control. If you use a program to combine or rearrange source
335   files into an intermediate file which is then compiled, you can use
336   line control to inform the compiler of where each source line
337   originally came from.
338
339 %description -l pl -n cpp
340 Przeprocesor C jest "makro procesorem" który jest automatycznie
341 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
342 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
343 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
344 d³ugich konstrukcji w jêzyku C.
345
346 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
347
348 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
349   deklaracji polecenia do³±czenia innego pliku.
350 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
351   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
352   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
353 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
354   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
355   fragmenty obrabianego strumienia tekstów.
356 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
357   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
358   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
359   odpowiada fragment pliku wynikowego.
360
361 %prep
362 %setup -q -n %{name}-%{GCC_VERSION}
363
364 %build
365 cd gcc && autoconf; cd ..
366 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
367
368 CFLAGS="%{rpmcflags}" \
369 CXXFLAGS="%{rpmcflags}" \
370 TEXCONFIG=false ../configure \
371         --prefix=%{_prefix} \
372         --infodir=%{_infodir} \
373         --mandir=%{_mandir} \
374         --enable-shared \
375 %ifarch sparc
376         --with-cpu=sparc \
377 %endif
378 %ifarch sparc64
379         --with-cpu=ultrasparc \
380 %endif
381         --enable-threads=posix \
382         --enable-haifa \
383         --enable-languages="c,c++,f77,gcov,java,objc" \
384         --enable-long-long \
385         --enable-namespaces \
386         --enable-multilib \
387         --with-gnu-as \
388         --with-gnu-ld \
389         --with-system-zlib \
390         --with-slibdir=%{_slibdir} \
391         --without-x \
392         %{_target_platform}
393
394 PATH=$PATH:/sbin:%{_sbindir}
395
396 cd ..
397 %{__make} -C obj-%{_target_platform} bootstrap-lean \
398         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
399         mandir=%{_mandir} \
400         infodir=%{_infodir}
401
402 %install
403 rm -rf $RPM_BUILD_ROOT
404 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
405
406 cd obj-%{_target_platform}
407 PATH=$PATH:/sbin:%{_sbindir}
408
409 # workaround
410 sed -e 's,slibdir = /lib,slibdir = $(DESTDIR)%{_slibdir},g' gcc/Makefile > gcc/Makfefile.
411 mv -f gcc/Makfefile. gcc/Makefile
412
413 %{__make} install \
414         prefix=$RPM_BUILD_ROOT%{_prefix} \
415         mandir=$RPM_BUILD_ROOT%{_mandir} \
416         infodir=$RPM_BUILD_ROOT%{_infodir} \
417         slibdir=$RPM_BUILD_ROOT%{_slibdir} \
418         DESTDIR=$RPM_BUILD_ROOT
419
420 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
421
422 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
423
424 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
425
426 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
427
428 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
429
430 gzip -9nf ../READ* ../ChangeLog
431
432 %post
433 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
434
435 %postun
436 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
437
438 %post g77
439 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
440
441 %postun g77
442 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
443
444 %post chill
445 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
446
447 %postun chill
448 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
449
450 %post -n cpp
451 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
452
453 %postun -n cpp
454 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
455
456 %post   -p /sbin/ldconfig -n libgcc
457 %postun -p /sbin/ldconfig -n libgcc
458 %post   -p /sbin/ldconfig -n libstdc++
459 %postun -p /sbin/ldconfig -n libstdc++
460 %post   -p /sbin/ldconfig -n libgcj
461 %postun -p /sbin/ldconfig -n libgcj
462
463 %clean
464 rm -rf $RPM_BUILD_ROOT
465
466 %files
467 %defattr(644,root,root,755)
468 %doc READ* ChangeLog.gz
469 %dir %{_libdir}/gcc-lib
470 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
471 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
472 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
473 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
474 %attr(755,root,root) %{_bindir}/gcc
475 %attr(755,root,root) %{_bindir}/gccbug
476 %attr(755,root,root) %{_bindir}/gcov
477 %attr(755,root,root) %{_bindir}/cc
478
479 %{_mandir}/man1/gcc.1*
480 %{_mandir}/man1/gcov.1*
481 %{_infodir}/gcc*
482
483 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
484 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
485 #%ifnarch alpha
486 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
487 #%endif
488 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
489 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
490
491 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
492 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
493 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
494 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
495 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
496 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
497 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
498 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
499 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
500
501 %files c++
502 %defattr(644,root,root,755)
503 %{_mandir}/man1/g++.1.gz
504 %attr(755,root,root) %{_bindir}/g++
505 %attr(755,root,root) %{_bindir}/c++
506 %attr(755,root,root) %{_bindir}/c++filt
507 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
508 %attr(755,root,root) %{_libdir}/libsupc++.la
509 %{_libdir}/libsupc++.a
510
511 %files objc
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
514 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
515 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
516 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
517 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
518
519 %files g77
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_bindir}/g77
522 %attr(755,root,root) %{_bindir}/f77
523 %{_infodir}/g77*
524 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
525 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
526 %{_mandir}/man1/g77.1*
527 %{_mandir}/man1/f77.1*
528 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
529
530 %ifarch no_longer_supported_by_gcc_team
531 %files chill
532 %defattr(644,root,root,755)
533 %doc gcc/ch/chill.brochure.gz
534
535 %attr(755,root,root) %{_bindir}/chill
536 %{_infodir}/chill*
537 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
538 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
539 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
540 %endif
541
542 %files java
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_bindir}/gcj*
545 %attr(755,root,root) %{_bindir}/gij
546 %attr(755,root,root) %{_bindir}/jcf-dump
547 %attr(755,root,root) %{_bindir}/jv-*
548 %attr(755,root,root) %{_bindir}/jar
549 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
550 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
551 %{_infodir}/gcj*
552
553 %files -n libgcj
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
556
557 %files -n libgcj-devel
558 %defattr(644,root,root,755)
559 %{_includedir}/java
560 %{_includedir}/gcj
561 %{_includedir}/j*.h
562 %{_includedir}/gnu/*
563 %{_libdir}/lib*cj.spec
564 %{_datadir}/libgcj.jar
565 %attr(755,root,root) %{_libdir}/lib*cj*.la
566 %attr(755,root,root) %{_libdir}/lib*cj*.so
567
568 %files -n libgcj-static
569 %defattr(644,root,root,755)
570 %{_libdir}/lib*cj*.a
571
572 %files -n libstdc++
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
575
576 %files -n libstdc++-devel
577 %defattr(644,root,root,755)
578 %{_includedir}/g++*
579 %attr(755,root,root) %{_libdir}/libstdc++.so
580
581 %files -n libstdc++-static
582 %defattr(644,root,root,755)
583 %attr(644,root,root) %{_libdir}/libstdc++.a
584
585 %files -n libgcc
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_slibdir}/lib*.so*
588
589 %files -n cpp
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_slibdir}/cpp
592 %attr(755,root,root) %{_bindir}/cpp
593 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
594 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
595 %{_mandir}/man1/cpp.1*
596 %{_infodir}/cpp*
This page took 0.066358 seconds and 4 git commands to generate.