]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
- br gettext-devel (ANY package that uses %%find_lang must have it!)
[packages/gcc.git] / gcc.spec
1 #
2 # Conditional build:
3 # _without_ada  - build without ADA support
4 # _without_java - build without Java support
5 #
6 %define         DASHED_SNAP     %{nil}
7 %define         SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
8 %define         GCC_VERSION     3.2.1
9 %define         KSI_VERSION     pre55
10
11 Summary:        GNU Compiler Collection
12 Summary(pl):    Kolekcja kompilatorów GNU
13 Name:           gcc
14 Version:        %{GCC_VERSION}
15 Release:        0.pre.1
16 License:        GPL
17 Group:          Development/Languages
18 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-3.2.tar.bz2
19 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
20 Source2:        %{name}-non-english-man-pages.tar.bz2
21 Patch0:         %{name}-slibdir.patch
22 Patch1:         %{name}-paths.patch
23 Patch2:         %{name}-ada-no-addr2line.patch
24 Patch3:         %{name}-ada-no-prefix.o.patch
25 Patch4:         %{name}-nolocalefiles.patch
26 Patch5:         %{name}-march-i686-fix.patch
27 Patch6:         %{name}-info.patch
28 # -- stolen patches from RH --
29 Patch10:        gcc32-ada-link.patch
30 Patch11:        gcc32-attr-visibility.patch
31 Patch12:        gcc32-attr-visibility2.patch
32 Patch13:        gcc32-attr-visibility3.patch
33 Patch14:        gcc32-attr-visibility4.patch
34 Patch15:        gcc32-attr-visibility5.patch
35 Patch16:        gcc32-boehm-gc-libs.patch
36 Patch17:        gcc32-bogus-inline.patch
37 Patch18:        gcc32-c++-nrv-test.patch
38 Patch19:        gcc32-c++-pretty_function.patch
39 Patch20:        gcc32-c++-tsubst-asm.patch
40 Patch21:        gcc32-cfg-eh.patch
41 Patch22:        gcc32-debug-pr7241.patch
42 Patch23:        gcc32-doc-gcov.patch 
43 Patch24:        gcc32-duplicate-decl.patch
44 Patch25:        gcc32-dwarf2-pr6381.patch 
45 Patch26:        gcc32-dwarf2-pr6436-test.patch
46 Patch27:        gcc32-fde-merge-compat.patch 
47 Patch28:        gcc32-fold-const-associate.patch
48 Patch29:        gcc32-hard-reg-sharing.patch
49 Patch30:        gcc32-hard-reg-sharing2.patch 
50 Patch31:        gcc32-i386-default-momit-leaf-frame-pointer.patch
51 Patch32:        gcc32-i386-memtest-test.patch 
52 Patch33:        gcc32-i386-no-default-momit-leaf-frame-pointer.patch
53 Patch34:        gcc32-i386-pic-label-thunk.patch
54 Patch35:        gcc32-i386-profile-olfp.patch
55 Patch36:        gcc32-inline-label.patch 
56 Patch37:        gcc32-java-no-rpath.patch
57 Patch38:        gcc32-pr6842.patch 
58 Patch39:        gcc32-sparc-sll1.patch
59 Patch40:        gcc32-test-rh65771.patch 
60 Patch41:        gcc32-test-rotate.patch  
61 Patch42:        gcc32-tls-dwarf2.patch 
62 Patch43:        gcc32-tls.patch      
63 Patch44:        gcc32-tls2.patch 
64 Patch45:        gcc32-tls3.patch
65 Patch46:        gcc32-tls4.patch 
66 Patch47:        gcc32-tls5.patch    
67 Patch100:       gcc-pre-3.2.1.patch.gz
68 BuildRequires:  autoconf
69 BuildRequires:  bison
70 BuildRequires:  fileutils >= 4.0.41
71 BuildRequires:  gcc
72 %{!?_without_ada:BuildRequires: gcc-ada}
73 BuildRequires:  glibc-devel >= 2.2.5-20
74 BuildRequires:  perl-devel
75 BuildRequires:  texinfo >= 4.1
76 BuildRequires:  zlib-devel
77 BuildRequires:  gettext-devel
78 Requires:       binutils >= 2.12.90.0.4
79 Requires:       cpp = %{GCC_VERSION}
80 Requires:       libgcc = %{GCC_VERSION}
81 Conflicts:      glibc-devel < 2.2.5-20
82 URL:            http://gcc.gnu.org/
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _slibdir        /lib
86
87 %description
88 A compiler aimed at integrating all the optimizations and features
89 necessary for a high-performance and stable development environment.
90
91 %description -l pl
92 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
93 wyprodukowania szybkiego i stablinego kodu wynikowego.
94
95 %package -n libgcc
96 Summary:        Shared gcc library
97 Summary(pl):    Biblioteka gcc
98 Group:          Libraries
99 Version:        %{GCC_VERSION}
100
101 %description -n libgcc
102 Shared gcc library.
103
104 %description -n libgcc -l pl
105 Biblioteka dynamiczna gcc.
106
107 %package c++
108 Summary:        C++ support for gcc
109 Summary(pl):    Obs³uga C++ dla gcc
110 Group:          Development/Languages
111 Obsoletes:      egcc-c++
112 Obsoletes:      egcs-c++
113 Requires:       gcc = %{GCC_VERSION}
114
115 %description c++
116 This package adds C++ support to the GNU C compiler. It includes
117 support for most of the current C++ specification, including templates
118 and exception handling. It does not include a standard C++ library,
119 which is available separately.
120
121 %description c++ -l de
122 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
123 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
124 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
125 sie ist getrennt erhältlich.
126
127 %description c++ -l fr
128 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
129 support pour la plupart des spécifications actuelles de C++, dont les
130 modéles et la gestion des exceptions. Il ne comprend pas une
131 bibliothéque C++ standard, qui est disponible séparément.
132
133 %description c++ -l pl
134 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
135 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
136 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
137
138 %description c++ -l tr
139 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
140 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
141 C++ kitaplýðý bu pakette yer almaz.
142
143 %package objc
144 Summary:        Objective C support for gcc
145 Summary(de):    Objektive C-Unterstützung für gcc
146 Summary(fr):    Gestion d'Objective C pour gcc
147 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
148 Summary(tr):    gcc için Objective C desteði
149 Group:          Development/Languages
150 Obsoletes:      egcc-objc
151 Obsoletes:      egcs-objc
152 Requires:       libobjc = %{GCC_VERSION}
153 Requires:       gcc = %{GCC_VERSION}
154
155 %description objc
156 This package adds Objective C support to the GNU C compiler. Objective
157 C is a object oriented derivative of the C language, mainly used on
158 systems running NeXTSTEP. This package does not include the standard
159 objective C object library.
160
161 %description objc -l de
162 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
163 Objective C ist ein objektorientiertes Derivat von C, das zur
164 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
165 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
166
167 %description objc -l fr
168 Ce package ajoute un support Objective C au compilateur C GNU.
169 L'Objective C est un langage orienté objetdérivé du langage C,
170 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
171 pas la bibliothéque Objective C standard.
172
173 %description objc -l pl
174 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
175 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
176 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
177 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
178
179 %description objc -l tr
180 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
181 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
182 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
183 kitaplýðý bu pakette yer almaz.
184
185 %package -n libobjc
186 Summary:        Objective C Libraries
187 Summary(pl):    Biblioteki Obiektowego C
188 Group:          Libraries
189 Version:        %{GCC_VERSION}
190 Epoch:          3
191
192 %description -n libobjc
193 Objective C Libraries.
194
195 %description -n libobjc -l pl
196 Biblioteki Obiektowego C.
197
198 %package -n libobjc-static
199 Summary:        Static Objective C Libraries
200 Summary(pl):    Statyczne Biblioteki Obiektowego C
201 Group:          Development/Libraries
202 Version:        %{GCC_VERSION}
203 Epoch:          4
204 Requires:       libobjc = %{GCC_VERSION}
205
206 %description -n libobjc-static
207 Static Objective C Libraries.
208
209 %description -n libobjc-static -l pl
210 Statyczne biblioteki Obiektowego C.
211
212 %package g77
213 Summary:        Fortran 77 support for gcc
214 Summary(pl):    Obs³uga Fortranu 77 dla gcc
215 Group:          Development/Languages
216 Version:        %{GCC_VERSION}
217 Obsoletes:      egcs-g77
218 Requires:       libg2c = %{GCC_VERSION}
219
220 %description g77
221 This apckage adds support for compiling Fortran 77 programs with the
222 GNU compiler.
223
224 %description g77 -l pl
225 Ten pakiet dodaje obs³ugê Fortranu 77 do kompilatora gcc. Jest
226 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
227
228 %package -n libg2c
229 Summary:        Fortran 77 Libraries
230 Summary(pl):    Biblioteki Fortranu 77
231 Group:          Libraries
232 Version:        %{GCC_VERSION}
233
234 %description -n libg2c
235 Fortran 77 Libraries.
236
237 %description -n libg2c -l pl
238 Biblioteki Fortranu 77.
239
240 %package -n libg2c-static
241 Summary:        Static Fortran 77 Libraries
242 Summary(pl):    Statyczne Biblioteki Fortranu 77
243 Group:          Development/Libraries
244 Version:        %{GCC_VERSION}
245 Epoch:          2
246 Requires:       libg2c = %{GCC_VERSION}
247
248 %description -n libg2c-static
249 Static Fortran 77 Libraries.
250
251 %description -n libg2c-static -l pl
252 Statyczne biblioteki Fortranu 77.
253
254 %package java
255 Summary:        Java support for gcc
256 Summary(pl):    Obs³uga Javy dla gcc
257 Group:          Development/Languages
258 Version:        %{GCC_VERSION}
259 Requires:       %{name} = %{version}
260 Requires:       libgcj >= 3.0.0
261 Provides:       gcj = %{epoch}:%{GCC_VERSION}-%{release}
262 Provides:       jar = %{epoch}:%{GCC_VERSION}-%{release}
263
264 %description java
265 This package adds experimental support for compiling Java(tm) programs
266 and bytecode into native code. To use this you will also need the
267 libgcj package.
268
269 %description -l pl java
270 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
271 do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
272 by³o przeprowadziæ kompilacjê.
273
274 %package -n libgcj
275 Summary:        Java Class Libraries
276 Summary(pl):    Biblioteki Klas Javy
277 Group:          Libraries
278 Version:        %{GCC_VERSION}
279 Epoch:          2
280 Requires:       zlib
281
282 %description -n libgcj
283 Java Class Libraries.
284
285 %description -n libgcj -l pl
286 Biblioteki Klas Javy.
287
288 %package -n libgcj-devel
289 Summary:        Development files for Java Class Libraries
290 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
291 Group:          Development/Libraries
292 Version:        %{GCC_VERSION}
293 Epoch:          2
294 Requires:       libgcj = %{GCC_VERSION}
295 Requires:       %{name}-java
296
297 %description -n libgcj-devel
298 Development files for Java Class Libraries.
299
300 %description -n libgcj-devel -l pl
301 Pliki nag³ówkowe dla Bibliotek Klas Javy.
302
303 %package -n libgcj-static
304 Summary:        Static Java Class Libraries
305 Summary(pl):    Statyczne Biblioteki Klas Javy
306 Group:          Development/Libraries
307 Version:        %{GCC_VERSION}
308 Epoch:          2
309 Requires:       libstdc++-devel = %{GCC_VERSION}
310 Requires:       libgcj-devel = %{GCC_VERSION}
311
312 %description -n libgcj-static
313 Static Java Class Libraries.
314
315 %description -n libgcj-static -l pl
316 Statyczne Biblioteki Klas Javy.
317
318 %package -n libstdc++
319 Summary:        GNU c++ library
320 Summary(pl):    Biblioteki GNU C++ 
321 Group:          Libraries
322 Version:        %{GCC_VERSION}
323 Epoch:          1
324 Obsoletes:      libg++
325
326 %description -n libstdc++
327 This is the GNU implementation of the standard C++ libraries, along
328 with additional GNU tools. This package includes the shared libraries
329 necessary to run C++ applications.
330
331 %description -n libstdc++ -l de
332 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
333 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
334 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
335
336 %description -n libstdc++ -l fr
337 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
338 des outils GNU supplémentaires. Ce package comprend les librairies
339 partagées nécessaires à l'exécution d'application C++.
340
341 %description -n libstdc++ -l pl
342 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
343 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
344 uruchomienia aplikacji napisanych w C++.
345
346 %description -n libstdc++ -l tr
347 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
348 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
349
350 %package -n libstdc++-devel
351 Summary:        Header files and documentatino for C++ development
352 Summary(de):    Header-Dateien zur Entwicklung mit C++
353 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
354 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
355 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
356 Group:          Development/Libraries
357 Version:        %{GCC_VERSION}
358 Epoch:          1
359 Requires:       libstdc++ = %{GCC_VERSION}
360 Requires:       %{name}-c++
361 Obsoletes:      libg++-devel
362
363 %description -n libstdc++-devel
364 This is the GNU implementation of the standard C++ libraries. This
365 package includes the header files needed for C++ development and
366 library documentation.
367
368 %description -n libstdc++-devel -l pl
369 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
370 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
371 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
372
373 %package -n libstdc++-static
374 Summary:        Static C++ standard library
375 Summary(pl):    Statyczna biblioteka standardowa C++
376 Group:          Development/Libraries
377 Version:        %{GCC_VERSION}
378 Epoch:          1
379 Requires:       libstdc++-devel = %{GCC_VERSION}
380
381 %description -n libstdc++-static
382 Static C++ standard library.
383
384 %description -n libstdc++-static -l pl
385 Statycza biblioteka standardowa C++.
386
387 %package ada
388 Summary:        Ada support for gcc
389 Summary(pl):    Obs³uga Ady do gcc
390 Group:          Development/Languages
391 Version:        %{GCC_VERSION}
392 Requires:       libgnat = %{GCC_VERSION}
393 Requires:       gcc = %{GCC_VERSION}
394 Obsoletes:      gcc-gnat
395 Obsoletes:      gnat-devel
396
397 %description ada
398 This package adds experimental support for compiling Ada programs.
399
400 %description -l pl ada
401 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
402 w Adzie.
403
404 %package -n libgnat
405 Summary:        Ada standard libraries
406 Summary(pl):    Biblioteki standardowe dla Ady
407 Group:          Libraries
408 Version:        %{GCC_VERSION}
409 Obsoletes:      gnat
410
411 %description -n libgnat
412 This package contains shared libraries needed to run programs written
413 in Ada.
414
415 %description -n libgnat -l pl
416 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów napisanych
417 w Adzie.
418
419 %package -n libgnat-static
420 Summary:        Static Ada standard libraries
421 Summary(pl):    Statyczne biblioteki standardowe dla Ady
422 Group:          Libraries
423 Version:        %{GCC_VERSION}
424 Obsoletes:      gnat-static
425
426 %description -n libgnat-static
427 This package contains static libraries for programs written in Ada.
428
429 %description -n libgnat-static -l pl
430 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
431 Adzie.
432
433 %package ksi
434 Summary:        Ksi support for gcc
435 Summary(pl):    Obs³uga Ksi dla gcc
436 Version:        %{GCC_VERSION}.%{KSI_VERSION}
437 Group:          Development/Languages
438 Requires:       gcc = %{GCC_VERSION}
439
440 %description ksi
441 This package adds experimental support for compiling Ksi programs
442 into native code. You proabably don't need it, unless your are going
443 to develop a compiler using Ksi as intermediate representation or
444 you are using such compiler (like Gont).
445
446 %description ksi -l pl
447 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
448 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
449 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jako reprezentacji
450 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
451
452 %package -n cpp
453 Summary:        The C Pre Processor
454 Summary(pl):    Preprocesor C
455 Group:          Development/Languages
456 Version:        %{GCC_VERSION}
457 Obsoletes:      egcs-cpp
458 Obsoletes:      gcc-cpp
459
460 %description -n cpp
461 The C preprocessor is a "macro processor" that is used automatically
462 by the C compiler to transform your program before actual compilation.
463 It is called a macro processor because it allows you to define
464 "macros", which are brief abbreviations for longer constructs.
465
466 The C preprocessor provides four separate facilities that you can use
467 as you see fit:
468
469 - Inclusion of header files. These are files of declarations that can
470   be substituted into your program.
471 - Macro expansion. You can define "macros", which are abbreviations
472   for arbitrary fragments of C code, and then the C preprocessor will
473   replace the macros with their definitions throughout the program.
474 - Conditional compilation. Using special preprocessing directives, you
475   can include or exclude parts of the program according to various
476   conditions.
477 - Line control. If you use a program to combine or rearrange source
478   files into an intermediate file which is then compiled, you can use
479   line control to inform the compiler of where each source line
480   originally came from.
481
482 %description -n cpp -l pl
483 Przeprocesor C jest "makro procesorem" który jest automatycznie
484 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
485 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
486 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
487 d³ugich konstrukcji w jêzyku C.
488
489 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
490
491 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
492   deklaracji polecenia do³±czenia innego pliku.
493 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
494   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
495   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
496 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
497   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
498   fragmenty obrabianego strumienia tekstów.
499 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
500   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
501   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
502   odpowiada fragment pliku wynikowego.
503
504 %prep
505 %setup -q -a1 -n %{name}-3.2
506 mv ksi-%{KSI_VERSION} gcc/ksi
507 %patch100 -p1
508
509 %patch0 -p1
510 %patch1 -p1
511 %patch2 -p1
512 %patch3 -p1
513 %patch4 -p1
514 %ifarch %{ix86}
515 %patch5 -p0
516 %endif
517
518 %patch10 
519 %patch11 
520 %patch12 
521 %patch13 
522 %patch14 
523 %patch15 
524 %patch16 
525 %patch17 
526 %patch18 
527 %patch19 
528 %patch20 
529 %patch21 
530 %patch22 
531 %patch23 
532 %patch24 
533 %patch25 
534 %patch26 
535 %patch27 
536 %patch28 
537 %patch29 
538 %patch30 
539 %patch31 
540 %patch32 
541 %patch33 
542 %patch34 
543 %patch35 
544 %patch36 
545 %patch37 
546 %patch38 
547 %patch39 
548 %patch40 
549 %patch41 
550 %patch42 
551 %patch43
552 %patch44 
553 %patch45 
554 %patch46
555 %patch47
556
557 %patch6 -p1
558
559 %build
560 # cd gcc && autoconf; cd ..
561 # autoconf is not needed!
562 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform}
563
564 CFLAGS="%{rpmcflags}" \
565 CXXFLAGS="%{rpmcflags}" \
566 TEXCONFIG=false ../configure \
567         --prefix=%{_prefix} \
568         --infodir=%{_infodir} \
569         --mandir=%{_mandir} \
570         --enable-shared \
571         --enable-threads=posix \
572         --enable-__cxa_atexit \
573         --enable-languages="c,c++,f77,gcov,objc,ksi%{!?_without_ada:,ada}%{!?_without_java:,java}" \
574         --enable-c99 \
575         --enable-long-long \
576         --enable-multilib \
577         --enable-nls \
578         --with-gnu-as \
579         --with-gnu-ld \
580         --with-system-zlib \
581         --with-slibdir=%{_slibdir} \
582         --without-x \
583         %{_target_platform}
584
585 PATH=$PATH:/sbin:%{_sbindir}
586
587 # this dirty hack is relict of setting, where objdir is subdir of srcdir
588 %if %{!?_without_ada:1}%{?_without_ada:0}
589 sed -e 's/srcdir=\$(fsrcdir)/srcdir=\$(fsrcdir) VPATH=\$(fsrcdir)/' \
590         gcc/ada/Makefile > makefile.tmp
591 mv -f makefile.tmp gcc/ada/Makefile
592 %endif
593
594 cd ..
595 %{__make} -C obj-%{_target_platform} bootstrap-lean \
596         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
597         mandir=%{_mandir} \
598         infodir=%{_infodir}
599
600 %if %{!?_without_ada:1}%{?_without_ada:0}
601 %{__make} -C obj-%{_target_platform}/gcc gnatlib gnattools gnatlib-shared \
602         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
603         mandir=%{_mandir} \
604         infodir=%{_infodir}
605
606 # make Gnat Reference Manual
607 %{__make} -C obj-%{_target_platform}/gcc/ada doc
608 %endif
609
610 %install
611 rm -rf $RPM_BUILD_ROOT
612 install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_infodir}}
613
614 cd obj-%{_target_platform}
615 PATH=$PATH:/sbin:%{_sbindir}
616
617 %{__make} install \
618         prefix=$RPM_BUILD_ROOT%{_prefix} \
619         mandir=$RPM_BUILD_ROOT%{_mandir} \
620         infodir=$RPM_BUILD_ROOT%{_infodir} \
621         slibdir=$RPM_BUILD_ROOT/lib
622
623 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
624 echo .so gcc.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
625
626 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
627 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
628
629 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
630  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/ ; \
631  ln -sf ../../../${LIBSTDC} libstdc++.so ; \
632  ln -sf ../../../libstdc++.la libstdc++.la)
633
634 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
635         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
636
637 LIBSTDC=$(ls -d $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/* | sed -e "s#$RPM_BUILD_ROOT##g")
638 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.la $RPM_BUILD_ROOT%{_libdir}/libstdc++.la.old
639 sed -e "s#^libdir='/usr/lib'#libdir='$LIBSTDC'#g" $RPM_BUILD_ROOT%{_libdir}/libstdc++.la.old \
640  > $RPM_BUILD_ROOT%{_libdir}/libstdc++.la
641
642 %if %{!?_without_ada:1}%{?_without_ada:0}
643 # move ada shared libraries to proper place...
644 mv $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*-*so.1 \
645         $RPM_BUILD_ROOT%{_libdir}
646 rm -f $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.so.1
647 (cd $RPM_BUILD_ROOT%{_libdir} && \
648  ln -s libgnat-*so.1 libgnat.so.1 && \
649  ln -s libgnarl-*so.1 libgnarl.so.1)
650 %endif
651
652 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
653
654 cd ..
655
656 %if %{!?_without_ada:1}%{?_without_ada:0}
657 install obj-%{_target_platform}/gcc/ada/gnat_rm.info* $RPM_BUILD_ROOT%{_infodir}
658 install obj-%{_target_platform}/gcc/ada/gnat_ug_unx.info* $RPM_BUILD_ROOT%{_infodir}
659 %endif
660
661 %if %{!?_without_java:1}%{?_without_java:0}
662 install -d java-doc
663 cp -f libjava/doc/cni.sgml libjava/READ* java-doc
664 cp -f fastjar/README java-doc/README.fastjar
665 cp -f libffi/README java-doc/README.libffi
666 cp -f libffi/LICENSE java-doc/LICENSE.libffi
667
668 cp -f libobjc/README gcc/objc/README.libobjc
669 %endif
670
671 bzip2 -dc %{SOURCE2} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
672 mv -f $RPM_BUILD_ROOT%{_mandir}/ja/man1/{cccp,cpp}.1
673
674 %find_lang %{name}
675 %find_lang libstdc\+\+
676
677 %clean
678 rm -rf $RPM_BUILD_ROOT
679
680 %post
681 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
682
683 %postun
684 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
685
686 %post g77
687 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
688
689 %postun g77
690 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
691
692 %post java
693 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
694
695 %postun java
696 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
697
698 %post ksi
699 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
700
701 %postun ksi
702 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
703
704 %post -n cpp
705 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
706
707 %postun -n cpp
708 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
709
710 %post   -p /sbin/ldconfig -n libgcc
711 %postun -p /sbin/ldconfig -n libgcc
712 %post   -p /sbin/ldconfig -n libstdc++
713 %postun -p /sbin/ldconfig -n libstdc++
714 %post   -p /sbin/ldconfig -n libobjc
715 %postun -p /sbin/ldconfig -n libobjc
716 %post   -p /sbin/ldconfig -n libg2c
717 %postun -p /sbin/ldconfig -n libg2c
718 %post   -p /sbin/ldconfig -n libgcj
719 %postun -p /sbin/ldconfig -n libgcj
720 %post   -p /sbin/ldconfig -n libgnat
721 %postun -p /sbin/ldconfig -n libgnat
722
723 %files -f %{name}.lang
724 %defattr(644,root,root,755)
725 %doc READ* ChangeLog
726 %dir %{_libdir}/gcc-lib
727 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
728 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
729 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
730 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
731 %attr(755,root,root) %{_bindir}/gcc
732 %attr(755,root,root) %{_bindir}/gccbug
733 %attr(755,root,root) %{_bindir}/gcov
734 %attr(755,root,root) %{_bindir}/cc
735
736 %{_mandir}/man1/gcc.1*
737 %{_mandir}/man1/cc.1*
738 %{_mandir}/man1/gcov.1*
739 %lang(fr) %{_mandir}/fr/man1/gcc.1*
740 %lang(ja) %{_mandir}/ja/man1/gcc.1*
741 %{_infodir}/gcc*
742
743 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
744 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
745 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
746 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
747 %ifarch ppc
748 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ecrt*.o
749 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ncrt*.o
750 %{_libdir}/gcc-lib/%{_target_cpu}*/*/nof
751 %dir %{_libdir}/nof
752 %endif
753 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
754 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
755
756 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
757 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
758 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
759 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
760 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
761 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
762 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
763 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
764 %ifarch %{ix86}
765 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/mmintrin.h
766 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/xmmintrin.h
767 %endif
768 %ifarch ppc
769 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/altivec.h
770 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/ppc-asm.h
771 %endif
772
773 %files -n libgcc
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_slibdir}/lib*.so*
776
777 %files c++
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_bindir}/g++
780 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
781 %attr(755,root,root) %{_bindir}/c++
782 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
783 %attr(755,root,root) %{_bindir}/c++filt
784 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
785 %attr(755,root,root) %{_libdir}/libsupc++.la
786 %ifarch ppc
787 %attr(755,root,root) %{_libdir}/nof/libsupc++.la
788 %{_libdir}/nof/libsupc++.a
789 %endif
790 %{_libdir}/libsupc++.a
791 %{_mandir}/man1/g++.1*
792 %lang(es) %{_mandir}/es/man1/c++filt.1*
793 %lang(ja) %{_mandir}/ja/man1/g++.1*
794
795 %files -n libstdc++ -f libstdc++.lang
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
798 %ifarch ppc
799 %attr(755,root,root) %{_libdir}/nof/libstdc++.so.*.*.*
800 %endif
801
802 %files -n libstdc++-devel
803 %defattr(644,root,root,755)
804 %doc libstdc++-v3/docs/html
805 %dir %{_includedir}/c++
806 %{_includedir}/c++/%{GCC_VERSION}
807 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
808 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.la
809 %attr(755,root,root) %{_libdir}/libstdc++.la
810 %ifarch ppc
811 %attr(755,root,root) %{_libdir}/nof/libstdc++.so
812 %attr(755,root,root) %{_libdir}/nof/libstdc++.la
813 %endif
814
815 %files -n libstdc++-static
816 %defattr(644,root,root,755)
817 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
818 %ifarch ppc
819 %{_libdir}/nof/libstdc++.a
820 %endif
821
822 %files objc
823 %defattr(644,root,root,755)
824 %doc gcc/objc/READ*
825 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
826 %attr(755,root,root) %{_libdir}/libobjc.so
827 %attr(755,root,root) %{_libdir}/libobjc.la
828 %ifarch ppc
829 %attr(755,root,root) %{_libdir}/nof/libobjc.so
830 %attr(755,root,root) %{_libdir}/nof/libobjc.la
831 %endif
832 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
833
834 %files -n libobjc
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
837 %ifarch ppc
838 %attr(755,root,root) %{_libdir}/nof/libobjc.so.*.*.*
839 %endif
840
841 %files -n libobjc-static
842 %defattr(644,root,root,755)
843 %{_libdir}/libobjc.a
844 %ifarch ppc
845 %{_libdir}/nof/libobjc.a
846 %endif
847
848 %files g77
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_bindir}/g77
851 %attr(755,root,root) %{_bindir}/f77
852 %{_infodir}/g77*
853 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
854 %{_libdir}/libfrtbegin.a
855 %attr(755,root,root) %{_libdir}/libg2c.la
856 %attr(755,root,root) %{_libdir}/libg2c.so
857 %ifarch ppc
858 %{_libdir}/nof/libfrtbegin.a
859 %attr(755,root,root) %{_libdir}/nof/libg2c.la
860 %attr(755,root,root) %{_libdir}/nof/libg2c.so
861 %endif
862 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
863 %{_mandir}/man1/g77.1*
864 %{_mandir}/man1/f77.1*
865 %lang(ja) %{_mandir}/ja/man1/g77.1*
866 %lang(ja) %{_mandir}/ja/man1/f77.1*
867
868 %files -n libg2c
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_libdir}/libg2c.so.*.*.*
871 %ifarch ppc
872 %attr(755,root,root) %{_libdir}/nof/libg2c.so.*.*.*
873 %endif
874
875 %files -n libg2c-static
876 %{_libdir}/libg2c.a
877 %ifarch ppc
878 %{_libdir}/nof/libg2c.a
879 %endif
880
881 %if %{!?_without_java:1}%{?_without_java:0}
882 %files java
883 %defattr(644,root,root,755)
884 %doc java-doc/*
885 %attr(755,root,root) %{_bindir}/gcj*
886 %attr(755,root,root) %{_bindir}/gij
887 %attr(755,root,root) %{_bindir}/jcf-dump
888 %attr(755,root,root) %{_bindir}/jv-*
889 %attr(755,root,root) %{_bindir}/rmi*
890 %attr(755,root,root) %{_bindir}/jar
891 %attr(755,root,root) %{_bindir}/grepjar
892 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
893 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
894 %{_infodir}/gcj*
895 %{_mandir}/man1/jcf-*
896 %{_mandir}/man1/jv-*
897 %{_mandir}/man1/gij*
898 %{_mandir}/man1/gcj*
899 %{_mandir}/man1/rmi*
900
901 %files -n libgcj
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_bindir}/addr2name.awk
904 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
905 %ifarch ppc
906 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so.*
907 %endif
908
909 %files -n libgcj-devel
910 %defattr(644,root,root,755)
911 %{_includedir}/java
912 %{_includedir}/javax
913 %{_includedir}/org
914 %{_includedir}/gcj
915 %{_includedir}/j*.h
916 %{_includedir}/gnu/*
917 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/gcj
918 %{_libdir}/security/*
919 %dir %{_datadir}/java
920 %{_datadir}/java/libgcj*.jar
921 %{_libdir}/lib*cj.spec
922 %attr(755,root,root) %{_libdir}/lib*cj*.la
923 %attr(755,root,root) %{_libdir}/lib*cj*.so
924 %ifarch ppc
925 %{_libdir}/nof/lib*cj.spec
926 %attr(755,root,root) %{_libdir}/nof/lib*cj*.la
927 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so
928 %endif
929
930 %files -n libgcj-static
931 %defattr(644,root,root,755)
932 %{_libdir}/lib*cj*.a
933 %ifarch ppc
934 %{_libdir}/nof/lib*cj*.a
935 %endif
936 %endif
937
938 %if %{!?_without_ada:1}%{?_without_ada:0}
939 %files ada
940 %defattr(644,root,root,755)
941 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/gnat1
942 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adainclude
943 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib
944 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.ali
945 %ifnarch ppc
946 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgmem.a
947 %endif
948 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/Makefile.adalib
949 %attr(755,root,root) %{_bindir}/gnat*
950 %{_infodir}/gnat*
951 %attr(755,root,root) %{_libdir}/libgnat.so.1
952 %attr(755,root,root) %{_libdir}/libgnarl.so.1
953
954 %files -n libgnat
955 %defattr(644,root,root,755)
956 %attr(755,root,root) %{_libdir}/libgna*-*so.1
957
958 %files -n libgnat-static
959 %defattr(644,root,root,755)
960 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgna*.a
961 %endif
962
963 %files ksi
964 %defattr(644,root,root,755)
965 %doc gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
966 %{_infodir}/ksi*
967 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
968
969 %files -n cpp
970 %defattr(644,root,root,755)
971 %attr(755,root,root) %{_slibdir}/cpp
972 %attr(755,root,root) %{_bindir}/cpp
973 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
974 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
975 %{_mandir}/man1/cpp.1*
976 %lang(ja) %{_mandir}/ja/man1/cpp.1*
977 %{_infodir}/cpp*
This page took 0.174389 seconds and 4 git commands to generate.