]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
- update to snapshot 20010614
[packages/gcc.git] / gcc.spec
1 %define         STDC_VERSION    3.0.0
2 %define         GCJ_VERSION     3.0.0
3 %define         rver            3.0
4 %define         snap            20010614
5 Summary:        GNU Compiler Collection
6 Summary(pl):    Kolekcja kompilatorów GNU
7 Name:           gcc
8 Version:        %{rver}
9 Release:        0.%{snap}
10 License:        GPL
11 Group:          Development/Languages
12 Group(de):      Entwicklung/Sprachen
13 Group(pl):      Programowanie/Jêzyki
14 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/%{snap}/%{name}-%{version}-%{snap}.tar.bz2
15 Patch0:         %{name}-disableshared.patch
16 BuildRequires:  bison
17 BuildRequires:  texinfo
18 BuildRequires:  zlib-devel
19 BuildRequires:  fileutils >= 4.0.41
20 BuildRequires:  autoconf
21 Requires:       binutils >= 2.9.1.0.25
22 Requires:       cpp = %{version}
23 URL:            http://gcc.gnu.org/
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A compiler aimed at integrating all the optimizations and features
28 necessary for a high-performance and stable development environment.
29
30 %description -l pl
31 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
32 wyprodukowania szybkiego i stablinego kodu wynikowego.
33
34 %package c++
35 Summary:        C++ support for gcc
36 Summary(fr):    Support C++ pour le compilateur gcc
37 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
38 Summary(tr):    gcc için C++ desteði
39 Group:          Development/Languages
40 Group(de):      Entwicklung/Sprachen
41 Group(pl):      Programowanie/Jêzyki
42 Obsoletes:      egcc-c++
43 Obsoletes:      egcs-c++
44
45 %description c++
46 This package adds C++ support to the GNU C compiler. It includes
47 support for most of the current C++ specification, including templates
48 and exception handling. It does not include a standard C++ library,
49 which is available separately.
50
51 %description -l de c++
52 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
53 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
54 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
55 sie ist getrennt erhältlich.
56
57 %description -l fr c++
58 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
59 support pour la plupart des spécifications actuelles de C++, dont les
60 modéles et la gestion des exceptions. Il ne comprend pas une
61 bibliothéque C++ standard, qui est disponible séparément.
62
63 %description -l pl c++
64 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
65 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
66 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
67
68 %description -l tr c++
69 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
70 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
71 C++ kitaplýðý bu pakette yer almaz.
72
73 %package objc
74 Summary:        Objective C support for gcc
75 Summary(de):    Objektive C-Unterstützung für gcc
76 Summary(fr):    Gestion d'Objective C pour gcc
77 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
78 Summary(tr):    gcc için Objective C desteði
79 Group:          Development/Languages
80 Group(de):      Entwicklung/Sprachen
81 Group(pl):      Programowanie/Jêzyki
82 Obsoletes:      egcc-objc
83 Obsoletes:      egcs-objc
84
85 %description objc
86 This package adds Objective C support to the GNU C compiler. Objective
87 C is a object oriented derivative of the C language, mainly used on
88 systems running NeXTSTEP. This package does not include the standard
89 objective C object library.
90
91 %description -l de objc
92 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
93 Objective C ist ein objektorientiertes Derivat von C, das zur
94 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
95 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
96
97 %description -l fr objc
98 Ce package ajoute un support Objective C au compilateur C GNU.
99 L'Objective C est un langage orienté objetdérivé du langage C,
100 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
101 pas la bibliothéque Objective C standard.
102
103 %description -l pl objc
104 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
105 pakiecie nie ma jeszcze bibliotek C-obj.
106
107 %description -l tr objc
108 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
109 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
110 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
111 kitaplýðý bu pakette yer almaz.
112
113 %package g77
114 Summary:        Fortran 77 support for gcc
115 Summary(pl):    Wspomaganie Fortran 77 dla gcc
116 Group:          Development/Languages
117 Group(de):      Entwicklung/Sprachen
118 Group(pl):      Programowanie/Jêzyki
119 Obsoletes:      egcs-g77
120
121 %description g77
122 This apckage adds support for compiling Fortran 77 programs with the
123 GNU compiler.
124
125 %description -l pl g77
126 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
127 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
128
129 %package chill
130 Summary:        CHILL support for gcc
131 Summary(pl):    Wspomoganie CHILL dla gcc
132 Group:          Development/Languages
133 Group(de):      Entwicklung/Sprachen
134 Group(pl):      Programowanie/Jêzyki
135 Requires:       %{name} = %{version}
136
137 %description chill
138 This package adds support for compiling CHILL programs with the GNU
139 compiler.
140
141 Chill is the "CCITT High-Level Language", where CCITT is the old name
142 for what is now ITU, the International Telecommunications Union. It is
143 is language in the Modula2 family, and targets many of the same
144 applications as Ada (especially large embedded systems). Chill was
145 never used much in the United States, but is still being used in
146 Europe, Brazil, Korea, and other places.
147
148 %package java
149 Summary:        Java support for gcc
150 Summary(pl):    Wspomoganie Java dla gcc
151 Group:          Development/Languages
152 Group(de):      Entwicklung/Sprachen
153 Group(pl):      Programowanie/Jêzyki
154 Requires:       %{name} = %{version}
155 Requires:       libgcj >= 2.95.1
156
157 %description java
158 This package adds experimental support for compiling Java(tm) programs
159 and bytecode into native code. To use this you will also need the
160 libgcj package.
161
162 %description -l pl java
163 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
164 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
165 przeprowadziæ kompilacjê.
166
167 %package -n libgcj
168 Summary:        Java Class Libraries
169 Summary(pl):    Biblioteki Klas Javy
170 Group:          Libraries
171 Group(de):      Libraries
172 Group(es):      Bibliotecas
173 Group(fr):      Librairies
174 Group(pl):      Biblioteki
175 Version:        %{GCJ_VERSION}
176 Requires:       zlib
177
178 %description -n libgcj
179 Java Class Libraries
180
181 %description -n libgcj -l pl
182 Biblioteki Klass Javy
183
184 %package -n libgcj-devel
185 Summary:        Development files for Java Class Libraries
186 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
187 Group:          Development/Libraries
188 Group(de):      Entwicklung/Libraries
189 Group(fr):      Development/Librairies
190 Group(pl):      Programowanie/Biblioteki
191 Version:        %{GCJ_VERSION}
192 Requires:       libgcj = %{GCJ_VERSION}
193 Requires:       %{name}-java
194
195 %description -n libgcj-devel
196 Development files for Java Class Libraries
197
198 %description -n libgcj-devel -l pl
199 Pliki nag³ówkowe dla Bibliotek Klass Javy
200
201 %package -n libgcj-static
202 Summary:        Static Java Class Libraries
203 Summary(pl):    Statyczne Biblioteki Klass Javy
204 Group:          Development/Libraries
205 Group(de):      Entwicklung/Libraries
206 Group(fr):      Development/Librairies
207 Group(pl):      Programowanie/Biblioteki
208 Version:        %{GCJ_VERSION}
209 Requires:       libstdc++-devel = %{GCJ_VERSION}
210
211 %description -n libgcj-static
212 Static Java Class Libraries
213
214 %description -l pl -n libgcj-static
215 Statyczne Biblioteki Klass Javy
216
217 %package -n libstdc++
218 Summary:        GNU c++ library
219 Summary(pl):    Biblioteki GNU C++ 
220 Group:          Libraries
221 Group(de):      Libraries
222 Group(es):      Bibliotecas
223 Group(fr):      Librairies
224 Group(pl):      Biblioteki
225 Version:        %{STDC_VERSION}
226 Obsoletes:      libg++
227
228 %description -n libstdc++
229 This is the GNU implementation of the standard C++ libraries, along
230 with additional GNU tools. This package includes the shared libraries
231 necessary to run C++ applications.
232
233 %description -l de -n libstdc++
234 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
235 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
236 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
237
238 %description -l fr -n libstdc++
239 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
240 des outils GNU supplémentaires. Ce package comprend les librairies
241 partagées nécessaires à l'exécution d'application C++.
242
243 %description -l pl -n libstdc++  
244 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
245 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
246 uruchomienia aplikacji napisanych w C++.
247
248 %description -l tr -n libstdc++
249 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
250 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
251
252 %package -n libstdc++-devel
253 Summary:        Header files and libraries for C++ development
254 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
255 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
256 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
257 Group:          Development/Libraries
258 Group(de):      Entwicklung/Libraries
259 Group(fr):      Development/Librairies
260 Group(pl):      Programowanie/Biblioteki
261 Version:        %{STDC_VERSION}
262 Requires:       libstdc++ = %{STDC_VERSION}
263 Requires:       %{name}-c++
264 Obsoletes:      libg++-devel
265
266 %description -n libstdc++-devel
267 This is the GNU implementation of the standard C++ libraries. This
268 package includes the header files and libraries needed for C++
269 development.
270
271 %description -l pl -n libstdc++-devel
272 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
273 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
274 programowaniu w jêzyku C++.
275
276 %package -n libstdc++-static
277 Summary:        Static c++ standard library
278 Summary(pl):    Biblioeka statyczna c++
279 Group:          Development/Libraries
280 Group(de):      Entwicklung/Libraries
281 Group(fr):      Development/Librairies
282 Group(pl):      Programowanie/Biblioteki
283 Version:        %{STDC_VERSION}
284 Requires:       libstdc++-devel = %{STDC_VERSION}
285
286 %description -n libstdc++-static
287 Static c++ standard library.
288
289 %description -l pl -n libstdc++-static
290 Biblioteka statyczna C++.
291
292 %package -n cpp
293 Summary:        The C Pre Processor
294 Summary(pl):    Preprocesor C
295 Group:          Development/Languages
296 Group(de):      Entwicklung/Sprachen
297 Group(pl):      Programowanie/Jêzyki
298 Version:        %{rver}
299 Obsoletes:      egcs-cpp
300
301 %description -n cpp
302 The C preprocessor is a "macro processor" that is used automatically
303 by the C compiler to transform your program before actual compilation.
304 It is called a macro processor because it allows you to define
305 "macros", which are brief abbreviations for longer constructs.
306
307 The C preprocessor provides four separate facilities that you can use
308 as you see fit:
309
310 - Inclusion of header files. These are files of declarations that can
311   be substituted into your program.
312 - Macro expansion. You can define "macros", which are abbreviations
313   for arbitrary fragments of C code, and then the C preprocessor will
314   replace the macros with their definitions throughout the program.
315 - Conditional compilation. Using special preprocessing directives, you
316   can include or exclude parts of the program according to various
317   conditions.
318 - Line control. If you use a program to combine or rearrange source
319   files into an intermediate file which is then compiled, you can use
320   line control to inform the compiler of where each source line
321   originally came from.
322
323 %description -l pl -n cpp
324 Przeprocesor C jest "makro procesorem" który jest automatycznie
325 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
326 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
327 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
328 d³ugich konstrukcji w jêzyku C.
329
330 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
331
332 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
333   deklaracji polecenia do³±czenia innego pliku.
334 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
335   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
336   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
337 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
338   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
339   fragmenty obrabianego strumienia tekstów.
340 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
341   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
342   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
343   odpowiada fragment pliku wynikowego.
344
345 %prep
346 %setup -q -n %{name}-%{version}-%{snap}
347 %patch0 -p1
348
349 %build
350 cd gcc && autoconf; cd ..
351 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
352
353 CFLAGS="%{rpmcflags}" \
354 CXXFLAGS="%{rpmcflags}" \
355 TEXCONFIG=false ../configure \
356         --prefix=%{_prefix} \
357         --infodir=%{_infodir} \
358         --mandir=%{_mandir} \
359         --enable-shared \
360 %ifarch sparc
361         --with-cpu=sparc \
362 %endif
363 %ifarch sparc64
364         --with-cpu=ultrasparc \
365 %endif
366         --enable-threads=posix \
367         --enable-haifa \
368         --enable-languages="c,gcov,c++,objc,java,f77" \
369         --enable-long-long \
370         --enable-namespaces \
371         --enable-multilib \
372         --with-gnu-as \
373         --with-gnu-ld \
374         --with-system-zlib \
375         --without-x \
376         %{_target_platform}
377
378 PATH=$PATH:/sbin:%{_sbindir}
379
380 cd ..
381 %{__make} -C obj-%{_target_platform} bootstrap-lean \
382         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
383         mandir=%{_mandir} \
384         infodir=%{_infodir}
385
386 %install
387 rm -rf $RPM_BUILD_ROOT
388 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
389
390 cd obj-%{_target_platform}
391 PATH=$PATH:/sbin:%{_sbindir}
392
393 %{__make} install \
394         prefix=$RPM_BUILD_ROOT%{_prefix} \
395         mandir=$RPM_BUILD_ROOT%{_mandir} \
396         infodir=$RPM_BUILD_ROOT%{_infodir}
397
398 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
399
400 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
401
402 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
403
404 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
405
406 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
407
408 gzip -9nf ../READ* ../ChangeLog
409
410 %post
411 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
412
413 %postun
414 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
415
416 %post g77
417 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
418
419 %postun g77
420 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
421
422 %post chill
423 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
424
425 %postun chill
426 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
427
428 %post -n cpp
429 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
430
431 %postun -n cpp
432 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
433
434 %post   -p /sbin/ldconfig -n libstdc++
435 %postun -p /sbin/ldconfig -n libstdc++
436
437 %clean
438 rm -rf $RPM_BUILD_ROOT
439
440 %files
441 %defattr(644,root,root,755)
442 %doc READ* ChangeLog.gz
443 %dir %{_libdir}/gcc-lib
444 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
445 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
446 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
447 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
448 %attr(755,root,root) %{_bindir}/gcc
449 %attr(755,root,root) %{_bindir}/gccbug
450 %attr(755,root,root) %{_bindir}/gcov
451 %attr(755,root,root) %{_bindir}/cc
452
453 %{_mandir}/man1/gcc.1*
454 %{_mandir}/man1/gcov.1*
455 %{_infodir}/gcc*
456
457 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
458 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
459 #%ifnarch alpha
460 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
461 #%endif
462 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
463 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
464
465 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
466 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
467 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
468 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
469 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
470 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
471 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
472 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
473 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
474
475 %files c++
476 %defattr(644,root,root,755)
477 %{_mandir}/man1/g++.1.gz
478 %attr(755,root,root) %{_bindir}/g++
479 %attr(755,root,root) %{_bindir}/c++
480 %attr(755,root,root) %{_bindir}/c++filt
481 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
482 %attr(755,root,root) %{_libdir}/libsupc++.la
483 %{_libdir}/libsupc++.a
484 %{_infodir}/c-tree*
485
486 %files objc
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
489 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
490 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
491 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
492 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
493
494 %files g77
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{_bindir}/g77
497 %attr(755,root,root) %{_bindir}/f77
498 %{_infodir}/g77*
499 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
500 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
501 %{_mandir}/man1/g77.1*
502 %{_mandir}/man1/f77.1*
503 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
504
505 %ifarch no_longer_supported_by_gcc_team
506 %files chill
507 %defattr(644,root,root,755)
508 %doc gcc/ch/chill.brochure.gz
509
510 %attr(755,root,root) %{_bindir}/chill
511 %{_infodir}/chill*
512 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
513 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
514 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
515 %endif
516
517 %files java
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_bindir}/gcj*
520 %attr(755,root,root) %{_bindir}/gij
521 %attr(755,root,root) %{_bindir}/jcf-dump
522 %attr(755,root,root) %{_bindir}/jv-*
523 %attr(755,root,root) %{_bindir}/fastjar
524 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
525 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
526 %{_infodir}/gcj*
527
528 %files -n libgcj
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
531
532 %files -n libgcj-devel
533 %defattr(644,root,root,755)
534 %{_includedir}/java
535 %{_includedir}/gcj
536 %{_includedir}/j*.h
537 %{_includedir}/gnu/*
538 %{_libdir}/lib*cj.spec
539 %{_datadir}/libgcj.jar
540 %attr(755,root,root) %{_libdir}/lib*cj*.la
541 %attr(755,root,root) %{_libdir}/lib*cj*.so
542
543 %files -n libgcj-static
544 %defattr(644,root,root,755)
545 %{_libdir}/lib*cj*.a
546
547 %files -n libstdc++
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
550
551 %files -n libstdc++-devel
552 %defattr(644,root,root,755)
553 %{_includedir}/g++*
554 %{_prefix}/%{_target_cpu}*
555 %attr(755,root,root) %{_libdir}/libstdc++.so
556
557 %files -n libstdc++-static
558 %defattr(644,root,root,755)
559 %attr(644,root,root) %{_libdir}/libstdc++.a
560
561 %files -n cpp
562 %defattr(644,root,root,755)
563 %attr(755,root,root) /lib/cpp
564 %attr(755,root,root) %{_bindir}/cpp
565 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
566 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
567 %{_mandir}/man1/cpp.1*
568 %{_infodir}/cpp*
This page took 0.086253 seconds and 3 git commands to generate.