]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
- three digit version (3.0.0) to get all requires properly resolved
[packages/gcc.git] / gcc.spec
1 %define         STDC_VERSION    3.0.0
2 %define         GCJ_VERSION     3.0.0
3 Summary:        GNU Compiler Collection
4 Summary(pl):    Kolekcja kompilatorów GNU
5 Name:           gcc
6 Version:        3.0.0
7 Release:        0.85
8 License:        GPL
9 Group:          Development/Languages
10 Group(de):      Entwicklung/Sprachen
11 Group(pl):      Programowanie/Jêzyki
12 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{snap}/%{name}-%{version}.tar.bz2
13 BuildRequires:  bison
14 BuildRequires:  texinfo
15 BuildRequires:  zlib-devel
16 BuildRequires:  fileutils >= 4.0.41
17 BuildRequires:  autoconf
18 Requires:       binutils >= 2.9.1.0.25
19 Requires:       cpp = %{version}
20 URL:            http://gcc.gnu.org/
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _slibdir        /lib
24
25 %description
26 A compiler aimed at integrating all the optimizations and features
27 necessary for a high-performance and stable development environment.
28
29 %description -l pl
30 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
31 wyprodukowania szybkiego i stablinego kodu wynikowego.
32
33 %package c++
34 Summary:        C++ support for gcc
35 Summary(fr):    Support C++ pour le compilateur gcc
36 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
37 Summary(tr):    gcc için C++ desteði
38 Group:          Development/Languages
39 Group(de):      Entwicklung/Sprachen
40 Group(pl):      Programowanie/Jêzyki
41 Obsoletes:      egcc-c++
42 Obsoletes:      egcs-c++
43
44 %description c++
45 This package adds C++ support to the GNU C compiler. It includes
46 support for most of the current C++ specification, including templates
47 and exception handling. It does not include a standard C++ library,
48 which is available separately.
49
50 %description -l de c++
51 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
52 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
53 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
54 sie ist getrennt erhältlich.
55
56 %description -l fr c++
57 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
58 support pour la plupart des spécifications actuelles de C++, dont les
59 modéles et la gestion des exceptions. Il ne comprend pas une
60 bibliothéque C++ standard, qui est disponible séparément.
61
62 %description -l pl c++
63 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
64 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
65 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
66
67 %description -l tr c++
68 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
69 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
70 C++ kitaplýðý bu pakette yer almaz.
71
72 %package objc
73 Summary:        Objective C support for gcc
74 Summary(de):    Objektive C-Unterstützung für gcc
75 Summary(fr):    Gestion d'Objective C pour gcc
76 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
77 Summary(tr):    gcc için Objective C desteði
78 Group:          Development/Languages
79 Group(de):      Entwicklung/Sprachen
80 Group(pl):      Programowanie/Jêzyki
81 Obsoletes:      egcc-objc
82 Obsoletes:      egcs-objc
83
84 %description objc
85 This package adds Objective C support to the GNU C compiler. Objective
86 C is a object oriented derivative of the C language, mainly used on
87 systems running NeXTSTEP. This package does not include the standard
88 objective C object library.
89
90 %description -l de objc
91 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
92 Objective C ist ein objektorientiertes Derivat von C, das zur
93 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
94 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
95
96 %description -l fr objc
97 Ce package ajoute un support Objective C au compilateur C GNU.
98 L'Objective C est un langage orienté objetdérivé du langage C,
99 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
100 pas la bibliothéque Objective C standard.
101
102 %description -l pl objc
103 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
104 pakiecie nie ma jeszcze bibliotek C-obj.
105
106 %description -l tr objc
107 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
108 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
109 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
110 kitaplýðý bu pakette yer almaz.
111
112 %package g77
113 Summary:        Fortran 77 support for gcc
114 Summary(pl):    Wspomaganie Fortran 77 dla gcc
115 Group:          Development/Languages
116 Group(de):      Entwicklung/Sprachen
117 Group(pl):      Programowanie/Jêzyki
118 Obsoletes:      egcs-g77
119
120 %description g77
121 This apckage adds support for compiling Fortran 77 programs with the
122 GNU compiler.
123
124 %description -l pl g77
125 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
126 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
127
128 %package chill
129 Summary:        CHILL support for gcc
130 Summary(pl):    Wspomoganie CHILL dla gcc
131 Group:          Development/Languages
132 Group(de):      Entwicklung/Sprachen
133 Group(pl):      Programowanie/Jêzyki
134 Requires:       %{name} = %{version}
135
136 %description chill
137 This package adds support for compiling CHILL programs with the GNU
138 compiler.
139
140 Chill is the "CCITT High-Level Language", where CCITT is the old name
141 for what is now ITU, the International Telecommunications Union. It is
142 is language in the Modula2 family, and targets many of the same
143 applications as Ada (especially large embedded systems). Chill was
144 never used much in the United States, but is still being used in
145 Europe, Brazil, Korea, and other places.
146
147 %package java
148 Summary:        Java support for gcc
149 Summary(pl):    Wspomoganie Java dla gcc
150 Group:          Development/Languages
151 Group(de):      Entwicklung/Sprachen
152 Group(pl):      Programowanie/Jêzyki
153 Requires:       %{name} = %{version}
154 Requires:       libgcj >= 2.95.1
155
156 %description java
157 This package adds experimental support for compiling Java(tm) programs
158 and bytecode into native code. To use this you will also need the
159 libgcj package.
160
161 %description -l pl java
162 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
163 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
164 przeprowadziæ kompilacjê.
165
166 %package -n libgcj
167 Summary:        Java Class Libraries
168 Summary(pl):    Biblioteki Klas Javy
169 Group:          Libraries
170 Group(de):      Libraries
171 Group(es):      Bibliotecas
172 Group(fr):      Librairies
173 Group(pl):      Biblioteki
174 Version:        %{GCJ_VERSION}
175 Requires:       zlib
176
177 %description -n libgcj
178 Java Class Libraries
179
180 %description -n libgcj -l pl
181 Biblioteki Klass Javy
182
183 %package -n libgcj-devel
184 Summary:        Development files for Java Class Libraries
185 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
186 Group:          Development/Libraries
187 Group(de):      Entwicklung/Libraries
188 Group(fr):      Development/Librairies
189 Group(pl):      Programowanie/Biblioteki
190 Version:        %{GCJ_VERSION}
191 Requires:       libgcj = %{GCJ_VERSION}
192 Requires:       %{name}-java
193
194 %description -n libgcj-devel
195 Development files for Java Class Libraries
196
197 %description -n libgcj-devel -l pl
198 Pliki nag³ówkowe dla Bibliotek Klass Javy
199
200 %package -n libgcj-static
201 Summary:        Static Java Class Libraries
202 Summary(pl):    Statyczne Biblioteki Klass Javy
203 Group:          Development/Libraries
204 Group(de):      Entwicklung/Libraries
205 Group(fr):      Development/Librairies
206 Group(pl):      Programowanie/Biblioteki
207 Version:        %{GCJ_VERSION}
208 Requires:       libstdc++-devel = %{GCJ_VERSION}
209
210 %description -n libgcj-static
211 Static Java Class Libraries
212
213 %description -l pl -n libgcj-static
214 Statyczne Biblioteki Klass Javy
215
216 %package -n libstdc++
217 Summary:        GNU c++ library
218 Summary(pl):    Biblioteki GNU C++ 
219 Group:          Libraries
220 Group(de):      Libraries
221 Group(es):      Bibliotecas
222 Group(fr):      Librairies
223 Group(pl):      Biblioteki
224 Version:        %{STDC_VERSION}
225 Obsoletes:      libg++
226
227 %description -n libstdc++
228 This is the GNU implementation of the standard C++ libraries, along
229 with additional GNU tools. This package includes the shared libraries
230 necessary to run C++ applications.
231
232 %description -l de -n libstdc++
233 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
234 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
235 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
236
237 %description -l fr -n libstdc++
238 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
239 des outils GNU supplémentaires. Ce package comprend les librairies
240 partagées nécessaires à l'exécution d'application C++.
241
242 %description -l pl -n libstdc++  
243 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
244 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
245 uruchomienia aplikacji napisanych w C++.
246
247 %description -l tr -n libstdc++
248 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
249 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
250
251 %package -n libstdc++-devel
252 Summary:        Header files and libraries for C++ development
253 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
254 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
255 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
256 Group:          Development/Libraries
257 Group(de):      Entwicklung/Libraries
258 Group(fr):      Development/Librairies
259 Group(pl):      Programowanie/Biblioteki
260 Version:        %{STDC_VERSION}
261 Requires:       libstdc++ = %{STDC_VERSION}
262 Requires:       %{name}-c++
263 Obsoletes:      libg++-devel
264
265 %description -n libstdc++-devel
266 This is the GNU implementation of the standard C++ libraries. This
267 package includes the header files and libraries needed for C++
268 development.
269
270 %description -l pl -n libstdc++-devel
271 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
272 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
273 programowaniu w jêzyku C++.
274
275 %package -n libstdc++-static
276 Summary:        Static c++ standard library
277 Summary(pl):    Biblioteka statyczna c++
278 Group:          Development/Libraries
279 Group(de):      Entwicklung/Libraries
280 Group(fr):      Development/Librairies
281 Group(pl):      Programowanie/Biblioteki
282 Version:        %{STDC_VERSION}
283 Requires:       libstdc++-devel = %{STDC_VERSION}
284
285 %description -n libstdc++-static
286 Static c++ standard library.
287
288 %description -l pl -n libstdc++-static
289 Biblioteka statyczna C++.
290
291 %package -n libgcc
292 Summary:        Shared gcc library
293 Summary(pl):    Biblioteka gcc
294 Group:          Libraries
295 Group(de):      Libraries
296 Group(fr):      Librairies
297 Group(pl):      Biblioteki
298 Version:        %{version}
299
300 %description -n libgcc
301 Shared gcc library.
302
303 %description -l pl -n libgcc
304 Biblioteka dynamiczna gcc.
305
306 %package -n cpp
307 Summary:        The C Pre Processor
308 Summary(pl):    Preprocesor C
309 Group:          Development/Languages
310 Group(de):      Entwicklung/Sprachen
311 Group(pl):      Programowanie/Jêzyki
312 Version:        %{version}
313 Obsoletes:      egcs-cpp
314 Obsoletes:      gcc-cpp
315
316 %description -n cpp
317 The C preprocessor is a "macro processor" that is used automatically
318 by the C compiler to transform your program before actual compilation.
319 It is called a macro processor because it allows you to define
320 "macros", which are brief abbreviations for longer constructs.
321
322 The C preprocessor provides four separate facilities that you can use
323 as you see fit:
324
325 - Inclusion of header files. These are files of declarations that can
326   be substituted into your program.
327 - Macro expansion. You can define "macros", which are abbreviations
328   for arbitrary fragments of C code, and then the C preprocessor will
329   replace the macros with their definitions throughout the program.
330 - Conditional compilation. Using special preprocessing directives, you
331   can include or exclude parts of the program according to various
332   conditions.
333 - Line control. If you use a program to combine or rearrange source
334   files into an intermediate file which is then compiled, you can use
335   line control to inform the compiler of where each source line
336   originally came from.
337
338 %description -l pl -n cpp
339 Przeprocesor C jest "makro procesorem" który jest automatycznie
340 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
341 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
342 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
343 d³ugich konstrukcji w jêzyku C.
344
345 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
346
347 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
348   deklaracji polecenia do³±czenia innego pliku.
349 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
350   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
351   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
352 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
353   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
354   fragmenty obrabianego strumienia tekstów.
355 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
356   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
357   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
358   odpowiada fragment pliku wynikowego.
359
360 %prep
361 %setup -q
362
363 %build
364 cd gcc && autoconf; cd ..
365 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
366
367 CFLAGS="%{rpmcflags}" \
368 CXXFLAGS="%{rpmcflags}" \
369 TEXCONFIG=false ../configure \
370         --prefix=%{_prefix} \
371         --infodir=%{_infodir} \
372         --mandir=%{_mandir} \
373         --enable-shared \
374 %ifarch sparc
375         --with-cpu=sparc \
376 %endif
377 %ifarch sparc64
378         --with-cpu=ultrasparc \
379 %endif
380         --enable-threads=posix \
381         --enable-haifa \
382         --enable-languages="c,c++,f77,gcov,java,objc" \
383         --enable-long-long \
384         --enable-namespaces \
385         --enable-multilib \
386         --with-gnu-as \
387         --with-gnu-ld \
388         --with-system-zlib \
389         --with-slibdir=%{_slibdir} \
390         --without-x \
391         %{_target_platform}
392
393 PATH=$PATH:/sbin:%{_sbindir}
394
395 cd ..
396 %{__make} -C obj-%{_target_platform} bootstrap-lean \
397         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
398         mandir=%{_mandir} \
399         infodir=%{_infodir}
400
401 %install
402 rm -rf $RPM_BUILD_ROOT
403 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
404
405 cd obj-%{_target_platform}
406 PATH=$PATH:/sbin:%{_sbindir}
407
408 # workaround
409 cat gcc/Makefile | sed -e 's,slibdir = /lib,slibdir = $(DESTDIR)%{_slibdir},g' > gcc/Makfefile.
410 mv -f gcc/Makfefile. gcc/Makefile
411
412 %{__make} install \
413         prefix=$RPM_BUILD_ROOT%{_prefix} \
414         mandir=$RPM_BUILD_ROOT%{_mandir} \
415         infodir=$RPM_BUILD_ROOT%{_infodir} \
416         DESTDIR=$RPM_BUILD_ROOT
417
418 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
419
420 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
421
422 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
423
424 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
425
426 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
427
428 gzip -9nf ../READ* ../ChangeLog
429
430 %post
431 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
432
433 %postun
434 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
435
436 %post g77
437 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
438
439 %postun g77
440 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
441
442 %post chill
443 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
444
445 %postun chill
446 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
447
448 %post -n cpp
449 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
450
451 %postun -n cpp
452 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
453
454 %post   -p /sbin/ldconfig -n libstdc++
455 %postun -p /sbin/ldconfig -n libstdc++
456
457 %clean
458 rm -rf $RPM_BUILD_ROOT
459
460 %files
461 %defattr(644,root,root,755)
462 %doc READ* ChangeLog.gz
463 %dir %{_libdir}/gcc-lib
464 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
465 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
466 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
467 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
468 %attr(755,root,root) %{_bindir}/gcc
469 %attr(755,root,root) %{_bindir}/gccbug
470 %attr(755,root,root) %{_bindir}/gcov
471 %attr(755,root,root) %{_bindir}/cc
472
473 %{_mandir}/man1/gcc.1*
474 %{_mandir}/man1/gcov.1*
475 %{_infodir}/gcc*
476
477 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
478 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
479 #%ifnarch alpha
480 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
481 #%endif
482 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
483 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
484
485 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
486 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
487 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
488 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
489 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
490 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
491 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
492 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
493 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
494
495 %files c++
496 %defattr(644,root,root,755)
497 %{_mandir}/man1/g++.1.gz
498 %attr(755,root,root) %{_bindir}/g++
499 %attr(755,root,root) %{_bindir}/c++
500 %attr(755,root,root) %{_bindir}/c++filt
501 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
502 %attr(755,root,root) %{_libdir}/libsupc++.la
503 %{_libdir}/libsupc++.a
504
505 %files objc
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
508 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
509 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
510 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
511 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
512
513 %files g77
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_bindir}/g77
516 %attr(755,root,root) %{_bindir}/f77
517 %{_infodir}/g77*
518 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
519 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
520 %{_mandir}/man1/g77.1*
521 %{_mandir}/man1/f77.1*
522 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
523
524 %ifarch no_longer_supported_by_gcc_team
525 %files chill
526 %defattr(644,root,root,755)
527 %doc gcc/ch/chill.brochure.gz
528
529 %attr(755,root,root) %{_bindir}/chill
530 %{_infodir}/chill*
531 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
532 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
533 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
534 %endif
535
536 %files java
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_bindir}/gcj*
539 %attr(755,root,root) %{_bindir}/gij
540 %attr(755,root,root) %{_bindir}/jcf-dump
541 %attr(755,root,root) %{_bindir}/jv-*
542 %attr(755,root,root) %{_bindir}/jar
543 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
544 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
545 %{_infodir}/gcj*
546
547 %files -n libgcj
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
550
551 %files -n libgcj-devel
552 %defattr(644,root,root,755)
553 %{_includedir}/java
554 %{_includedir}/gcj
555 %{_includedir}/j*.h
556 %{_includedir}/gnu/*
557 %{_libdir}/lib*cj.spec
558 %{_datadir}/libgcj.jar
559 %attr(755,root,root) %{_libdir}/lib*cj*.la
560 %attr(755,root,root) %{_libdir}/lib*cj*.so
561
562 %files -n libgcj-static
563 %defattr(644,root,root,755)
564 %{_libdir}/lib*cj*.a
565
566 %files -n libstdc++
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
569
570 %files -n libstdc++-devel
571 %defattr(644,root,root,755)
572 %{_includedir}/g++*
573 %attr(755,root,root) %{_libdir}/libstdc++.so
574
575 %files -n libstdc++-static
576 %defattr(644,root,root,755)
577 %attr(644,root,root) %{_libdir}/libstdc++.a
578
579 %files -n libgcc
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_slibdir}/lib*.so*
582
583 %files -n cpp
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_slibdir}/cpp
586 %attr(755,root,root) %{_bindir}/cpp
587 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
588 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
589 %{_mandir}/man1/cpp.1*
590 %{_infodir}/cpp*
This page took 0.204896 seconds and 3 git commands to generate.