]> git.pld-linux.org Git - packages/freerdp.git/blob - freerdp.spec
- raw
[packages/freerdp.git] / freerdp.spec
1 Summary:        Remote Desktop Protocol client
2 Name:           freerdp
3 Version:        1.0.1
4 Release:        0.1
5 License:        ASL 2.0
6 Group:          Applications/Communications
7 URL:            http://www.freerdp.com/
8 Source0:        https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
9 # https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
10 Patch0:         fastpath_send_input_pdu-sec_bytes.patch
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12 BuildRequires:  cmake
13 BuildRequires:  cups-devel
14 BuildRequires:  desktop-file-utils
15 BuildRequires:  libXcursor-devel
16 BuildRequires:  libXdamage-devel
17 BuildRequires:  libXv-devel
18 BuildRequires:  libxkbfile-devel
19 BuildRequires:  openssl-devel
20 BuildRequires:  pcsc-lite-devel
21 BuildRequires:  pulseaudio-devel
22 BuildRequires:  xmlto
23 BuildRequires:  xorg-lib-libX11-devel
24 BuildRequires:  xorg-lib-libXext-devel
25 BuildRequires:  xorg-lib-libXinerama-devel
26
27 Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
28 Requires:       %{name}-plugins%{?_isa} = %{version}-%{release}
29 Provides:       xfreerdp = %{version}-%{release}
30
31 %description
32 The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
33 project.
34
35 xfreerdp can connect to RDP servers such as Microsoft Windows
36 machines, xrdp and VirtualBox.
37
38
39 %package        libs
40 %description    libs
41 libfreerdp-core can be embedded in applications.
42
43 libfreerdp-channels and libfreerdp-kbd might be convenient to use in X
44 applications together with libfreerdp-core.
45
46 libfreerdp-core can be extended with plugins handling RDP channels.
47
48
49 %package        plugins
50 %description    plugins
51 A set of plugins to the channel manager implementing the standard
52 virtual channels extending RDP core functionality. For instance,
53 sounds, clipboard sync, disk/printer redirection, etc.
54
55
56 %package        devel
57 Summary:        Core libraries implementing the RDP protocol
58 Summary:        Development files for %{name}
59 Summary:        Plugins for handling the standard RDP channels
60 Group:          Applications/Communications
61 Group:          Applications/Communications
62 Group:          Development/Libraries
63 Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
64 Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
65 Requires:       pkgconfig
66
67 %description    devel
68 The %{name}-devel package contains libraries and header files for
69 developing applications that use %{name}-libs.
70
71
72 %prep
73
74 %setup -q
75 %patch0 -p1
76
77 cat << EOF > xfreerdp.desktop
78 [Desktop Entry]
79 Type=Application
80 Name=X FreeRDP
81 NoDisplay=true
82 Comment=Connect to RDP server and display remote desktop
83 Icon=%{name}
84 Exec=%{_bindir}/xfreerdp
85 Terminal=false
86 Categories=Network;RemoteAccess;
87 EOF
88
89
90 %build
91
92 %cmake \
93                 -DWITH_CUPS=ON \
94                 -DWITH_PCSC=ON \
95                 -DWITH_PULSEAUDIO=ON \
96                 -DWITH_X11=ON \
97                 -DWITH_XCURSOR=ON \
98                 -DWITH_XEXT=ON \
99                 -DWITH_XINERAMA=ON \
100                 -DWITH_XKBFILE=ON \
101                 -DWITH_XV=ON \
102                 -DWITH_ALSA=OFF \
103                 -DWITH_CUNIT=OFF \
104                 -DWITH_DIRECTFB=OFF \
105                 -DWITH_FFMPEG=OFF \
106                 -DWITH_SSE2=OFF \
107                 -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
108                 .
109
110 %{__make} %{?_smp_mflags}
111
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
117
118 # No need for keymap files when using xkbfile
119 rm -rf $RPM_BUILD_ROOT%{_datadir}/freerdp
120
121 desktop-file-install --dir=$RPM_BUILD_ROOT%{_desktopdir} xfreerdp.desktop
122 install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
123
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128
129 %post
130 # This is no gtk application, but try to integrate nicely with GNOME if it is available
131 gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
132
133
134 %post libs -p /sbin/ldconfig
135
136
137 %postun libs -p /sbin/ldconfig
138
139
140 %files
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/xfreerdp
143 %{_mandir}/man1/xfreerdp.*
144 %{_desktopdir}/xfreerdp.desktop
145 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
146
147 %files libs
148 %defattr(644,root,root,755)
149 %doc LICENSE README ChangeLog
150 %{_libdir}/lib%{name}-*.so.*
151 %dir %{_libdir}/%{name}/
152
153 %files plugins
154 %defattr(644,root,root,755)
155 %{_libdir}/%{name}/*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %{_includedir}/%{name}/
160 %{_libdir}/lib%{name}-*.so
161 %{_pkgconfigdir}/%{name}.pc
This page took 0.06283 seconds and 3 git commands to generate.