]> git.pld-linux.org Git - packages/freeciv.git/blob - freeciv.spec
- proper and complete merge with DEVEL
[packages/freeciv.git] / freeciv.spec
1 #
2 # TODO
3 # - dozen of unpackaged files
4 # - consider using desktop file included with project (for clinet icon presentation)
5 #
6 # Conditional build:
7 %bcond_without  gtk2            # build gtk1 client, not gtk2
8 #
9 Summary:        FREE CIVilization clone
10 Summary(es.UTF-8):      Clon del juego Civilization
11 Summary(pl.UTF-8):      Niekomercyjny klon CIVilization
12 Summary(pt_BR.UTF-8):   Clone do jogo Civilization
13 Name:           freeciv
14 Version:        2.1.0
15 Release:        0.1
16 License:        GPL v2+
17 Group:          X11/Applications/Games/Strategy
18 Source0:        http://dl.sourceforge.net/freeciv/%{name}-%{version}.tar.bz2
19 # Source0-md5:  f640aa48abca0a235220d6df22b9bc82
20 Source1:        ftp://ftp.freeciv.org/pub/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz
21 # Source1-md5:  77215914712f2f351092918f5e41e39e
22 Source2:        ftp://ftp.freeciv.org/pub/freeciv/contrib/tilesets/freeland/freeland-normal-2.0.0.tar.gz
23 # Source2-md5:  c9f061fca82aa50a19fbbc89c06ff81d
24 Source3:        %{name}-client.desktop
25 Source4:        %{name}-server.desktop
26 Source5:        %{name}.png
27 Patch0:         %{name}-link.patch
28 URL:            http://www.freeciv.org/
29 BuildRequires:  SDL_mixer-devel
30 BuildRequires:  autoconf >= 2.52
31 BuildRequires:  automake
32 BuildRequires:  esound-devel
33 %{!?with_gtk2:BuildRequires:    gtk+-devel > 1.2.1}
34 %{?with_gtk2:BuildRequires:     gtk+2-devel}
35 %{!?with_gtk2:BuildRequires:    imlib-devel >= 1.9.2}
36 BuildRequires:  pkgconfig
37 BuildRequires:  readline-devel
38 BuildRequires:  zlib-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Free clone of Sid Meier's Civilization. Free Civilization clone for
43 unix and X. This is multiplayer strategic game and you can also play
44 against computer-AI players.
45
46 %description -l es.UTF-8
47 Clon del juego Civilization.
48
49 %description -l pl.UTF-8
50 Freeciv jest to niekomercyjny (GPL) klon gry Civilization Sida Meiera.
51 Jest to gra strategiczna dla systemu X Window. Można grać w nią z
52 innymi osobami poprzez sieć, a także przeciwko "graczom" zarządzanym
53 przez komputer.
54
55 %description -l pt_BR.UTF-8
56 O FreeCiv é uma implementação do Civilization II para o Sistema X
57 Window.
58
59 %package client
60 Summary:        Freeciv game client
61 Summary(pl.UTF-8):      Klient gry Freeciv
62 Group:          X11/Applications/Games/Strategy
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       SDL_mixer
65 Requires:       esound
66 %{!?with_gtk2:Requires: gtk+ > 1.2.1}
67 %{!?with_gtk2:Requires: imlib >= 1.9.2}
68
69 %description client
70 This package contains Freeciv game client.
71
72 %description client -l pl.UTF-8
73 Ten pakiet zawiera klienta gry Freeciv.
74
75 %package server
76 Summary:        Freeciv game server
77 Summary(pl.UTF-8):      Serwer gry Freeciv
78 Group:          X11/Applications/Games/Strategy
79 Requires:       %{name} = %{version}-%{release}
80
81 %description server
82 This package contans Freeciv game server.
83
84 %description server -l pl.UTF-8
85 Ten pakiet zawiera server gry Freeciv.
86
87 %prep
88 %setup -q -a1 -a2
89 %patch0 -p1
90
91 %build
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97 %{!?with_gtk2:  --enable-client=gtk} \
98 %{?with_gtk2:   --enable-client=gtk2}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
110 install %{SOURCE5} $RPM_BUILD_ROOT%{_pixmapsdir}
111
112 cp -rf data/stdsounds{,.soundspec} $RPM_BUILD_ROOT%{_datadir}/%{name}
113 cp -f freeland.tilespec $RPM_BUILD_ROOT%{_datadir}/%{name}
114 cp -rf freeland $RPM_BUILD_ROOT%{_datadir}/%{name}
115
116 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
117
118 %find_lang %{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS README ChangeLog NEWS
126 %{_pixmapsdir}/*
127 %dir %{_datadir}/%{name}
128 %{_datadir}/%{name}/helpdata.txt
129
130 %files server
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/civserver
133 %{_desktopdir}/%{name}-server.desktop
134 %{_datadir}/%{name}/civ1
135 %{_datadir}/%{name}/civ2
136 %{_datadir}/%{name}/default
137 %{_datadir}/%{name}/nation
138 %{_datadir}/%{name}/scenario
139 %{_datadir}/%{name}/*.serv
140 %{_mandir}/man6/civserver.6*
141
142 %files client
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/civclient
145 %attr(755,root,root) %{_bindir}/civmanual
146 %{_desktopdir}/%{name}-client.desktop
147 %{_datadir}/%{name}/amplio
148 %{_datadir}/%{name}/freeciv.rc*
149 %{_datadir}/%{name}/freeland
150 %{_datadir}/%{name}/isophex
151 %{_datadir}/%{name}/isotrident
152 %{_datadir}/%{name}/misc
153 %{_datadir}/%{name}/trident
154 %{_datadir}/%{name}/flags
155 %{_datadir}/%{name}/*.*spec
156 %{_datadir}/%{name}/stdsounds
157 %{_mandir}/man6/civclient.6*
This page took 0.070595 seconds and 4 git commands to generate.