]> git.pld-linux.org Git - packages/freeciv.git/blob - freeciv.spec
- rel 0.1 (TODO)
[packages/freeciv.git] / freeciv.spec
1 #
2 # TODO: - try to create bconds for supported clients
3 #       - separate desktop files for all clients
4 #       - gtk client doesn't display menubars and main map
5 #
6 # Conditional build:
7 %bcond_without  ggz_client      # build without ggz client
8 %bcond_without  ggz_server      # build without ggz server
9 #
10 Summary:        FREE CIVilization clone
11 Summary(es.UTF-8):      Clon del juego Civilization
12 Summary(pl.UTF-8):      Niekomercyjny klon CIVilization
13 Summary(pt_BR.UTF-8):   Clone do jogo Civilization
14 Name:           freeciv
15 Version:        2.3.0
16 Release:        0.1
17 License:        GPL v2+
18 Group:          X11/Applications/Games/Strategy
19 Source0:        http://downloads.sourceforge.net/freeciv/%{name}-%{version}.tar.bz2
20 # Source0-md5:  70fd4285f2da7d41bdadac43458e62c9
21 # NOTE: current version of freeland tiles does not work with newest freeciv version
22 #Source1:       http://download.gna.org/freeciv/contrib/tilesets/freeland/freeland-normal-2.0.0.tar.gz
23 Patch0:         %{name}-link.patch
24 Patch1:         %{name}-desktop.patch
25 Patch2:         %{name}-ggz.patch
26 URL:            http://freeciv.wikia.com/
27 BuildRequires:  SDL_mixer-devel
28 BuildRequires:  autoconf >= 2.52
29 BuildRequires:  automake
30 BuildRequires:  gettext-devel
31 %{?with_ggz_client:BuildRequires:       ggz-gtk-client-devel}
32 BuildRequires:  gtk+2-devel
33 BuildRequires:  libggz-devel
34 BuildRequires:  libpng-devel
35 BuildRequires:  libtool
36 BuildRequires:  pkgconfig
37 BuildRequires:  readline-devel
38 BuildRequires:  zlib-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         specflags       -O1
42
43 %description
44 Free clone of Sid Meier's Civilization. Free Civilization clone for
45 Unix and X. This is multiplayer strategic game and you can also play
46 against computer-AI players.
47
48 %description -l es.UTF-8
49 Clon del juego Civilization.
50
51 %description -l pl.UTF-8
52 Freeciv jest to niekomercyjny (GPL) klon gry Civilization Sida Meiera.
53 Jest to gra strategiczna dla systemu X Window. Można grać w nią z
54 innymi osobami poprzez sieć, a także przeciwko "graczom" zarządzanym
55 przez komputer.
56
57 %description -l pt_BR.UTF-8
58 O FreeCiv é uma implementação do Civilization II para o Sistema X
59 Window.
60
61 %package client
62 Summary:        Freeciv game client
63 Summary(pl.UTF-8):      Klient gry Freeciv
64 Group:          X11/Applications/Games/Strategy
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       SDL_mixer
67 Suggests:       %{name}-server = %{version}-%{release}
68
69 %description client
70 This package contains Freeciv game client.
71
72 %description client -l pl.UTF-8
73 Ten pakiet zawiera klienta gry Freeciv.
74
75 %package server
76 Summary:        Freeciv game server
77 Summary(pl.UTF-8):      Serwer gry Freeciv
78 Group:          X11/Applications/Games/Strategy
79 Requires:       %{name} = %{version}-%{release}
80
81 %description server
82 This package contans Freeciv game server.
83
84 %description server -l pl.UTF-8
85 Ten pakiet zawiera server gry Freeciv.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92
93 %build
94 %{__libtoolize}
95 %{__aclocal} -I m4
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         --with-ggzd-confdir=%{_sysconfdir}/ggzd \
101         --disable-silent-rules \
102         --enable-client=all \
103         %{!?with_ggz_client:--without-ggz-client} \
104         %{!?with_ggz_server:--without-ggz-server}
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 cp -a client/%{name}.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}-client.desktop
116 cp -a server/%{name}-server.desktop $RPM_BUILD_ROOT%{_desktopdir}
117 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
118
119 cp -a data/icons/32x32/*.png $RPM_BUILD_ROOT%{_pixmapsdir}
120 cp -a data/stdsounds{,.soundspec} $RPM_BUILD_ROOT%{_datadir}/%{name}
121 #cp -a freeland.tilespec $RPM_BUILD_ROOT%{_datadir}/%{name}
122 #cp -a freeland $RPM_BUILD_ROOT%{_datadir}/%{name}
123
124 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/no
125 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules
126
127 cp -a data/gtk_menus.xml $RPM_BUILD_ROOT%{_datadir}/%{name}
128
129 %if %{with ggz_server}
130 install -d $RPM_BUILD_ROOT%{_sysconfdir}/ggzd/{games,rooms}
131 cp -a data/civserver.dsc $RPM_BUILD_ROOT%{_sysconfdir}/ggzd/games/civserver.dsc
132 cp -a data/civserver.room $RPM_BUILD_ROOT%{_sysconfdir}/ggzd/rooms/civserver.room
133 %endif
134
135 %find_lang %{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS README ChangeLog NEWS
143 %dir %{_datadir}/%{name}
144 %{_datadir}/%{name}/helpdata.txt
145
146 %files server
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/freeciv-server
149 %{_desktopdir}/%{name}-server.desktop
150 %{_datadir}/%{name}/civ1
151 %{_datadir}/%{name}/civ2
152 %{_datadir}/%{name}/default
153 %{_datadir}/%{name}/experimental
154 %{_datadir}/%{name}/multiplayer
155 %{_datadir}/%{name}/nation
156 %{_datadir}/%{name}/scenario
157 %{_datadir}/%{name}/*.serv
158 %{_mandir}/man6/freeciv-server.6*
159 %{_iconsdir}/hicolor/*/apps/freeciv-server.png
160 %{_pixmapsdir}/freeciv-server.png
161
162 %if %{with ggz_server}
163 %dir %{_sysconfdir}/ggzd
164 %dir %{_sysconfdir}/ggzd/games
165 %dir %{_sysconfdir}/ggzd/rooms
166 %{_sysconfdir}/ggzd/games/civserver.dsc
167 %{_sysconfdir}/ggzd/rooms/civserver.room
168 %endif
169
170 %files client
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/freeciv-gtk2
173 %attr(755,root,root) %{_bindir}/freeciv-sdl
174 %attr(755,root,root) %{_bindir}/freeciv-stub
175 %attr(755,root,root) %{_bindir}/freeciv-xaw
176 %attr(755,root,root) %{_bindir}/freeciv-manual
177 %attr(755,root,root) %{_bindir}/freeciv-modpack
178 %{_desktopdir}/%{name}-client.desktop
179 %{_datadir}/%{name}/*.*spec
180 %{_datadir}/%{name}/amplio2
181 %{_datadir}/%{name}/buildings
182 %{_datadir}/%{name}/flags
183 %{_datadir}/%{name}/freeciv.rc*
184 #%%{_datadir}/%{name}/freeland
185 %{_datadir}/%{name}/gtk_menus.xml
186 %{_datadir}/%{name}/hex2t
187 %{_datadir}/%{name}/isophex
188 %{_datadir}/%{name}/isotrident
189 %{_datadir}/%{name}/misc
190 %{_datadir}/%{name}/stdsounds
191 %{_datadir}/%{name}/themes
192 %{_datadir}/%{name}/trident
193 %{_datadir}/%{name}/wonders
194 %{_mandir}/man6/freeciv-client.6*
195 %{_mandir}/man6/freeciv-ftwl.6*
196 %{_mandir}/man6/freeciv-gtk2.6*
197 %{_mandir}/man6/freeciv-sdl.6*
198 %{_mandir}/man6/freeciv-win32.6*
199 %{_mandir}/man6/freeciv-xaw.6*
200 %{_iconsdir}/hicolor/*/apps/freeciv-client.png
201 %{_pixmapsdir}/freeciv-client.png
This page took 0.076301 seconds and 4 git commands to generate.