]> git.pld-linux.org Git - packages/folks.git/blob - folks.spec
- updated to 0.13.2
[packages/folks.git] / folks.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # API documentation (broken install: HTML for devhelp part, sources+HTML for gtk-doc?)
4 %bcond_without  vala            # Vala API
5 %bcond_without  bluez           # Bluez backend
6 %bcond_without  evolution       # EDS (Evolution Data Server) backend
7 %bcond_without  ofono           # oFono backend
8 %bcond_without  telepathy       # Telepathy backend
9 %bcond_without  zeitgeist       # ` Zeitgeist support in Telepathy backend
10 %bcond_without  tracker         # Tracker backend
11
12 %if %{without telepathy}
13 %undefine       with_zeitgeist
14 %endif
15 Summary:        GObject contact aggregation library
16 Summary(pl.UTF-8):      Biblioteka GObject do agregowania kontaktów
17 Name:           folks
18 Version:        0.13.2
19 Release:        1
20 License:        LGPL v2.1+
21 Group:          Libraries
22 Source0:        http://ftp.gnome.org/pub/GNOME/sources/folks/0.13/%{name}-%{version}.tar.xz
23 # Source0-md5:  e9e8d37bbd2b6405c5d23269d9df2d49
24 Patch0:         %{name}-meson.patch
25 Patch1:         %{name}-module.patch
26 URL:            https://wiki.gnome.org/Projects/Folks
27 BuildRequires:  dbus-devel
28 %{?with_telepathy:BuildRequires:        dbus-glib-devel}
29 %if %{with bluez} || %{with evolution} || %{with ofono}
30 # libebook for all; libebook-contacts, libedataserver, evolution-data-server for evolution
31 BuildRequires:  evolution-data-server-devel >= 3.33.2
32 %endif
33 BuildRequires:  gettext-tools
34 BuildRequires:  glib2-devel >= 1:2.44
35 BuildRequires:  gobject-introspection-devel >= 1.30.0
36 BuildRequires:  libgee-devel >= 0.8.4
37 BuildRequires:  libxml2-devel >= 2.0
38 BuildRequires:  meson >= 0.51
39 BuildRequires:  ncurses-devel
40 BuildRequires:  ninja >= 1.5
41 BuildRequires:  pkgconfig >= 1:0.21
42 BuildRequires:  python3 >= 1:3.2
43 %{?with_bluez:BuildRequires:    python3-dbusmock}
44 BuildRequires:  rpmbuild(macros) >= 1.736
45 BuildRequires:  readline-devel
46 BuildRequires:  tar >= 1:1.22
47 %{?with_telepathy:BuildRequires:        telepathy-glib-devel >= 0.19.9}
48 %{?with_tracker:BuildRequires:  tracker-devel >= 2.0}
49 %if %{with vala}
50 BuildRequires:  vala >= 2:0.22.1
51 %if %{with bluez} || %{with evolution} || %{with ofono}
52 BuildRequires:  vala-evolution-data-server >= 3.33.2
53 %endif
54 BuildRequires:  vala-libgee >= 0.8.4
55 %{?with_telepathy:BuildRequires:        vala-telepathy-glib >= 0.19.9}
56 %{?with_tracker:BuildRequires:  vala-tracker >= 2.0}
57 %{?with_zeitgeist:BuildRequires:        vala-zeitgeist >= 0.9.14}
58 %endif
59 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
60 BuildRequires:  xz
61 %{?with_zeitgeist:BuildRequires:        zeitgeist-devel >= 0.9.14}
62 %if %{with bluez} || %{with evolution} || %{with ofono}
63 Requires:       evolution-data-server-libs >= 3.33.2
64 %endif
65 Requires:       glib2 >= 1:2.44
66 Requires:       libgee >= 0.8.4
67 %{?with_telepathy:Requires:     telepathy-glib >= 0.19.9}
68 %{?with_tracker:Requires:       tracker-libs >= 2.0}
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         abiver  45
72
73 %description
74 libfolks is a library that aggregates people from multiple sources
75 (e.g. Telepathy connection managers and eventually evolution data
76 server, Facebook, etc.) to create meta-contacts.
77
78 %description -l pl.UTF-8
79 libfolks to biblioteka gromadząca osoby z wielu źródeł (np. zarządców
80 połączeń Telepathy, serwera danych Evolution, Facebooka itp.), aby
81 utworzyć metakontakty.
82
83 %package devel
84 Summary:        Development files for folks libraries
85 Summary(pl.UTF-8):      Pliki programistyczne bibliotek folks
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 %if %{with bluez} || %{with evolution} || %{with ofono}
89 Requires:       evolution-data-server-devel >= 3.33.2
90 %endif
91 Requires:       glib2-devel >= 1:2.44
92 Requires:       libgee-devel >= 0.8.4
93 %{?with_telepathy:Requires:     telepathy-glib-devel >= 0.19.9}
94 %{?with_tracker:Requires:       tracker-devel >= 2.0}
95
96 %description devel
97 Development files for folks libraries.
98
99 %description devel -l pl.UTF-8
100 Pliki programistyczne bibliotek folks.
101
102 %package -n vala-folks
103 Summary:        folks API for Vala language
104 Summary(pl.UTF-8):      API folks dla języka Vala
105 Group:          Development/Libraries
106 Requires:       %{name}-devel = %{version}-%{release}
107 Requires:       vala >= 2:0.22.1
108 %if %{with bluez} || %{with evolution} || %{with ofono}
109 Requires:       vala-evolution-data-server >= 3.33.2
110 %endif
111 Requires:       vala-libgee >= 0.8.4
112 %{?with_telepathy:Requires:     vala-telepathy-glib >= 0.19.9}
113 %{?with_tracker:Requires:       vala-tracker >= 2.0}
114 %if "%{_rpmversion}" >= "4.6"
115 BuildArch:      noarch
116 %endif
117
118 %description -n vala-folks
119 folks API for Vala language.
120
121 %description -n vala-folks -l pl.UTF-8
122 API folks dla języka Vala.
123
124 %prep
125 %setup -q
126 %patch0 -p1
127 %patch1 -p1
128
129 %build
130 %meson build \
131         %{!?with_bluez:-Dbluez_backend=false} \
132         %{?with_apidocs:-Ddocs=true} \
133         %{!?with_evolution:-Deds_backend=false} \
134         %{!?with_ofono:-Dofono_backend=false} \
135         %{?with_tracker:-Dtracker_backend=true} \
136         %{!?with_telepathy:-Dtelepathy_backend=false} \
137         %{?with_zeitgeist:-Dzeitgeist=true}
138
139 %ninja_build -C build
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %ninja_install -C build
145
146 %find_lang %{name}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files -f %{name}.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS MAINTAINERS NEWS README.md
157 %attr(755,root,root) %{_bindir}/folks-import
158 %attr(755,root,root) %{_bindir}/folks-inspect
159 %attr(755,root,root) %{_libdir}/libfolks.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libfolks.so.25
161 %attr(755,root,root) %{_libdir}/libfolks-dummy.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libfolks-dummy.so.25
163 %{_libdir}/girepository-1.0/Folks-0.6.typelib
164 %{_libdir}/girepository-1.0/FolksDummy-0.6.typelib
165 %dir %{_libdir}/folks
166 %dir %{_libdir}/folks/%{abiver}
167 %dir %{_libdir}/folks/%{abiver}/backends
168 %dir %{_libdir}/folks/%{abiver}/backends/dummy
169 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/dummy/dummy.so
170 %dir %{_libdir}/folks/%{abiver}/backends/key-file
171 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/key-file/key-file.so
172 %if %{with bluez}
173 %dir %{_libdir}/folks/%{abiver}/backends/bluez
174 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/bluez/bluez.so
175 %endif
176 %if %{with ofono}
177 %dir %{_libdir}/folks/%{abiver}/backends/ofono
178 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/ofono/ofono.so
179 %endif
180 %if %{with evolution}
181 %attr(755,root,root) %{_libdir}/libfolks-eds.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libfolks-eds.so.25
183 %{_libdir}/girepository-1.0/FolksEds-0.6.typelib
184 %dir %{_libdir}/folks/%{abiver}/backends/eds
185 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/eds/eds.so
186 %endif
187 %if %{with telepathy}
188 %attr(755,root,root) %{_libdir}/libfolks-telepathy.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libfolks-telepathy.so.25
190 %{_libdir}/girepository-1.0/FolksTelepathy-0.6.typelib
191 %dir %{_libdir}/folks/%{abiver}/backends/telepathy
192 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/telepathy/telepathy.so
193 %endif
194 %if %{with tracker}
195 %attr(755,root,root) %{_libdir}/libfolks-tracker.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libfolks-tracker.so.25
197 %{_libdir}/girepository-1.0/FolksTracker-0.6.typelib
198 %dir %{_libdir}/folks/%{abiver}/backends/tracker
199 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/tracker/tracker.so
200 %endif
201 %{_datadir}/GConf/gsettings/folks.convert
202 %{_datadir}/glib-2.0/schemas/org.freedesktop.folks.gschema.xml
203
204 %files devel
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/libfolks.so
207 %attr(755,root,root) %{_libdir}/libfolks-dummy.so
208 %{_datadir}/gir-1.0/Folks-0.6.gir
209 %{_datadir}/gir-1.0/FolksDummy-0.6.gir
210 %{_includedir}/folks
211 %{_pkgconfigdir}/folks.pc
212 %{_pkgconfigdir}/folks-dummy.pc
213 %if %{with evolution}
214 %attr(755,root,root) %{_libdir}/libfolks-eds.so
215 %{_datadir}/gir-1.0/FolksEds-0.6.gir
216 %{_pkgconfigdir}/folks-eds.pc
217 %endif
218 %if %{with telepathy}
219 %attr(755,root,root) %{_libdir}/libfolks-telepathy.so
220 %{_datadir}/gir-1.0/FolksTelepathy-0.6.gir
221 %{_pkgconfigdir}/folks-telepathy.pc
222 %endif
223 %if %{with tracker}
224 %attr(755,root,root) %{_libdir}/libfolks-tracker.so
225 %{_datadir}/gir-1.0/FolksTracker-0.6.gir
226 %{_pkgconfigdir}/folks-tracker.pc
227 %endif
228
229 %if %{with vala}
230 %files -n vala-folks
231 %defattr(644,root,root,755)
232 %{_datadir}/vala/vapi/folks.deps
233 %{_datadir}/vala/vapi/folks.vapi
234 %{_datadir}/vala/vapi/folks-dummy.deps
235 %{_datadir}/vala/vapi/folks-dummy.vapi
236 %if %{with evolution}
237 %{_datadir}/vala/vapi/folks-eds.deps
238 %{_datadir}/vala/vapi/folks-eds.vapi
239 %endif
240 %if %{with telepathy}
241 %{_datadir}/vala/vapi/folks-telepathy.deps
242 %{_datadir}/vala/vapi/folks-telepathy.vapi
243 %endif
244 %if %{with tracker}
245 %{_datadir}/vala/vapi/folks-tracker.deps
246 %{_datadir}/vala/vapi/folks-tracker.vapi
247 %endif
248 %endif
This page took 0.043443 seconds and 4 git commands to generate.