]> git.pld-linux.org Git - packages/fio.git/blob - fio.spec
up to 3.28
[packages/fio.git] / fio.spec
1 # TODO:
2 # - HDFS (hadoop, --enable-libhdfs, requires also java)
3 # - fusion-aw (nvm-primitives): http://opennvm.github.io/
4 # - cuda
5 #
6 # Conditional build:
7 %bcond_without  ceph            # RBD (CephFS) support
8 %bcond_without  glusterfs       # GFAPI support
9 %bcond_without  gtk             # GTK+ based GUI (gfio)
10 %bcond_without  numa            # NUMA support
11 %bcond_without  pmem            # NVM support (using PMDK)
12 #
13 %ifnarch %{x8664} aarch64
14 %undefine       with_pmem
15 %endif
16 Summary:        I/O tool for benchmark and stress/hardware verification
17 Summary(pl.UTF-8):      Narzędzie do mierzenia wydajności I/O i sprawdzania sprawności sprzętu
18 Name:           fio
19 Version:        3.28
20 Release:        1
21 License:        GPL v2+
22 Group:          Applications/System
23 Source0:        http://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2
24 # Source0-md5:  09059eedfe246294049254355cdf2741
25 Patch0:         %{name}-config.patch
26 URL:            http://git.kernel.dk/?p=fio.git;a=summary
27 BuildRequires:  bison
28 %{?with_ceph:BuildRequires:     ceph-devel}
29 BuildRequires:  flex
30 %{?with_glusterfs:BuildRequires:        glusterfs-devel}
31 BuildRequires:  libaio-devel
32 BuildRequires:  libibverbs-devel
33 BuildRequires:  libnfs-devel
34 BuildRequires:  librdmacm-devel
35 BuildRequires:  libzbc-devel
36 BuildRequires:  numactl-devel
37 BuildRequires:  pkgconfig
38 %{?with_pmem:BuildRequires:     pmdk-devel}
39 BuildRequires:  sed >= 4.0
40 BuildRequires:  zlib-devel
41 %if %{with gtk}
42 BuildRequires:  cairo-devel
43 BuildRequires:  glib2-devel >= 2.0
44 BuildRequires:  gtk+2-devel >= 2:2.18.0
45 BuildRequires:  pkgconfig
46 %endif
47 # x86 features detection relies on cpuid
48 ExcludeArch:    i386 i486
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 fio is an I/O tool meant to be used both for benchmark and
53 stress/hardware verification. It has support for 9 different types of
54 I/O engines (sync, mmap, libaio, posixaio, SG v3, splice, null,
55 network, syslet), I/O priorities (for newer Linux kernels), rate I/O,
56 forked or threaded jobs, and much more. It can work on block devices
57 as well as files. fio accepts job descriptions in a
58 simple-to-understand text format. Several example job files are
59 included. fio displays all sorts of I/O performance information. It
60 supports Linux, FreeBSD, and OpenSolaris.
61
62 %description -l pl.UTF-8
63 fio to narzędzie do mierzenia wydajności I/O oraz sprawdzania
64 sprawności sprzętu pod dużym obciążeniem. Obsługuje 9 różnych rodzajów
65 silników I/O (sync, mmap, libaio, posixaio, SG v3, splice, null,
66 network, syslet), priorytety I/O (dla nowszych jąder Linuksa),
67 przepustowość I/O, zadania wieloprocesowe lub wielowątkowe i wiele
68 więcej. Może działać na urządzeniach blokowych oraz na plikach. fio
69 przyjmuje opisy zadań w formacie tekstowym prostym do zrozumienia. Ma
70 załączone kilka przykładowych plików zadań. Wyświetla wszystkie
71 rodzaje informacji o wydajności I/O. Obsługuje Linuksa, FreeBSD i
72 OpenSolarisa.
73
74 %package devel
75 Summary:        Header files for developing FIO engine modules
76 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia modułów silników FIO
77 Group:          Development/Libraries
78
79 %description devel
80 Header files for developing FIO engine modules.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe do tworzenia modułów silników FIO.
84
85 %package -n gfio
86 Summary:        GTK+ based graphical front-end for fio
87 Summary(pl.UTF-8):      Oparty na GTK+ graficzny interfejs do fio
88 Group:          X11/Applications
89 Requires:       %{name} = %{version}-%{release}
90
91 %description -n gfio
92 gfio is a GTK+ based graphical front-end for fio. It is often
93 installed on the testers workstation whereas fio would be installed on
94 the server.
95
96 %description -n gfio -l pl.UTF-8
97 gfio to oparty na GTK+ graficzny interfejs do fio. Zwykle jest
98 instalowany na komputerze testerów, podczas gdy fio jest zainstalowany
99 na serwerze.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104
105 %{__sed} -i -e '1s,/usr/bin/bash,/bin/bash,' tools/genfio
106 %{__sed} -i -e '1s,/usr/bin/env python3$,%{__python3},' tools/{hist/fio-histo-log-pctiles.py,plot/fio2gnuplot,hist/fiologparser_hist.py,fiologparser.py,fio_jsonplus_clat2csv}
107
108 %build
109 ./configure \
110         --cc="%{__cc}" \
111         --extra-cflags="%{rpmcflags} %{rpmcppflags}" \
112         %{!?with_glusterfs:--disable-gfapi} \
113         %{?with_gtk:--enable-gfio} \
114         %{!?with_numa:--disable-numa} \
115         %{!?with_pmem:--disable-pmem} \
116         %{!?with_ceph:--disable-rbd}
117
118 %{__make} \
119         LDFLAGS="%{rpmldflags}" \
120         V=1
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         prefix="%{_prefix}" \
127         mandir="%{_mandir}" \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 # development files for fio modules
131 install -d $RPM_BUILD_ROOT%{_includedir}/fio/{arch,crc,compiler,engines,lib,os/linux,oslib}
132 cp -p blktrace_api.h blktrace.h cairo_text_helpers.h cgroup.h client.h config-host.h debug.h diskutil.h err.h fifo.h file.h filehash.h filelock.h fio.h fio_sem.h fio_time.h flist.h flow.h gclient.h gcompat.h gerror.h gettime.h gfio.h ghelpers.h goptions.h graph.h hash.h helpers.h helper_thread.h idletime.h io_ddir.h ioengines.h iolog.h io_u.h io_u_queue.h json.h log.h minmax.h optgroup.h options.h parse.h printing.h profile.h pshared.h rate-submit.h rwlock.h server.h smalloc.h stat.h steadystate.h td_error.h thread_options.h tickmarks.h trim.h verify.h verify-state.h workqueue.h zbd.h zbd_types.h zone-dist.h $RPM_BUILD_ROOT%{_includedir}/fio
133 cp -p arch/arch.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
134 %ifarch %{ix86} %{x8664} x32
135 cp -p arch/arch-x86.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
136 %endif
137 %ifarch %{x8664} x32
138 cp -p arch/arch-x86_64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
139 %endif
140 %ifarch %{ix86} %{x8664} x32
141 cp -p arch/arch-x86-common.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
142 %endif
143 %ifarch ppc ppc64
144 cp -p arch/arch-ppc.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
145 %endif
146 %ifarch ia64
147 cp -p arch/arch-ia64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
148 %endif
149 %ifarch alpha
150 cp -p arch/arch-ia64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
151 %endif
152 %ifarch s390 s390x
153 cp -p arch/arch-s390.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
154 %endif
155 %ifarch sparc sparcv9 sparc64
156 cp -p arch/arch-sparc.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
157 %endif
158 %ifarch sparc64
159 cp -p arch/arch-sparc64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
160 %endif
161 %ifarch %{arm} aarch64
162 cp -p arch/arch-arm.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
163 %endif
164 %ifarch mips
165 cp -p arch/arch-mips.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
166 %endif
167 %ifarch sh
168 cp -p arch/arch-sh.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
169 %endif
170 %ifarch hppa
171 cp -p arch/arch-hppa.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
172 %endif
173 %ifarch aarch64
174 cp -p arch/arch-aarch64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
175 %endif
176 %ifnarch %{ix86} %{x8664} x32 ppc ppc64 ia64 alpha s390 s390x sparc sparcv9 sparc64 %{arm} mips sh hppa aarch64
177 cp -p arch/arch-generic.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
178 %endif
179 cp -p compiler/compiler.h $RPM_BUILD_ROOT%{_includedir}/fio/compiler
180 cp -p crc/{crc{16,32,32c,64,7},fnv,md5,murmur3,sha{1,256,3,512},test,xxhash}.h $RPM_BUILD_ROOT%{_includedir}/fio/crc
181 cp -p lib/{axmap,bloom,bswap,ffz,fls,gauss,getrusage,hweight,ieee754,lfsr,memalign,memcpy,mountcheck,nowarn_snprintf,num2str,output_buffer,pattern,pow2,prio_tree,rand,rbtree,seqlock,strntol,types,zipf}.h $RPM_BUILD_ROOT%{_includedir}/fio/lib
182 cp -p os/{os,os-linux,os-linux-syscall}.h $RPM_BUILD_ROOT%{_includedir}/fio/os
183 cp -p os/linux/io_uring.h $RPM_BUILD_ROOT%{_includedir}/fio/os/linux
184 cp -p oslib/{asprintf,getopt,inet_aton,libmtd_common,libmtd,libmtd_int,libmtd_xalloc,linux-dev-lookup,strcasestr,strlcat,strndup,strsep}.h $RPM_BUILD_ROOT%{_includedir}/fio/oslib
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %files
190 %defattr(644,root,root,755)
191 %doc GFIO-TODO HOWTO MORAL-LICENSE README REPORTING-BUGS SERVER-TODO STEADYSTATE-TODO examples
192 %attr(755,root,root) %{_bindir}/fio
193 %attr(755,root,root) %{_bindir}/fio-btrace2fio
194 %attr(755,root,root) %{_bindir}/fio-dedupe
195 %attr(755,root,root) %{_bindir}/fio-genzipf
196 %attr(755,root,root) %{_bindir}/fio-histo-log-pctiles.py
197 %attr(755,root,root) %{_bindir}/fio-verify-state
198 %attr(755,root,root) %{_bindir}/fio2gnuplot
199 %attr(755,root,root) %{_bindir}/fio_generate_plots
200 %attr(755,root,root) %{_bindir}/fio_jsonplus_clat2csv
201 %attr(755,root,root) %{_bindir}/fiologparser.py
202 %attr(755,root,root) %{_bindir}/fiologparser_hist.py
203 %attr(755,root,root) %{_bindir}/genfio
204 %{_datadir}/fio
205 %{_mandir}/man1/fio.1*
206 %{_mandir}/man1/fio2gnuplot.1*
207 %{_mandir}/man1/fio_generate_plots.1*
208 %{_mandir}/man1/fiologparser_hist.py.1*
209
210 %files devel
211 %defattr(644,root,root,755)
212 %{_includedir}/fio
213
214 %if %{with gtk}
215 %files -n gfio
216 %defattr(644,root,root,755)
217 %doc GFIO-TODO
218 %attr(755,root,root) %{_bindir}/gfio
219 %endif
This page took 0.346263 seconds and 3 git commands to generate.