]> git.pld-linux.org Git - packages/file-roller.git/blob - file-roller.spec
- updated to 44.3
[packages/file-roller.git] / file-roller.spec
1 # TODO: use gtk4-update-icon-theme
2 #
3 # Conditional build:
4 %bcond_with     apidocs         # API documentation (API not packaged, so disabled for now)
5 %bcond_without  libportal       # native app chooser via libportal
6 %bcond_without  nautilus        # Nautilus extension
7 #
8 Summary:        An archive manager for GNOME
9 Summary(pl.UTF-8):      Zarządca archiwów dla GNOME
10 Summary(pt_BR.UTF-8):   Gerenciador de arquivos compactados para o GNOME
11 Name:           file-roller
12 Version:        44.3
13 Release:        1
14 License:        GPL v2+
15 Group:          X11/Applications
16 Source0:        https://download.gnome.org/sources/file-roller/44/%{name}-%{version}.tar.xz
17 # Source0-md5:  8f309a2af9788b2291512bdf0cd76ffd
18 Patch0:         %{name}-packages.patch
19 URL:            https://wiki.gnome.org/Apps/FileRoller
20 BuildRequires:  cpio
21 BuildRequires:  desktop-file-utils
22 BuildRequires:  docbook-dtd412-xml
23 BuildRequires:  gettext-tools
24 %{?with_apidocs:BuildRequires:  gi-docgen >= 2021.1}
25 BuildRequires:  glib2-devel >= 1:2.38
26 BuildRequires:  gobject-introspection-devel
27 BuildRequires:  gtk4-devel >= 4.8.1
28 BuildRequires:  json-glib-devel >= 0.14.0
29 BuildRequires:  libadwaita-devel >= 1.2
30 BuildRequires:  libarchive-devel >= 3.2.0
31 %{?with_libportal:BuildRequires:        libportal-devel >= 0.5}
32 %{?with_libportal:BuildRequires:        libportal-gtk4-devel >= 0.5}
33 BuildRequires:  meson >= 0.59
34 %{?with_nautilus:BuildRequires: nautilus-devel >= 43}
35 BuildRequires:  ninja >= 1.5
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpmbuild(find_lang) >= 1.23
38 BuildRequires:  rpmbuild(macros) >= 1.736
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  xz
41 BuildRequires:  yelp-tools
42 Requires(post,postun):  desktop-file-utils
43 Requires(post,postun):  glib2 >= 1:2.38
44 Requires(post,postun):  gtk-update-icon-cache
45 Requires:       glib2 >= 1:2.38
46 Requires:       gtk4 >= 4.8.1
47 Requires:       hicolor-icon-theme
48 Requires:       json-glib >= 0.14.0
49 Requires:       libadwaita >= 1.2
50 Requires:       libarchive >= 3.2.0
51 Suggests:       bzip2
52 Suggests:       cpio
53 Suggests:       gzip
54 Suggests:       p7zip
55 %ifarch %{ix86}
56 Suggests:       rar
57 %else
58 Suggests:       unrar
59 %endif
60 Suggests:       tar
61 Suggests:       zip
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 File Roller is an archive manager for the GNOME environment. With File
66 Roller you can: create and modify archives; view the content of an
67 archive; view a file contained in the archive; extract files from the
68 archive. File Roller is only a front-end (a graphical interface) to
69 various archiving programs. The supported file types are:
70 - Tar archives uncompressed (.tar) or compressed with
71  - gzip (.tar.gz , .tgz)
72  - bzip (.tar.bz , .tbz)
73  - bzip2 (.tar.bz2 , .tbz2)
74  - compress (.tar.Z , .taz)
75  - lzop (.tar.lzo , .tzo)
76 - Zip archives (.zip)
77 - Jar archives (.jar , .ear , .war)
78 - Lha archives (.lzh)
79 - Rar archives (.rar)
80 - Single files compressed with gzip, bzip, bzip2, compress, lzop.
81
82 %description -l pl.UTF-8
83 File Roller to zarządca archiwów dla środowiska GNOME. Przy jego
84 pomocy można: tworzyć i modyfikować archiwa, oglądać ich zawartość,
85 oglądać poszczególne pliki zawarte w archiwum oraz rozpakowywać pliki
86 z archiwów. File Roller jest tylko interfejsem graficznym do
87 właściwych programów archiwizujących. Obsługiwane typy plików to:
88 - archiwa tar nieskompresowane (.tar) lub skompresowane programami:
89  - gzip (.tar.gz, .tgz)
90  - bzip (.tar.bz, .tbz)
91  - bzip2 (.tar.bz2, .tbz2)
92  - compress (.tar.Z, .taz)
93  - lzop (.tar.lzo, .tzo)
94 - archiwa zip (.zip)
95 - archiwa jar (.jar, .ear, .war)
96 - archiwa lha (.lzh)
97 - archiwa rar (.rar)
98 - pojedyncze pliki skompresowane programami gzip, bzip, bzip2,
99   compress, lzop.
100
101 %description -l pt_BR.UTF-8
102 File Roller é um gerenciador de pacotes de arquivos compactados para o
103 ambiente GNOME. Com ele é possível criar arquivos, visualizar o
104 conteúdo de arquivos existentes, visualizar um arquivo contido em um
105 pacote e extrair os arquivos de um pacote.
106
107 %package -n nautilus-extension-file-roller
108 Summary:        File Roller (archive manager) extension for Nautilus (GNOME file manager)
109 Summary(pl.UTF-8):      Rozszerzenie File Roller (zarządca archiwów) Nautilusa (zarządcy plików GNOME)
110 Group:          X11/Applications
111 Requires:       %{name} = %{version}-%{release}
112 Requires:       nautilus >= 43
113
114 %description -n nautilus-extension-file-roller
115 File Roller (archive manager) extension for Nautilus (GNOME file
116 manager).
117
118 %description -n nautilus-extension-file-roller -l pl.UTF-8
119 Rozszerzenie File Roller (zarządca archiwów) Nautilusa (zarządcy
120 plików GNOME).
121
122 %prep
123 %setup -q
124 %patch0 -p1
125
126 %build
127 %meson build \
128         %{?with_apidocs:-Dapi_docs=enabled} \
129         -Dintrospection=enabled \
130         %{!?with_nautilus:-Dnautilus-actions=disabled} \
131         %{!?with_libportal:-Duse_native_appchooser=false}
132
133 %ninja_build -C build
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %ninja_install -C build
139
140 # unify name
141 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr@ije,sr@ijekavian}
142 # not supported by glibc (as of 2.38)
143 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
144
145 %find_lang %{name} --with-gnome
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post
151 %update_desktop_database_post
152 %update_icon_cache hicolor
153 %glib_compile_schemas
154
155 %postun
156 %update_desktop_database_postun
157 %update_icon_cache hicolor
158 %glib_compile_schemas
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc AUTHORS MAINTAINERS NEWS README.md README_COMMANDLINE
163 %attr(755,root,root) %{_bindir}/file-roller
164 %dir %{_libexecdir}/file-roller
165 %attr(755,root,root) %{_libexecdir}/file-roller/isoinfo.sh
166 %attr(755,root,root) %{_libexecdir}/file-roller/rpm2cpio
167 %{_datadir}/dbus-1/services/org.gnome.ArchiveManager1.service
168 %{_datadir}/dbus-1/services/org.gnome.FileRoller.service
169 %{_datadir}/file-roller
170 %{_datadir}/glib-2.0/schemas/org.gnome.FileRoller.gschema.xml
171 %{_datadir}/metainfo/org.gnome.FileRoller.appdata.xml
172 %{_desktopdir}/org.gnome.FileRoller.desktop
173 %{_iconsdir}/hicolor/scalable/apps/org.gnome.FileRoller.svg
174 %{_iconsdir}/hicolor/scalable/apps/org.gnome.FileRoller.Devel.svg
175 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.FileRoller-symbolic.svg
176
177 %if %{with nautilus}
178 %files -n nautilus-extension-file-roller
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/nautilus/extensions-4/libnautilus-fileroller.so
181 %endif
This page took 0.117378 seconds and 4 git commands to generate.