]> git.pld-linux.org Git - packages/file-roller.git/blob - file-roller.spec
- updated to 3.42.0
[packages/file-roller.git] / file-roller.spec
1 #
2 # Conditional build:
3 %bcond_without  nautilus        # Nautilus extension
4 #
5 Summary:        An archive manager for GNOME
6 Summary(pl.UTF-8):      Zarządca archiwów dla GNOME
7 Summary(pt_BR.UTF-8):   Gerenciador de arquivos compactados para o GNOME
8 Name:           file-roller
9 Version:        3.42.0
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications
13 Source0:        https://download.gnome.org/sources/file-roller/3.42/%{name}-%{version}.tar.xz
14 # Source0-md5:  c7564ff0532df8b7379a46c895ab4fcd
15 Patch0:         %{name}-packages.patch
16 URL:            https://wiki.gnome.org/Apps/FileRoller
17 BuildRequires:  desktop-file-utils
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  gettext-tools
20 BuildRequires:  glib2-devel >= 1:2.38
21 BuildRequires:  gtk+3-devel >= 3.22.0
22 BuildRequires:  json-glib-devel >= 0.14.0
23 BuildRequires:  libarchive-devel >= 3.2.0
24 BuildRequires:  libhandy1-devel >= 1.5.0
25 BuildRequires:  libnotify-devel >= 0.4.3
26 BuildRequires:  libxml2-progs
27 BuildRequires:  meson >= 0.50
28 %{?with_nautilus:BuildRequires: nautilus-devel >= 3.28.0}
29 BuildRequires:  ninja >= 1.5
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(find_lang) >= 1.23
32 BuildRequires:  rpmbuild(macros) >= 1.736
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRequires:  yelp-tools
36 Requires(post,postun):  desktop-file-utils
37 Requires(post,postun):  glib2 >= 1:2.38
38 Requires(post,postun):  gtk-update-icon-cache
39 Requires:       glib2 >= 1:2.38
40 Requires:       gtk+3 >= 3.22.0
41 Requires:       hicolor-icon-theme
42 Requires:       json-glib >= 0.14.0
43 Requires:       libarchive >= 3.2.0
44 Requires:       libhandy1 >= 1.5.0
45 Requires:       libnotify >= 0.4.3
46 Suggests:       bzip2
47 Suggests:       gzip
48 Suggests:       p7zip
49 %ifarch %{ix86}
50 Suggests:       rar
51 %else
52 Suggests:       unrar
53 %endif
54 Suggests:       tar
55 Suggests:       zip
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 File Roller is an archive manager for the GNOME environment. With File
60 Roller you can: create and modify archives; view the content of an
61 archive; view a file contained in the archive; extract files from the
62 archive. File Roller is only a front-end (a graphical interface) to
63 various archiving programs. The supported file types are:
64 - Tar archives uncompressed (.tar) or compressed with
65  - gzip (.tar.gz , .tgz)
66  - bzip (.tar.bz , .tbz)
67  - bzip2 (.tar.bz2 , .tbz2)
68  - compress (.tar.Z , .taz)
69  - lzop (.tar.lzo , .tzo)
70 - Zip archives (.zip)
71 - Jar archives (.jar , .ear , .war)
72 - Lha archives (.lzh)
73 - Rar archives (.rar)
74 - Single files compressed with gzip, bzip, bzip2, compress, lzop.
75
76 %description -l pl.UTF-8
77 File Roller to zarządca archiwów dla środowiska GNOME. Przy jego
78 pomocy można: tworzyć i modyfikować archiwa, oglądać ich zawartość,
79 oglądać poszczególne pliki zawarte w archiwum oraz rozpakowywać pliki
80 z archiwów. File Roller jest tylko interfejsem graficznym do
81 właściwych programów archiwizujących. Obsługiwane typy plików to:
82 - archiwa tar nieskompresowane (.tar) lub skompresowane programami:
83  - gzip (.tar.gz, .tgz)
84  - bzip (.tar.bz, .tbz)
85  - bzip2 (.tar.bz2, .tbz2)
86  - compress (.tar.Z, .taz)
87  - lzop (.tar.lzo, .tzo)
88 - archiwa zip (.zip)
89 - archiwa jar (.jar, .ear, .war)
90 - archiwa lha (.lzh)
91 - archiwa rar (.rar)
92 - pojedyncze pliki skompresowane programami gzip, bzip, bzip2,
93   compress, lzop.
94
95 %description -l pt_BR.UTF-8
96 File Roller é um gerenciador de pacotes de arquivos compactados para o
97 ambiente GNOME. Com ele é possível criar arquivos, visualizar o
98 conteúdo de arquivos existentes, visualizar um arquivo contido em um
99 pacote e extrair os arquivos de um pacote.
100
101 %package -n nautilus-extension-file-roller
102 Summary:        File Roller (archive manager) extension for Nautilus (GNOME file manager)
103 Summary(pl.UTF-8):      Rozszerzenie File Roller (zarządca archiwów) Nautilusa (zarządcy plików GNOME)
104 Group:          X11/Applications
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       nautilus >= 3.28.0
107
108 %description -n nautilus-extension-file-roller
109 File Roller (archive manager) extension for Nautilus (GNOME file
110 manager).
111
112 %description -n nautilus-extension-file-roller -l pl.UTF-8
113 Rozszerzenie File Roller (zarządca archiwów) Nautilusa (zarządcy
114 plików GNOME).
115
116 %prep
117 %setup -q
118 %patch0 -p1
119
120 %build
121 %meson build
122
123 %ninja_build -C build \
124         %{!?with_nautilus:-Dnautilus-actions=false}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %ninja_install -C build
130
131 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr@ije,sr@ijekavian}
132
133 %find_lang %{name} --with-gnome
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post
139 %update_desktop_database_post
140 %update_icon_cache hicolor
141 %glib_compile_schemas
142
143 %postun
144 %update_desktop_database_postun
145 %update_icon_cache hicolor
146 %glib_compile_schemas
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS MAINTAINERS NEWS README.md README_COMMANDLINE
151 %attr(755,root,root) %{_bindir}/file-roller
152 %dir %{_libexecdir}/file-roller
153 %attr(755,root,root) %{_libexecdir}/file-roller/isoinfo.sh
154 %attr(755,root,root) %{_libexecdir}/file-roller/rpm2cpio
155 %{_datadir}/dbus-1/services/org.gnome.ArchiveManager1.service
156 %{_datadir}/dbus-1/services/org.gnome.FileRoller.service
157 %{_datadir}/file-roller
158 %{_datadir}/glib-2.0/schemas/org.gnome.FileRoller.gschema.xml
159 %{_datadir}/metainfo/org.gnome.FileRoller.appdata.xml
160 %{_desktopdir}/org.gnome.FileRoller.desktop
161 %{_iconsdir}/hicolor/scalable/apps/org.gnome.ArchiveManager.svg
162 %{_iconsdir}/hicolor/scalable/apps/org.gnome.ArchiveManager.Devel.svg
163 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.ArchiveManager-symbolic.svg
164
165 %if %{with nautilus}
166 %files -n nautilus-extension-file-roller
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/nautilus/extensions-3.0/libnautilus-fileroller.so
169 %endif
This page took 0.042788 seconds and 4 git commands to generate.