]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- use install-headers to install headers
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # How to deal with ffmpeg/opencv checken-egg problem:
3 #       1. make-request -r --without opencv ffmpeg.spec
4 #       2. make-request -r opencv.spec
5 #       3. bump release of ffmpeg.spec
6 #       4. make-request -r ffmpeg.spec
7 #
8 # Conditional build:
9 %bcond_with     nonfree         # non free options of package (currently: faac)
10 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
11 %bcond_with     fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
12 %bcond_without  caca            # textual display using libcaca
13 %bcond_without  flite           # flite voice synthesis support
14 %bcond_without  frei0r          # frei0r video filtering
15 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
16 %bcond_without  openal          # OpenAL 1.1 capture support
17 %bcond_without  opencv          # OpenCV video filtering
18 %bcond_without  pulseaudio      # PulseAudio input support
19 %bcond_without  x264            # x264 encoder
20 %bcond_without  utvideo         # Ut Video decoder
21 %bcond_without  va              # VAAPI (Video Acceleration API)
22 %bcond_without  vpx             # VP8, a high-quality video codec
23 %bcond_without  doc             # don't build docs
24
25 Summary:        FFmpeg - a very fast video and audio converter
26 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
27 Name:           ffmpeg
28 Version:        1.0.1
29 Release:        1
30 # LGPL or GPL, chosen at configure time (GPL version is more featured)
31 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
32 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
33 License:        GPL v3+ with LGPL v3+ parts
34 Group:          Applications/Multimedia
35 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
36 # Source0-md5:  dbbb88ce5525dea22b24aaa098a9bcc2
37 Source1:        ffserver.init
38 Source2:        ffserver.sysconfig
39 Source3:        ffserver.conf
40 Patch0:         %{name}-gsm.patch
41 Patch1:         %{name}-opencv24.patch
42 Patch2:         %{name}-openjpeg.patch
43 Patch3:         %{name}-cdio-paranoia.patch
44 URL:            http://www.ffmpeg.org/
45 %{?with_openal:BuildRequires:   OpenAL-devel}
46 BuildRequires:  SDL-devel >= 1.2.1
47 BuildRequires:  alsa-lib-devel
48 BuildRequires:  bzip2-devel
49 BuildRequires:  celt-devel >= 0.11.0
50 %{?with_nonfree:BuildRequires:  faac-devel}
51 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
52 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
53 BuildRequires:  fontconfig-devel
54 BuildRequires:  freetype-devel
55 %{?with_frei0r:BuildRequires:   frei0r-devel}
56 %ifarch ppc
57 # require version with altivec support fixed
58 BuildRequires:  gcc >= 5:3.3.2-3
59 %endif
60 BuildRequires:  gnutls-devel
61 BuildRequires:  jack-audio-connection-kit-devel
62 BuildRequires:  lame-libs-devel >= 3.98.3
63 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
64 BuildRequires:  libass-devel
65 BuildRequires:  libavc1394-devel
66 BuildRequires:  libbluray-devel
67 %{?with_caca:BuildRequires:     libcaca-devel}
68 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
69 BuildRequires:  libdc1394-devel >= 2
70 BuildRequires:  libgsm-devel
71 BuildRequires:  libiec61883-devel
72 BuildRequires:  libmodplug-devel
73 BuildRequires:  libnut-devel
74 BuildRequires:  libraw1394-devel >= 2
75 BuildRequires:  librtmp-devel
76 BuildRequires:  libtheora-devel >= 1.0-0.beta3
77 BuildRequires:  libtool >= 2:1.4d-3
78 BuildRequires:  libv4l-devel
79 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
80 BuildRequires:  libvdpau-devel >= 0.2
81 BuildRequires:  libvorbis-devel
82 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.6}
83 # X264_BUILD >= 118
84 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
85 %ifarch %{ix86}
86 %ifnarch i386 i486
87 BuildRequires:  nasm
88 %endif
89 %endif
90 BuildRequires:  opencore-amr-devel
91 %{?with_opencv:BuildRequires:   opencv-devel}
92 BuildRequires:  openjpeg-devel >= 1.5
93 BuildRequires:  opus-devel
94 BuildRequires:  perl-Encode
95 BuildRequires:  perl-tools-pod
96 BuildRequires:  pkgconfig
97 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
98 BuildRequires:  rpmbuild(macros) >= 1.470
99 BuildRequires:  schroedinger-devel
100 BuildRequires:  speex-devel >= 1:1.2-rc1
101 %{?with_doc:BuildRequires:      tetex}
102 %{?with_doc:BuildRequires:      texi2html}
103 %{?with_doc:BuildRequires:      texinfo}
104 BuildRequires:  twolame-devel
105 %{?with_utvideo:BuildRequires:  utvideo-devel}
106 BuildRequires:  vo-aacenc-devel
107 BuildRequires:  vo-amrwbenc-devel
108 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
109 BuildRequires:  xavs-devel
110 BuildRequires:  xorg-lib-libXext-devel
111 BuildRequires:  xorg-lib-libXfixes-devel
112 BuildRequires:  xvid-devel >= 1:1.1.0
113 BuildRequires:  yasm
114 BuildRequires:  zlib-devel
115 %{?with_autoreqdep:BuildConflicts:      libpostproc}
116 # overflows maximum hash table size
117 BuildConflicts: pdksh < 5.2.14-57
118 Requires:       %{name}-libs = %{version}-%{release}
119 %{?with_ilbc:Requires:  webrtc-libilbc}
120 Requires:       xvid >= 1:1.1.0
121 Obsoletes:      libpostproc
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
125
126 %define         specflags       -fno-strict-aliasing
127
128 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
129 %define         specflags_ia32  -fomit-frame-pointer
130 # -mmmx is needed to enable <mmintrin.h> code.
131 %define         specflags_i586  -mmmx
132 %define         specflags_i686  -mmmx
133 %define         specflags_ppc   -fPIC
134
135 %description
136 FFmpeg is a complete solution to record, convert and stream audio and
137 video. It is a command line tool to convert one video file format to
138 another. It also supports grabbing and encoding in real time from a TV
139 card.
140
141 %description -l pl.UTF-8
142 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
143 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
144 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
145 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
146 telewizyjnej.
147
148 %package libs
149 Summary:        ffmpeg libraries
150 Summary(pl.UTF-8):      Biblioteki ffmpeg
151 Group:          Libraries
152
153 %description libs
154 This package contains the ffmpeg shared libraries:
155 - the codec library (libavcodec). It supports most existing encoding
156   formats (MPEG, DivX, MPEG4, AC3, DV...),
157 - demuxer library (libavformat). It supports most existing file
158   formats (AVI, MPEG, OGG, Matroska, ASF...),
159 - video postprocessing library (libpostproc).
160
161 %description libs -l pl.UTF-8
162 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
163 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
164   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
165 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
166   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
167 - bibliotekę postprocessingu (libpostproc).
168
169 %package devel
170 Summary:        ffmpeg header files
171 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
172 Group:          Development/Libraries
173 Requires:       %{name}-libs = %{version}-%{release}
174 # Libs.private from *.pc (unreasonably they are all the same)
175 Requires:       SDL-devel >= 1.2.1
176 Requires:       alsa-lib-devel
177 Requires:       bzip2-devel
178 Requires:       celt-devel >= 0.11.0
179 %{?with_nonfree:Requires:       faac-devel}
180 %{?with_fdk_aac:Requires:       fdk-aac-devel}
181 Requires:       fontconfig-devel
182 Requires:       freetype-devel
183 Requires:       jack-audio-connection-kit-devel
184 %{?with_flite:Requires: flite-devel >= 1.4}
185 Requires:       lame-libs-devel >= 3.98.3
186 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
187 Requires:       libass-devel
188 Requires:       libavc1394-devel
189 Requires:       libbluray-devel
190 Requires:       libcdio-paranoia-devel >= 0.90-2
191 Requires:       libdc1394-devel >= 2
192 Requires:       libgsm-devel
193 Requires:       libiec61883-devel
194 Requires:       libmodplug-devel
195 Requires:       libnut-devel
196 Requires:       libraw1394-devel >= 2
197 Requires:       librtmp-devel
198 Requires:       libtheora-devel >= 1.0-0.beta3
199 %{?with_va:Requires:    libva-devel >= 1.0.3}
200 Requires:       libvorbis-devel
201 %{?with_vpx:Requires:   libvpx-devel >= 0.9.6}
202 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
203 Requires:       opencore-amr-devel
204 %{?with_opencv:Requires:        opencv-devel}
205 Requires:       openjpeg-devel >= 1.5
206 Requires:       schroedinger-devel
207 Requires:       speex-devel >= 1:1.2-rc1
208 Requires:       twolame-devel
209 Requires:       vo-aacenc-devel
210 Requires:       vo-amrwbenc-devel
211 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
212 Requires:       xavs-devel
213 Requires:       xorg-lib-libXext-devel
214 Requires:       xorg-lib-libXfixes-devel
215 Requires:       xvid-devel >= 1:1.1.0
216 Requires:       zlib-devel
217 Obsoletes:      libpostproc-devel
218
219 %description devel
220 ffmpeg header files.
221
222 %description devel -l pl.UTF-8
223 Pliki nagłówkowe ffmpeg.
224
225 %package static
226 Summary:        ffmpeg static libraries
227 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
228 Group:          Development/Libraries
229 Requires:       %{name}-devel = %{version}-%{release}
230
231 %description static
232 ffmpeg static libraries (libavcodec and libavformat).
233
234 %description static -l pl.UTF-8
235 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
236
237 %package ffplay
238 Summary:        FFplay - SDL-based media player
239 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
240 Group:          Applications/Multimedia
241 Requires:       %{name}-libs = %{version}-%{release}
242
243 %description ffplay
244 FFplay is a very simple and portable media player using the FFmpeg
245 libraries and the SDL library. It is mostly used as a test bench for
246 the various APIs of FFmpeg.
247
248 %description ffplay -l pl.UTF-8
249 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
250 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
251 testowania różnych API FFmpeg.
252
253 %package ffserver
254 Summary:        FFserver video server
255 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
256 Group:          Daemons
257 Requires(post,preun):   /sbin/chkconfig
258 Requires:       %{name}-libs = %{version}-%{release}
259 Requires:       rc-scripts >= 0.4.0.10
260
261 %description ffserver
262 FFserver is a streaming server for both audio and video. It supports
263 several live feeds, streaming from files and time shifting on live
264 feeds (you can seek to positions in the past on each live feed,
265 provided you specify a big enough feed storage in ffserver.conf).
266
267 %description ffserver -l pl.UTF-8
268 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
269 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
270 czasie dla źródeł na żywo (można przeskakiwać na położenia w
271 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
272 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
273
274 %prep
275 %setup -q
276 %patch0 -p1
277 %patch1 -p0
278 %patch2 -p1
279 %patch3 -p1
280
281 # package the grep result for mplayer, the result formatted as ./mplayer/configure
282 cat <<EOF > ffmpeg-avconfig
283 #! /bin/sh
284 _libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
285 _libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
286 _libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
287 _libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
288 _libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
289 _libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
290 _libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
291 EOF
292 cat <<'EOF' >> ffmpeg-avconfig
293
294 case "$1" in
295 --decoders)
296         echo $_libavdecoders_all
297         ;;
298 --encoders)
299         echo $_libavencoders_all
300         ;;
301 --parsers)
302         echo $_libavparsers_all
303         ;;
304 --bsfs)
305         echo $_libavbsfs_all
306         ;;
307 --demuxers)
308         echo $_libavdemuxers_all
309         ;;
310 --muxers)
311         echo $_libavmuxers_all
312         ;;
313 --protocols)
314         echo $_libavprotocols_all
315         ;;
316 *)
317         cat <<USAGE
318 Usage: $0 [OPTION]
319 Options:
320   --decoders
321   --encoders
322   --parsers
323   --bsfs
324   --demuxers
325   --muxers
326   --protocols
327 USAGE
328         exit 1;;
329 esac
330
331 exit 0
332 EOF
333
334 %build
335 # notes:
336 # - it's not autoconf configure
337 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
338 ./configure \
339         --arch=%{_target_base_arch} \
340         --prefix=%{_prefix} \
341         --libdir=%{_libdir} \
342         --shlibdir=%{_libdir} \
343         --mandir=%{_mandir} \
344         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
345         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
346         --cc="%{__cc}" \
347         --disable-debug \
348         --disable-optimizations \
349         --disable-stripping \
350         --enable-avfilter \
351         --enable-avresample \
352         --enable-gnutls \
353         --enable-gpl \
354         --enable-version3 \
355         --enable-fontconfig \
356         %{?with_frei0r:--enable-frei0r} \
357         %{?with_aacplus:--enable-libaacplus} \
358         --enable-libass \
359         --enable-libbluray \
360         %{?with_caca:--enable-libcaca} \
361         --enable-libcelt \
362         --enable-libcdio \
363         --enable-libdc1394 \
364         %{?with_fdk_aac:--enable-libfdk-aac} \
365         %{?with_flite:--enable-libflite} \
366         --enable-libfreetype \
367         --enable-libgsm \
368         --enable-libiec61883 \
369         %{?with_ilbc:--enable-libilbc} \
370         --enable-libmodplug \
371         --enable-libmp3lame \
372         --enable-libnut \
373         --enable-libopencore-amrnb \
374         --enable-libopencore-amrwb \
375         %{?with_opencv:--enable-libopencv} \
376         --enable-libopenjpeg \
377         --enable-libopus \
378         %{?with_pulseaudio:--enable-libpulse} \
379         --enable-librtmp \
380         --enable-libschroedinger \
381         --enable-libspeex \
382         --enable-libtheora \
383         --enable-libtwolame \
384         %{?with_utvideo:--enable-libutvideo} \
385         --enable-libv4l2 \
386         --enable-libvo-aacenc \
387         --enable-libvo-amrwbenc \
388         --enable-libvorbis \
389         %{?with_vpx:--enable-libvpx} \
390         %{?with_x264:--enable-libx264} \
391         --enable-libxavs \
392         --enable-libxvid \
393         %{?with_openal:--enable-openal} \
394         --enable-postproc \
395         --enable-pthreads \
396         --enable-shared \
397         --enable-swscale \
398         %{?with_va:--enable-vaapi} \
399         --enable-vdpau \
400         --enable-x11grab \
401 %ifnarch %{ix86} %{x8664}
402         --disable-mmx \
403 %endif
404 %ifarch i386 i486
405         --disable-mmx \
406 %endif
407 %if %{with nonfree}
408         --enable-nonfree \
409         --enable-libfaac \
410 %endif
411         --enable-runtime-cpudetect
412
413 # force oldscaler build
414 %{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
415
416 %{__make} \
417         V=1
418
419 # CC_O to add -c to commandline. makefile should be patched
420 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
421
422 %install
423 rm -rf $RPM_BUILD_ROOT
424 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
425         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
426         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
427
428 %{__make} install install-headers \
429         DESTDIR=$RPM_BUILD_ROOT \
430         V=1
431
432 # install nonstandard, non-public headers manually
433 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
434 for a in libavutil/*/bswap.h; do
435         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
436 done
437 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
438 # for lim-omx ffmpeg components
439 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
440
441 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
442 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
443 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
444 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
445 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
446
447 # install as ffmpeg-avconfig to avoid with possible programs looking for
448 # ffmpeg-config and expecting --libs output from it which is not implemented
449 # simple to do (by querying pkgconfig), but why?
450 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %post   libs -p /sbin/ldconfig
456 %postun libs -p /sbin/ldconfig
457
458 %pre ffserver
459 %groupadd -g 167 ffserver
460 %useradd -g ffserver -u 167 ffserver
461
462 %post ffserver
463 /sbin/chkconfig --add ffserver
464 %service ffserver restart
465
466 %preun ffserver
467 if [ "$1" = 0 ]; then
468         %service ffserver stop
469         /sbin/chkconfig --del ffserver
470 fi
471
472 %postun ffserver
473 if [ "$1" = 0 ]; then
474         %userremove ffserver
475         %groupremove ffserver
476 fi
477
478 %files
479 %defattr(644,root,root,755)
480 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
481 %attr(755,root,root) %{_bindir}/ffmpeg
482 %attr(755,root,root) %{_bindir}/ffprobe
483 %attr(755,root,root) %{_bindir}/qt-faststart
484 %dir %{_datadir}/ffmpeg
485 %{_datadir}/ffmpeg/*.ffpreset
486 %{_datadir}/ffmpeg/ffprobe.xsd
487 %{?with_doc:%{_mandir}/man1/ffmpeg.1*}
488 %{?with_doc:%{_mandir}/man1/ffprobe.1*}
489
490 %files libs
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
493 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
494 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
495 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
496 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
497 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
498 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
499 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
500 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
501 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.0
502 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
503 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
504 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
505 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
506 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
507 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
508 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
509 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
510
511 %files devel
512 %defattr(644,root,root,755)
513 %doc doc/optimization.txt
514 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
515 %attr(755,root,root) %{_libdir}/libavcodec.so
516 %attr(755,root,root) %{_libdir}/libavdevice.so
517 %attr(755,root,root) %{_libdir}/libavfilter.so
518 %attr(755,root,root) %{_libdir}/libavformat.so
519 %attr(755,root,root) %{_libdir}/libavresample.so
520 %attr(755,root,root) %{_libdir}/libavutil.so
521 %attr(755,root,root) %{_libdir}/libpostproc.so
522 %attr(755,root,root) %{_libdir}/libswresample.so
523 %attr(755,root,root) %{_libdir}/libswscale.so
524 %{_includedir}/ffmpeg
525 %{_includedir}/libavcodec
526 %{_includedir}/libavdevice
527 %{_includedir}/libavfilter
528 %{_includedir}/libavformat
529 %{_includedir}/libavresample
530 %{_includedir}/libavutil
531 %{_includedir}/libpostproc
532 %{_includedir}/libswresample
533 %{_includedir}/libswscale
534 %{_pkgconfigdir}/libavcodec.pc
535 %{_pkgconfigdir}/libavdevice.pc
536 %{_pkgconfigdir}/libavfilter.pc
537 %{_pkgconfigdir}/libavformat.pc
538 %{_pkgconfigdir}/libavresample.pc
539 %{_pkgconfigdir}/libavutil.pc
540 %{_pkgconfigdir}/libpostproc.pc
541 %{_pkgconfigdir}/libswresample.pc
542 %{_pkgconfigdir}/libswscale.pc
543
544 %files static
545 %defattr(644,root,root,755)
546 %{_libdir}/libavcodec.a
547 %{_libdir}/libavdevice.a
548 %{_libdir}/libavfilter.a
549 %{_libdir}/libavformat.a
550 %{_libdir}/libavresample.a
551 %{_libdir}/libavutil.a
552 %{_libdir}/libpostproc.a
553 %{_libdir}/libswresample.a
554 %{_libdir}/libswscale.a
555
556 %files ffplay
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_bindir}/ffplay
559 %{?with_doc:%{_mandir}/man1/ffplay.1*}
560
561 %files ffserver
562 %defattr(644,root,root,755)
563 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
564 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
565 %attr(755,root,root) %{_sbindir}/ffserver
566 %attr(754,root,root) /etc/rc.d/init.d/ffserver
567 %{?with_doc:%{_mandir}/man1/ffserver.1*}
568 %dir %attr(770,root,ffserver) /var/cache/ffserver
569 %dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.073866 seconds and 4 git commands to generate.