]> git.pld-linux.org Git - packages/exim.git/blob - exim.spec
- main spec file rework.
[packages/exim.git] / exim.spec
1 Summary:        University of Cambridge Mail Transfer Agent 
2 Name:           exim
3 Version:        2.12
4 Release:        10
5 Copyright:      GPL
6 Group:          Daemons
7 Source0:        ftp://ftp.cus.cam.ac.uk/pub/software/programs/exim/%{name}-%version}.tar.gz
8 Source1:        ftp://ftp.cus.cam.ac.uk/pub/software/programs/exim/exim-texinfo-2.10.tar.gz
9 Source2:        exim.init
10 Source3:        exim.cron.db
11 Source4:        exim.8
12 Source5:        analyse-log-errors
13 Source6:        one-line-queuelist
14 Source6:        EDITME
15 Source7:        Makefile-Linux
16 Source8:        eximon.conf
17 Source9:        exim.aliases
18 Source10:       exim.conf
19 Source11:       newaliases
20 Source12:       exim.lorrotate
21 Provides:       smtpdaemon
22 BuildRoot:      /tmp/%{name}-%version}root
23
24 %description
25 Smail like Mail Transfer Agent with single configuration file. Features:
26 flexible retry algorithms, header & envelope rewriting, multiple deliveries
27 down single connection or multiple deliveries in parallel, regular
28 expressions in configuration parameters, file lookups, supports sender
29 and/or reciever verification, selective relaying, supports virtual domains,
30 built-in mail filtering and can be configured to drop root privilleges when
31 possible.
32
33 %package X11
34 Summary:        X windows based Exim administration tool
35 Group:          X11/Utilities
36
37 %description X11
38 X windows based monitor & administration utility for the Exim Mail Transfer
39 Agent.
40
41 %prep
42 %setup -T -b 0
43 %setup -T -D -a 1
44 mkdir -p Local
45 cp $RPM_SOURCE_DIR/EDITME Local/Makefile
46 cp $RPM_SOURCE_DIR/Makefile-Linux Local/
47 cp $RPM_SOURCE_DIR/eximon.conf Local/
48
49 %build
50 make "CFLAGS=$RPM_OPT_FLAGS"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT/etc/{cron.{daily,weekly},logrotate.d,rc.d/init.d,sysconfig} \
55         $RPM_BUILD_ROOT/usr/{bin,lib,man/man8,sbin}
56
57 install -m4755 -g root -o root build-Linux-i386/exim $RPM_BUILD_ROOT/usr/bin
58 install build-Linux-i386/exim_fixdb $RPM_BUILD_ROOT/usr/bin
59 install build-Linux-i386/exim_tidydb $RPM_BUILD_ROOT/usr/bin
60 install build-Linux-i386/exim_dbmbuild $RPM_BUILD_ROOT/usr/bin
61 install build-Linux-i386/eximon.bin $RPM_BUILD_ROOT/usr/bin
62 install build-Linux-i386/eximon $RPM_BUILD_ROOT/usr/bin
63 install build-Linux-i386/exim_dumpdb $RPM_BUILD_ROOT/usr/bin
64 install build-Linux-i386/exicyclog $RPM_BUILD_ROOT/usr/bin
65 install build-Linux-i386/exim_lock $RPM_BUILD_ROOT/usr/bin
66 install build-Linux-i386/exinext $RPM_BUILD_ROOT/usr/bin
67 install build-Linux-i386/exiwhat $RPM_BUILD_ROOT/usr/bin
68 install util/exigrep $RPM_BUILD_ROOT/usr/bin
69 install util/eximstats $RPM_BUILD_ROOT/usr/bin
70 install util/exiqsumm $RPM_BUILD_ROOT/usr/bin 
71 install util/unknownuser.sh $RPM_BUILD_ROOT/usr/bin
72 install util/transport-filter.pl $RPM_BUILD_ROOT/usr/bin
73 install $RPM_SOURCE_DIR/analyse-log-errors $RPM_BUILD_ROOT/usr/bin
74 install $RPM_SOURCE_DIR/one-line-queuelist $RPM_BUILD_ROOT/usr/bin
75 install $RPM_SOURCE_DIR/newaliases $RPM_BUILD_ROOT/usr/bin
76 cp -f $RPM_SOURCE_DIR/exim.sc $RPM_BUILD_ROOT/etc/sysconfig/exim
77 cp -f $RPM_SOURCE_DIR/exim.lr $RPM_BUILD_ROOT/etc/logrotate.d/exim
78 install $RPM_SOURCE_DIR/exim.conf $RPM_BUILD_ROOT/etc
79
80 ln -s /usr/bin/exim $RPM_BUILD_ROOT/usr/sbin/sendmail
81 ln -s /usr/bin/exim $RPM_BUILD_ROOT/usr/lib/sendmail
82 ln -s /usr/bin/exim $RPM_BUILD_ROOT/usr/sbin/mailq
83 ln -s /usr/bin/exim $RPM_BUILD_ROOT/usr/sbin/rsmtp
84 ln -s /usr/bin/exim $RPM_BUILD_ROOT/usr/sbin/rmail
85 ln -s /usr/bin/exim $RPM_BUILD_ROOT/usr/sbin/runq
86
87 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/exim
88 install  $RPM_BUILD_ROOT/etc/cron.daily
89 cp -a $RPM_SOURCE_DIR/exim.cron.log $RPM_BUILD_ROOT/etc/cron.weekly
90
91 install $RPM_SOURCE_DIR/exim.8 $RPM_BUILD_ROOT/usr/man/man8
92 install $RPM_SOURCE_DIR/aliases $RPM_BUILD_ROOT/etc/aliases
93
94 strip $RPM_BUILD_ROOT/usr/{bin,sbin}/*
95
96 gzip -9nf $RPM_BUILD_ROOT/usr/man/man8/*
97
98 %post
99 /sbin/chkconfig --add exim
100 if test -r /var/run/exim.pid; then
101         /etc/rc.d/init.d/exim stop >&2
102         /etc/rc.d/init.d/exim start >&2
103 else
104         echo "Run \"/etc/rc.d/init.d/exim start\" to start exim daemon."
105 fi
106
107 %preun
108 if [ "$1" = "0" ]; then
109         /sbin/chkconfig --del exim
110         /etc/rc.d/init.d/exim stop >&2
111 fi
112
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc README* NOTICE LICENCE 
120 %config /etc/exim.conf
121 %config /etc/aliases
122 %attr(640,root,root) %config(noreplace) /etc/sysconfig/exim
123 %config /etc/logrotate.d/exim
124 %attr(754,root,root) /etc/rc.d/init.d/exim
125 /usr/bin/exim
126 /usr/bin/exim_dumpdb
127 /usr/bin/exim_fixdb
128 /usr/bin/exim_tidydb
129 /usr/bin/exinext
130 /usr/bin/exiwhat
131 /usr/bin/exim_dbmbuild
132 /usr/bin/exicyclog
133 /usr/bin/exigrep
134 /usr/bin/eximstats
135 /usr/bin/exiqsumm
136 /usr/bin/unknownuser.sh
137 /usr/bin/transport-filter.pl
138 /usr/man/man8/*
139
140 /usr/sbin/sendmail
141 /usr/sbin/mailq
142 /usr/sbin/rsmtp
143 /usr/sbin/runq
144 /usr/sbin/rmail
145 /etc/cron.daily/exim.cron.db
146 /etc/cron.weekly/exim.cron.log
147 /usr/bin/newaliases
148
149 %files X11
150 /usr/bin/eximon
151 /usr/bin/eximon.bin
152
153 %changelog
154 * Mon May  3 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
155   [2.12-10]
156 - added %post{un} sections with automated restart/stop exim on
157   upgrade/uninstall,
158 - removed %config from binaries,
159 - removed LICENCE from %doc (exim is GPL),
160 - added %clean section,
161 - removed ps, html and pdf documentation (can be generated from info).
162
163 * Thu Mar 4 1999 Florian Wallner <wallner@speed-link.de>
164  - Build package of version 2.12
165  - uses logrotate now, though exicyclog still gets installed.
166  - all binaries and scripts reside in /usr/bin
167  - config file is now /etc/exim.conf
168  - added Procmail Transport and Director to the sample exim.conf.
169  - added 'newaliases' and modified the alias director to do a dbm lookup.
170  - I did all this to seamlessly replace Sendmail on a RH installation. 
171
172 * Wed Dec 21 1998 Arkadi E. Shislov <arkadi@kvin.lv>
173   - Build package with changes provided by Andrew Inggs <aminggs@leviathan.cs.sun.ac.za>
174
175 * Fri Nov 20 1998 Arkadi E. Shislov <arkadi@kvin.lv>
176   - Build package based on 2.05 offical release (glibc).
177
178 * Fri Aug 21 1998 Arkadi E. Shislov <arkadi@kvin.lv>
179   - Build package based on 2.02 offical release (glibc).
180
181 * Sat Apr 11 1998 Hans Grobler <grobh@sun.ac.za>
182   - Build package based on 1.90 offical release (glibc).
183
184 * Sun Dec 22 1997 Hans Grobler <grobh@sun.ac.za>
185   - Build package based on 1.82 offical release (glibc).
186
187 * Fri Dec 11 1997 Hans Grobler <grobh@sun.ac.za>
188   - Build package based on 1.81 offical release (glibc).
189
190 * Sat Oct 11 1997 Hans Grobler <grobh@nolian.ee.sun.ac.za>
191   - Added signal handler patch.
192   - Build package based on 1.73 offical release (glibc).
193
194 * Wed Oct 7 1997 Hans Grobler <grobh@nolian.ee.sun.ac.za>
195   - Build package based on 1.73 offical release.
196
197 * Tue Sep 15 1997 Hans Grobler <grobh@nolian.ee.sun.ac.za>
198   - Build package based on 1.71 offical release.
199   - Add latest documentation.
200
201 * Sun Aug 10 1997 Hans Grobler <grobh@nolian.ee.sun.ac.za>
202   - Added new default configuration file.
203   - Add smail compatible links (runq/rmail/rsmtp).
204   - Intall the exiqsumm script.
205
206 * Sat Aug  2 1997 Hans Grobler <grobh@nolian.ee.sun.ac.za>
207   - Build package based on 1.653 test release.
This page took 0.039111 seconds and 4 git commands to generate.