]> git.pld-linux.org Git - packages/exact-image.git/blob - exact-image.spec
- added evas patch (fixes build with evas 1.8+)
[packages/exact-image.git] / exact-image.spec
1 #
2 # Conditional build:
3 %bcond_without  evas    # Edisplay support
4 %bcond_without  gif     # GIF support
5 %bcond_without  lua     # Lua API
6 %bcond_without  perl    # Perl API
7 %bcond_with     php     # PHP API
8 %bcond_without  python  # Python API
9
10 %ifarch %{x8664}
11 %undefine       with_lua
12 %undefine       with_perl
13 %undefine       with_python
14 %endif
15 Summary:        A fast, modern and generic image processing library
16 Summary(pl.UTF-8):      Szybka, nowoczesna i ogólna biblioteka do przetwarzania obrazu
17 Name:           exact-image
18 Version:        0.8.9
19 Release:        2
20 License:        GPL v2
21 Group:          Applications/Graphics
22 Source0:        http://dl.exactcode.de/oss/exact-image/%{name}-%{version}.tar.bz2
23 # Source0-md5:  a8694722cd7cc9aa9407950a8440f0cd
24 Patch0:         %{name}-libs.patch
25 Patch1:         exactimage_0.8.5-1.patch
26 Patch2:         %{name}-giflib.patch
27 Patch3:         %{name}-evas.patch
28 URL:            http://www.exactcode.de/site/open_source/exactimage/
29 BuildRequires:  OpenEXR-devel >= 1.2.0
30 BuildRequires:  agg-devel >= 2.3
31 %{?with_evas:BuildRequires:     evas-devel >= 0.9.9}
32 BuildRequires:  expat-devel
33 # pkgconfig(freetype) >= 9.5.0
34 BuildRequires:  freetype-devel >= 2.1.6
35 %{?with_gif:BuildRequires:      giflib-devel >= 5}
36 BuildRequires:  jasper-devel
37 BuildRequires:  lcms-devel >= 1.10
38 BuildRequires:  libjpeg-devel
39 BuildRequires:  libpng-devel >= 2:1.5
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtiff-devel
42 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
43 BuildRequires:  perl-devel >= 1:5.8.0
44 %{?with_php:BuildRequires:      php-devel >= 5.2.0}
45 %{?with_python:BuildRequires:   python-devel >= 1:2.5.0}
46 BuildRequires:  ruby-devel >= 1.8.5
47 %{?with_perl:BuildRequires:     swig-perl >= 1.3.32}
48 %{?with_php:BuildRequires:      swig-php >= 1.3.32}
49 %{?with_python:BuildRequires:   swig-python >= 1.3.32}
50 BuildRequires:  xorg-lib-libX11-devel >= 1.3
51 BuildRequires:  zlib-devel
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 A fast, modern and generic (template based) C++ image processing
56 library, alternative to ImageMagick.
57
58 %description -l pl.UTF-8
59 Szybka, nowoczesna i ogólna (oparta na szablonach) biblioteka C++
60 do przetwarzania obrazu, będąca alternatywą dla biblioteki
61 ImageMagick.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69
70 %build
71 ./configure \
72         --prefix=%{_prefix} \
73         %{!?with_evas:--without-evas} \
74         %{!?with_gif:--without-libungif} \
75         %{!?with_lua:--without-lua} \
76         %{!?with_perl:--without-perl} \
77         %{!?with_php:--without-php} \
78         %{!?with_python:--without-python}
79
80 %{__make} \
81         CFLAGS="%{rpmcflags}" \
82         CXXFLAGS="%{rpmcflags}" \
83         Q=
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT \
90         Q=
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc README TODO
98 %attr(755,root,root) %{_bindir}/bardecode
99 %attr(755,root,root) %{_bindir}/e2mtiff
100 %attr(755,root,root) %{_bindir}/econvert
101 %attr(755,root,root) %{_bindir}/edentify
102 %{?with_evas:%attr(755,root,root) %{_bindir}/edisplay}
103 %attr(755,root,root) %{_bindir}/empty-page
104 %attr(755,root,root) %{_bindir}/hocr2pdf
105 %attr(755,root,root) %{_bindir}/optimize2bw
This page took 0.07364 seconds and 4 git commands to generate.