]> git.pld-linux.org Git - packages/evince.git/blob - evince.spec
- ver. 0.5.4
[packages/evince.git] / evince.spec
1 #
2 # TODO: fix t1lib build time misdetection (very low prio)
3 #
4 # Conditional build:
5 %bcond_without  dbus    # enable DBUS support
6 #
7 Summary:        Document viewer for multiple document formats
8 Summary(pl):    Przegl±darka dokumentów w wielu formatach
9 Name:           evince
10 Version:        0.5.4
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Applications/Graphics
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/evince/0.5/%{name}-%{version}.tar.bz2
15 # Source0-md5:  82ea2cc4ae080aa5cbc2b1c7739ccb96
16 Patch0:         %{name}-desktop.patch
17 Patch1:         %{name}-gs8.patch
18 URL:            http://www.gnome.org/projects/evince/
19 BuildRequires:  GConf2-devel >= 2.14.0
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.36}
23 BuildRequires:  djvulibre-devel >= 3.5.17
24 BuildRequires:  ghostscript
25 BuildRequires:  gnome-doc-utils >= 0.3.2
26 BuildRequires:  gnome-vfs2-devel >= 2.14.0
27 BuildRequires:  gtk+2-devel >= 2:2.8.0
28 BuildRequires:  intltool >= 0.34.2-2
29 BuildRequires:  kpathsea-devel
30 BuildRequires:  libglade2-devel >= 1:2.5.1
31 BuildRequires:  libgnomeprintui-devel >= 2.12.0
32 BuildRequires:  libgnomeui-devel >= 2.14.0
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtiff-devel
35 BuildRequires:  libxslt-progs
36 BuildRequires:  nautilus-devel
37 BuildRequires:  pkgconfig
38 BuildRequires:  poppler-glib-devel >= 0.5.2
39 BuildRequires:  python-libxml2
40 BuildRequires:  rpmbuild(macros) >= 1.197
41 BuildRequires:  scrollkeeper
42 Requires(post,preun):   GConf2
43 Requires(post,postun):  desktop-file-utils
44 Requires(post,postun):  scrollkeeper
45 Requires:       cairo >= 0.9.2-2
46 Requires:       djvulibre >= 3.5.17
47 Requires:       gtk+2 >= 2:2.8.0
48 Requires:       libgnomeui >= 2.14.0
49 Requires:       poppler-glib >= 0.5.0
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Evince is a document viewer for multiple document formats like pdf,
54 postscript, and many others. The goal of evince is to replace the
55 multiple document viewers that exist on the GNOME Desktop, like ggv,
56 gpdf, and xpdf with a single simple application.
57
58 %description -l pl
59 Evince jest przegl±dark± dokumentów w wielu formatach takich jak pdf,
60 postscript i wielu innych. W zamierzeniach program ma zast±piæ
61 przegl±darki dokumentów dla ¶rodowiska GNOME, takie jak ggv, gpdf i
62 xpdf jedn± prost± aplikacj±.
63
64 %package -n nautilus-extension-evince
65 Summary:        Evince extension for Nautilus
66 Summary(pl):    Rozszerzenie Evince dla Nautilusa
67 Group:          X11/Applications
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       nautilus >= 2.14
70
71 %description -n nautilus-extension-evince
72 Shows Evince document properties in Nautilus.
73
74 %description -n nautilus-extension-evince -l pl
75 Pokazuje w³a¶ciwo¶ci dokumentu Evince w Nautilusie.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 gnome-doc-prepare --copy --force
84 %{__aclocal}
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --disable-static \
90         --disable-schemas-install \
91         %{?with_dbus:--enable-dbus} \
92         --enable-djvu \
93         --enable-dvi \
94         --enable-nautilus \
95         --enable-pixbuf \
96         --enable-tiff
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.la
106
107 %find_lang %{name} --with-gnome
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 %gconf_schema_install evince-thumbnailer-djvu.schemas
114 %gconf_schema_install evince-thumbnailer-dvi.schemas
115 %gconf_schema_install evince-thumbnailer.schemas
116 %gconf_schema_install evince.schemas
117 %update_desktop_database_post
118 %scrollkeeper_update_post
119
120 %preun
121 %gconf_schema_uninstall evince-thumbnailer-djvu.schemas
122 %gconf_schema_uninstall evince-thumbnailer-dvi.schemas
123 %gconf_schema_uninstall evince-thumbnailer.schemas
124 %gconf_schema_uninstall evince.schemas
125
126 %postun
127 %update_desktop_database_postun
128 %scrollkeeper_update_postun
129
130 %files -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README TODO
133 %attr(755,root,root) %{_bindir}/*
134 %{_sysconfdir}/gconf/schemas/evince-thumbnailer-djvu.schemas
135 %{_sysconfdir}/gconf/schemas/evince-thumbnailer-dvi.schemas
136 %{_sysconfdir}/gconf/schemas/evince-thumbnailer.schemas
137 %{_sysconfdir}/gconf/schemas/evince.schemas
138 %{_datadir}/%{name}
139 %{_desktopdir}/*.desktop
140 %{_iconsdir}/*/*/*
141 %{_omf_dest_dir}/evince
142
143 %files -n nautilus-extension-evince
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/nautilus/extensions-1.0/*.so*
This page took 0.465062 seconds and 4 git commands to generate.